none
Windows 7 mapping DFS share versus Regular Share

    Question

  • I have an interesting issue that is preventing us from moving to Windows 7 from Windows XP.

    From a Windows 7 system I can map a drive using the following command easily enough to a server with a simply File Share:
    "net use Z: \\server1\share$ /user:DOMAIN\userA"

    But when I try the following command to map a network drive to a DFS share:
    "net use x: \\server1\dfs\share /user:DOMAIN\userA"

    I get the following error message:
    "System error 1312 has occurred.
    A specified logon session does not exist. It may already have been terminated."

    This only happens when trying to map to our DFS server, even trying to map to the root DFS. Through the "Map Network Drives" option it gives you the same error, just without the error code. The letter I'm using does not make a difference, nor does the account I'm using, as any letter or account returns the same error when trying to map to the DFS share. Nor does providing the password as part of the command line make a difference either. Nor does adding the Fully Qualified Server name such as server1.domain.edu make a difference.

    The system is currently not on the windows domain, but we need this to work for machines that are not part of our domain.

    The server is windows 2003 running a stand-alone DFS tree.

    Any thoughts on this?

    Wednesday, April 28, 2010 1:29 PM

All replies

  • We've had the exact same problem. Mapping or net use to a DFS share when not logged on as a domain user doesn't work.

    This 1312 error seems to be something to do with passing on credentials over more than one hop. In this case the server I'm trying to connect to is Server 2008 but it and its DFS shares sit on a 2003 domain.

    Error occurs on mapping to DFS share, or any folders on the (non-DC) server that have DFS aliases. Shares that don't have DFS pointers on the same server work okay.

    Tuesday, May 25, 2010 4:10 PM
  • Did you find an answer to this?
    both
    Friday, June 04, 2010 7:57 AM
  • At this point I've still not found an answer for this issue.
    Friday, June 04, 2010 11:04 AM
  • Hi,

    might be caused by the security policy "Network access: Do not allow storage of credentials or .NET Passports for network authentication.". 

    See http://technet.microsoft.com/en-us/library/cc779377(WS.10).aspx for more info about the policy.

    Also check "Error message when you try to automatically deploy agents in MOM 2005: "A specified logon session does not exist. It may have already been terminated"" (http://support.microsoft.com/kb/912998) for a similar error.

    Thursday, February 03, 2011 8:50 AM
  • Hi

    we had the same problem on the W7 clients, the following KB article for Vista suggests a workaround and it worked for us. we changed the existing client GPO to disable the network access policy "Do not allow storage of credentials or .NET Passports for network authentication"

     

    http://support.microsoft.com/kb/968264

    CAUSE
    This behavior occurs when the "Do not allow storage of credentials or .NET Passp...

     

    This behavior occurs when the "Do not allow storage of credentials or .NET Passports for network authentication" Network access policy is enabled.

     

    WORKAROUND
    To work around this behavior, follow these steps: On the Management Server, clic...

     

    To work around this behavior, follow these steps:
    1. On the Management Server, click Start, click Run, type gpedit.msc, and then click OK.
    2. Under Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand Security Options.
    3. In the Policy pane, right-click Network access: Do not allow storage of credentials or .NET Passports for network authentication, click Properties, click Disabled, and then click OK.

    • Proposed as answer by Haruna Tuesday, August 30, 2011 11:58 AM
    Tuesday, August 30, 2011 11:53 AM
  • We followed the above solution but we had not set up as Enabled. Default setting is Disabled but to be on the safe side, we set this to Disabled.

    The problem persists.

    Thursday, November 01, 2012 7:41 AM
  • Same here, that above solution does not work for me either. I continue to get the error.
    Thursday, November 15, 2012 9:41 AM
  • I have tried all suggestions in thread and still no luck.  Any thoughts.

    Monday, December 03, 2012 4:07 PM
  • This solution will not work for me either as the option is already disabled.  However, for those who do have it enabled, just a reminder that you need to gpudpate /force to update the policy or reboot the system.
    Wednesday, March 05, 2014 2:40 PM