none
Starcraft Broodwar won't render with correct color

    Question

  • I have PresarioV2000 laptop, Starcraft worked fine with WinXP, but now in Windows7, the color is all wrong, even in game. I tried compatibility mode, but it says ERROR: can't find font/font.gid, so it won't even start.

    Any suggestions? 
    Thursday, January 15, 2009 8:54 AM

Answers

  • I would guess you need a better video driver for win7

    Give us feedback on the Windows 7 Beta!

    As an MSDN subscriber you have the ability to register with Microsoft Connect to track the status of bugs you report. You will also be able to search, view and vote on bugs other MSDN subscribers have filed.

    To register on Connect, please click here. This will enroll you into the MSDN Bug Filing Program. Once you are enrolled in the program you may file bugs using any “send feedback” link in the product and access your feedback tracking page directly from this link.  Source: http://msdn.microsoft.com/subscriptions


    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Thursday, January 15, 2009 3:09 PM
    Moderator

All replies

  • I would guess you need a better video driver for win7

    Give us feedback on the Windows 7 Beta!

    As an MSDN subscriber you have the ability to register with Microsoft Connect to track the status of bugs you report. You will also be able to search, view and vote on bugs other MSDN subscribers have filed.

    To register on Connect, please click here. This will enroll you into the MSDN Bug Filing Program. Once you are enrolled in the program you may file bugs using any “send feedback” link in the product and access your feedback tracking page directly from this link.  Source: http://msdn.microsoft.com/subscriptions


    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Thursday, January 15, 2009 3:09 PM
    Moderator
  • Same issue here.  NVIDIA GeForce 9800 GT (XFX) using NVIDIA's pre-release drivers from Windows Update.  I'm also having issues with Quake 3 based games where the gamma cannot be set into hardware, which is a similar issue.
    Thursday, January 15, 2009 4:21 PM
  • Try running the 181.20 WQHL from Nvidia's site instead of the wddm betas and if i can find my Starcraft discs i'll try them
    Thursday, January 15, 2009 4:36 PM
  • The problem is that PresarioV2000 doesn't have video driver for Vista, so I am only using generic driver.
    Thursday, January 15, 2009 7:36 PM
  • I have the same issue as well. Have a 8800 GT and I haven't found a way around this yet. Seems to me StarCraft is not playable at this stage.
    Saturday, January 31, 2009 10:13 AM
  • This starcraft fix might help
    Saturday, January 31, 2009 10:51 AM
  • veef said:

    This starcraft fix might help


    Thank you!  This worked for me :)
    Sunday, February 01, 2009 6:08 AM
  • If you create a Battle.net account via the website, you can now tie your cd-key to it. Once you do that you can download the game from their site. I installed the downloaded version which comes with Brood war free if you did not have it. There downloaded installation works perfect for me. When I tried to use my CD i got the same problem you are having now.
    Friday, May 15, 2009 8:03 PM
  • for more convenient launching of SC with fixed colour, create a batch file in your sc root directory with this content:

    @echo off
    @echo ================================================
    @echo                               Rumburak's colour fix for SC
    @echo ================================================
    @echo This fix closes explorer.exe, waits until it is closed and then launches a colour bug free SC.
    @echo off

    taskkill /f /IM explorer.exe
    starcraft.exe
    Start explorer.exe
    • Proposed as answer by CharRebelle Wednesday, February 08, 2012 8:35 PM
    Saturday, May 30, 2009 12:49 PM
  • I'm running Windows 7 on my new ASUS G1Sn X1 Gaming Laptop

    I had the odd color problem but the batch file that j_bors came up with fixed it.  My current problem is that the game is running in a small 640x480 window in the middle of the screen (surrounded by black) instead of running full-screen.  This happened after I was mucking around trying to get it to run with proper colors.  (I changed my windows resolution to 640x480 at that time) and it won't return to being full screen now even if I uninstall/reinstall.. so I think Windows 7 has stored some sort of sizing data about it and won't let it go full screen anymore.

    Anyone else having this issue?  I've tried basically everything I can think of (compatibility modes, native rez, registry edit etc)
    Sunday, May 31, 2009 9:51 AM
  • I had the same problem, but solved it by checking the "run in 640x480 resolution" and "run in 256 colors" from the compatibility options. I came to this after trying playing it in "xp mode" from vpc7 it gave me an error telling me to set my desktop res to 640x480 and 256 color or update drivers etc. after that i tryed in win 7 using the compatibility setings leaving everything untouched except the 2 check boxes (run in 640x480 and run in 256 colors) when i started the game Surprise !!! it actually worked. i hope this info is usefull to you guys.

    P.S. Since you canot change your desktop setings to 256 color depth minimum beeing 16 bit and all, when ever you try to switch tasks (alt+tab) when you get back to the game you'll have the color problem again :(. So you'll have to save the game, exit it and then reload it. (hey at least loading is instant on today's pc's ) :))
    Wednesday, September 09, 2009 3:51 PM
  • so the download Installation did work very well and playing after that without color problem for both of alternative download game or cd Installation have color problem ??


    about windows 7
    Thursday, January 28, 2010 10:15 AM
  • Yes. The downloaded installation works. There is no color issue with it. HOWEVER, this is because it is not the newest version of starcraft. If you were to install starcraft from the cd and not install the 1.16 updates, then you would not have color issues either. Version 1.16 and LATER has the color issue on Windows 7. So, even if you use the downloaded version, as soon as you update starcraft to the newest version, you will get the color problem again.

    You can try the "open screen resolution" fix. It works for me sometimes, but not always. Sometimes I have to open an internet explorer window, minimize it, then open screen resolution (leaver it alone after opening, don't touch it), and then run starcraft.

    Just experiment. Thats really the best option. You can download one of the color fix batch files and it will work always. You just won't be able to tab out or anything.

    This is why the color problem is so annoying. No one can seem to fix the root cause. I am wondering if it has to do with the IE 8 version that is embedded in Win7.

    Good luck!
    Friday, January 29, 2010 5:48 AM
  • Yo, this was already fixed a while ago, and tested by myself. It works great.

    The problem with starcraft is windows Aero/the Taskbar in general.

    Windows Aero has the nice functionality of trying to stay over top of everything fullscreen.

    With newer games, there's already fixes so that this doesn't happen. not quite sure how.

    With older games (Somebody mentioned Quake3) they don't like that. So there is a color bug.

    Here's how to solve this :

    Make a new Text file. (Right click on the desktop > New > Text Document)
    Lets call it..... "Starcraft - Brood War.txt"
    Open the file, and put this in. Yes, you need the quotes.

    taskkill /f /IM explorer.exe
    "C:\Program Files (x86)\Starcraft\Starcraft.exe"
    Start explorer.exe

     

    Now, what this does :
    First line : Kills the taskbar application, so it doesn't create the color bug.
    Second line: This may or may not change based on where you installed starcraft. This is the default path. For those who didn't mess around with it, you can just use it like that.
    Third Line : Starts the taskbar back up when the game has been closed.


    Now that you're done that, rename the .txt at the end of the file to .bat
    And when you double click on it, it runs, executing the commands that you put in there.

    Tadaa! Color is fixed! :D
    You're welcome to all the people that this helps! :D

    • Proposed as answer by RylenK Thursday, March 25, 2010 12:17 PM
    Thursday, March 25, 2010 12:12 PM
  • This works beatifully every and every time, Im wondering if this little fix might work for some other older games under windows 7/vista too (just changing the middle line to their exe files).

    In any case thanks man, you have no idea how annoying the colours thing was getting for me :D

    Saturday, April 03, 2010 1:17 PM
  • am I the only one that this technique didn't work for?
    Tuesday, May 11, 2010 12:57 AM
  • Hey Bualdoot - btw very creative name! Thumbs up!

    Do you think you'd be able to Alt+Esc out instead of Alt-Tabbing?

    I haven't tried the taskkill solution yet, only because it seems too brutal to me.  You're effectively killing the shell, so that's a little too much for my liking.

    I am wondering if there's a registry setting to make the taskbar NOT be on top of all windows (topmost).  It has to be there for legacy reasons, although I can't remember where off the top of my head and I don't know if it will be applicable for the new taskbar.

    I'll try to dig around for it in my registry, but if you know of a setting like that, pls let me know :)

    R

    Wednesday, May 26, 2010 9:49 AM
  • so, i tried this, but it didnt work, am i doing this wrong or is there another way to fix this problem?
    Tuesday, July 27, 2010 1:42 AM
  • Hey, it didn't work for me either. I'd open up screen resolution but it didn nothingn to the game. However, inspired by the fix posted above I messed about a bit and founf a diffrent way. Mine works perfectly when you have both the screen resolution and the starcarft broodwar properties boxes open on screen. Hope this works for the rest of you as well!

    Friday, July 30, 2010 7:27 AM
  • If you got 1.16.1 try this import in regedit (worked for me and others)

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectDraw\Compatibility\Starcraft116]
    "Flags"=hex:00,08,00,00
    "Name"="Starcraft.exe"
    "ID"=hex:ca,89,65,49

    and for 64bit (I think?)

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DirectDraw\Compatibility\Starcraft116]
    "Flags"=hex:00,08,00,00
    "Name"="Starcraft.exe"
    "ID"=hex:ca,89,65,49

    Source : http://www.sevenforums.com/gaming/2981-starcraft-fix-holy-cow-20.html#post774096

    Thursday, August 26, 2010 11:34 AM
  • those reg commands did the job thanks man. wonderful fix. im running widows 7 x64, and i used the x64 one... worked like a charm! good fix, best fix Ive seen out there. 
    Sunday, August 21, 2011 7:14 AM
  • like a charm perfect... solution
    Wednesday, February 08, 2012 8:36 PM