none
WTClient.exe

    Question

  • Since I installed my Trust TB-5300 Slimline Design Tablet in Windows 7, I quite often get a high CPU usage of the WTClient.exe process, even when the tablet is not attached. The processor usage is then around 50%. However, this only happens when my laptop (Acer Aspire 7520) restarts after hibernation. After a 'normal' startup, the processor usage is just low, as it should be when doing nothing. Installing the tablet doesn't help, en to quit the process all the times isn't a pleasure too. I also tried to force not to start WTClient.exe at startup (using Ccleaner), but that didn't work, everytime WTClient.exe is one of the processes, even when the tablet is not used. How can I fix the problem of the 50% processor usage? Thanks in advance!
    Tuesday, November 17, 2009 1:59 PM

Answers

  • Looks like WinTab32 is trying to interact with the taskbar (creating a taskbar icon) but failing.

    0:000> kM
     # ChildEBP RetAddr 
    00 0012fa9c 76ec5e4c ntdll!KiFastSystemCallRet
    01 0012faa0 75266872 ntdll!ZwWaitForMultipleObjects+0xc
    02 0012fb3c 7569f12a KERNELBASE!WaitForMultipleObjectsEx+0x100
    03 0012fb84 752e90be kernel32!WaitForMultipleObjectsExImplementation+0xe0
    04 0012fbd8 752e59fe user32!RealMsgWaitForMultipleObjectsEx+0x13c
    05 0012fbf4 10013b00 user32!MsgWaitForMultipleObjects+0x1f
    WARNING: Stack unwind information not available. Following frames may be wrong.
    06 0012fc5c 0040166f WinTab32!RunTaskBarIcon+0x70
    07 0012fc9c 752dbaf1 WTClient+0x166f
    08 0012fd18 752db98b user32!UserCallDlgProcCheckWow+0x132
    09 0012fd60 752dbb7b user32!DefDlgProcWorker+0xa8
    0a 0012fd7c 752e86ef user32!DefDlgProcW+0x22
    0b 0012fda8 752e8876 user32!InternalCallWinProc+0x23
    0c 0012fe20 752e89b5 user32!UserCallWinProcCheckWow+0x14b
    0d 0012fe80 752e3578 user32!DispatchMessageWorker+0x35e
    0e 0012fe90 10013b6f user32!DispatchMessageA+0xf
    0f 0012fee8 0040166f WinTab32!RunTaskBarIcon+0xdf
    10 0012ff88 756a1174 WTClient+0x166f
    11 0012ff94 76edb3f5 kernel32!BaseThreadInitThunk+0xe
    12 0012ffd4 76edb3c8 ntdll!__RtlUserThreadStart+0x70
    13 0012ffec 00000000 ntdll!_RtlUserThreadStart+0x1b

    Could one of you try to set the 'run as administrator' in the 'Properties of WTClient -> Compatibility -> Chance settings for all users' and try again?

    Thanks,

    Daniel

    Saturday, December 12, 2009 2:24 PM
    Moderator

All replies

  • Hi tomgreep,

    Have you tried installing the latest Windows 7 driver package from Trust?
    http://trust.com/products/productdrivers.aspx?artnr=15356

    The WTClient is the Tablet Client Driver program from the Trust software package.
    Have you taken this up with Trust?

    I hope this helps solving your issue,

    Daniel
    Saturday, November 21, 2009 2:07 PM
    Moderator
  • Hi, dgrund.

    Unfortunately your solution didn't help. I have Genius G-PEN 4500 tablet and on the official website there are drivers specifically to Windows 7, and still the SAME behavior as tomgreep has. Still WMClient.exe consumes constantly about 50% of CPU usage after resuming from Hibernation. I didn't notice that on my desktop computer, but it's very crucial on the netbook, where I could actually discover this problem...

    Maybe I'll try to contact Genius, however it seems like it's not exactly driver issue - now there are two of us - Trust and Genius. And maybe those, who were too lazy to register here and respond :)

    Cheers,
    Hope someone finds a solution!
    Wednesday, December 09, 2009 9:12 AM
  • Hi TheFunkyOne,

    Could you create a process dump, when the issue occurs, and put it on a SkyDrive ?
    To create a process dump you can right-click on the process in Task Manager and select Create Dump File.

    Thanks,

    Daniel
    Thursday, December 10, 2009 6:10 PM
    Moderator
  • Hi again,

    I've turned on my netbook, it woke up from Hibernation, and the process WTClient.exe had 45-55% of CPU usage, when I created dump of this process. Then RAR'ed it and placed on SkyDrive here.

    Cheers,
    Hope that helps.
    Thursday, December 10, 2009 9:55 PM
  • Same situation here. I have a Genius MousePen 8x6 tablet and this situation occurs exactly as described both in my laptop (Dell Vostro 1500, C2D T5470, 2GB) and in my desktop (C2D E6600, 2GB) PCs, both of them have Windows 7 installed. And both of them use the drivers provided by Genius specifically for Windows 7. WTClient.exe has 45-55% of CPU usage after returning from hibernation. I can kill the process manually and everything goes back to normal, but it's annoying.
    Any ideas?
    Thanks!
    Friday, December 11, 2009 3:04 AM
  • Looks like WinTab32 is trying to interact with the taskbar (creating a taskbar icon) but failing.

    0:000> kM
     # ChildEBP RetAddr 
    00 0012fa9c 76ec5e4c ntdll!KiFastSystemCallRet
    01 0012faa0 75266872 ntdll!ZwWaitForMultipleObjects+0xc
    02 0012fb3c 7569f12a KERNELBASE!WaitForMultipleObjectsEx+0x100
    03 0012fb84 752e90be kernel32!WaitForMultipleObjectsExImplementation+0xe0
    04 0012fbd8 752e59fe user32!RealMsgWaitForMultipleObjectsEx+0x13c
    05 0012fbf4 10013b00 user32!MsgWaitForMultipleObjects+0x1f
    WARNING: Stack unwind information not available. Following frames may be wrong.
    06 0012fc5c 0040166f WinTab32!RunTaskBarIcon+0x70
    07 0012fc9c 752dbaf1 WTClient+0x166f
    08 0012fd18 752db98b user32!UserCallDlgProcCheckWow+0x132
    09 0012fd60 752dbb7b user32!DefDlgProcWorker+0xa8
    0a 0012fd7c 752e86ef user32!DefDlgProcW+0x22
    0b 0012fda8 752e8876 user32!InternalCallWinProc+0x23
    0c 0012fe20 752e89b5 user32!UserCallWinProcCheckWow+0x14b
    0d 0012fe80 752e3578 user32!DispatchMessageWorker+0x35e
    0e 0012fe90 10013b6f user32!DispatchMessageA+0xf
    0f 0012fee8 0040166f WinTab32!RunTaskBarIcon+0xdf
    10 0012ff88 756a1174 WTClient+0x166f
    11 0012ff94 76edb3f5 kernel32!BaseThreadInitThunk+0xe
    12 0012ffd4 76edb3c8 ntdll!__RtlUserThreadStart+0x70
    13 0012ffec 00000000 ntdll!_RtlUserThreadStart+0x1b

    Could one of you try to set the 'run as administrator' in the 'Properties of WTClient -> Compatibility -> Chance settings for all users' and try again?

    Thanks,

    Daniel

    Saturday, December 12, 2009 2:24 PM
    Moderator
  • I tried your suggestion, then resumed from hibernation and WTClient again uses 50% of the CPU.
    Here is my process dump:

    http://cid-a943d76fe9529a9f.skydrive.live.com/self.aspx/P%c3%bablico/WTClient-AfterHybernationWithAdministrativePriv.rar

    Hope this helps.
    Saturday, December 12, 2009 11:03 PM
  • Hmm it was my mistake, I had changed the administrative setting but not inside the "Change for all users" section. Now I tried it like you said and after returning from hibernation everything seems fine, WTClient doesn't even show up in the process list!!

    Thanks!
    Sunday, December 13, 2009 12:09 AM
  • I have the same issue but unable to set 'run as administrator' under 'Compatibility -> Change settings for all users'
    Im running Vista home premium x64.
    Any help is appreciated. Thaks!

    Sunday, January 10, 2010 3:27 PM
  • Not my case. When I saw your reply, I thought it was solved, but now when I'm using tablet again, I can see that nothing had been changed.
    Checked "Run as administrator" inside "Change for all users", but after normal Reboot, Hibernation and returning from it I'm getting 50% of CPU usage of WTClient.exe. If in order to solve this issue someone needs to have some more dumps, just ask...

    Meanwhile, Windows 7 is not on my netbook anymore, especially after this annoying problem.
    Wednesday, January 13, 2010 5:10 PM
  • I have the same problem in Windows 7. I didn´t find a good solution either.
    I use Systernals Process Explorer and I manually SUSPEND the process WTClient.exe. Once you do it every startup, it will not get the CPU anymore.
    Monday, February 08, 2010 5:46 PM
  • Your suggestions solved the problem in my machine also! (Windows 7 x64)
    Thanks.
    Dimitris Papadimitriou, Software Development Professional
    Wednesday, February 10, 2010 4:48 PM
  • Hi,

     

    I've forwarded this issue to tech. support of Genius tablets. Their answer was:

    After testing on Win 7 x64 and we found when login as administrator and it doesn't have this problem,
    but when you use as a standard user then CPU loading might increase, please try to change the configuration as attachment.
    It should solve your problem, thanks

    In the attachment they've shown how to change the properties of the file WTClient.exe (which`s usually located in c:\Windows\System32\) so it'll be ran as Administrator for all users.

    I've set it to be ran in Administrator mode and it solved the problem for me (Windows 7 Professional 64bit).

    Good luck!

    Tuesday, March 23, 2010 11:15 AM
  • not working in my case. win 7 home premium x64
    Monday, June 07, 2010 5:42 PM
  • didn't help me either, i have win 7 ultimate  32bit
    Friday, July 16, 2010 8:12 PM
  • same problem here, i also have a slimline tablet running win7 pro 64bit and every time the machine comes out of the sleep mode WTClient.exe is using 100% of one core.

    i contacted trust about this problem and they deny that their drivers have any problems....

    is there a way to restart this task after a while when returned out the sleepmode/login?

     

     

    Thursday, July 22, 2010 12:43 PM
  • so i wrote a little bat file which gets executed with an event shedule to end the WTClinet.exe and restart it.

    fixes the problem for me...

    here is the downloadlink to the bat file and the event xml (you might need to change the "<UserId>computer name\user</UserId>" (line22) to be able to import it.

    and change "<Command>"C:\WTClientRestart.bat"</Command>" (line 50) to where you have the bat file.

     

    http://www.file-upload.net/download-2691780/WTClientRestarter.rar.html

     

     

     

     

     

     

    • Proposed as answer by Herman J Sunday, September 12, 2010 12:19 PM
    Friday, July 23, 2010 9:03 AM
  • so i wrote a little bat file which gets executed with an event shedule to end the WTClinet.exe and restart it.

    fixes the problem for me...

    here is the downloadlink to the bat file and the event xml (you might need to change the "<UserId>computer name\user</UserId>" (line22) to be able to import it.

    and change "<Command>"C:\WTClientRestart.bat"</Command>" (line 50) to where you have the bat file.

     

    http://www.file-upload.net/download-2691780/WTClientRestarter.rar.html

     

     

     

     

     

     

    Recommended solution! Worked for me. By the way: Sometimes after rebooting from sleep (or how d'you call that..), WTClient just crashed. But this bat combined with a task fixed it all. Thanks grognaz!
    Sunday, September 12, 2010 12:27 PM
  • Hi,

    This solution worked for me, thank you very much!  Im using Windows 7 and a Genius MousePen 8x6.

    Cheers,

    Andrés

    Sunday, December 05, 2010 5:22 PM
  • Hi, 

    The link is broken.

    Could someone upload it?

    Thank's

     

    PrimoCL

    Sunday, January 30, 2011 4:25 PM
  • Hi!

    I have Windows Vista. After installing Genius Tablet I have got the problem with Wtclient - after going to "Sleepmode" and than awaking the computer, WTClient process used 50% of my CPU.

    I tried (as described above) to set Administator rights to WTClient, but it didn't helt. And there was no possibility to set "run as administrator".

    I tried to uninstall tablet driver, but it didn't help.

     

    n.b.!

    Yesterday I have just renaimed WTClient.exe to _WTClient.exe and it helped. I hope the problem will not arise anymore!

     

    Try It!

     

    Eugen

    Thursday, February 17, 2011 6:24 PM
  • Hey everybody,

    I had the same problem with my Genius 8x6 MousePen: WTClient using 50% of my CPU after resuming from Standby/Sleep. Ending the process in Task Manager and restarting it does reduce CPU use to 2% but doing that every time is ridiculous.

    However, setting WTClient.exe to "Run as Administrator" did work for me on my Windows 7 Home Premium, but there were a couple of tricky things.

    1. There are multiple WTClient.exe files in C:\Windows. One is in "System32" and the other is in "SysWOW64". For each of these, right click on the file and choose Properties. Select the Compatibility tab and click "Change settings for all users" at the bottom. In the window that pops up, check the "Run this program as an administrator" box at the bottom. Click Ok a couple of times and repeat for the other file.

    2. I used CCleaner to disable WTClient.exe at startup.

    3. My MousePen tablet works perfectly when I plug it into the USB port, but the WTClient.exe process never appears at all in Task Manager. Maybe WTClient.exe isn't even necessary?

    • Proposed as answer by w1zarD220 Friday, April 08, 2011 4:35 AM
    Friday, April 08, 2011 4:19 AM
  • Hi,

    Well I also had the problem above with a Trust Tb-6300 (with trust the product doesn't matter you download the same driver package for all, the installer finds out which one you have ("Please plug your device in")).

    So for this WTclient thing well on a my win7x64 the one that is running is from the system32 dir(and I'm pretty sure this is the case for any trust product) and your pen's working when wtclient isn't running because of the win7 native support for similar devices implemented in wisptis.exe that is part of the "Tablet PC Input Service" (as the name states it's a service).

    The problem occurs when your tablet can do better than win7 can support, like a multilevel pressure input (pressure sensitivity)  so you need to use the buggy WTclient served by the manufacturer.

    So the solution that worked for me:

    1:Disable the Tablet PC Input Service in the services list (in control panel services find Tablet Pc Input Service and change the startuptype to disabled)

    2:Create a new file somewhere that's going to be the small program restarting wtclient after hibernate and resume from sleep name it something.cmd

    3:Edit the something.cmd write inside line-by-line:

    • taskkill /F /IM wtsrv.exe
    • taskkill /F /IM wisptis.exe
    • taskkill /F /IM wtclient.exe
    • start wtclient

    4: Go to Task Scheduler and create a new task that starts "On workstation unlock of any user" and runs our something.cmd

    Then you'r done and here is the way I found out how to solve this:

    I inspected the wtclient when it was in it's "using a whole cpu core" state (this is the case mentioned above; 50% means you have a dual core system) and the first stack trace posted is correct the application hangs in a spinwait in the wintab32 module in the RunTaskbarIcon() function trying to wait for multiple handles (MsgWaitForMultipleObjects) well in fact it waits for two: one is \BaseNamedObjects\UCQUEUEMSGEVENTNAME (that's always 0xD8 and is a event) and the other is not present in wtclient.
    MsgWaitForMultipleObjects returns 0 every time called by wtclient, that means  none of the two handles given satisfies the "wait condition" so it tries again and again and again... , but never succeed.
    Well I figured maybe if it would return; it didn't work I could not reproduce a proper state to return from because the problem causing the malfunction is not in the wintab32 module not even in wtclient, the RunTaskbarIcon calls the wintab32.1000BFA0 function and that send a message to some window (via PostMessage) with a msg_id of 0x600 (it may be some custom message) with no parameters (lparam,wparam = 0) I think that's suppose to register the device or something so I didn't stand a chance in resolving this by just modifying some return value (of course).

    I figured there's gotta be something other that wtclient that causing this. I looked around realising that my pen works even without the wtclient.exe running that gave me the idea that maybe the wtclient can't process it's functionality because some other program claims it's already processing the input (from the tablet (this is the case with webcams: only one program can use your webcam at a time)) so I dug into the services list and found Tablet PC Input Service I was like "yeah I found it" shut it down immediately, well who would think, it didn't work...  my pen was still working without wtclient and now without TabetPCInputService (that's ridiculous) but then again I noticed the TabFlicks icon on the taskbar (at the system tray part) and found out it was the same program running as the TabletPcInputService (wisptis.exe) so I killed that too and finally my cursor stayed still no matter how hard I brushed my tablet with the pen (now I was like "yeah" for real).

    Then I restarted the wtclient from console (in the startup(msconfig) list (you can see that only the wtclient starts wtsrv is launched by wtclient)), and voilà after like 2 seconds wait that is needed to start the wtclient and the wtserv register the taskbaricon and everything, my tablet finally works like it should.

    • Proposed as answer by a.souini Sunday, February 26, 2012 11:04 AM
    Friday, October 28, 2011 4:54 PM
  • Hi Guys,

    I have had this problem on my Acer emachine for some time.

    What I have done and it seems to work is disable the tray icon for the pointing device. If you right click on the tray icon and go to properties you will see an option to disable the tray icon. 

    This may be a a temp fix and would like to know if you could try it please and let me know if it works. It seems to work on my machine. Its possible that there is a bug in the microsoft code when the tray icon activates.

    Please let me know if it works so I can report a bug if it does.

     

    Thankd

    Sunday, January 08, 2012 5:12 AM
  • I just end the process when it takes up all my CPU. This is not my problem. My problem is that, when I turn it on, my tablet limits the cursor movement to the actual dimensions of the tablet, which is considerably smaller than my screen. End the process, tablet funstions normally. This wouldn't be a problem if I didn't require WTClient to use pen pressure. This is aggravating, as I can't access my layers or color selection while WTClient is on.
    Thursday, January 26, 2012 2:34 AM
  • you sir, have found us a practical solution to this issues, thank you
    Sunday, February 26, 2012 11:06 AM
  • Nagyszulejman, you are the man. You should be awarded a prize by Trust who have consistently showed up tiny on this one.

    jebbushell*yahoo!com

    However, now a week later I notice that I sometimes have to reboot to straighten it out.  Manually running the task in Task Scheduler sometimes does not work.  The Tablet PC icon was visible in the tray at the time I first noticed this and I was unable to identify its process in order to try killing it.
    • Proposed as answer by jebbushell Monday, December 17, 2012 10:15 AM
    • Edited by jebbushell Wednesday, December 26, 2012 12:40 PM
    Monday, December 17, 2012 10:14 AM
  • The post marked as the answer is not the answer anymore:  Start the Win7-64 system, note that wtclient.exe is not using cpu. Lock windows and then unlock.  Note that wtclient.exe is now using a whole processor.  Repeat with Trust tablet disconnected and get same result:  Flake City.

    jebbushell*yahoo!com



    • Edited by jebbushell Monday, December 31, 2012 11:47 AM
    Monday, December 31, 2012 11:32 AM