none
Kernel Power event 41 error possible solution in windows 7

    General discussion

  • I too have been getting the dreaded kernel power error and also a atikmdag error. I have spoken to Microsoft and after a few days of getting no-wear the last thing that they told me to do was to disable the RAC task in scheduled tasks. I did this and also uninstalled all my programs and uninstalled my ATI drivers and catalyst controller. Then I installed the ATI catalyst control and drivers from an earlier date (9-7_vista64_win7_64_dd_ccc_wdm_enu). I no longer get the atikmdag error and yet to get the random reboot associated with the kernel power error, it has now been 5 days trouble free (cross my fingers). I know how annoying this problem is and i believe that it is not a hardware problem like some people may think. I do believe that it is a Microsoft problem that may be resolved in later patches,SP. I think that Microsoft has done something in the RTM that some motherboards are not agreeing with therefor causing this kernel power error. I hope this helps some of you.
    Monday, January 18, 2010 9:39 AM

All replies

  • obviously, that is not hardware trouble, if you search about kernel 41 ,you see a lot of people with new power supplys made by best reseller like pc power & cooling,seasonic,zalman, etc, new hardware and the trouble is there and is real, is 100% software and 100% incompatibility with something relationated to ATI.with my old gtx 260 ,i use seven 24/7 on downloading blurays weeks and weeks,then when buy ati 5870, the system can not stable 2 days or one! without kernel 41 random freeze.
    Tuesday, February 09, 2010 6:54 PM
  • Hi,

    To address this issue, Microsoft has published a knowledge base (KB) article:

    Windows Kernel event ID 41 error in Windows 7 or in Windows Server 2008 R2: "The system has rebooted without cleanly shutting down first".

    Click the following link to view the article in the Microsoft Knowledge Base:

    http://support.microsoft.com/kb/2028504

    Regards,


    Magon Liu - MSFT
    Tuesday, June 08, 2010 3:22 AM
  • Thank you for this, it seems to be the most helpful thing I've found. Hope it works!
    Thursday, January 13, 2011 6:26 PM
  • I have had this problem (kernel power 41) since i bought my laptop and think i found the solution-  In the event log when the reboot happens the time was just updated and changed to a time that was earlier- i disabled time updating and have not had the problem since- hope this helps
    Saturday, December 24, 2011 1:29 PM