none
Adding Multiple Images to .wim using ImageX

    Question

  • Hello,

    Hopefully somebody can help.

    I have 2 virtually identical fat images in .wim format. The sizes of these are 4.3Gb and 4.4Gb. The difference between the 2 are a few driver packages and maybe 1 or 2 pieces of software. Both are Windows7 x86 os images captured in identical fashion, using WDS. When I use the /append command in imagex I can combine the 2 images but I am left with a .wim file of over 8.7Gb.

    The description for the /append command states "Creates a single instance of the file, comparing it against the resources that already exist in the .wim file, so that you do not capture the same file twice."

    So can anybody tell me why my images are holding duplicate files, when they should be using a single instance?


    Here is a copy of the Deployment Tools Command Prompt:

    C:\Program Files\Windows AIK\Tools\PETools>imagex /append c:\images\wim\ c:\imag
    es\f.66.wim "test add image"

    ImageX Tool for Windows
    Copyright (C) Microsoft Corp. All rights reserved.
    Version: 6.1.7600.16385

    Files/folders excluded from image capture by default:

     \$windows.~bt
     \$windows.~ls
     \winpepge.sys
     \Windows\CSC
     \Recycled
     \Recycler
     \$Recycle.Bin\*
     \System Volume Information
     \pagefile.sys
     \hiberfil.sys

    [ 100% ] Appending progress

    Successfully imaged c:\images\wim\

    Total elapsed time: 5 min 25 sec




    Thanks and Regards.

    Thursday, February 18, 2010 2:45 PM

Answers

  • I'm thinking that imagex just added one wim file into the other instead of opening it and moving the files over.

    try to mount one wim and /append the files in the mounted folder into the other wim file
    My certificates: https://www.mcpvirtualbusinesscard.com/Profile.aspx?ID=2251ddfe-3d9f-41dc-af62-a512ca5888b6
    • Marked as answer by Teabag7 Friday, February 19, 2010 2:01 PM
    Thursday, February 18, 2010 2:50 PM

All replies

  • I'm thinking that imagex just added one wim file into the other instead of opening it and moving the files over.

    try to mount one wim and /append the files in the mounted folder into the other wim file
    My certificates: https://www.mcpvirtualbusinesscard.com/Profile.aspx?ID=2251ddfe-3d9f-41dc-af62-a512ca5888b6
    • Marked as answer by Teabag7 Friday, February 19, 2010 2:01 PM
    Thursday, February 18, 2010 2:50 PM
  • I believe you need to use /export switch

    From the WinPE User Guide:

    Exports a copy of the specified .wim file to another .wim file. The source and destination files must use the same compression type. You can also optimize an image by exporting to a new image file. When you modify an image, ImageX stores additional resource files that increase the overall size of the image. Exporting the image will remove unnecessary resource files.

     
    Thursday, February 18, 2010 3:09 PM
  • Nico, that certainly sounds feasible.. Ill give it a whirl and let you know the outcome.

    Thursday, February 18, 2010 3:09 PM
  • Thanks for you answers guys, mounting the image before appending it did the trick.
    Friday, February 19, 2010 2:01 PM