none
Cannot edit file properties for mp3 files in Windows 7

    Question

  • I recently upgraded from Vista Home Premium to Windows 7 Ultimate. Now I can't change the artist, album, genre, etc. info on any of my music files when I go to the file's Properties and under the Details tab, or with the tags at the bottom of the Windows Explorer. If I try to change something and click apply or OK, it just changes right back. I have all the permissions checked under my account. I tried unchecking the Read-Only attribute of the folder and files, but it after I click apply or OK, again, it changes back when I reopen the dialog box.There are several other threads with the same problem, but none have a satisfactory answer/solution. I had no problem with this before I upgraded. Please help, it's very frustrating.

    Also, I'd rather a SOLUTION from Microsoft rather than a way around it with third party tag software. Thanks.
    Monday, December 21, 2009 5:13 AM

Answers

  • Hi,

     

    I would like to confirm if this issue occurs on every music file.

     

    You can take a file from C:\Users\Public\Music\Sample Music and test it.

     

    If it only occurs on some files, please let me know the file format and where they came from.

     

    To troubleshoot this issue, you can try the following steps:

     

    Enable built-in admin account

    ==============

    1. Click Start, click "All Programs", please find and open "Accessories" folder.

    2. Please right-click on "Command Prompt" item and select "Run as administrator".

    3. Please type the following command line in to the coming window.

     

    net user administrator /active:yes

     

    Note: There is a space between "Administrator" and "/active:yes".

     

    4. Log off and log on the Administrator account.

     

    Does it work?


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, December 28, 2009 3:08 AM
    Tuesday, December 22, 2009 7:53 AM

All replies

  • Hi,

     

    I would like to confirm if this issue occurs on every music file.

     

    You can take a file from C:\Users\Public\Music\Sample Music and test it.

     

    If it only occurs on some files, please let me know the file format and where they came from.

     

    To troubleshoot this issue, you can try the following steps:

     

    Enable built-in admin account

    ==============

    1. Click Start, click "All Programs", please find and open "Accessories" folder.

    2. Please right-click on "Command Prompt" item and select "Run as administrator".

    3. Please type the following command line in to the coming window.

     

    net user administrator /active:yes

     

    Note: There is a space between "Administrator" and "/active:yes".

     

    4. Log off and log on the Administrator account.

     

    Does it work?


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, December 28, 2009 3:08 AM
    Tuesday, December 22, 2009 7:53 AM
  • Hi,
    I understand that manu hasn't replied back just yet but just wanted to say thanks,
    I was having a similar problem and the solution provided works.

    However, may I ask whether the ability to edit information would be taken back if I were to make the administrator account inactive again?
    Tuesday, December 22, 2009 6:14 PM
  • Hi Vivian,

    This did not work.

    Why is Windows 7 locking the ability to edit the file details. I don't understand.

    I have tried to edit my movie files and I cannot. I have several home movies and video files that I can no longer edit the meta details such as author year, genre etc.

    Please help
    Saturday, January 02, 2010 5:06 PM
  • Hi Vivian,

    Manu: Sorry to barge in on your thread!

    Vivian, I did what you suggested, although my user was already an administrator. I created a new account, 'Administrator' and logged in as that user. But then what?

    I started the Explorer but it looked exactly the same. I also tried creating an 'Explorer' icon and ran that as Administator, but I cannot see where I am supposed to be able to alter the fields necessary.

    I would really appreciate it if you could carry on; I have 480 filed, mostly .WAV, which contain 'Unknown' in the "Title" field, even though I've corrected the "Name" field in Windows Media Player. My particular problem is that I use Logitech Squeezebox Duet, and that application uses the "Title" field, ending up with 480 songs from 480 albums in need of correction. Logitech suggests re-rip of all albums, but there simply must be an easier solution to this!

    Krgs, Chris
    Monday, January 04, 2010 7:10 PM
  • Chris, that's probably related to the fact that these are WAV files. WAV has very poor support for tagging, and any information you edit in WMP's library won't actually be written to the files themselves. See this page for more info.

    I would suggest to convert the WAV files to a format that does allow proper tagging, such as MP3 or WMA Lossless.
    Tim De Baets
    http://www.bm-productions.tk
    Monday, January 04, 2010 8:35 PM
  • I had this exact same problem and spent all day yesterday trying to solve it, finding no help on any of the sites I searched. However, today I have SOLVED the problem and so have registered here so I can post the solution:

    THIS IS NOTHING TO DO WITH USER ACCOUNT CONTROL!!!!!

    The problem seems to be with the ID3 tags in the files. I suspect in my case iTunes has caused some conflict with how the ID3 tags are handled but I'm no expert on all that to be honest. I was however able to use iTunes to easily solve the problem.

    All I did was open the problem file in iTunes, right click on it and select 'Convert ID3 Tags' then from the drop-down menu in 'ID3 Tag Version' select 'v2.2' (I didn't try any of the others maybe they also work?)

    You can select multiple tracks at once to convert them all.

    If you go back to windows explorer you will find that the song information is now back and fully editable.

    I'm sure there are other programs you can use to convert the ID3 tags but iTunes worked for me.

    This is a bit of a long and laborious process if you have many tracks to do but worth it in the end.
    • Proposed as answer by CaliRocks365 Wednesday, January 27, 2010 9:19 AM
    Saturday, January 16, 2010 2:53 PM
  • Thank you for this post.

    I have Windows XP Pro, SP2, Explorer 8 and Windows Media Player 10.

    I have Itunes and feel this solution should work. It it doesn't I'll be back.

    Wednesday, January 27, 2010 9:18 AM
  • I hope this thread is not dead and that Vivian is still moderating.

    My problem is the same. 

    Bought a new PC with Windows Professional installed. 
    I transferred my music library which consists of mp3 files. 
    Some songs will not play in neither iTunes nor WMP.
    Same songs will not transfer to iPod because they are deemed unavailable.
    The problem sees to be related to CDs I ripped from my cd collection 4 or 5 years ago, as far as I can tell, and apply to all songs from that specific album/folder.
    I have changed the security settings per this forum and other forums. That enabled me to edit iTunes data in some folders, but not all.
    The ones that I was able to edit had still allowed the songs to play.  That is not the case with the remaining files. 
    I have set up the admin account per above to make sure that the security settings are changed properly.
    When I tried to edit the ID tag per the above suggestion in a tag editor, the file/folder is not recognized.
    When I tried to edit the ID tag in iTunes, I receive a message that the files can not be converted because they are write protected or of the wrong type.  
    Also, in iTunes, the info is grayed out which means that I can not edit other iTunes data.
    f I replace the folders from my backup hard drive, they play fine.  However, that process seems laborious and fraught with trial and error re which folders will not play. The folders to be replaced all have the same date of addition to my library which is when I moved it to a new hard drive. I am since 2 computers past then, although only i hard drive.

    It seems to be a Windows 7 issue because the folders will not play in iTunes or WMP.
    I would appreciate any advice, especially from Vivian.
    Saturday, February 13, 2010 5:49 PM
  • Vivian, are you trying to be unhelpful?  Because you are succeeding by not addressing follow up questions. 
    Sunday, February 14, 2010 4:35 PM
  • You have to change the user account control (UAC) settings. Go to the start menu, control panel, user accounts and family safety, user accounts, change user account control settings, and make it so you are never notified. Restart and it will work.
    Friday, March 19, 2010 1:14 AM
  • Catepelose;

     

    Thanks for the post, but I had already tried that to no avail per my above post.  I never was able to solve the problem at the OS level or iTunes level.  I ended up manually deleting the bad folders and replacing them with backup copies from an external hard drive.  It was painful, but ultimately successful. 

    I would have appreciated a response from Vivian.

    IB

    Monday, March 22, 2010 7:51 PM
  • Catepelose;

     

    Thanks for the post, but I had already tried that to no avail per my above post.  I never was able to solve the problem at the OS level or iTunes level.  I ended up manually deleting the bad folders and replacing them with backup copies from an external hard drive.  It was painful, but ultimately successful. 

    I would have appreciated a response from Vivian.

    IB

    Monday, March 22, 2010 7:51 PM
  • Im suspicious that Vivian has not replied. In all recent versions of windows and media player it was very simple to edit metadata for audio tracks and I find it difficult to beleive that a basic tagging system has spontaneously stopped working. I may be acused of being cynical but perhaps Microsoft has done this deliberately? 
    Monday, April 05, 2010 7:19 PM
  • I've written a program in C# that renames mp3 files based on their ID3 v2 tags.  So I have a bit of knowledge regarding the ID3v2 format, but by no means to be considered an expert.

    In both Windows XP (work computer) and Windows Vista (home computer) once I have converted my mp3 library to use ID3v2.4, Windows will not read the ID3 information.  The same files in ID3v2.3 format work ok.

    This can also be seen when a file contains both ID3v2.4 tag and an ID3v1 tag.  Windows will display the ID3v1 Artist, Title, Track, etc information.  If you right click the file, go to properties and modify the data and click Apply, Windows will write an ID3v2.3 tag to the beginning of the file directly in front of the existing ID3v2.4 tag.  Not only is this a problem, but you will no longer be able to import this file into iTunes until you delete the newly created ID3v2.3 tag created by Windows Explorer with a Hex Editor or equivalent program.

    There definitely is a problem here, but I don't have Windows 7 yet so I am unable to see if this is also a problem in that operating system.

    Tuesday, May 18, 2010 6:55 PM
  • ^-- You should read up on ID3v2.3 and ID3v2.4 compatibility.  Windows supports ID3v2.3 at this time.  Given the lack of backwards compatibility with v2.4, it appears Microsoft went with the more-legacy-compatible ID3v2.3 option.
    Wednesday, May 19, 2010 5:11 AM

  • I had this issue after upgrading from Vista to 7 where some of the mp3 details in Explorer were not there and WMP12 put them in the unknown category.
    Although most of my MP3 files did have details in Explorer.
    I could edit the details for the mp3's that already had them but couldn't add details to those that did not.

    Using the program "MP3tag" I discovered that the files with missing details in Explorer and WMP12 were displayed in this program.

    My solution was this:
    In MP3tag, highlight the files without tags displayed in Explorer.
    Right-click, remove tag, save.
    The details miraculously were displayed in Explorer and editable.
    The details were still displayed after Undoing the save and the remove tag in Mp3tag,
    Some of the albums in WMP12 were moved from the Unknown category and filed properly immediately.
    For the others, I deleted the Unknown folder in WMP12, then click Tools, Advanced, Restore deleted library items.
    I was left with 1 rogue file that wouldn't update.

    Hope this helps somebody
    • Proposed as answer by Gomezjl Friday, October 01, 2010 4:12 PM
    Saturday, May 22, 2010 9:14 AM
  • Hi manu,

     

    Probably you have an alternative or solved this by now but I would like to share my 1 cent worth alternate work around which worked successfull for me in Windows 7.

    I had exactly the same problem, I wanted to add album name for an MP3 but none of the fields were editable. I converted the file again from MP3 to WAV and again the WAV to MP3. The newly converted file had the properties in editable condition. There was one error while converting MP3 to WAV. (stream conversion error at one line), i just bypassed it (as it sounds not very significant). The new MP3 file is of less size and I played it, its absolutely fine. I was able to add Album name also. (all the file properties can be edited for that matter.)

    With this I conclude that the erroneous behaviour of fields being in non editable condition pertains to the very file (data). It happens.

    Thanks,

    Srinath

     

     

    Tuesday, July 27, 2010 5:00 PM
  • I tried this and it worked beautifully. I can finally edit my songs. Thanks!
    Friday, October 01, 2010 4:13 PM
  • This is EXACTLY what I did, and it is in my opinion the simplest solution considering I only come across these files every once in awhile....with one exception: use a converter that takes it MP3->MP3, instead of the whole MP3->WMA->MP3 business. That's too time consuming, and too many steps....although the premise is dead on. Go MP3->MP3 (thus creating a new MP3 file altogether). It worked perfectly for me.

     

    For anyone whom this information might help: I'm using Ashampoo Music Studio 3 for converting.

     

    TELL ME IF THIS HELPS!!!

    Monday, November 22, 2010 3:03 PM
  • I had the same problem and went looking for the answer on the web.  This is what I found that works:

    If you have iTunes you can edit your tag info.  Open the track in iTunes, right click on the track listing and you'll get a menu.  Select "Get Info" and you get a box with tabs.  Select the "Info" tab and you will see your tag info.  Make the appropriate corrections and select "OK."  It worked for me, I hope it works for you.


    Thursday, April 28, 2011 3:27 AM
  • BoyFromTaint,

     

    That doesn't work.  That will sort your files by your edited information while in iTunes, but the core file will not have changed.  If you move them to any other program or reinstall itunes, you will just have to edit the info again.


    Wednesday, June 22, 2011 2:28 PM
  • use mp3 tag editing software open your search engine and search for it ok
    Wednesday, June 29, 2011 9:08 AM
  • I know this is a few years old, but I couldn't find a solution...my issue was definitely not an administrative issue, and iTunes would not edit any of the information.  I added the album to a Windows Media Player playlist and tried to edit it there.  While it temporarily allowed me to rename the files, it was only a temporary fix for Media Player specifically...in windows explorer, the files were still the exact same.  I have a Zune and figured I would just add the playlist to the Zune player and edit it, and then sync it while the names were still how I wanted them (even if it didn't change the actual file).

     

    As odd as this may be, the Zune software completely renamed the files themselves.  While Windows Media Player only updated the information for my Windows Media Player playlists, the Zune software actually changed the file information.  Windows Explorer and Windows Media Player were useless, but the Zune software worked.  That could have just been worked in my case, but it's worth a shot if anyone still has this problem and has the Zune player software.  Just throw it into the Zune software database, edit it, then reload the containing folder in windows exporer and see if it helped.  Good luck!

     

    Oh and Manu, this is "technically" a solution from Microsoft, at least by their program :-)

    • Proposed as answer by GrubMasta Thursday, July 21, 2011 6:25 PM
    Thursday, July 21, 2011 6:24 PM
  • I've been using mp3tag to fix the messed up mp3 files.  it's little tricky to use.  drag and drop files in.  SELECT THE FILE(S) YOU WANT TO CHANGE (shift click for more than one), type in the info on the left, and then HIT SAVE (don't forget to hit save).  It will then write to the files.

    http://www.mp3tag.de/en/

    Can't find anything to fix the video files yet though...

     

    Sunday, July 24, 2011 10:52 PM
  • Stumbled across this forum while having similar issues with id3 tags displaying in explorer/wmp. I finally found a solution over at hydrogenaudio's forum where someone suggested that it was possible the mp3's had "chained id3 tags." That is an id3v2 tag followed by an id3v2.4 tag. It's my understanding that windows 7 (and obviously wmp) do not support the id3v2.4 and opted for the legacy id3v2.

    The solution suggested (which worked for me) was to use foobar2000. Load your music library (or afflicted mp3's) and select all. Then right-click and select: Tagging>MP3 Tag Types> Select the "Override ID3v2 Revision" and select ID3v2 as your format. Finally select the 'Update Files' button and let it process.

    After doing this I had no more issues with explorer/wmp reading and displaying the tag information. Hope this helps somebody! 

    • Proposed as answer by Mr.November Monday, July 29, 2013 7:28 AM
    Sunday, August 28, 2011 3:20 AM
  • Hi there...

    Have you at any time had trouble accessing avi files in Explorer and had to run the following command:

    regsvr32 u/shmedia.dll

    ???

    If yes, that may be the cause of the problem, you can reverse it by clicking Start -> Run -> type:
    regsvr32 shmedia.dll
    Click OK

    However, this is likely to cause you Explorer crashes with .avi files again.

    If the above doesn't apply, it may be worthwhile trying the command then rebooting to see if it helps :)
    • Proposed as answer by TUROKY Friday, September 02, 2011 7:29 AM
    Friday, September 02, 2011 7:14 AM
  • Thank you Geoff81D, This seems to have worked fabulously.  Fixing all my files in iTunes now.  
    Saturday, September 17, 2011 11:35 PM
  • you have no idea how happy this made me when it actually worked! thanks!!!!
    • Proposed as answer by DirtyPaws11 Monday, October 31, 2011 5:07 AM
    • Unproposed as answer by DirtyPaws11 Monday, October 31, 2011 5:07 AM
    Monday, October 24, 2011 2:58 PM
  • All, if you are still having this problem and you have dBpoweramp installed, make sure you have the latest version (14.2) There has been this recent bug fix:
    "Bug Fix: Uninstall could leave the Windows Property details page for previously registered formats (such as mp3) inoperable"
    Once I upgraded to the latest version, all my tags reappeared in Windows Explorer and I was able to edit them, yay

     

    http://www.dbpoweramp.com/Version-Changes-DMC.htm

     

    Monday, October 31, 2011 5:09 AM
  • This solved it for me, I was able to go all the way to v2.3. v2.4 doesn't appear to be supported by Win7.
    Saturday, December 03, 2011 1:22 AM
  • This fixed the problem for me!! I tried what everyone else was saying too, and this is the only options that was successful!
    Friday, December 09, 2011 4:18 PM
  • Thanks Geoff, that worked perfectly! Though I did it once, no change, selected No ID, slected 2.2 again and it worked that time.
    Friday, January 13, 2012 9:56 AM
  • Ekk i took your advice and now i have a redundant admin account. How do i remove this monstrosity lol? Windows now reverts to a login screen :(
    Tuesday, April 17, 2012 7:55 AM
  • invizzi1: you can remove it again through Control Panel - Add or remove user accounts.

    Tim De Baets
    http://www.bm-productions.tk

    Thursday, April 19, 2012 8:03 PM
  • I've also encountered this problem a few times in the past (in all versions of Windows).  Because it generally did not occur with all MP3 files, I simply used an audio software program called Goldwave and used the "save as" option and renamed the file(s).  Cleared up any errant ID3tag information that might have been present in the original file.  Also, the program can perform 'batch' function.   I don't believe it's merely a Windows problem but corruption within the file properties...
    Tuesday, August 21, 2012 7:52 PM
  • NYCGRIFF777: I'm not sure if Goldwave re-encodes the file if you use "save as", but if it does then you will have quite some loss in audio quality.

    Tim De Baets
    http://www.bm-productions.tk

    Thursday, August 23, 2012 9:55 PM
  • Just wanted to let you know that I had a similar experience - although I am not using Zune, I was able to access and change the properties of mp3 files out of a 3rd party software (itools - Chinese, but free). When importing the files into the library, a window opens and a right click on the individual files opens the same menu items as in Windows explorer, only that here the read-only box is not gray. Yay!.  Lot's of work, but the result are neatly arranged albums in itunes.
    Saturday, September 22, 2012 8:04 AM
  • Thanks! It worked for me, you should change the version of ID3 tags in iTunes and then keep the changes. It'll work.

    This problem has nothing to do with the administrator account!

    Friday, October 05, 2012 1:36 PM
  • I had this exact same problem and spent all day yesterday trying to solve it, finding no help on any of the sites I searched. However, today I have SOLVED the problem and so have registered here so I can post the solution:

    THIS IS NOTHING TO DO WITH USER ACCOUNT CONTROL!!!!!

    The problem seems to be with the ID3 tags in the files. I suspect in my case iTunes has caused some conflict with how the ID3 tags are handled but I'm no expert on all that to be honest. I was however able to use iTunes to easily solve the problem.

    All I did was open the problem file in iTunes, right click on it and select 'Convert ID3 Tags' then from the drop-down menu in 'ID3 Tag Version' select 'v2.2' (I didn't try any of the others maybe they also work?)

    You can select multiple tracks at once to convert them all.

    If you go back to windows explorer you will find that the song information is now back and fully editable.

    I'm sure there are other programs you can use to convert the ID3 tags but iTunes worked for me.

    This is a bit of a long and laborious process if you have many tracks to do but worth it in the end.

    Thank you very much... I was struggling with this issue and your solution saved my time!!! Thank you!!!

    Monday, October 15, 2012 3:35 PM
  • Wish I`d found this thread earlier, it solved my problem.
    Sunday, October 28, 2012 4:09 PM
  • Good morning boys & girls. Your quest for problem solving on this issue is at an end. ALL you have to do is go into tools - options - library and ensure that there is NO tick in either of the rename music files using rip settings and rearrange music in rip music folder. Then click apply. Voila!!!!!!!! 

    Took me days to work this one out so donations please how ever small to Account 39265816. Sort Code 090126.

    Ta very much.

    Sunday, December 02, 2012 10:30 AM
  • Guys, I'd suggest using an id3tag editor like TagScanner (http://www.xdlab.ru/en/download.htm). It's free and the developer even made a portable version (http://xdlab.ru/files/tagscan5.1.625.zip), which means you don't have to install shit. Simply download, open the program and re-tag whatever you need, and delete it. Clean, fast, no install.


    To edit tags:

    1. drag and drop files to tagscanner, push the tag editor tab (top left)
    2. select mp3s and add info (right, under main)
    3. save (bottom right)

    Sidenote: you can also use tagscanner to save changes to all tags at once (id3v1, id3v2 and ape).

    Tuesday, December 18, 2012 4:16 PM
  • Guys, I'd suggest using an id3tag editor like TagScanner (http://www.xdlab.ru/en/download.htm). It's free and the developer even made a portable version (http://xdlab.ru/files/tagscan5.1.625.zip), which means you don't have to install shit. Simply download, open the program and re-tag whatever you need, and delete it. Clean, fast, no install.


    To edit tags:

    1. drag and drop files to tagscanner, push the tag editor tab (top left)
    2. select mp3s and add info (right, under main)
    3. save (bottom right)

    Sidenote: you can also use tagscanner to save changes to all tags at once (id3v1, id3v2 and ape).

    Tuesday, December 18, 2012 4:16 PM
  • Guys, I'd suggest using an id3tag editor like TagScanner. It's free and the developer even made a portable version , which means you don't have to install shit. Simply download, open the program and re-tag whatever you need, and delete it. Clean, fast, no install.


    To edit tags:

    1. drag and drop files to tagscanner, push the tag editor tab (top left)
    2. select mp3s and add info (right, under main)
    3. save (bottom right)

    Sidenote: you can also use tagscanner to save changes to all tags at once (id3v1, id3v2 and ape).

    ps: arrrgh stupid social technet won't let me provide links! just google it and in the downloads section you'll find the portable version.

    • Proposed as answer by cicardia Tuesday, December 18, 2012 4:18 PM
    Tuesday, December 18, 2012 4:18 PM
  • This problem persists (win7 x64). It exists, for me, for approximately 5% of all my music files. I just CANNOT write an ID3 tag with mp3tag (it won't save, or show up in the explorer, or in itunes. I can manually edit the properties of each file individually (not by selecting all at once, that also won't save the info) in the explorer, but there is way too many files to do so individually. I have stated editing the info in itunes, and the info added there sticks, but for itunes only, the windows explorer and mp3tag do not accept the infos added in itunes, and show the id3 tag as blank. Is there a working workaround (the abovementioned didn't work for me so far)?

    Edit: Just tried editing the files in XPsp3, works like a charm, in mp3tag, win explorer (selecting all files at once) and itunes all the same.

    • Edited by Sub21 Saturday, January 05, 2013 8:33 AM
    Saturday, January 05, 2013 8:23 AM
  • Sub21: I suggest that you use Mp3tag to completely remove all ID3 tags (right-click - Remove tag). Then after adding new tags, make sure that they're in ID3v2.3 format by checking Properties.

    Alternatively, you could also give MP3 Validator a try to fix possible MP3 file corruption.


    Tim De Baets
    http://www.bm-productions.tk

    Saturday, January 05, 2013 1:20 PM
  • Hey Microsoft - Pay attention:

    This is a problem in Windows 7 (and perhaps other versions) but not in Windows XP.  The ID Tags cannot be edited in Windows 7 using either Windows own tag editor or ID3 Tag (a third party editor).  However, the very same files (existing on a USB drive) can be edited on Windows XP.  This is clearly a problem on Windows 7 that needs to be fixed.

    I can't comment on the other work-arounds proposed here, but it you have access to a Windows XP machine, that might be a good way to fix your ID3 tag problem.

    Sunday, March 03, 2013 10:02 PM
  • Does anyone know if this problem has been fixed in Windows 8?  This thread is over 3 years old and at this point I doubt Microsoft is going to do anything about it as their approach is typically abandon for the latest version.
    Saturday, March 09, 2013 6:51 PM
  • my problem is like:   I can right click on the mp3 file and open the properties, and able to edit most of the tags, but not for the COMMENT tag, each time I edit some words in it and apply and exit, and check again, the COMMENT tag change back to blank. But I'm sure the tag is saved cuz I can see it if I open the mp3 file in foobar2000 or iTunes, but in explorer, I cannot. What's wrong with it ?

    BTW, this problem happen to mp3 files only. wma or other audio files works all right.


    Wednesday, April 17, 2013 1:11 PM
  • I dindt read the entire thing, got to the talk about ID3v1 and ID3v2.

    Found out I could use my winamp to fill out the locked datafields by viewing file info in winamp and pasting the right info in the ID3v2 field + copying it to the ID3v1 tab.

    Thursday, July 25, 2013 6:13 PM
  • Tried a few things and this one worked. Anyone that needs to fix the tags on their music should try this. Foobar is a music player that you might like also, I had VLC so it was just replaced. Plus now I can fix all my music the way I like.

    Thanks again.

    Monday, July 29, 2013 7:28 AM
  • Great! It Worked!

    Thanks a lot.

    Sunday, August 25, 2013 9:10 PM
  • Thanks, I had the same problem but with Windows 8.1.

    I troubleshoot by following the steps you gave.

    Thanks again,

    nuno1430

    Wednesday, November 20, 2013 6:54 PM
  • Dont know if this was solved for everyone but it has been driving me bananas finally found a way to do it. It involved VLC media player WHICH is my default player anyway.

    If you play the song, then right click on it in VLC then information it will let you delete the wrong info or the info you dont want, and then click save meta tag and you are done.
    Tuesday, November 26, 2013 6:06 PM
  • As I understand it is that the file is tagged as system and hidden

    the solution is to go to command line(I did it as Administrator)

    and chage the two attirbute simultaneously

    for example:

    say you have "song.mp3" in "c:\music\"

    if you try

    attrib -h c:\music\song.mp3

    you get this message

    "not reseting hidden file"

    if you try

    attrib -h c:\music\song.mp3

    you get this message

    "not reseting system file"

    THE TRICK IS TO USE THEM BOTH IN ONE COMMAND

    attrib -h -s c:\music\song.mp3


    Friday, December 20, 2013 7:33 PM
  • I had this issue and found a solution. Right-click on your file > uncheck Read-Only and click Apply > Without closing the dialog box, go to Details and you should be able to edit the info. Once you close the dialog box the Read-Only box will automatically re-check itself.
    Friday, February 07, 2014 11:14 PM
  • Guys, I'd suggest using an id3tag editor like TagScanner (http://www.xdlab.ru/en/download.htm). It's free and the developer even made a portable version (http://xdlab.ru/files/tagscan5.1.625.zip), which means you don't have to install shit. Simply download, open the program and re-tag whatever you need, and delete it. Clean, fast, no install.


    To edit tags:

    1. drag and drop files to tagscanner, push the tag editor tab (top left)
    2. select mp3s and add info (right, under main)
    3. save (bottom right)

    Sidenote: you can also use tagscanner to save changes to all tags at once (id3v1, id3v2 and ape).

    To add to this here is a site from Lifehacker of 6 IDV3 tag editing software (and most of them are free). Just drag and drop the files in question and you can edit them all in Excel-like ability.

    six best mp3 tagging tools (most are freeware)

    Using arcane command line prompts is NOT the way a UI that is graphical is supposed to be used in our modern age. Otherwise we would all be using command lines to get everything done.


    • Edited by passionfly1 Tuesday, February 18, 2014 11:30 PM
    Tuesday, February 18, 2014 11:29 PM
  • FOUND THE SOLUTION! Hope this will get everyone's attentions. I had hundred of mp3 files that somehow I cannot edit the file properties after transferred. When I read this forum, Tim De Baets said "convert file" at this point a light lits up in my poor memories head that I've solved this problems 3 years ago on Win XP machine. Please be asure that this problem have nothing to do with OS's or permissions to files or folders. Here is the solution: go to: http://download.cnet.com/Freemake-Video-Converter/3000-2194_4-75218346.html and download and install this Freemake video/audio converter (CNET is safe place). I also used "Real Player Converter" but like Freemake better. Run FM, highlight defected files or a single file and drag it onto FM windows, Click "Convert" and select "wmv" and put the completed files wherever you like(take all defaults and do not change any property). After the files converted, repeat the same procedures to converted all the wmv files back to the mp3 then all the meta data will reappeared automatically. Sorry that this process take times to convert but it's the only way I know how. Best of lucks.
    Saturday, March 22, 2014 4:24 PM
  • friends it is very easy... do this steps
    1. first open the MP3 song on notepad++ ( some symboles are visible dont mind that)
    2. then go to edit menu on notepad ++ and select ------> clear read only flag
    3. next close notepad
    4. finally right click on the song and go to properties and change the artist, album name.. 
    doneeeeee
    thank you.. it will work.... do it.. IT IS WORKING ON ALL WINDOWS OS
    God bless you....



    Tuesday, May 13, 2014 10:39 AM
  • I found out that my problem was just because I had the song open in Windows Media Player while I was trying to edit it and once I closed out of it on WMP I was able to edit everything.
    Sunday, May 25, 2014 4:34 PM
  • This worked for me, I was having troubles with some .mp3 files, and was able to edit them using MP3tag.

    Thanks for the solution!

    Saturday, May 31, 2014 9:00 PM
  • - I HAVE FOUND A SOLUTION -

    Okay, so what you need to do is as follows:

    • You're going to want to navigate to your "Music library" or "My Music" or whatever.
    • Find the ALBUM/FOLDER (NOT THE ACTUAL SONG OR MUSIC FILE) within your "Music library" that the music files you are having trouble with are found.
    • Right click on the folder and go down to "Properties"
    • Now click on the "Advanced" button at the bottom of the window.
    • Un-tick the second box down, it should read "Allow files in this folder to have...blah,blah,blah... properties."
    • Click "Okay"
    • Now click "Apply"
    • And as if by magic, you can now edit the information of the MP3 files contained in that folder.

    This is what worked for me, for other individuals it may differ however try this method first if you don't want to use converters and other things which drop the quality of the file.

    If you would like a video tutorial and I get a high enough demand, I will upload one to YouTube and link you guys to it.

    Luke

    Sunday, June 08, 2014 8:44 PM
  • 30 SECOND SOLUTION !!!!!

    Go to properties, and de-select read only box and then click ok. DONE!

    Thursday, September 11, 2014 8:28 AM