none
Dual Monitors Windows 7 Problems

    Question

  • Ok, this problem is getting really annoying and I think its a problem with windows 7 itself and not my computer.

    Basically I have a dual monitor setup with the left hand monitor as my secondary and right hand monitor as my primary.  Whenever I have an application with any graphics on it at all such as a progress bar on my left hand monitor moving windows around becomes laggy and juddery, yet this doesn't happen when the graphical app is on my primary monitor!

    My system Specs: 
    ASUS Striker Extreme MOBO
    OCZ 850W gameXtreme
    Core 2 Duo 2.4GHz CPU
    4GB (4x1GB) OCZ DDR2 1066MHz RAM
    Nvidia 8800GTX
    Sound blaster x-fi Xtreme Gamer (older PCI version)
    3 x 80GB HD for system drive in RAID 0
    1 x 500GB and 1 x 250GB drives for storage
    Monitors are 1680 x 1050 res

    Windows 7 Exp Index:
    CPU: 5.9
    Memory: 5.9
    Graphics: 6.8
    Gaming Graphics: 6.8
    Primary HD: 5.9


    What iv tried:
    • Updating to latest drivers
    • Upgraded system memory from 2GB to 4GB
    • Installing 64-bit version
    • removing sound card and re-installing windows from scratch
    • upgraded my PSU

    Thanks for your help!


     
    Thursday, November 05, 2009 11:06 PM

All replies

  • Please capture a screenshot when the issue occurs and submit to your SkyDrive. From the screenshot we can see the detail situation.
    Arthur Xie - MSFT
    Friday, November 06, 2009 8:37 AM
    Moderator
  • I am unable to capture a screenshot of the issue because no lag is seen.  To see the lag it would require a video.
    Friday, November 06, 2009 3:13 PM
  • It should be compatibility issue of the application. What is the program? Is it indicated to be compatible with Windows 7?  
    Arthur Xie - MSFT
    Thursday, November 12, 2009 9:24 AM
    Moderator
  • same issues here with win 7 64, 4 g ram, ati radeon card 512 mb. i don't use graphic intensive apps but it always occurs after sleep mode and requires a hard reboot.
    Thursday, November 12, 2009 1:47 PM
  • It should be compatibility issue of the application. What is the program? Is it indicated to be compatible with Windows 7?  
    Arthur Xie - MSFT

    It's ANY application.  Any application will experience the problem and ANY application with a slight amount of graphics being processed placed on the left hand monitor will cause other windows to become rough and laggy during moving them.
    Saturday, November 14, 2009 2:37 PM
  • is this after waking from sleep mode? i did some testing and what i found is for me anyway, the video gets corrupted after waking from sleep mode. if i set it to only power down the monitors, it doesn't wig out.
    Saturday, November 14, 2009 2:39 PM
  • is this after waking from sleep mode? i did some testing and what i found is for me anyway, the video gets corrupted after waking from sleep mode. if i set it to only power down the monitors, it doesn't wig out.
    Nope, my computer never sleeps or hibernates so defiantly not the cause.
    Sunday, November 15, 2009 10:40 PM
  • I have the exact same problem. Win7 Home Premium x64, Intel Core 2 Duo E8400 @ 4.01GHz, NVIDIA GeForce GTX 280, 4GB DDR2-800MHz, left (primary) monitor is 1680x1050 and right monitor is a 1360x768 TV. It only occurs with NVIDIA'S WDDM 1.1-enabled drivers.

    So here are the workarounds.
    1. Disable transparency effects.
    2. Disable Aero entirely (less desirable).
    3. Backtracking to the 182.50 drivers, which are only WDDM 1.0-enabled, completely eliminates the problem for me (they're at nvidia.com under Beta/Archived drivers). http://www.nvidia.com/object/winvista_x64_182.50_whql.html

    The choppiness is due to a VSYNC step-down in the desktop window manager. As an example of this phenomenon, in video games with VSYNC enabled, when the full refresh rate is unable to be met (typically 60FPS), fractions of the refresh rate will be attempted in a "step-down" (30FPS, 15FPS, etc.). Using Fraps and instructing it to monitor Aero has shown this to be the case. When the refresh rate for my primary monitor is set to 60Hz, during these moments of choppiness it is shown to bog down to exactly 30FPS. When the refresh rate is set to 75Hz, it will bog down to between 37 and 38FPS, sometimes dropping all the way to 25FPS (1/2 and 1/3 of the refresh rate).

    It's not just moving windows around that triggers it--it's ANYTHING that involves Aero. If the overall framerate for one viewport (in my case, the secondary monitor) is high, and Aero interactions on the other monitor cause its framerate to become high as well, choppiness ensues. Here are some other triggers I've found which cause Aero to reach a high framerate, triggering its part of the problem:
    1. Orange taskbar glow for an application desiring attention.
    2. Moving the mouse across the taskbar icons or the minimize/maximize/close buttons of an unskinned (Aero-style) window.
    3. Hovering over a taskbar icon to produce a thumbnail of an application on the other monitor which is running at a high framerate.

    Uh, as for a solution, I don't have one, but the workarounds should do, for now. I've reported the problem to NVIDIA through their feedback system, but I'm not sure if the responsibility lies with them or not.

    Interestingly, no matter which DVI port I plug the monitors into, and independently of which monitor is primary or secondary, for me the problem is always related to high framerates on the right monitor and Aero interactions on the left. *shrug* I'm not a driver developer, so I can't say what that means, except that it makes it seem like a low-level driver issue (i.e. NVIDIA's issue to solve).

    The high-framerate application on the secondary monitor (or in OP's case the left monitor) need not be graphically intensive whatsoever. It could even be a high-framerate GIF file. I've used NVIDIA's System Monitor to monitor CPU and GPU usage during some instances of this problem. The CPU and GPU usages were under 10%.
    • Proposed as answer by Twizzlerite Thursday, November 19, 2009 3:06 AM
    Wednesday, November 18, 2009 2:17 AM
  • Thanks for the suggestion, Vegan Fanatic! Unfortunately, the problem continues for me after installing 195.55 beta. Are you running dual monitors? And if so, what resolutions? (The monitor models would be interesting to know, too.)
    Wednesday, November 18, 2009 8:14 AM
  • Sounds like a plan. Alternatively, the 182.50 drivers work flawlessly.
    Wednesday, November 18, 2009 8:25 PM
  • I have the same issue here with a 9800GT using any recent driver, including the latest beta. I've reported the problem to nvidia.
    Sunday, January 10, 2010 4:19 AM
  • I have been searching the web for two weeks or more looking for an answer to this problem. After reading hundreds of posts, this is by far the best explanation I found for my issue.  I was experiencing pretty much the exact same behavior you described Twizzlerite.  I use MediaPortal as my media center which opens on my secondary monitor and suddenly in Win7 64 bit with the new nVidia drivers, everything was choppy, even though the same hardware (8600 GTS vid card) worked fine in XP and even reasonably well in Vista 32 bit (with older drivers) while Aero was on. 

    For now, I just created a shortcut to disable Aero when MediaPortal opens and re enable Aero when MediaPortal closes (Shortcut - Compatibility Tab, Disable Desktop Composition), and all is working well. Hopefully, one day nVidia and MS can sort this out! 

    Thursday, March 11, 2010 4:41 PM
  • I suggest looking for updated drivers weekly.

    LOL, that comment should probably be rescinded around now .

    Anyway, Dadadeo, glad you found a workaround, unfortunate as it is. There's been no fix or acknowledgment of this problem by NVIDIA as of yet, as far as I know. I am not holding my breath for a fix, as they are starting to seem incompetent, especially given the driver problems on my laptop, along with this latest debacle...
    Thursday, March 11, 2010 8:48 PM
  • To be honest Twizzlerite, I am not convinced this is really an nVidia driver issue. I have continued reading tons more posts about similar problems using dual monitors in Win7 even which also occur with other gfx cards, and turning Aero off can workaround the issue in most cases. Everyone seems to blame the graphics drivers, but the problem appears to lie with DWM/Aero taking control. I have tried changing VSync and other settings in nVidia drivers and Aero appears to override them. Many sites suggest altering hardware acceleration settings using the Troubleshoot tab in Display Settings. But that is grayed out for me! DXDiag does show acceleration is enabled. I originally had the same issue on my desktop. However, when I removed a faulty gadget it cleared up the fps dropping on my desktop. ??? (figure that one out!) I have read other posts where users have resolved the issue by changing priorites of some other apps. It's odd because Taskbar manager shows my CPU performance pretty steady at about 18% and memory steady at 40% while playing HD videos. No change in CPU or RAM is recorded when Aero suddenly has a flippy and decides to reduce framerates. I still suspect some app may be giving it the jitters! So it's back to hunt and peck!
    Wednesday, March 17, 2010 7:58 AM
  • I can't seem to find AMD users with this issue in my searching, Dadadeo. There were lots of dual monitor issues in early Windows 7 drivers from both sides, but they usually manifested themselves in gray/black screens and crashing. I'm glad that's over (well, I hope it's over; I never experienced it), but it's different from what we're seeing here.

    If you've found otherwise, please share! :)
    (I'd mention Intel but I don't expect integrated graphics to perform decently anyway. Funny thing is, having said that, they probably don't have these issues.)
    Wednesday, March 17, 2010 10:52 AM
  • I have found the cause of this bug, and a reason why some experience it and others don't. I have another workaround.

    My Dell 2007WFP running on DVI shows in Windows as 60Hz, but the manual says it really runs at a maximum of 59.9Hz on its digital input. The manual for my second monitor, however, a Sony Bravia KDL-32S3000 (yes, a TV), shows exactly 60Hz as its maximum vertical refresh rate.

    My primary monitor, the Dell, allows me to select 75Hz as the refresh rate at low resolutions. In experimenting, I found doing this aggravates the problem to an extreme. That's what got me thinking the problem was related to refresh rate.

    One workaround is using NVIDIA's "Custom Resolutions" to add a 59Hz for both monitors. There seems to be a problem setting specific refresh rates using this method - even though it allows you 3-decimal precision, it appears anything after the decimal point is not actualized. Theoretically, I could set my TV to run at 59.9Hz as well, and this would solve the problem, but since I can't get that level of precision, and the Dell can't reach 60Hz digitally, I have to set them both to 59Hz. This causes a little blurring and color distortion on my Dell, so it's not desirable, but it does eliminate the performance issues.

    However! Luckily for me, the Dell's manual does show that running on VGA, the monitor can reach a full 60Hz. So, I tried switching to VGA for my Dell, and the problem vanished entirely.

    The fact that everything performs just swimmingly without Aero interaction proves this is a bug *somewhere*. I can be playing a full-screen game at 60fps on one monitor and watching a video on the other with no performance issues, using DVI or VGA, and not even having to think about refresh rates. I tested this just now with my original setup; it's amazing how moving the mouse over the taskbar can bog everything down whereas Dragon Age Origins at 1680x1050@60fps won't. It is only when Aero comes into play that this stuttering occurs.

    I've tried manipulating 3D settings for dwm.exe and it has no effect. I am starting to wonder if you're right, Dadadeo, but I don't have a new enough AMD card to test this (it's limited to, or at least exacerbated by, WDDM1.1 after all).

    So in summary, WDDM 1.1 and Aero (at least with NVIDIA cards) are especially picky about the refresh rates for your connected monitors being identical. If they aren't, you'll suffer from these performance issues.
    • Edited by Twizzlerite Thursday, March 18, 2010 3:12 AM cleaning up
    Thursday, March 18, 2010 3:10 AM
  • An update on this issue. While using VGA, and thus giving both monitors a more similar 60Hz resolution, significantly reduced the presence of this issue, it did not eliminate it entirely. It basically takes a lot more Aero interaction to set it off, but it will still happen.

    Meh. I doubt I can find anything else out on my own. This is for NVIDIA/Microsoft to fix; I can do no more.

    Tuesday, March 23, 2010 6:23 AM
  • (Latest update) This is the best I can do to alleviate the problem, and does reduce its severity immensely, but I found myself still noticing some slight playback glitches in videos on my second monitor which probably also translate to anything else with movement. I have tested with a panning scene in one of my videos and there is a subtle micro-stutter on my second monitor which I can find no way to fix. This doesn't occur if outputting to a single display, one or the other, nor does it occur when playing the video on my primary monitor in a dual-monitor configuration. Note that when I say "primary monitor", I am not referring to the monitor Windows has marked as primary, but my actual monitor rather than TV. In a dual-monitor configuration, this micro-stutter will only occur when playing video on my right monitor (TV), regardless of settings or which ports the monitors are connected to on the GPU. The micro-stutter occurs with no relation to the activity on the other screen, as it can be completely still. I can confirm the micro-stutter does not occur at all with Desktop Window Manager (Aero) disabled. In short, this is a nightmare.
    (Note that this micro-stutter is equally replicable in the 182.50 (WDDM1.1-less) driver, meaning there is no way to solve it other than disabling Aero or outputting to a single monitor.)

    I think I've solved the problem.. for me, anyway. I've divided this into short answer and "long answer", which is closer to a stream of consciousness in some ways, as I found out about Force10Level9 as I was writing.

    The short version:
    I've found some registry keys which seem to have fixed the problem for me. I haven't experienced any side effects, but use the tweaks at your own risk!

    I don't know exactly what they do. This comes from a lot of.. experimentation. I believe FrameRateMin tells the Desktop Window Manager that it's crucial to try to keep the framerate at or above the value specified (more details below), and Force10Level9 sounds like it forces DWM to use DirectX 9. I'm fairly certain about the former, not as certain about the latter, but together they do wonders.

    You can view the fix below. You can then save it as a .reg file and import it into your registry. Restart the Desktop Window Manager service or reboot to see the changes.

    Fix: http://pastebin.com/FFDbubw9
    Undo: http://pastebin.com/zA8CJY06

    (P.S. Just ran a FurMark test between fix applied and no fix. No difference in performance, with an inactive secondary monitor. I also noticed no difference in Physical Memory usage as reported by Task Manager. YMMV, let me know if you have any side effects.)
    (P.P.S. The screen fade that happens when you log in/out is just as choppy as before (or if it wasn't choppy for you, that shouldn't have changed). Oh well, how often do we see that thing, anyway? :))

    By the way, it appears 10Level9 is Windows 7's emulation platform for running DX10 on DX9 hardware. It's reported to be at least a 0.5x performance hit, so it's surprising that it actually makes Aero run better. If this article is anything to go by, Force10Level9 makes Aero run exactly the same as it does with older WDDM 1.0-only drivers like 182.50: http://www.techarp.com/showarticle.aspx?artno=637&pgno=1

     

    The long version:
    Well... I was able to do one more thing.

    There is an undocumented registry key which allows you to fine-tune the Desktop Window Manager's scheduling. Unfortunately, all of its values seem to be defunct in the final version of Windows 7 we all use today... except one: FrameRateMin.

    From what I gather, the Desktop Window Manager (Aero) carefully monitors the framerate it is able to achieve, and when it can't measure up to its own expectations, it will perform a "step down", or framerate reduction, and maintain this lower framerate for a given period of time (at one time specifiable with a registry value) before trying again at maximum speed.

    I presume it does all this to keep things looking "smooth".

    The problem is, in most cases, it doesn't help, and actually prolongs the stuttering duration. By "in most cases", I mean in every case it's happened in my personal usage of my Windows 7 computers.

    So what helped me was setting this FrameRateMin value to 60. That way, the Desktop Window Manager considers anything under 60fps to be unacceptable and will not remain at a lower framerate for purposes of perceived smoothness. Thus, the stuttering will take up as little time as possible, making it nearly unnoticeable most of the time.

    Keep in mind DWM shouldn't be having performance problems to begin with, but apparently in some cases, like with my particular hardware (desktop and laptop) and the latest NVIDIA drivers, it does.

    Down to brass tacks. The registry key is HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\DWM\Schedule. The value is FrameRateMin, a DWORD representing the minimum framerate DWM will consider as acceptable. I set it to 60, but you can set it to whatever you want.

    To repeat, this WILL NOT prevent Aero from ever getting below the framerate you specify; it simply prevents Aero from retaining a lower framerate after a stutter in order to give the illusion of smoothness (an illusion which fails).

    I imagine the main reason it fails so spectacularly in my usage is because I watch a lot of videos which play back at 24fps. Such a framerate plays back terribly with a 30Hz refresh rate, which is what Aero would reduce itself to for extended lengths of time. Now, performance hiccups are minimal, but sadly still existent.

    So this isn't a solution, but it does help. I am still uncertain of where the problem lies, considering GPU-Z shows graphics card loads to be as low as always when it's happening.

    Oh, and I found one more registry value. This one is far more important. :) It solves the problem for me entirely, from what I can tell.

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics

    add the DWORD value Force10Level9 with a value of 1.

    I haven't noticed any side effects, just smooth performance.

    Apply these tweaks at your own risk!

    • Proposed as answer by Twizzlerite Wednesday, April 07, 2010 12:41 PM
    • Edited by Twizzlerite Wednesday, April 07, 2010 8:16 PM 10Level9
    Wednesday, April 07, 2010 12:31 PM
  • This will be my closing post on the issue.

    I have just tried an older card, ATI Radeon X800XT, vs my newer NVIDIA GeForce GTX 280. The Radeon is slower for games, but for dual monitors, it is smooth as silk.

    As I mentioned in my last post, I recently noticed a "micro-stutter" on NVIDIA's latest drivers, and even on their older WDDM 1.0-only drivers. This leveled the playing field for testing my older ATI card, as it is not DirectX 10-capable and thus cannot support WDDM 1.1.

    I can report that the ATI card demonstrates no such micro-stutter OR lasting stutter whatsoever, with or without my registry modifications. In fact, seeking H.264 Matroska seemed to be a lot more responsive, and no matter what my monitor configuration, video playback appeared smoother; it looked like there were more frames, somehow, which surprised me.

    These are subjective tests, but in repeating the same panning scene 15 times, there was no micro-stutter with the ATI card on either monitor, and it even appeared to have more frames to work with, as the playback was quite smooth (in my opinion it appeared about twice as smooth).

    I will not be buying another NVIDIA product. Their motherboards are garbage, and apparently their drivers are the same.

    So here are your choices: stop using NVIDIA, stop using multiple monitors, or stop using Aero. If any of this is out of the question, you can improve your results with my workaround in the post above, but the micro-stutter cannot be eliminated entirely.

    • Edited by Twizzlerite Thursday, April 15, 2010 6:01 AM grammar
    Thursday, April 15, 2010 6:00 AM
  • The short version:
    I've found some registry keys which seem to have fixed the problem for me. I haven't experienced any side effects, but use the tweaks at your own risk!

    I don't know exactly what they do. This comes from a lot of.. experimentation. I believe FrameRateMin tells the Desktop Window Manager that it's crucial to try to keep the framerate at or above the value specified (more details below), and Force10Level9 sounds like it forces DWM to use DirectX 9. I'm fairly certain about the former, not as certain about the latter, but together they do wonders.

    You can view the fix below. You can then save it as a .reg file and import it into your registry. Restart the Desktop Window Manager service or reboot to see the changes.

    Fix: http://pastebin.com/FFDbubw9
    Undo: http://pastebin.com/zA8CJY06

    (P.S. Just ran a FurMark test between fix applied and no fix. No difference in performance, with an inactive secondary monitor. I also noticed no difference in Physical Memory usage as reported by Task Manager. YMMV, let me know if you have any side effects.)
    (P.P.S. The screen fade that happens when you log in/out is just as choppy as before (or if it wasn't choppy for you, that shouldn't have changed). Oh well, how often do we see that thing, anyway? :))

    By the way, it appears 10Level9 is Windows 7's emulation platform for running DX10 on DX9 hardware. It's reported to be at least a 0.5x performance hit, so it's surprising that it actually makes Aero run better. If this article is anything to go by, Force10Level9 makes Aero run exactly the same as it does with older WDDM 1.0-only drivers like 182.50: http://www.techarp.com/showarticle.aspx?artno=637&pgno=1

    My problem is running Media Center in full screen on my second monitor where as the video would stutter in full screen mode. The above fix helped reduce the stuttering a lot (thank you), but it did not completely resolve the problem as there was still a slight stutter (is this what you mean by 'micro stutter'?).

    By running MCEMultiMon, I can use that to make media center appear as full screen and together with the above fix, no stuttering :)

    Here the link for MCEMultiMon.

    http://www.ryansfindings.com/apps

    Sunday, May 30, 2010 3:51 PM
  • The above fix helped reduce the stuttering a lot (thank you), but it did not completely resolve the problem as there was still a slight stutter (is this what you mean by 'micro stutter'?).

    Most-likely, yes. The micro-stutter I experienced appeared to be, to the best of my memory, a missing frame every 60 or so frames. 60 is a complete guess by the way, I can't quite remember and I'm writing this from another computer. Besides, I've resorted to disabling Aero every time I want to watch a video, which fixes the stutter problem. Unfortunately, with Media Player Classic, this creates an odd "bar" at the bottom of the second monitor which has VSYNC issues, but I just pretend it isn't there, because I'll drive myself nuts if I keep trying to fix NVIDIA's problems.

    Fascinating that MCEMultiMon fixes it for you with MCE. Glad to hear that. I wonder why it fixes it.. And I'm glad my registry modifications were able to assist someone.

    In any case, this is a problem that NVIDIA needs to look into, but I doubt they will, because if you ask me, they're all about numbers. They want the fastest framerates, highest benchmark scores, (longest cards *cough*) and could care less about customers or quality until there are enough complaints. Though in that same regard, if a large enough number of people reported issues with this, they might care. I'm most-likely describing every corporation in existence, but I like to give them the benefit of the doubt.. NVIDIA had that benefit long enough from me, and I no longer respect them as a company.

    I've reported the problem 2-3 times via their driver feedback page over the course of a year or two, and not one visible attempt has been made to solve it. Never a word about it in the change log, etc.

    In all honesty, as obnoxious as this problem is to those of us that can see it, I'd wager most people don't pay enough attention to detail to notice, let alone care, regardless of how much money they spent on their graphics card. And since it only occurs in multi-monitor scenarios, the number of users it "affects" is naturally going to seem low.

    So, if you're just reading this thread and this problem affects you, try the workarounds, particularly disabling Aero as it is the easiest and most effective, and hang in there until your video card becomes obsolete, at which point.. buy an ATI (or Intel, lol, if they have (decent) discrete cards out by then).

    Sunday, May 30, 2010 10:09 PM
  • Ihave ATI HD 5750 and the same problem.....I ll tell more soon....really, W7 is still for unpretentious people, like iPhowne

     x64, 10.5 catalyst, Mediaportal (even MPC or WMP)

    more info: so just turn off aero but vsync is not working......probably bug of W7

    edit: the hack of Twizzlelerite works in 95 %...thank you!

    • Edited by maysider22 Wednesday, June 02, 2010 2:20 PM more info
    Wednesday, June 02, 2010 11:15 AM
  • Thanks Twizzlerite,

    Your regentries sort of fixed the issues as far as I can see. I started looking at the issue after a number of weeks, actually not wanting to watch any movies, due to the jerkiness seen, and the hazzle of shfting primary screen. I really don't want to fiddle too much (unless it can be automated). And then I came across this thread :)

    Strange thing. I use a number of different HTPC software and players, where XBMC has been my primary player for a while. I also use VLC, DirectShow players like ZoomPlayer, grapedit to verify codecs, etc. All of these encounter the problem described, without the fix. Yesterday I took time to set up Windows Media Center for a try. Also for playing on my secondary display. Screen manually set to 24Hz, and played a 720p MKV file - without any jerkiness what so ever! Strange MCE works for me but not you others :-\ Or has there been any patches applied on MCE? And again, this was before applying the "hack".

    My system:

    Windows 7 x86, AMD Phenom X4 9850, ATI 5750

    Primary (right hand side): DELL 24" 1920x1200 @60

    Secondary (left side): Samsung 40" 1920x1080p @60, @50, @24 (depending on movie), adjusted by XBMC.

    Thursday, July 22, 2010 10:54 PM
  • I have ATI Radeon 3100 HD built-in graphics and experience a similar issue.  Video plays fine on my primary monitor but is not smooth on my second monitor (a 42" plasma television).  However, when I set Windows 7 to optimize my graphics for performance (removing Aero, etc) then it works fine.  I would imagine the built in graphics could handle two monitors but maybe not?  Any input from those who are more into the graphics hardware/driver sort of thing?

    Thanks!

    Thursday, August 19, 2010 4:32 AM
  • so AMD support has written this:

     

    "AMD Engineering is aware of the issues and working on them with Microsoft and the driver team.

    You have covered all of the workarounds we have to suggest in your submission."

    Wednesday, November 24, 2010 12:10 PM
  • I've had similar problems with various PCs... common elements: dual monitors, nvidia graphics.  My standard answer to folks asking me about graphics cards the past decade has been something along the lines of "ATI makes some really fast hardware, but their drivers are horrible; stick with nVidia!".   I don't know if Aero / DWM or the graphics drivers are to blame here, but my opinion of one company vs. the other has changed.

    Most of my graphics issues appear when using regular windows apps (visual studio, SQL mgmt studio, IE/Chrome) and when scrolling or dragging windows around.  Especially noticeable when dragging a window from one screen to the next.

    Anyway, in my case, it has been a stuttering problem with various Quadro cards.  Previously it was an NVS-295 and a pair of Dell E207WFP panels at 60hz, so no cross-display mismatch ( I don't think)  I had the same graphics card at home with a pair of 2208 WFPs and NO stuttering problems.. so it might have been an interface issue or some other system difference.

    My current system is a dual Xeon X5680 with 24GB of ram and a Quadro 2000 driving a single Dell 2408.  This thoroughbred definitely shouldn't be "stuttering"!  Then I added my old NVS-295 & E207's into the mix, and that's when the video lag and judder began. That older/smaller card is relatively weak, so I was able to transplant an older, but likely more powerful, Quadro FX 4600.  The problem seemed to get better, but not much...

    After reading these posts, I just changed the E207's to use a customized 59hz refresh rate to match that of the 2408.  At a glance, it seems to have helped.  I've just made the registry changes & will see if that does any additional good.

    [Update]

    between the refresh rate tweaks & the registry tweaks, Twizzlerite's fixes have *mostly* resolved the issue for me too!

    • Edited by xyvyx Wednesday, January 19, 2011 10:08 PM update
    Wednesday, January 19, 2011 8:54 PM
  • Another update...

    The combination of the updates above with the nvidia 266.45 Quadro drivers  (released on Jan 12, 2011) has resolved my video issue 100%!  Dragging windows around across monitors and scrolling is liquid-smooth.  Don't know about higher-res video, but 720p via youtube (with Flash version 10,1,102,64) is about as good as I've ever seen.

    Friday, January 21, 2011 8:35 PM
  • I also have a problem on dual displays on extended mode. That is Secondary display flash garbage when change setting on primary display (Extended display mode) on Win7.

     

    Here is my reproduce steps:
    1. enter Win7 with LVDS+DP(Dell 2711).
    2. Open CUI,
    3. Change to "Extend-Pri/LFP+ Sec/DP(Dell 2711)".
    4. Change the resolution of "LFP" from lower to higher (ex: 800x600->1024x768 or 800x600->1280x800, or 1024x768->1280x800) -->Issue (garbage) happens

    In my experiments, not just LVDS+DP combinations, Any two display devices can also cause the same issue such as DP+HDMI, LVDS+CRT, DP+CRT...under extended display.

    I also try the same issue on Navidia 3rd-party card, issue is also happening.

    In extended display mode, for example,

    When LVDS is setting 800x600 resolution, CRT external extend display is using 800x600 desktop picture in 1280x800 resolution.

    When LVDS is setting 1024x768 resolution, CRT external extend display is using 1024x768 desktop picture in 1280x800 resolution.

    When LVDS is setting 1280x800 resolution, CRT external extend display is using 1280x800 desktop picture(fill all screen now) in 1280x800 resolution.

    It is looking like OS is helping change the size of desktop picture on secondary display, but the speed is not as fast as possible thus users see the action of changing desktop picture with new picture size and feel a flashing garbage.

    Is it the known issue on win7 OS?

    Thursday, September 01, 2011 6:30 AM
  • I have this problem too. Have been using a Dell 2408 with a Samsung Syncmaster 22' with no problems. Decided to replace the Samsung with a Dell U2410, so I'm using that with the 2408 in a dual monitor setup.

    Aero movements lag when on the 2410 (primary monitor). They don't lag when they're on the 2408, nor do window movements lag when the window is across both monitors (i.e dragging from the 2408 onto both, and moving up/down). Funnily enough, sometimes if I drag a window from the 2410 onto the 2408 it'll keep lagging until I 'let go' of the window on the 2408 and then click on it to start dragging again, at which point it's silky smooth once more.

    Also, other 3D apps don't lag on either. Funnily enough, Ubuntu running it's 3D UI (Unity) in a virtual machine (with 3d acceleration) is also silky smooth on both monitors.

    My graphics card is a GTX 560 Ti, with 2gb Vram (so plenty for driving both monitors at 1920 x 1200), and I've got the latest drivers/patches and everything is up to date.

    None of the fixes suggested here seem to work :(

    Hopefully NVidia/Microsoft will sort this out as it's a really annoying bug, affecting things like window minimise/maximise animations too. It's always there and really frustrating!


    • Edited by AlistairG87 Thursday, September 08, 2011 12:21 PM added detail
    Thursday, September 08, 2011 12:18 PM
  • Alistair, 

     how are both of these monitors connected? DVI or maybe display port?  If you swap physical connections and/or designation of the primary monitor, does the lag follow the monitor or the connection?  Can you verify the refresh rate in the LCD's info menu?  If I remember correctly, one of my problems was that setting the E207's refresh rate to 59Hz had no effect.. it was still being sent a 60Hz signal.

    Hmm.. if it helps any, compare your refresh rates & driver versions... granted, my drivers aren't the most current now...

     

    [Display]

    Operating System: Windows 7 Professional, 64-bit (Service Pack 1)

    DirectX version: 11.0 

    GPU processor: Quadro 2000

    Driver version: 266.45

    DirectX support: 11

    CUDA Cores: 192 

    Core clock: 625 MHz 

    Shader clock: 1251 MHz

    Memory clock: 1304 MHz (2608 MHz data rate) 

    Memory interface: 128-bit 

    Total available graphics memory: 13054 MB

    Dedicated video memory: 1024 MB GDDR5

    System video memory: 0 MB

    Shared system memory: 12030 MB

    Video BIOS version: 70.06.0D.00.02

    IRQ: 24

    Bus: PCI Express x16 Gen2

    GPU processor: Quadro FX 4600

    Driver version: 266.45

    DirectX support: 10

    CUDA Cores: 96 

    Core clock: 500 MHz 

    Shader clock: 1200 MHz

    Memory clock: 700 MHz (1400 MHz data rate) 

    Memory interface: 384-bit 

    Total available graphics memory: 4351 MB

    Dedicated video memory: 768 MB GDDR3

    System video memory: 0 MB
    Shared system memory: 3583 MB

    Video BIOS version: 60.80.0B.00.06

    IRQ: 30

    Bus: PCI Express x16

     

    [Components]

     

    nvui.dll 7.17.12.6645 NVIDIA User Experience Driver Component

    nvxdsync.exe 7.17.12.6645 NVIDIA User Experience Driver Component

    nvxdplcy.dll 7.17.12.6645 NVIDIA User Experience Driver Component

    nvxdbat.dll 7.17.12.6645 NVIDIA User Experience Driver Component

    nvxdapix.dll 7.17.12.6645 NVIDIA User Experience Driver Component

    NVCPL.DLL 7.17.12.6645 NVIDIA Compatible Windows Vista Display driver, Version 266.45 

    nvCplUI.exe 3.5.792.0 NVIDIA Control Panel

    nvWSS.dll 6.14.12.6645 NVIDIA Workstation Server

    nvViTvS.dll 6.14.12.6645 NVIDIA Video Server

    NVMCTRAY.DLL 8.17.12.6645 NVIDIA Media Center Library

    nvDispS.dll 6.14.12.6645 NVIDIA Display Server

    NVCUDA.DLL 8.17.12.6645 NVIDIA CUDA 3.2.1 driver

    nvGameS.dll 6.14.12.6645 NVIDIA 3D Settings Server

    Thursday, September 08, 2011 2:23 PM
  • I have this problem and it is driving me nuts!

    I have 2 Samsung SyncMaster BX2231  1920x1080 monitors.
    Latest updated version of windows 7 x64 with SP1
    Latest NVIDIA drivers 280.26

    Any simple graphical movement will cause stuttering in the DWM (desktop windows management) so if I am playing music with windows media player on my left monitor and then drag a transparent windows on my right monitor it has terrible lag! 
    If I minimize Windows media player and then drag a aero transparant windows about there is tiny to no lag!!

    The regedit tweaks posted earlier on in the thread are outdated because as far as im aware you cannot do them anymore because SP1's registry is different. 

    Playing a 1080p MKV video file in VLC media player in full screen on my left monitor is unmatchable with transparency turned on.

    Turning transparancy off does help allot. But I want transparancy!! And also.. I don't want this problem.

    Both of my identical monitors run at 60Hz. I used the NVIDIA control pannel to change them both to 59Hz but It didn't have any noticeable effect and the problem was/is still there!

    I tested the Windows 8 Developers Preview x64 a few nights ago. The problem isn't there!!!! 
    But, I didn't install the nvidia drivers and just used the drivers out the box.

    My graphics card is a GTX 470. Its a really good card. 

    Really dissapointed at this actually, wish somebody would actually read this at microsoft/nvidia and do something about it. It sucks.
    Spending about £300+ for a nice dual monitor setup and then having to loose aero transparancy and have some other problems with lag and movie playback just because nobody seems to care about the problem.

    Im glad Im not the only one looking into this.... lets get it solved.

    PS... anymore news? Improvements? Workarounds? Driver/configuration tweaks?
     
    Friday, September 16, 2011 2:45 PM
  • not all programs will work spanned across monitors

     


    Windows MVP, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint etc.

    My page on Video Card Problems is now my most popular landing page. My Page on SSD is now #2. See my gaming site for game reviews etc.

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Right... we are talking about lag in DWM.
    Friday, September 16, 2011 9:14 PM
  • I've been running a dual monitor setup on a home-built PC, using an nVidia GeForce 9600GT w/2GB GDDR2 VRAM dual-DVI with 2 24" Sceptre LCDs set to 1920x1200 and I have had the problem you describe. Been using Win 7 Pro 64-bit for two years. It IS possible that you might have a monitor about to fail, or the cable may be bad. Have you checked your cables and connections?
    Saturday, September 17, 2011 1:25 PM
  • I have tried multiple video cards and cables and it is not the issue. It id software/system config
    Saturday, September 17, 2011 2:48 PM
  • Moving the Windows Media Center window from one monitor to another causes pauses/lags in playing video. On the same system, Windows Media Player, VLC and QuickTime don't have this issue.

    Software info: Windows 7 Version 6.1.7601.17514.

    • Edited by i.rebel Saturday, October 29, 2011 1:56 AM
    Saturday, October 29, 2011 1:51 AM
  • Moving the Windows Media Center window from one monitor to another causes pauses/lags in playing video. On the same system, Windows Media Player, VLC and QuickTime don't have this issue.

    Software info: Windows 7 Version 6.1.7601.17514.

    We're still having this problem 3 years later...

    Edit: So I've solved all of my performance issues by plugging in my second monitor in to a second GPU I had laying around. I realize that this isn't a solution for single GPU customers, but if you have two GPUs it works great.

    Dual monitor/GPU connection diagram.



    • Proposed as answer by LouisAW Thursday, March 15, 2012 10:30 AM
    • Edited by LouisAW Thursday, March 15, 2012 10:33 AM
    • Unproposed as answer by LouisAW Saturday, March 17, 2012 2:13 PM
    Tuesday, February 21, 2012 2:27 AM
  • LouisAW, 

     in my case, I've always had multiple video cards driving the monitors when this behavior cropped up.  Originally it seemed to be fixed by a number of registry tweaks, refresh rate settings and all the other things mentioned above.  Today I'm using the 276.52 drivers with the same LCDs & cards referenced above.  Somewhere along the way, the refresh rates of my 2408 and just ONE of my E207's got set to 60Hz yet the scrolling remains smooth.

    What drivers and refresh rates are you using?

    Thursday, March 15, 2012 3:22 PM
  • Hi xyvyx,

    Both of my displays are running at 60Hz. 

    I'm using these GeForce R295 drivers (295.73). I just tried updating to 296.10, and the problem came back.

    Looks like I'll be sticking with the 295.73's for the time being.

    Edit: Sorry, I shouldn't have said I solved "all of my performance issues", I still have that lag/blackout when dragging video across monitors. I meant that I solved the issues of video on the second monitor being laggy.
    • Edited by LouisAW Saturday, March 17, 2012 2:13 PM
    Saturday, March 17, 2012 2:05 PM
  • Unfortunately, the problems are back. The dual GPU idea isn't a solution.
    Sunday, March 18, 2012 11:29 PM
  • I was just about to try this. I have 2 GTX 470's
    Does anybody know if this stupid annoying problem is also in Windows 8?
    I honestly can't believe this problem hasn't been solved. Sucks!
    Sunday, May 06, 2012 12:39 PM
  • The problem persists on Windows 8 and Windows 8.1. Further to that the registry keys seem to have disappeared as well so the reg hack likely wont work anymore.

    Having 2x Nvidia GPUs will not solve the problem, I have a pair of 680's and they suffer from it just as badly as a single card does.

    Monday, November 04, 2013 12:27 PM
  • Wow, this thread is four years old and the problem persists.  If anyone can help, I am having this same problem.

    Setup:

    -Dual monitors, both having a native resolution of 1680 x 1050 @ 60 Hz.

    -Win7 Pro x64

    I was running an ATI 4850 with both monitors connected via DVI and had no issues.  I then upgraded to an Asus GTX 660 and started having issues with choppy video.  Typically would occur while playing a 720p x264 mkv video using both Media Center Classic and VLC with the video displaying full screen in the secondary monitor.  The video was just choppy, not the audio, just the video. 

    After doing a lot of troubleshooting, I found a suggestion to run the monitors at different refresh rates. Setting the secondary monitor to 59 Hz did not completely fix the problem, but it made it occur less often.

    I then borrowed a Sapphire HD 7790 from a friend and installed it after using Driver Sweeper to remove all Nvidia drivers.  To my surprise, this did not resolve the issue.  (Both monitors still connected via DVI, neither has HDMI or Displayport.)

    After doing more troubleshooting, including multiple suggestions from this thread, I have finally found that if I set MPC-HC to disable Aero when playing videos, it fixes the problem 100% of the time.  But I have to believe that there is a better solution that this.

    If anyone has any idea what I can do to resolve this I would greatly appreciate it.  I just don't understand how upgrading my video card has caused a downgrade in performance.

    Thanks!

    Saturday, November 09, 2013 4:20 AM
  • 4.5 years later, still happening.

    And for everyone talking about Windows 7, this also happens on Vista, although it is actually less severe despite 7 being a more refined OS.

    GTX 780, 337.50/61 drivers, 2 completely different monitors connected via DVI..

    I didn't spend $700 on my GPU (and $450 on the second monitor) to suffer from a bug that's been happening since WDDM 1.1 came out on NVIDIA hardware.

    I will try the registry tweaks, but I don't see DWM anywhere in the registry in that location, so I'm doubtful it will work. Edit: It's there in HKCU, seems HKLM applies it system wide, which is better.  Disabling Aero is out of the question, as it also disables VSync (critical for LCDs, especially when gaming) and makes the UI ugly to boot.  Not running 2 monitors is also out of the question.

    I've bumped a thread on the NVIDIA forum, but seeing as it's coming around to 5 years since this thread was started, I don't believe it will ever be fixed.

    Windows 8 doesn't use Aero anymore, so things will be fine there, but 8 is the worst Windows OS I have ever tried using, so I won't even touch it, nor 9 if it continues in the same direction. (I had to fix a laptop running 8; a few minutes into my troubleshooting and I wanted to throw the thing out the window, it frustrated me THAT badly.)

    PS: Tried to strike out a portion of my post, but despite it showing in the WYSIWYG editor when editing the HTML, it's not applying when submitting post.


    • Edited by DAOWAce Thursday, May 08, 2014 12:27 PM
    Thursday, May 08, 2014 12:13 PM