none
WDS / WinPE does not find DHCP Server (WdsClient Error)? How?

    Question

  • That one is strange, and it has been on my nerves for about two days now. I simply can not get WDS to work reliably for Vista. I got in two days ONE install going.

    On my workstation (Sn25P, NForce 4 chipset), I run Windows XP and can run FVista perfecty, with DHCP. I can go into the boot manager on start and select the NVidia boot agent, starting the network boot through TFTP. For this, naturally, the DHCP Server in the network is queried.

    THen Windows PE starts, takes some time and - boom:

    WdsClient: An error occured while obtaining an IP Address from the DHCP Server.

    And that is it. But I do have a working DHCP Server. If I make an IpConfig /renew, it reacts immediately, and we have zero negative reports about it.

    Anyone an idea? WinPe does also not seem to have any way to get a logfile, or?

    Wednesday, November 29, 2006 11:46 AM

All replies

  • I have the same issue, I hit <shift> F10 and I get a command prompt, I do a ipconfig/renew and I get an IP address.  So I know dhcp is working.
    Wednesday, December 13, 2006 9:55 PM
  • I am having the same problem using WinPE 2005 and WinPE 2.0 on Dell Optiplex machines.  What model hardware are you two having the problems on?
    Thursday, December 14, 2006 1:41 PM
  • I have a Dell Poweredge 2950 server with a Broadcom BCM5708C Netxtreme II GigE.
    Thursday, December 14, 2006 4:39 PM
  • I am having the same problem here. I inserted the Broadcom Driver into the boot.wim using imagex to mountrw and peimg to insert driver, but alas, no luck. The machine I am using is a Dell D600 with Broadcom 57XX GigEoCu adpater.
    Wednesday, December 20, 2006 5:29 PM
  • I opened up a ticket with microsoft support and with their help we found the solution.  The problem was with the Cisco switch.  I needed to have spanning tree port fast enabled. Once that was done everything was working.
    Friday, December 22, 2006 5:17 PM
  •  

    Hi,

     

    I am having a similar problem.

     

    We have Windows PE (WDS) version running on a Windows 2003 server and our DHCP server is on Windows 2000.

     

    I have Cisco swtiches all over.

     

    You said enabling STP Port Fast

     

    Switch(config)#interface

    Switch(config-if)#spanning-tree portfast

     

    fixed your issue.

     

    Does this have any other impact as I am not a 100% sure of the configuration as I have been here for a very less time.

     

    If I apply port fast to the PXE Server (Windows PE) and the test client ports will it work, or does the DHCP Server port need changing as well.

     

    I also get the same problem when a windows vista built machine tries to obtain an IP from the DHCP server.

     

    Thanks,

     

    Sagar.

    Friday, August 01, 2008 1:32 PM
  •  EddieP wrote:
    I opened up a ticket with microsoft support and with their help we found the solution.  The problem was with the Cisco switch.  I needed to have spanning tree port fast enabled. Once that was done everything was working.

     

    Yeah! This is the solution!!!

     

    I had this problem a long time ago!
     

    [ ]'s
    Jamal Ibrahim
    Deployment Tips & Tricks
    http://jamal-ibrahim.spaces.live.com/

    Monday, August 04, 2008 5:41 PM
  • Just goes to prove again that a Systems Administrator/Engineer still needs to have the skill set of a Network Administrator/Engineer...  Thanks for the find EddieP!  This was my problem as well.

    Friday, October 10, 2008 5:38 PM
  •  Jamal Ibrahim wrote:

     EddieP wrote:
    I opened up a ticket with microsoft support and with their help we found the solution.  The problem was with the Cisco switch.  I needed to have spanning tree port fast enabled. Once that was done everything was working.

     

    Yeah! This is the solution!!!

     

    I had this problem a long time ago!
     

    [ ]'s
    Jamal Ibrahim
    Deployment Tips & Tricks
    http://jamal-ibrahim.spaces.live.com/

     

    This post fixed my issue and was spot on. I too had the client on a cisco swich that has a enhanced cisco ISO image and it my cisco poort was trunking (switchport mode trunk). After reading Mr. Ibrahim's post I fixed my switch port in 5 minutes. FYI - the cisco portfast option has no effect on a trunk port even though it may be set, so switch to an access port type.

    !
    interface GigabitEthernet0/x
     switchport access vlan x  ! only if requirred by your network topology.
     switchport mode access
     spanning-tree portfast

     

    B Chaffin, Network Engineer

    Saturday, October 25, 2008 12:23 PM
  • I'm having a similar issue, but I don't know if it's the same.

     

    I have Dell switches (2724) and they don't have Spanning Tree on the OS.  But when I boot from WinPE it will not get an IP.

    I have tried my WinPE CD against multiple Workstaions and the CD works fine, but when I try to use it on my Dell Poweredge 2950 server with a Broadcom BCM5708C Netxtreme II GigE, The server never gets the IP.  I can see that the Net drivers loaded because I can ping the local server and it responds with a localhost address., but when I do an IPCONFIG release and renew I get an error.

    I have tested the physical connection and it's fine.  But I can't seem to get it to find the DHCP.

    Has anyone encountered anything like this that may shed some light on the matter?

    Thank you in advanced for your help.

    René

    Monday, January 26, 2009 4:43 PM
  • just an FYI to all on this subject, if this is not resolved by adding spanning tree portfast to your ports on the switches, please take a look at the drivers that are being used by the NIC's. this is an email from my client who was facing the same issues.

    "

    It turns out to be a driver issue.  I had to include a Latitude XT / Broadcom network driver in the install image.  That seems to have resolved it.

     

    At least we know that the spanning tree port fast is set on the Cisco switch, so if this question comes up in the future, we’ll know it’s on."

    thanks
    habib
    ccvp

    • Proposed as answer by El Capitan PL Tuesday, November 06, 2012 9:05 PM
    Tuesday, April 28, 2009 1:25 AM
  • I'm having a similar issue, but I don't know if it's the same.

     

    I have Dell switches (2724) and they don't have Spanning Tree on the OS.  But when I boot from WinPE it will not get an IP.

    I have tried my WinPE CD against multiple Workstaions and the CD works fine, but when I try to use it on my Dell Poweredge 2950 server with a Broadcom BCM5708C Netxtreme II GigE, The server never gets the IP.  I can see that the Net drivers loaded because I can ping the local server and it responds with a localhost address., but when I do an IPCONFIG release and renew I get an error.

    I have tested the physical connection and it's fine.  But I can't seem to get it to find the DHCP.

    Has anyone encountered anything like this that may shed some light on the matter?

    Thank you in advanced for your help.

    René

    My issue is similar to yours.  I have Dell switches as well (2624 and 2024).  The server I am trying to image is a Dell PowerEdge T610 with Broadcom BCM5709C NetXtreme II integrated controllers.

    Here's the interesting part:  The first time I got this error, I pressed Shift-F10 and I HAD an address!  It was obvious it got all the info from my DHCP (DNS servers were all there etc)

    I tried again and this time I pulled up the cmd window as fast as I could and did an ipconfig.  This time I got "media unoperational" for Local Area Connection 2 (the one that got the address last time).  I waited a couple seconds and tried again and BAM!  I had a fully configured address.

    So it seems to me that WDS just isn't patient enough and is failing out before I get an address.  Anyone have an idea how to make it wait longer?

    More info:  When I do a renew, it works fine but I get a message: An error occurred while releasing interface Loopback Pseudo-Interface 1: The system cannot find the file specified.  Don't know if that is significant or not.

    Friday, October 02, 2009 9:53 PM
  • Well I solved my issue in a very unlikely manner.

    I tried using a different network drop, and this time, success.  I don't have too much time to look into it but both drops were connected to the same switch, the only difference was one was CAT6 (the one that worked) and one was CAT5E (the one that didn't work).  Also, the CAT5E cable was crimped in house, and the CAT6 was a pre-fab. 

    Finally, the pre-fab cable seemed to be getting a full gigabit connection and the other was only getting 10/100.  

    Could it be it was just a bad crimp!?  If I have a chance to verify I will post back (although I doubt this will solve the issue for most of you).
    Friday, October 02, 2009 10:30 PM
  • We had the same error as described by the original poster.
    I opened up a ticket with microsoft support and with their help we found the solution.  The problem was with the Cisco switch.  I needed to have spanning tree port fast enabled. Once that was done everything was working.

    Looking at the above suggestion, we found that spanning-tree portfast was already enabled on our cisco switchports in question.

    Examining the switch logs with the help of my more experienced network colleagues, revealed a ~1.2 second delay between the 'link state=up' and 'line protocol state=up' events, which we believe was introducing the timing issue resulting in the observed DHCP error.

    To correct this, we added the following line to the switchport config (which stops 802.1q trunk negociation):

    switchport nonegociate

    Examining the switch logs again showed the delay between the 'link state=up' and 'line protocol=up' events had dropped to ~0.2 seconds.

    As a result, the WDS DHCP errors disappeared.

    Hopefully this additional info will help someone else.
    • Proposed as answer by David Couzens Thursday, September 23, 2010 1:39 PM
    Friday, March 05, 2010 5:20 PM
  • Thanks.... this solved the problem for me. My Cisco switches are old and dont support RST.

     

    Intrestingly PXE dhcp now worls a lot faster.

     

    i enabled this option on both the port for the server and the local workstation.

     

    thanks

     

    DC

    Thursday, September 23, 2010 1:40 PM
  • Hi you all!

    Correct, check the drivers as well.

    I was having the same error, but no CISCO or other switch with spanning tree was involved.  I had to remove some conflicting NIC drivers, from the driver package that supports the image.

    J.Guzman

    Tuesday, November 06, 2012 9:02 PM
  • I believe the command should be:

    switchport nonegotiate

    AtlNetAdmin

    Tuesday, November 20, 2012 8:16 PM