none
Windows 8.1 Loses Internet Connectivity

    Question

  • I recently upgrade from Windows 8 to Windows 8.1...  and evertything went fine!.. but now i constantle lose the internet connection.. or sometimes its so slow!.. that happen on everything (internet explorer or chrome.. Windows store.. apss that requires internet, etc)

    Before install Windows 8.1, using Windows 8 i never have this problem (never! i have a year!)..
    My laptop its a Toshiba...

    But its important to say, that have this problema on my Microsoft Surface RT with Windows 8.1!.... so :S!

    What can i do!?? i need to work u.u

    Thursday, October 17, 2013 11:00 PM

Answers

  • Have you tried flushing the DNS cache?

    Since installing a fresh copy of 8.1 on my ThinkPad T430 I've been having issues on WiFi. Connection is fine for a while then pictures and videos won't load correctly on webpages. Performing ipconfig /flushdns gets it working again but only for an hour two then I have to do it again. It's very frustrating!!

    Monday, October 21, 2013 3:10 AM

All replies

  • Right now I have a Laptop and a Surface RT running Windows 8.1, both without internet connectivity :S!! (the both are on the same wifi network)

    And Im writting from another laptop (connect to the same wi-fi network) running Windows 8, and i dont have any problem... Im going to cry :s!
    Thursday, October 17, 2013 11:29 PM
  • Same probleem heren. Any solutions yet?

    Friday, October 18, 2013 8:18 PM
  • Hi,

    It looks like a driver issue, can you update the network adapter for a test to check the result?

    Meanwhile, go to event log to check if there are any error information about this phenomenon.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Saturday, October 19, 2013 8:19 AM
    Moderator
  • Same problem here....internet runs for a while then stops.  Strange though....I can still get emails through outlook
    Saturday, October 19, 2013 10:52 PM
  • Unfortunately this seems to be a VERY common problem that has existed and not been fixed since the 8.1 Preview. I have three nearly unusable systems after upgrading to 8.1 -- a Dell XPS 14, a MacBook Air and a Surface RT... all identical issues, on WiFi and on Ethernet, so it's definitely not driver related.

    Sunday, October 20, 2013 4:10 PM
  • Have you tried flushing the DNS cache?

    Since installing a fresh copy of 8.1 on my ThinkPad T430 I've been having issues on WiFi. Connection is fine for a while then pictures and videos won't load correctly on webpages. Performing ipconfig /flushdns gets it working again but only for an hour two then I have to do it again. It's very frustrating!!

    Monday, October 21, 2013 3:10 AM
  • Thanks so much Andy,

    That did the trick temporarily for me too... I'm going to create a notepad file with the above command and save it as Flush.bat and save it to my desktop...so I can run it occationally.


    • Edited by BajaNomad Monday, October 21, 2013 11:20 PM
    Monday, October 21, 2013 11:10 PM
  • I have a Dell Inspiron 17R, have updated to the very latest drivers on the Dell site today, and still have the problem.  Is there a knowledgebase article I can track for resolving this?  This makes my PC unusable for any serious work
    Monday, November 18, 2013 3:47 PM
  • I also have the same problem.  My unit is a Lenovo

    Realtek RTL8188E Wireless Lan 802.1 in PCI=E NIC is not working

    Tuesday, November 19, 2013 11:31 AM
  • My Dell T-1500 has this issue and I also have the latest drivers.  I notice that if I am using more bandwidth it seems to shut down the Network adapter and the only fix is to reboot.  In other words, if I do anything with YouTube it shuts right down.  Sometimes if I am searching the internet and then run I-Tunes it shuts down.  Occasionally the troubleshooter will fix it, but not too often.  I tried the "remove the driver" and it only installs what it says is the best driver.  I saw this recommendation on another forum.  Very frustrating, especially not knowing if Dell or Microsoft are working on the issue.  I am running an old Windows XP for reliable internet at the same time, but I have so much important data on this computer I need it fixed.
    Saturday, November 23, 2013 12:27 PM
  • You need to go and change the properties of your network card to disable power saving features, 
    Saturday, November 23, 2013 3:16 PM
  • I used cmd on here and that command is not recognized at all. cmd doesn't recognize quite a bit. So I don't know how to flush the DNS as I have been having the same issue. How would I go about getting cmd or just Windows 8.1 in general to do that??
    Tuesday, November 26, 2013 6:49 PM
  • Why have Microsoft consistently failed to admit they have a huge problem with Windows 8 losing internet connectivity? This bollocks about the issue lying elsewhere is so annoying............ You run their troubleshooter application and it resolves the issue in the Windows 8 software. BUG fix it now!!!!!
    Friday, December 27, 2013 10:33 PM
  • i have exactly the same problem. Pls microsoft, type some code or do something or hacking something that can solve this problem. I would rather have no internet than have it for 5 min and then lose it for 10s then have it again.
    Saturday, December 28, 2013 11:44 PM
  • I have been having the same problem ever since I upgraded to Windows 8.1
    Thursday, January 09, 2014 11:38 PM
  • I have the same problem
    Friday, January 24, 2014 10:01 AM
  • Wow I have exactly the same problem on a HP envy...Ran fine on Windows 8 now I loose internet connectivity on 8.1...Its been months now and still no fix??????????  The joke is I'm ment to be Beta testing Microsoft's Project Spark but it only runs on Windows 8.1  (But not mine cause I loose Connectivity)  Nice one Microsoft
    Monday, January 27, 2014 3:41 AM
  • Problem Solved:   It is a DNS issue....With the upgrade from 8 to 8.1 Windows now handles DNS differently.

    The solution is to Change your DNS to the Google Public Setting...I have done this and haven't had a problem since.  I have even confirmed this fix with my ISP and they seemed surprised that I didn't know about it.

    So:  Step 1 Control Panel---Network and Sharing Center---Change adapter settings

    Step 2 Select the connection you are using...ie Wifi or LAN

    Step 3 Click on the networking tab.  Click on internet Protocol Version 4 (TCP/IPv4) and the Properties

    Step 4 Click on Avanced and then the DNS tab

    Step 5:  Uncheck the "obtain DNS server address automatically" and check the "Use the following DNS server address"

    Step 6 Use the following Google DNS settings ....Preferred DNS Server 8.8.8.8

                                                                            ...Alternative DNS Server 8.8.4.4.

    Step 7 Click OK and restart you network connection for changes to be applied.

    GOOD LUCK

    • Proposed as answer by PhatAlb3rtNZ Tuesday, January 28, 2014 10:33 PM
    Tuesday, January 28, 2014 10:32 PM
  • Thank you SO much for sharing this - it does seem to have finally solved my problem with losing my internet connection!!
    Tuesday, February 04, 2014 11:44 PM
  • I will try this later and see if it works. So, if it is a DNS issue, is Microsoft working on a patch? Surely it can't be a long term solution that everyone has to use the google dns servers? 
    Wednesday, February 05, 2014 9:13 AM
  • Got the same problem with an acer iconia. Shame on windows 8.1
    Thursday, February 06, 2014 7:01 AM
  • I LOVE YOU!!!!!!!!!  I recently got a new laptop running Windows 8.1

    I love it, but I have been going CRAZY trying to fix the signal loss problem over the internet.

    Then I found your easy fix. AWESOME!!!!!!!!!!!!!!!!!!!!!

    My internet now works great!    Thank you so much!  You made my day!!!

    Friday, February 07, 2014 2:32 AM
  • Problem Solved:   It is a DNS issue....With the upgrade from 8 to 8.1 Windows now handles DNS differently.

    The solution is to Change your DNS to the Google Public Setting...I have done this and haven't had a problem since.  I have even confirmed this fix with my ISP and they seemed surprised that I didn't know about it.

    So:  Step 1 Control Panel---Network and Sharing Center---Change adapter settings

    Step 2 Select the connection you are using...ie Wifi or LAN

    Step 3 Click on the networking tab.  Click on internet Protocol Version 4 (TCP/IPv4) and the Properties

    Step 4 Click on Avanced and then the DNS tab

    Step 5:  Uncheck the "obtain DNS server address automatically" and check the "Use the following DNS server address"

    Step 6 Use the following Google DNS settings ....Preferred DNS Server 8.8.8.8

                                                                            ...Alternative DNS Server 8.8.4.4.

    Step 7 Click OK and restart you network connection for changes to be applied.

    GOOD LUCK

    This did not solve it for me. It still drops internet connection after a while. Cant even reach local host.
    Saturday, February 08, 2014 9:30 AM
  • Thank you so much for the help. I'm not as literate on the computer as everyone here so I really appreciate your help!!  Thanks again.

    Jan

    Thursday, February 13, 2014 3:56 AM
  • I know this is old, but for anyone searching, this link might hold the answer. It seems to be the solution for some people. It seems MS installed their own drivers and rolling back to old drivers does the trick. There is also another fix for changing TCP settings

    limited wi fi connectivity issue Windows 8.1
    Thursday, February 13, 2014 4:08 AM
  • This did not work...
    Tuesday, March 25, 2014 3:08 PM
  • I had problems with frequently getting disconnected. My diagnosis was a conflict between Atheros Wireless and Bluetooth device drivers. It seems to be an issue with driver. I had it temporarily fixed by disabling bluetooth. But after installing some updates for my Asus Motherbaord, there are no more conflicts.

    Please check this article. It might help someone http://atechjourney.com/fix-wi-fi-keeps-disconnecting-in-windows-8-and-8-1.html/

    Good Luck

    Tuesday, March 25, 2014 4:54 PM
  • I also ave the same issue ,but ill hold off of using a google dns server thingy, Microsoft has to come out with a patch for this. period !!!
    Tuesday, March 25, 2014 6:32 PM
  • You wrote this in October, five months ago.  It is now the end of March 2014.  I just bought a new Sony Avio laptop with a I7 core, on Monday the 24th worked great.  On Tuesday the 25th I upgraded to 8.1.  Immediately after that upgrade I couldn't stay connected to my WiFi when using the APPS.  It will almost immediately disconnect. I can stay a little longer when using Desktop and Chrome. Today I tried  "The solution is to Change your DNS to the Google Public Setting" listed above.  Perhaps that is why I'm spending a little more time connected when I'm using the desktop.  I also flushed my connection, to no avail.

    What I'm really surprised about is that there has been no fix from Microsoft.  Perhaps we need to go a bit more public?  Or someone please find a fix!  Please.  Everything else in my home works great with the WiFi so it is definitely 8.1 that's the problem. 

    Sunday, March 30, 2014 5:38 PM
  • I have tried every fix on this page and more that I've found in internet searches. My new laptop STILL drops my wifi connection every 30 minutes.... I have 6 other devices that work perfectly fine. Someone at Microsoft needs to help address this issue!!!!!??!??!!
    Sunday, March 30, 2014 10:52 PM
  • I bought a Toshiba Satalite p850-337 last juli and it came whit windows 8. When Windows 8.1 came out i thought that i might just install it. No problems from the start just that the internett conetion did not wanna start agian before i restated my laptop. many mouths later i started haveing problems whit the internett conection just like the first time i installed 8.1. i tried everything but noting worked. I got pretty mad one day because i was in a game of Bf4.... turned on the flight modus on the wifi settings (down right corner) and i shorty after i turned it off agian and the nettwork conected instent or it had deselected the wifi i was on now i was up and running.

    Fix: Turn on and off flight modus and do what you want on the interwebs :D

    Tuesday, April 29, 2014 3:01 PM
  • Testing this. I've noticed that 8.1 drops my internet anywhere from 5-20 times a day, keeping tabs on it (I like to leave my pc running during the day)

    Going to reboot and have applied this fix. The internet dropping is almost methodical, after about 3 hours it drops for about a minute, every 3 hours.

    I upvoted you because I've done some testing and the latency appears to be diminished with the Google DNS server. Thanks for this.

    Thursday, May 01, 2014 4:55 PM
  • The same problem here. Bought a brand new ASUS laptop with Windows 8.0, upgraded to 8.1 and Windows started loosing the wired Internet connection. Usually every day when I start Windows 8.1 I cannot immediately connect to the Internet as the network adapter has status "Unidentified network" or "Identifying...". If I wait about a minute or two (or reset the adapter) it may find the connection and then everything works fine until next day Windows has again lost the connection. 

    I have the latest network drivers and windows updates, no difference. Contacted Realtek, the manufacturer of the network card, not their problem. Contacted ISP, no clue what's causing it. Contacted ASUS, recommended to downgrade to Windows 8.0. This is just freaking hilarious when nobody knows nothing or takes responsibility for this mess.

    If Microsoft support is on this forum, please forward this message to Microsoft engineers. This amateurish bug must be fixed regardless of whose fault it is. It's really embarrassing that Microsoft can't make a basic thing like Internet working in their flagship Windows 8.1 OS. 

    Thursday, May 08, 2014 5:01 PM
  • I have been having this issue since a week now and have tried to rebuild my machine with Win 8.1 but the issue does not seem to go away. My network drops every 15 - 20 mins and I have to use the Wireless on-off switch to enable it back. this is so annoying, I have got another laptop with the same specs running on Windows 7 with no issues. I have tried to load windows 8.1 on that and the same issue is back on the new laptop as well.

    Is Microsoft evening listeing on here? I have to downgrade my machine to Windows 7 as it is just impossible to get any work done. I hope there is a fix soon for this.

    Saturday, May 10, 2014 3:29 AM
  • This solution did not solve my problem. I tried every solution that was suggested, so far nothing works. I have to reboot my laptop every time I loses connection. It seems that every hour it loses the connection.
    Wednesday, May 14, 2014 2:34 AM
  • I know your problem. Had it too. I've looked it up. Here is your solution:

    Open Command Prompt. Type: netsh winsock reset

    That's pretty much it. It's not a driver issue and it explains what it does there.

    Taken from here.

    I hope this works for you, mate. 

    - LS

    Thursday, May 15, 2014 1:20 AM
  • Ty so much for ur help, it helped me to fix the issue i was gonna rollback to win8, but now it seems fixed, i hope they deliver a patch or something cause lose the conection sucks so bad, it was so bad to find ur solution, ty so much.
    Friday, May 16, 2014 7:59 AM
  • I know your problem. Had it too. I've looked it up. Here is your solution:

    Open Command Prompt. Type: netsh winsock reset

    That's pretty much it. It's not a driver issue and it explains what it does there.

    Taken from here.

    I hope this works for you, mate. 

    - LS

    Didn't help here. I've been a Microsoft guy for a long time but nowadays this company has started annoying me a big time. You just can't put out this kind of crap.
    • Edited by CodeHeaven Monday, May 19, 2014 4:54 PM
    Monday, May 19, 2014 4:53 PM
  • Hi! I wanted to let you know I took your advice and so far so good!!! I've been on the internet for a couple of hours doing multiple searches, watching movies and emailing and my connection hasn't dropped yet! I can't tell you how much time and effort I've spent trying to fix this problem. Thanks for sharing!!! -ama
    Saturday, May 24, 2014 12:27 PM
  • Problem Solved:   It is a DNS issue....With the upgrade from 8 to 8.1 Windows now handles DNS differently.

    The solution is to Change your DNS to the Google Public Setting...I have done this and haven't had a problem since.  I have even confirmed this fix with my ISP and they seemed surprised that I didn't know about it.

    So:  Step 1 Control Panel---Network and Sharing Center---Change adapter settings

    Step 2 Select the connection you are using...ie Wifi or LAN

    Step 3 Click on the networking tab.  Click on internet Protocol Version 4 (TCP/IPv4) and the Properties

    Step 4 Click on Avanced and then the DNS tab

    Step 5:  Uncheck the "obtain DNS server address automatically" and check the "Use the following DNS server address"

    Step 6 Use the following Google DNS settings ....Preferred DNS Server 8.8.8.8

                                                                            ...Alternative DNS Server 8.8.4.4.

    Step 7 Click OK and restart you network connection for changes to be applied.

    GOOD LUCK

    >>> I wanted to repost this suggestion so others will know the above process worked (for me)!!! I spent 6 WEEKS trying to get a brand new HP Envy laptop w/ Windows 8.1's internet connection to stop dropping. I even sent the laptop back to HP for them to "fix" the problem (whatever that might be) and the day I got it back, it STILL DID NOT WORK! I can't find a word to describe how I felt.  Last night I found this thread. I tried a couple of other suggestions before trying PhatAlb3rtNZ and neither worked for me.  But so far so good with changing my DNS settings. Thanks again for sharing.

    -ama

    Saturday, May 24, 2014 12:42 PM
  • It seems the issue here is the DNS registration. 

    Just solved this with a friend. 

    1. Start -> control Panel.
    2. Network and internet.
    3. Change Adapter Settings
    4. Select the wifi network.
    5. double click on the wifi network.
    6. double click on ipv6 connectivity
    7. Go to advanced.
    8. Go to DNS tab.
    9. Locate the box that says "use this connection DNS suffix in DNS registration".
    10. Check this box.

    seems that it worked totally fine after that.

    So the root cause might just be that DNS registration doesnt work correctly, and the workaround is manually inputting the Google DNS servers.

    Sunday, May 25, 2014 10:33 PM
  • Thanks for your help! Was starting to be a pain to have keep restarting the laptop.
    Friday, May 30, 2014 5:51 AM
  • yes it worked thank you very much friend ive reinstalled drivers all day and nothing this helped me out alot,,,GOD bless you friend thankz alot.
    Sunday, June 01, 2014 12:12 AM
  • Hi All,

    Just wanted to write an update to my post - After trying all the workaround's proposed in this forum - I finally was able to resolve my intermittent internet connectivity issue by Uninstalling the Network driver and installing it using a Win 7 driver that was available on the Dell Website. (just an fyi - I was running into this issue on a Dell Latitude e6420 laptop running Windows 8.1)

    Good luck to you all!

    Wednesday, June 04, 2014 4:46 PM
  • I face similar problems with my win 8.1 machine (Dell XPS m1530) and flushing the dns cache didn't work so far.
    But what about the sometimes installed bonjour service? I remember, it sometimes can change the dns to 0.0.0.0 (at least on win 7).

    What dns is active, when the connection is lost?

    I'll try that in the evening, too.

    Wednesday, June 11, 2014 2:16 PM
  • Not an answer, just a workaround. In my opinion MS still have to come up with a patch to solve this issue.

    • Edited by remboman Tuesday, June 17, 2014 11:26 AM
    Tuesday, June 17, 2014 11:22 AM
  • I have the same issue with my HP desktop after installing 8.1. Cannot connect with either Chrome or IE. Have tried all the suggested fixes in this thread, and only get a fleeting connection that goes away after trying to open another link. However, my email through outlook works fine and I can attach and send files and download and print files. So, not sure why that connection works, but the browser doesn't.
    Thursday, June 19, 2014 4:29 AM
  • not sure why that connection works, but the browser doesn't.

    Looks like a firewall issue perhaps at a protocol level.  What happens to tracert?  That would be  ICMP  (same as ping but allows you to see each step of the path--assuming each step of the path allows ICMP but that is what you would be testing). 

    You could also greatly simplify a simulation of HTTP by using the telnet client to port 80.  (The telnet client is an optional package in Windows Features.)  E.g. providing you saw the telnet screen clear you would know that you had connectivity to an HTTP server.  You could continue trying to simulate an HTTP session using telnet (by default without any benefit of a LocalEcho) if desired.



    Robert Aldwinckle
    ---

    Thursday, June 19, 2014 6:29 PM
  • I'm a newbie to implementing your suggestions, so had to do a little research.  Here's what I did and results, but not sure what the implications are.  

    Ran tracert to www.msn.com two times and it timed out waiting for response (the outbound steps were on the trace).  Ran it to www.outlook.com and it returned good trace, as it did for www.google.com.  (The browser does not connect to google.com however), but the mail app does connect to outlook.

    Enabled the telnet client and did an "o www.msn.com [80]"  reply was "Connecting to www.msn.com...Could not open connection to the host, on port [80]: Connect failed"

    What else should I be looking at?  What port does outlook use?

    Saturday, June 21, 2014 5:37 AM
  • Ran tracert to www.msn.com two times and it timed out waiting for response (the outbound steps were on the trace).  Ran it to www.outlook.com and it returned good trace, as it did for www.google.com.  (The browser does not connect to google.com however), but the mail app does connect to outlook.

    That sounds normal and looks like good connectivity.  What's your external problem symptom again?

    Enabled the telnet client and did an "o www.msn.com [80]"  reply was "Connecting to www.msn.com...Could not open connection to the host, on port [80]: Connect failed"

    Good work.  Unfortunately you were confused by meta-characters used in the Help file to show the syntax and to show that "port" is optional.  The default port for telnet is 23, so for our purposes port is always required and then the syntax could not have used those brackets without causing confusion--perhaps by using angle brackets instead to indicate that the word port was a placeholder name, which of course could not be similarly misinterpreted.   <eg>

    In fact, you could have had an implied Open command just by using the cmd window command line, for example:

    telnet  www.msn.com  80

     

    Again, if the screen clears that proves you have connectivity to an open HTTP port on that host.  However, if you would like to prove that the host you connected to actually has something to do with MSN you need to start typing in some HTTP requests.  By default, because of the LocalEcho setting I alluded to, you won't be able to see your typing.  Nevertheless, you could then enter:

    GET / HTTP/1.1

    Host: www.msn.com

    and an extra Enter.

    If you want to use the LocalEcho you could do it either by starting the way that you were or by escaping into the telnet subcommand mode (e.g. by pressing Ctrl-] ).  When you are already connected you can reconnect (i.e. leave the subcommand mode) by pressing Enter by itself.

     

    What else should I be looking at?  What port does outlook use?

    Evidently not 80

    Microsoft Telnet> o www.outlook.com 80
    Connecting To www.outlook.com...

    The screen did not clear.  I tried overtyping the HTTP requests but results were inconclusive.  We can not test HTTPS (port 443) as easily.  However, since you apparently have good connectivity I imagine that you would see some of this in the Developer Tools Network Capture tool.  (In IE11, F12, Ctrl-4, F5).

    What I do is start from About:Blank and make sure that Clear entries on navigate is not in effect (second last button up).  And that shows that the response to the first request was a 302 to https://www.outlook.com/

     

    HTH



    Robert Aldwinckle
    ---

    Saturday, June 21, 2014 3:21 PM
  • LS

    Thanks so much for your response.  That command totally did the trick and I've been dealing with this problem for some time.  It does suck that MS can't put out a totally clean piece of ware, but I can understand that sometime issues come up that were unexpected, but it would be nice if when they do we get an answer.  Thanks to you I have an answer and I don't have to use any workaround.  This simply cleared it up for me.

    Sean

    Monday, July 07, 2014 10:27 PM
  • This helped me, Thanks
    Tuesday, July 08, 2014 8:52 AM
  • This helped, many thanks!
    Tuesday, July 08, 2014 8:54 AM
  • My particular issue may not be a DNS issue, in fact, this is completely strange how and why this happened. First, the details. I have an Acer small form factor tower that I bought from Wal-Mart (first mistake right there). It came pre installed with Windows 8.1 (possible second mistake) and now, it is less than worthless. If it were an intermittent internet connection, I might be able to understand but what has happened has even me stumped, and I know my way around issues like this, or so I thought. The night before this actually started, I had relocated said tower from one side of my desk to the other, using standard shut down procedures to ensure its safety. I did the move, started it up, and everything was working fine, no problems, etc. I shut it down using the Windows shut down procedure and went to bed. The next morning, I woke up, started the system, and attempted to get online, only to find that sometime in the night, something happened to my PC, there is no NIC, the system doesn't even recognize that there is supposed to be an NIC when I check through device manager, I have a cable plugged in, but there is no orange traffic light indicating connectivity, the only light that is on is a green light that apparently stays lit even when the cable is not plugged in. I have done a system restore, I have tried to manually add the hardware, except, 1: I don't have an install disk for it (ha ha), and 2: even if I did, the device manager still is not seeing that there is supposed to be an NIC installed. Finally, as a last ditch, I shut down, opened the side, and popped the BIOS battery to see if I could force a hardware reset, or at least clear the BIOS and force it to return to default, still nothing. So, short of tossing it out the window (out $250 which was my third mistake tacked on to the ones above), is there any solution to this problem?
    Sunday, August 03, 2014 2:23 PM
  • POSSIBLE FIX FOUND........................

    Look at this page

    http://adamralph.com/2014/01/24/continuously-losing-internet-connectivity-in-windows-8-1/

    The fix may be as simple as running

    netsh winsock reset

    and reboot.

    Wednesday, August 20, 2014 5:45 PM
  • Same here. Still dropping my connection after a while. Badly need a solution.
    Wednesday, September 03, 2014 10:28 AM
  • Great advice, although it didn't completely work for me. I went into device manager and rolled back the wifi driver and that fixed it. I have a Samsung laptop with Windows 8 (haven't upgraded to 8.1)
    Friday, September 05, 2014 9:35 PM