none
Vista Application Error 4100 (0x8004230F)

All replies

  • Hello Gays!

    I found the answer my self.To enable shadow backup copy work again you must first enable the service VOLUME SHADOW COPY.Then you must look that you have the DATA EXECUTION PREVENTION to only TURN ON DEP FOR ESSENTIAL WINDOWS PROGRAMS AND SERVICES ONLY!!!That works for my(Win Vista Home Premium With SP1).I hope that this works for you to!!!  Smile  Smile  Smile
    Monday, June 09, 2008 3:23 PM
  • Hello can you explain all the steps you used to accomplish the end result.

     thanks

    Thursday, September 04, 2008 12:20 AM
  •  timtamemanmar wrote:

    Hello can you explain all the steps you used to accomplish the end result.

     thanks

     

    I found the answer my self.To enable shadow backup copy work again you must first enable the service VOLUME SHADOW COPY.Then you must look that you have the DATA EXECUTION PREVENTION to only TURN ON DEP FOR ESSENTIAL WINDOWS PROGRAMS AND SERVICES ONLY!!!That works for my(Win Vista Home Premium With SP1).I hope that this works for you to!!!

     

    timtamemanmar

     

    I wasn't involved in this thread, so I'm not sure what the original problem was?

     

    I can explain the steps that 'Casiocas' performed in the last message. 

     

    To enable the Volume Shadow Copy Service perform the following.

     

    1. Open Control Panel.

    Select Classic View in Tasks.

    Double click Administrative Tools to open.

    Select Services.

     

    In the Services window, scroll down to Volume Shadow Copy and double click to see the details.

    In the Startup Type box, select Automatic from the drop down menu. Click the Start button.

    Select Apply / OK.

    Exit the Services window.

     

    2. In Control Panel, double click System to open.

    In the Tasks, select Advanced System Settings.

    In the next window, select the Settings button in the Performance section.

    Select the Data Execution Prevention tab.

     

    Select the Turn on DEP for essential windows programs and services only.

    Click Apply / OK.

     

    Hope this helps.



    If this post helps to resolve your issue, click the Mark as Answer or Helpful button at the top of this message.
    By marking a post as Answered, or Helpful you help others find the answer faster.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Thursday, September 04, 2008 8:29 PM
  • Ronnie Vernon-In my case, this error message has been generated when using VIsta Ultimate x64/SP1  Backup and Restore Center feature to update my my HDD backups.  This feature only works immediately after reboot, with all future backups failing and generating the above error message.  

    I have been searching the various Vista forums for a solution, for several months now, and the best advice I've received is "fergettaboutit", and buy Acronis ( http://thevistaforums.com/index.php?showtopic=41485&hl=backup+restore+error+0x8004230F).  Tried Live Chat while still under 90 day warrenty, and the only solution there was "just keep rebooting".

    I have also tried "repair" using my Vista Disc, and a clean reinstall of Vista (done for reasons unrelated to this problem), all to no avail.

    Since I paid retail for my Vista, I have found the "Acronis" and "reboot" answers unacceptable, and have hoped that MS would fix such an essential feature of Vista.

    I will try this thread's suggestion and will post my results.

    Zalophus
    Friday, October 10, 2008 5:32 PM
  • Hello. Anyone have any success with this one?

    My scheduled back-up to an external HD was running successfully until mid last month. Now I too get the following message:
    "The restore point could not be created for the following reason: The shadow copy provider had an unexpected error while trying to process the specified operation (0x8004230F)   Please try again."

    I have tried the following with no success:
    • Removing all programs installed since the last successful backup
    • Rebooting
    • Clearing and re-Creating a restore point
    • Changing the Volume Shadow Copy service from Manual (started) to Automatic (started)
    • same with the MS Software Shadow Copy Provider service
    • re-registering the DLL's associated with VSS per a 2003 Server thread

    Thanks in advance,

    Aero

    Saturday, January 17, 2009 3:08 AM
  • Hi to you all,

    sorry to say, I have the same problem.

    am running Vista Ultimate x 64 and all was ok until a couple of weeks back.

    I now cannot create any system restore points

    Have tried all the various "remedies" but to no avail.

    Any further help would be appreciated

    John


    John J Flynn
    Friday, January 23, 2009 11:50 PM
  • I too am having this same issue, and I'm afraid to run the SP2 update until I can create a restore point.  I still haven't seen anything on how to actually resolve it though.
    Tuesday, January 05, 2010 3:44 AM
  •  

     

    Good day, does anyone actually have the answer for this problem? [the restore point cant be created. Shadow copy provider had unexpected error(0x8004230F) ] apart from restarting it, rebooting it, enabling Volume Shadow Copy and everything related in services.msc? I am using Vista Home Premium SP2, with Avira, AVG, Avast! and not running Norton or Zone Alarm. I have also tried checking and unchecking the appropriate box to create the restore point and DEP for Windows and essential programs only. I cannot restore my system to any earlier state because there's no saved copy from the previous restore point. Oh, there are at least 40G available for the space. I have also tried sfc /scannow and all is good. All commands are executed with admin privilege. Do I ( can I ) do something to the registry? Anything else that I have missed? Please help and thank you.

    Wednesday, September 22, 2010 8:54 AM
  • Go into 'services' and double click 'Microsoft Software Shadow Copy Provider'....Set to Automatic and that should take of the problem.

    I had the exact same situation with the exact same error message in Vista Home Premium.

    I tried everything to get my restore point(s) to work..finally setting the above did the trick.

    I too had no restore functions at all, now I have all my restore points, even restore points from many Months ago. 

     

    • Proposed as answer by drzoo22 Tuesday, October 23, 2012 1:07 AM
    Friday, November 19, 2010 7:48 PM
  • I too had the same error message in Vista Home Premium, and I tried so many times to get my restore points to work.

    This should do the trick: _____  Go into 'services'... double click on the 'Microsoft Software Shadow Copy Provider'.... Set to 'Automatic' and that should do it.

    I now have all my restore point functions, I can create a restore point, and I even have all my old restore points back from Months ago.

     

    Friday, November 19, 2010 7:55 PM
  • thank you.that was easy and fix it right away

     

    Sunday, March 06, 2011 3:18 PM
  • Unfortunately, it doesn¨t work with me. Tried out all possibilities listed.


    PEDRO B
    Tuesday, November 01, 2011 6:49 PM
  • This worked for me too, thanks.
    Monday, January 09, 2012 9:40 PM
  • Any other suggestions?

    I have tried this fix and it didn't fix it.

     

    Thanks.

    Saturday, January 28, 2012 12:57 AM
  • Many Thanks,

    have been trying for ages to create a restore point, did the above action , works fine

    Sunday, February 12, 2012 11:52 AM
  • I did this and voila      all fixed,,,thankyou guys and gals for ending this headache,,,,awesome!!!!   info,,,,*****   5 stars for this one....so happy to finally fix this mess

    Tuesday, June 26, 2012 10:21 PM
  • Go into 'services' and double click 'Microsoft Software Shadow Copy Provider'....Set to Automatic and that should take of the problem.

    I had the exact same situation with the exact same error message in Vista Home Premium.

    I tried everything to get my restore point(s) to work..finally setting the above did the trick.

    I too had no restore functions at all, now I have all my restore points, even restore points from many Months ago. 


    this fixed my computer TOTALLY...FOR THE PAST 4 MOTHS I WAS HAVING THIS SAME PROBLEM AND COULDN'T ACCESS THE INTERNET THIS SOLUTION ALLOWED TO ACCESS SYSTEM RESTORE WHICH JN TURN ALLOWED ME TO GO BACK TO 4 MONTHS AGO AND USE AND RESTORE  IT, NOW I'M BACK ON THE WEB!!!!!   WHEW......BIGGGG THANKS ...... DATELL......U B A LIFE-SAVER!!!!!!!
    Tuesday, October 23, 2012 1:15 AM