locked
FYI To Microsoft: Windows Time Synchronization Completely Broken (Vista, 2003, XP are all broken)

    Question

  • I hope someone at Microsoft bothers to read this, you have a serious issue that has cropped up recently:

     

    I've been at over 100 computers in 15 different businesses in the last 2 weeks. Our software depends on the system time being relatively accurate.  We've been seeing dates and times that are completely wrong on lots of computers (often set a day in the future, but the users swear that they haven't touched it and I believe them).

     

    Of the 100 computers in 15 different businesses with 15 different IT staff and everything from a domain to just a workgroup EVERY SINGLE COMPUTER CANNOT SYNCHRONIZE IT'S TIME WITH time.windows.com.

     

    Yes, that's right, the ALL fail. You have to reset the w32time service from scratch (you can't just change to a different time server, that will fail too) and then you have to use a different time service other than time.windows.com because it still won't work. If you change to time.nist.gov everything works after that.

     

    Either there is a massive virus going around that is doing this for some reason, or some update from MS screwed it up.

     

    Windows XP, 2003 and Vista are ALL affected.

     

    A complete reinstall from scratch also fails to work and requires these steps too, so we know it isn't a virus.

     

    All of our internal office computers are all exhibiting this behaviour too, and they've all been completely scaned for spyware, and viruses and they are prestine.

     

    I've written a script to fix this for now that all of our clients are running on their machines, but this is very not good.

    It looks like it started to happen around the time that day light savings in EDT kicked in, so I suspect that it's a bug in the day light savings time patch that was released.

     

    Please fix.

    Wednesday, April 11, 2007 2:26 PM

Answers

  • They just turned on time.windows.com again. Probably because last weekend was day light savings switch over so their system would work again and not give people the wrong time...
    Tuesday, May 01, 2007 9:38 PM

All replies

  • There appears to be a problem with the time.windows.com time server - I see the error message  "The time sample was rejected because: The peer's stratum is less than the host's stratum."  Using the time.nist.gov server works fine.  There is more information on this at http://www.computing.net/windowsxp/wwwboard/forum/161461.html .

    Saturday, April 14, 2007 7:53 PM
  • It's more than just that. Even switching to one of the other time servers won't work. You have to completely reset the w32time service and point it to one of the other ones and then the others work, but time.windows.com doesn't work no matter what you do...

     

    Nasty stuff, especially for web services and encryption that relies on the time being relatively accurate....

    Sunday, April 15, 2007 4:23 PM
  • Well, for what it's worth, I have Vista Business x86 and you are right, I noticed that the time in my PC was way off. I switched to time.nist.gov and it worked fine. No need to restart any services. Hope this helps.

    Tuesday, April 17, 2007 5:28 AM
  • ...looks like only Windows XP machines have to have the service reset after some more experimentation, still very bad.
    Tuesday, April 17, 2007 12:59 PM
  • Hi

     

    I have only been able to sychronise once since the change to British Summer Time on 25 March (I am in UK)

     

    I have received errors with both time.indows.com and time.nist.gov.  I get two different errors:

    "an error occurred while Windows was synchronising with.... ", and

    "The time sample was rejected because: The peer's stratum is less than the host's stratum" occurred today!

     

    I have just started using a wireless modem, but I dont expect this to affect it?

     

    I have since downloaded a time synchronizer by softnik but recently the time.nist.gov failed to connect, (although it accepts an can update the time with time.nrc.ca and clock.psu.ed  (wherever they are?)

     

    Please can anyone advise how to reset w32time?

     

    Thanks

     

    Mark

     

    Thursday, April 19, 2007 8:36 PM
  • I am using vista ultimate and xp (dual boot) and neither can synchronize with any of the default time servers, i have been forced to search for alternative servers to synchronize with, even if I resart the service it doesn't work!
    Thursday, April 19, 2007 8:37 PM
  • Toby, run this:

     

    net stop w32time
    w32tm /unregister [ignore error message]
    w32tm /unregister [enter a second time]
    w32tm /register
    reg add hklm\system\currentcontrolset\services\w32time\parameters\ /v NtpServer /t reg_sz /d time.nist.gov /f
    net start w32time

    You can put that in a batch file if you want.

     

    It should reset it. Then restart your computer and it should sync with time.nist.gov properly.... at least it has here about 80% of the time..

     

    MS you really really really need to fix this!

    Thursday, April 19, 2007 11:47 PM
  • No Luck!  After running the commands and restarting.
     
    I've concluded that the default time servers in XP - time.nist.gov and time.windows.com, are having problems with connections. I did a TraceRT on time.windows.com and it kept timing out. I also did a TraceRT on time.nist.gov and it got through sometimes but it did hang a couple of times on the route.  

    Here are some that are working as of 04/20/2007:

    Time Servers in USA:

    JUST COPY AND PASTE ONE IN THE (SERVER: BOX FIELD) UNDER THE INTERNET TIME TAB. Or you can hack the registry and add a bunch to a peers list.


      (Level One Servers):  tick.usno.navy.mil; tock.usno.navy.mil; bitsy.mit.edu; clock.isc.org

    (Level Two Servers):  ntp1.kansas.net; rolex.peachnet.edu; timex.peachnet.edu; ntp-1.vt.edu; ntp-2.vt.edu

     

    Here is the MS webpage info, not all servers listed are configured right to accept all types of internet traffic requests, but their are quite a few that work just fine. Probably the safest to use a Level One as I would expect them to be online 99.99%.

    http://support.microsoft.com/kb/307897

     

    Also, if you would like to change the default update interval (once a week is the default in XP) here is a small little 48KB utility that runs from anywhere. This program is a little GUI that works great, just reboot to update the new interval settings.

    Change Internet Time Sync Interval v1.2
    Copyright 2002-2004 - Doug Knox

    http://www.dougknox.com/xp/utils/xp_inet_time.htm

     

    I agree MS should have caught on to this as it has been sporadic problem for months. Especially when backups, syncing of files and any critical information is involved.  I am not sure why a domain running Active Directory would not sync up the time on the domain.

    How to synchronize the time on a member computer in an Active Directory domain

    1. Click Start, point to All Programs, point to Accessories, and then click Command Prompt.
    2. Type w32tm /resync, and then press ENTER.

    *Unless the Directory Server is having the same Time Sync problem when connecting to its default Internet time server. Could very well be the same problem as the Workgroups or stand-a-lone machines are having.

     

    The Event Logs can also be set up to give email, etc. notifications when this error occurs, which is probably a good idea for time critical functions, some OS's require installing an add-on for this.

     

    I found the simplest solution is to use a Level One Time Server and to change the interval to a few times a day to keep critical important services being able to run on their precisely scheduled times.

     

    Hope some of the above is helpful.

    Friday, April 20, 2007 6:42 AM
  • The problem with all of this is that the average user doesn't have a clue, and probably 90% of Windows 2003 servers that I've seen do not have any time synchronization setup for themselves at all anyhow, so it's left up to the client computers.

     

    End result is a royal mess.

    Friday, April 20, 2007 2:49 PM
  • The same here. I noticed this the last week in March. One by one each PC  started having problems synchronizing with the time servers. I have a total of 4 PC's on a wireless network, at the house. Two of them are running OS XP Pro( these update the time daily) and the other two are running OS Home( these update the time every 7 days). All 4 were affected. I didn't see anything on this issue, until I  ran across this forum. MS is keeping it hush.  I was going to e-mail their support, but notice that they are charging now, $59 a e-mail, on certain issues.
    Thursday, April 26, 2007 7:36 AM
  • Something you wrote in this post nagged at my attention...

     

    "not all servers listed are configured right to accept all types of internet traffic requests"

     

    I have been having this problem as well, and after I read that sentence I have begun to suspect my firewall/antivirus software maybe partially responsible.  If it's not passing the correct traffic on the correct port because of security concerns, then windows would not be able to communicate with the time servers.

     

    Can someone who's smarter than I check on this possibility?

     

    Monday, April 30, 2007 6:13 PM
  • Something you wrote nagged at my attention...

     

    "not all servers listed are configured right to accept all types of internet traffic requests"

     

    I have been having the same problem, and after reading the above statement I've begun to suspect that my firewall/anitvirus software may be the culprit.  If it's blocking certain types of traffic for security purposes, it may be preventing Windows from communicating with the online time servers.

     

    Can someone who's smarter than I check into this?

    Monday, April 30, 2007 6:18 PM
  •  

    Your best bet is to have a DC that syncs your entire domain instead of configuring systems individually.

    216734

     

    Note that w32tm.exe replaces net time commands in 2003+ (though net time can still be used)

    for options w32tm /?

     

    time servers listed are widely used and subject to internet traffic congestion.

     

    consider:

     

    time.mit.edu

    tick.usno.navy.mil

    tock.usno.navy.mil

    subitaneous.cpsc.ucalgary.ca (countries each have own time source)

     

    Your ISP should also have a reliable time source.

     

    If there is a network problem (DNS esp) w32tm will find it - getting w32tm to work will also solve other issues you're having with your network

     

    note there are also hotfixes for the change in Daylight Savings Time - these must be installed on all machines (regardless of WU)

     

     
    931836

     

     

     

     

     

     

     

     

    Tuesday, May 01, 2007 1:35 PM
  • tomack

     

    the point is htat the day light savings time hotfix breaks the windows time synchronization for all computers that are not in a domain (I haven't tried those that have it setup in a domain correctly).

     

    This means that all Windows XP Home/Media computers are no longer being synced. (i.e. most small business < 10 users)

     

    It also means that all machines that are not setup to use the domain to sync their time (most because the default doesn't sync it correctly) won't work.

     

    This is all directly related to the hotfix and issues with the DST change.  MS busted it all and it needs to be fixed. I think we're all aware that a properly configured domain will have it's own time server configured and have the DC manually setup (why there isn't a tab under the time to do this I don't know) to sync with an external source.  That's not the issue. The issue is all other cases are broken and time.windows.com is completely busted and useless right now which causes problems with all DCs that are using time.windows.com to sync their time in the first place.

    Tuesday, May 01, 2007 4:54 PM
  •  

    Hi John,

     

    Would it be possible to post more technical information than

     

    broke

    busted

     

    What is the exact error message seen?  Are there any corresponding events in the EV logs?  If so, what are they?

     

    does the behavior reproduce when using a different time server than time.windows .com?

     

     

     

    Tuesday, May 01, 2007 6:23 PM
  • Read the thread, it's very clear.

     

    Go to any Windows computer and open up the Internet Time synchronization tab and you'll see the error.

     

    This isn't rocket science. EVERY windows computer on the planet that isn't set to sync to a domain controller gets one form of error or another and thus can't sync it's time.  And if you have your domain controller set to sync with time.windows.com you're screwed too.

    Tuesday, May 01, 2007 7:04 PM
  •  

    sorry, when I do that on any of five machines not in a domain, there is no error

     

    in Vista, the window says

     

    This computer is set to automatically synchronize with 'time.windows.com'.

     

    Next synchronization: 5/4/2007 at 7:16 PM

     

    The clock was successfully synchronized with time .windows.com on 4/27/2007 at 7:16 PM.

     

    Tuesday, May 01, 2007 7:50 PM
  • They just turned on time.windows.com again. Probably because last weekend was day light savings switch over so their system would work again and not give people the wrong time...
    Tuesday, May 01, 2007 9:38 PM
  •  

    FYI - Quick fix for novice client users.

     

    Ah, yes the default good ole' Microsoft, windows.time.com is working again but, when will it screw up again??  With its bad track record, same thing happen in 2006, we simply don't trust it too much or any of the Windows defaults.  There is a simple fix for Workgroups and Standalone machines, and for Domains with their hierarchical time sync path not working right.

    Plus, some Windows OS's default time update (weekly) is not very sensible for time critical applications.  We now always use a default of every 8 hours, or what something may require.

    Change Internet Time Sync Interval v1.2 - a simple GUI interface to edit registry time sync intervals.
    http://www.dougknox.com/xp/utils/xp_inet_time.htm

    I've seen problems with the default external time servers, reliability, built into Windows OS's for years.  So we find it usually best to rely on a US military server such as USNO, as they monitor the Earth's movements. 

      

    For small Lans or for Individual Clients we are simply sending an email to all the clients computers flagging it as a company Security Update:

    We simply instruct them "to click on the time icon on the desktop, then click the Internet Time tab, and then copy the following blue text only - tick.usno.navy.mil - and next paste it in the Server: Field, then click on Apply, then Update Now and finally OK.  Done, no more error messages. 

    We started doing this today and believe me my counter parts were actually stunned, that even our clients most basic, don't have a clue users, actually successfully fixed 90% of the machines. Of course there's always your couple of favorite users, who asked us, "where's the time icon and where on my desk is it ??" Geez!!  For these few we just made a xxxxxx.REG file with notepad and told them to click on it and say YES when it asked them. Finally 100% success, we think the second way is what we'll be using, its the bottom rung of the latter, nothing is easier unless you eliminate the client in chair.

     

    I definitely agree that, so many Primary Domain Controllers using Window's Server are set up wrong in the first place. I had some customers today who were also setup wrong.  By default client machines use "default hierarchy" to synchronize time. When a break in the hierarchy chain happens, the time service can't update. I've had to go and waste time finding the hierarchical chain break and fix it. This is getting to be a chore we don't want to fix, since it would have been avoided with the proper setup from whoever started the server nodes & client nodes installs.

    So we have implemented a really simple fix for our customers networks to avoid having these problems.  We usually run a batch file on all the clients, changing the Registry, so every client node is using the same external U.S. Navy Observatory Time Server.


    Windows Registry Editor Version 5.00

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers]
    @="0"
    "0"="tick.usno.navy.mil"
    "1"="tock.usno.navy.mil"
    "2"="time.windows.com"
    "3"="time-b.nist.gov"

     

    Copy blue text to notepad and save as a .REG file, click on the file and tell it to merge into the registry.


    FYI: Always check if port blocking is a problem, Port 37 Time, and Port 123 Network Time Protocol. Make sure group policy is set for regedits, by proper users. Login auto-run batch scripts can also be used on clients to install fix easily. 

     

    Wednesday, May 02, 2007 11:40 PM
  • The discussion is getting off track...

     

    The time sync service is NOT broken! The errors are caused because your firewall is preventing access to the Network Time Protocol (NTP) port, port # 123.

     

    Go to your firewall and open port 123.

     

    It worked for me!

    Saturday, May 12, 2007 5:29 AM
  • Steve:

     

    It was broken, it's no longer broken.

     

    Unless you're using an outgoing firewall that blocks this stuff (and most of them are set to allow NTP automatically anyhow) there is no reason to open up your firewall because the traffic is OUTBOUND just like a web site. The reply is on the same socket that was opened to communicate to the site and as a result will always work no matter what you do with an inbound only firewall.

     

    By opening up that port, you're exposing the port for EXTERNAL users to connect to your machine on port 123 to query for NTP (or attack your machine if they're is a bug in Windows...).

     

    This is one of the great falacies of firewalls, and man it's a dangerous thing...

    Saturday, May 12, 2007 2:41 PM
  • I just tried it and it did snync with the time. This PC is now sync. I'll try the other 3. I made no other adjusments.

     

     

    Saturday, May 12, 2007 9:24 PM

  • I added the lines to the registry and then tried. It did synchronize at the first trial with each newly added line.

    At the second trial the error came back for each one, just like before.
    Monday, May 14, 2007 4:15 PM
  • I "may" have the same problem. I just received my laptop last Friday with Vista Home Premium Edition.

    After getting everything set up, including the time zone and the correct time. I turned off the laptop, and after a couple of hours I turned the laptop back on and the time was completely off again. This happened several times. Could this be a hardware problem that I need to return the laptop back to the manufacturer?  

    Monday, May 14, 2007 11:06 PM
  • One possible solution I've found is going into the System Properties, and into the Remote tab, and then unchecking the "Allow Remote Assistance connections to this computer" box. This apparently frees up the port to allow communication with the time server.

     

    I am now able to sync up to the server without any problems whatsoever.

    Wednesday, May 16, 2007 10:40 PM
  • I tried this re-register stuff and anything else I could find, and I cannot get this PC to sync...  If this worked 80% of the time, what did you do with the other 20%?
    Friday, May 18, 2007 11:35 PM
  • Hey, in case anyone's still having trouble with this, I just tried the command-line regedit and got an error that the time change was too big -- my new Vista machine was set nearly 24 hours in the future. So I manually reset the time to something closer and tried again through the Date and Time pane, and it worked with time.nist.gov with no issues whatsoever (so far!). Could it really be that simple?

    Monday, May 21, 2007 3:35 PM
  • But the true test will be when you shut the system OFF, wait overnight and turn it back on again. Will the time be consistent, or will the system clock be off again, as if the clock was unplugged when the system was turned off? There's the million dollar question!
    Monday, May 21, 2007 8:19 PM
  • What's the current status of this?  My desktop running XP seems OK, but my laptop running Vista (wireless-connected) at home cannot synchronize with *any* of the time servers that I've tried.  Any advice would be much appreciated.
    Saturday, May 26, 2007 11:40 PM
  • I am still at a complete loss. This Vista laptop just cannot keep the correct time. I'm glad I'm not the only one having this problem!
    Sunday, May 27, 2007 12:31 AM
  • The problem is not with failure to synchronize with a time server. The problem is with Windows itself!

    I am using Windows XP and have had no problems with the time service until around May 20, 2007. If I MANUALLY set the time and leave the "automatically synch with an internet time server" box UNCHECKED and shutdown my pc, the next time I fire it up the time is usually around SIX hours too early. 

     

    I do have "automatically adjust clock for daylight savings checked" , so I will try unchecking that to see if my pc can hold the correct time after a shutdown. Bottom line this IS STILL COMPLETELY BROKEN!!

    Sunday, May 27, 2007 4:16 PM
  • I tried unchecking daylight savings as well. After shutting down overnight, and to my shock, I still have the same problem. Although the time was only THREE hours early instead of SIX, which I guess is completely acceptable to MICROSUCKS!

     

    You can't even send them an email about your problem with their crappy software, without HAVING TO SHELL OUT $99!!@!#!&!!  You would have to be out of your mind to switch and PAY for VISTA! I'm switching to Apple, let someone else support Mr. Gates' Billionaire illegal monopolies.

    Monday, May 28, 2007 3:42 PM
  • Turn off your damn firewalls and it should work fine.
    Sunday, June 03, 2007 6:32 AM
  • Opening port 123 in McAfee's firewall settings worked for me too. It's amazing how often firewalls are the culprits of a lot of problems which seem unsolvable at the time! Thanks Steve. It was such an easy fix.
    Monday, June 04, 2007 11:52 AM
  • It is not just the firewall, that is just part of the problem. The computer/OS (Vista) will not maintain the time. It will gradually start losing it's time whether it goes to sleep or if it is turned off. That has been my particular problem, and I cannot determine if it is Vista's problem or the hardware is faulty.
    Monday, June 04, 2007 9:03 PM
  • My first Vista machine exhibited a slow time loss, of about a minute a day. It was woefully under-powered at 512MB. The machine was excruciatingly slow. Then I added RAM to bring it up to 2GB (only $90 USD), and the machine screams like a banshee now. It is a delight to use.

     

    And it doesn't lose time anymore!

     

    I'm told that Windows maintains the clock that we see by counting hardware "ticks" that occur about 55 times per second. If it catches all the ticks, then the clock will keep correct time. When the PC had only 512MB of RAM, it spent a lot, repeat, a LOT of time swapping memory back and forth to disk. (which is why it was so slow). I'm speculating that all the disk I/O traffic on the bus, and the CPU cycles spent to manage all that, allowed some ticks to be lost, and the clock lost ime.

     

    Don't rely on the Windows clock for very accurate long-term timekeeping. Even the best systems have "drift" in their clocks that varies from time to time. Windows understands this and schedules an internet time-sync every week or two, to fix the small errors that might have accumulated. If the time error is too big for your tastes, adjust the Registry to cause the time-sync to occur more frequently, say every day. And, of course, enable port 123 on the firewall.

    Monday, June 04, 2007 10:17 PM
  • A comment on the ram thing with Vista:

    MS says min specs for vista is 512ram, and reccomends 1gig. That's why it was all slow. And, I find 512/1gig rediculous for specs required/reccomended just to run the OS itself.. it's like your comp's RAM is "your physical ram - 1gig"

     

    But anyways...

    It's June 11th, '07, and I can't sync with time.windows.com or time.nist.gov, on this home XP or my XP that I reformatted and put XP on 2 days ago. The .REG file somebody said to make didn't workf or me on this comp, so I just (following the paths he provided in the .REG makeup, thankyou) did this (NOT for computer noobs):

     

    Start > Run: "regedit". A window will popup. Expand (if needed) the following:

    "My Computer"

    "HKEY_LOCAL_MACHINE"

    "Software"

    "Microsoft"

    "Windows"

    "DateTime"

    and click on "Servers"

     

    Once there,  on the right side of the screen, right-click, click "New" > "String Value".

    In the highlighted field (name field), give it the next number you see that isn't used (for me it was "3", so I named it "3"). Under the "Type" tap everything should say "REG_SZ". Under "Data" numbers 1 and 2 for me were servers, and "(Default)"  was "2".

    Rightclick the thing you just made, click the bolded "Modify" at the top of the list.  On the second line, where it says "Value Data" put in whichever server you want to be added to the drop-down list of times in the "Date and Time Properties" > Tab "Internet Time", where it has the list of servers. (Default is "time.windows.com" and "time.nist.gov").

    I added 2 Strings, one with the data of "tick.usno.navy.mil" and "tock.usno.navy.mil". After you add whatever you want, double click the time in the bottom right corner of the screen, click the "Internet Time" tab, and then the dropdown menu will have whatever URLs you just added! Update it, and click "OK" and it will now defaultly update with that server.

     

    The name of the String Value you add will be the order of which the servers appear in the drop-down list. I have "1" "tick.usno.navy.mil" and "2" "tock.usno.navy.mil", with "3" being "time.windows.com" and "4" "time.nist.gov". There is no real need to change the orders of which they appear in the list, I only set it like this because I was experimenting and didn't know what did what. If you want to take a server out of the list, simply delete it's String Value, and make sure there are no skips in numbers. (ie: it goes "1, 2, 3, 4, 5" instead of "1, 2, 4, 5,")

     

    ----------

     

    I did all of that in like 5 minutes, and have never worked with the registy or anything, and it was quite simple for me.. I'm no computer wiz, but my training starts this upcomeing school year! If it's not simple for you, I'm sorry to say, but you must be a computer "noob".

     

    -----

    Time URLs I compiled from this thread:

    time.windows.com       -- Obviously Microsofts server

    time.nist.gov                 -- .gov is U.S. government, so yah.

    tick.usno.navy.mil         -- U.S. Navy's server

    tock.usno.navy.mil        --U.S. Navy's second server

    rolex.peachnet.edu

    timex.peachnet.edu

    ntp-1.vt.edu

    npt-2.vt.edu

    clock.psu.edu

    bitsy.mit.edu

    clock.ist.orgntp1.kanses.net

    time.nrc.ca                                                                     .ca indicates it's a Canadian website

    time.mit.edusubitaneous.cpsc.ucalgary.ca                .ca again means it's Canadian

    Monday, June 11, 2007 11:05 AM
  • Have you opened port 123 in your firewall??

    Network time protocol (NTP) needs that port open.

    Monday, June 11, 2007 7:57 PM
  • The point is that Microsoft has screwed up all fo the sync system. (it's completely dead now) and it's causing havoc with anything to do with cyrptography.

     

    They need to fix it and make it work consistantly with every computer like it used to. This is nuts!

    Monday, June 11, 2007 7:58 PM
  •  Steve Harrold wrote:

    Have you opened port 123 in your firewall??

    Network time protocol (NTP) needs that port open.

     

    I'll say it again:

     

    You only need that port open if you're receiving requests against your own NTP server. You DO NOT need it open if you're requesting from the internet unless you've got a firewall that blocks outgoing traffic.

    Tuesday, June 12, 2007 3:35 AM
  • FINALLY ... a RIGHT answer to the Vista time sync problem.
    As soon as I allow port 123 the time sync worked perfectly.
    You were 100 % RIGHT about the firewall blocking that port.

    THANKS Steve
    Tuesday, June 12, 2007 3:09 PM
  • OMG! Thank You SOOOOOO Much ! I have tried for months to sync my time on this machine of mine.. It wouldnt go at all..

    The Kansas Link you gave worked for me no problem! Thanks Again ..

    Take Care ,

    Penny P. from Texas

    Sunday, June 24, 2007 2:32 AM
  • Still busted on every computer I've tried....
    Sunday, June 24, 2007 3:46 AM
  • follow along and do what i said and the other servers should work.

    it seems like microsoft broke the syncing with time.windows.com and time.nist.gov

    Tuesday, June 26, 2007 2:50 AM
  • I have discovered the following information on the website http://tf.nist.gov/timefreq/service/its.htm

    Starting on 14 April 2007 the server time.nist.gov will no longer respond to requests for time in the TIME format (as defined in RFC-868). These requests are generated by a number of different programs including DATE, RDATE, and other programs that connect to the time server using tcp or udp port 37. All of the other NIST servers (except for time-nw.nist.gov) will continue to respond to requests to either tcp or udp port 37 for time in the format specified in RFC-868.

    However, this format has poor error-handling capabilities in general, and many of the client programs that use this format are poorly written and may not handle network errors properly. Therefore users are strongly encouraged to switch to the Network Time Protocol (NTP), which is more robust and provides greater accuracy. We eventually intend to phase out support for the TIME format on all servers.

    Please send questions or comments regarding this issue to Judah Levine: jlevine@boulder.nist.gov

    Wednesday, June 27, 2007 4:46 AM
  • Good find, Walter. After reading the doc at this link, i changed my time server to a different public time server (time-a.nist.gov) and it worked. This problem has been annoying me for a while now. Neither time.windows.com or time.nist.gov would work.

     

    --Bob Foertsch

    Friday, June 29, 2007 11:57 PM
  • Thanks a lot, I followed your suggestion successfully.

    Hans Stoffels

    Friday, July 06, 2007 9:35 AM
  • Of course firewalls are a problem. but if you try to update your time with time.windows.com even with the firewall off, you wont be able to. But you can sync time with time.nist.gov. just turn pff your firewall for a minute and sync the time and then turn it on again. sure to work. happened the same with me. i tried to do a lot of stuff to sync the time but i couldnt. I then turned off the firewall (McAfee) and the pressed the 'update' button and it was successful
    Tuesday, July 10, 2007 6:51 AM
  • Why isn't MS updating their OSes to fix this???

     

    This is rediculous!

    Tuesday, July 10, 2007 1:24 PM
  • Hello,  Before I found this thread I was experimenting on getting the time to synchronize properly with my new Dell Vista PC.  During my experiments, I set the W32TIME service, "Log On" tab to Local System Account.  This didn't resolve the problem, so I attempted to change it back to "This Account: Local Service", but it won't accept the password which is shown as being hidden.  So I've disabled The W32TIME service until I figure out how to put it back the way it was.

     

    I am the only user on my PC and have not assigned a password to my user account, but a blank password does not work with this service.  Can anyone tell me what the password is?  Thanks!

    Tuesday, July 10, 2007 4:13 PM
  • OK, I've fixed the password problem and opened port 123.  I now have 6 different time servers configured with W32TIME and all 6 work fine.  Now I need a program that will enable me to change the time sync default from 7 days to 4 hours or so.  Doug Knox has a program named "Internet Time" which is supposed to do that, but it would not run on my VISTA machine.  I've sent an E-mail to Doug asking if he had a Vista version of this program, and in the meantime . . . does anyone know of a program that will change the sync process default?

     

    Thanks, Bill

     

    Wednesday, July 11, 2007 8:34 PM
  • Use the REGEDIT program to modify the interval between time syncs.

     

    The interval is set in the Registry in keys...
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\w32time\TimeProviders\NtpClient
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\w32time\TimeProviders\NtpClient
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpClient

     

    in field: SpecialPollInterval

     

    The value is in seconds.

     

    The default as delivered by Vista is 7 days, which works out to a value of 60 * 60 * 24 * 7, or 604800 (in decimal).  That's 0x00093A80 in hex.

     

    Change this value to your new interval, expressed in seconds.  For example, 60 * 60 * 24, or 86400 (in decimal) for 1 day.

     

    I don't know how ControlSet001 differs from ControlSet002 differs from CurrentControlSet.  Maybe the ControlSetxxx names go beyond 002 on other systems.  Better minds will have to make that determination. I just changed all 3 locations.

     

    To verify that this works:

     

    Before making any change, go to the time setting dialog (right click on the time of day in the system tray, as an admin userid).  Make a note of when the next sync will take place for "Internet time".  It will be
    somewhere between 0 and 7 days from now on a standard unmodified system, depending on how long the system has been up.

     

    Ask for a new sync of internet time.

     

    Look at the next scheduled sync time.  Now it will be 7 days into the future.

     

    Now, using REGEDIT, change the value in the Registry to your desired interval, in all the keys you find (my system has 3).

     

    Repeat the experiment of re-syncing the internet time.  You should now see that the next sync time corresponds to your new setting.

     

    Have fun.

    =========

    Thursday, July 12, 2007 5:17 AM
  •  MrBill wrote:

    OK, I've fixed the password problem and opened port 123.  I now have 6 different time servers configured with W32TIME and all 6 work fine.  Now I need a program that will enable me to change the time sync default from 7 days to 4 hours or so.  Doug Knox has a program named "Internet Time" which is supposed to do that, but it would not run on my VISTA machine.  I've sent an E-mail to Doug asking if he had a Vista version of this program, and in the meantime . . . does anyone know of a program that will change the sync process default?

     

    Thanks, Bill

     


     

    Copy blue text to notepad save as a xxxxx.REG file and right click and merge to registry.  This should edit your Current Control Set account if you are logged in as the administrator (or run as Administrator) in the UAC for Vista, or as an Admin account in XP.  You will need to reboot for registry to reset time polling.

     


    Windows Registry Editor Version 5.00

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpClient]
    "SpecialPollInterval"=dword:3840


    For 24 hrs or 86400 secs

    "UpdateInterval"=dword:15180

     

    For 12 hrs or 43200 secs

    "UpdateInterval"=dword:a8c0

     

    For 8 hrs or 28800 secs

    "UpdateInterval"=dword:7080

     

    For 4 hrs or 14400 secs

    "UpdateInterval"=dword:3840

     

    Use 60x60 x the number of hours you need for time interval number.  Use windows calculator and convert the number to a HEX Dword value. Then just plug in the number after =dword:????? 

     

    This should take a couple of minutes without digging through the Registry.

    ps:  It is always recommended to make sure you have a registry Back Up if you do want to ever recover from any mistakes made.  Or a good system restore point will suffice.

     

    Happy syncing up!! 

    MJJL

     

     

    Friday, July 13, 2007 1:05 AM
  • Thanks for the tips guys . . . my time sync is now set for 4 hours!

     

    - MrBill

     

    Friday, July 13, 2007 12:53 PM
  • Using time.nrc.ca works for me. I am running Vista Home Premium.
    Monday, July 16, 2007 4:08 AM
  • I changed my time server to "tick.usno.navy.mil" and my Vista clock has been perfectly normal for weeks now.  Thank you so very much!

    Tuesday, July 17, 2007 5:22 PM
  • Here's a list of time servers that "Do Work"

    time-a.nist.gov

    129.6.15.28 NIST, Gaithersburg, Maryland
    time-b.nist.gov 129.6.15.29 NIST, Gaithersburg, Maryland
    time-a.timefreq.bldrdoc.gov 132.163.4.101 NIST, Boulder, Colorado
    time-b.timefreq.bldrdoc.gov 132.163.4.102 NIST, Boulder, Colorado
    time-c.timefreq.bldrdoc.gov 132.163.4.103 NIST, Boulder, Colorado
    utcnist.colorado.edu 128.138.140.44 University of Colorado, Boulder
    time.nist.gov 192.43.244.18 NCAR, Boulder, Colorado
    time-nw.nist.gov 131.107.1.10 Microsoft, Redmond, Washington
    nist1.symmetricom.com 69.25.96.13 Symmetricom, San Jose, California
    nist1-dc.WiTime.net 206.246.118.250 WiTime, Virginia
    nist1-ny.WiTime.net 208.184.49.9 WiTime, New York City
    nist1-sj.WiTime.net 64.125.78.85 WiTime, San Jose, California
    nist1.aol-ca.symmetricom.com 207.200.81.113 Summetricom, AOL facility, Sunnyvale, California
    nist1.aol-va.symmetricom.com 64.236.96.53 Symmetricom, AOL facility, Virginia
    nist1.columbiacountyga.gov 68.216.79.113 Columbia County, Georgia
    nist.expertsmi.com 69.222.103.98 Monroe, Michigan

    Thursday, July 19, 2007 9:33 PM
  • Thanks for the list of IPs.  I have Vista Home Prem and was having this sysc problem like everyone else.  It turnes out my McAfee firewall was blocking all the time servers.  I now use time.nist.gov (192.43.244.18) and it works fine BUT I had to open McAfee and tell it this IP address was allowed.  Time sync works fine now!!!  My problem was McAfee firewall blocking all of these IPs.  A previous post allerted me to the McAfee problem.  THANKS!

     

    Wednesday, August 08, 2007 6:17 PM
  • Well, i tried all possible solutions stated above and my time sync still doesn't work. I have Vista Ultimate...

    Keep those solutions coming Wink
    Saturday, August 18, 2007 10:06 PM
  •  

    you trying changeing the time sync server to one of the follow:....?
    tick.usno.navy.mil
    tock.usno.navy.mil

    Saturday, August 18, 2007 10:43 PM
  • yes, i've tried ALL servers that were already mentioned.

    It says. An error occured.... ... The peer is unreachable.
    Saturday, August 18, 2007 10:47 PM
  • I have the same problem. Windows won't sync time on any of my operating systems. I tried everything.  I still get an error.  I cannot sync time.  Any recommendations?

    Friday, August 24, 2007 4:01 AM
  • I figured out my problem.
    I'm on a University network and have to connect to internet through a VPN-connection. Now it looks like the the network administrator has disabled something [perhaps port 123] which prevented me from syncing time. But now it seems our University network has an ntp server of it's own. When i sync on that ntp server it works...
    Friday, August 24, 2007 6:18 AM
  • We are experiencing all types of w32time sync issues as well but within a slightly different scenario.  When a computer is joined to a child domain the value changes from windows.time.com,0x1 to ntp1."RootDomain".com where RootDomain is the name of our Forest.  There is a Unix server that resolves from this name so I assume it is some old configuration still being set by the DC.  The  Type  value of AllSync does not change.  If I change the Type value to NT5DS each computers time sync issues seem to disapear.  They will now sync to domain controllers that seemed to previously ignored the time snyc request by each computer when the setting was AllSync.

    Could someone point me to any Microsoft articles that might explain this issue or maybe W32time value configuration best practices.

    Thanks,
    Adam
    Tuesday, August 28, 2007 4:50 PM
  • We have also been having problems but it seems like we are now okay.  I'm not altogether sure os what's happening. Besides, management has asked me to provide them on a monthly basis stats regarding the date and time as well as the name of the time source server for the last time synchronization on a number of our servers (we have over a humdred).  I'd like to write a script that will provide the information.  But I cannot find where that information is stored.  I know that with non-AD servers and XP clients the information could be gleaned from the Internet tab on the system clock's Date and Time dialog box.

     

    Does anyone know how I could get that information?  I'm sure it has to be stored somewhere other than in the dialog box.  Besides, AD units do not show the Internet tab.  By-the-way, is there a way to restore the Internet Tab on the system clock's Date and Time dialog box?

     

    Russ-S

    Monday, September 03, 2007 9:59 PM
  • Russ-S

     

    Just look in your Event Viewer in the windows MMC, (many forget how useful a tool this is) it will be in there, under the System Log listed as a W32Time entry in the Source Column, just double click the entry to show the details. I believe Event ID# 35 is the number for a successful update. 

     

    With the Windows Server OS's, you always have the configuration options with the Event Logs, to save, print or send emails, etc.  You could just have the servers automatically send each W32Time update event by email to one separate folder for this purpose.

     

    Give 'management' access to the data folder and usually they are 'happy campers.' Even though most of us know, that many times they haven't a clue as to what they're actually looking at.   ;-)~

     

    Good luck

    Monday, September 03, 2007 11:51 PM
  • Take a look at the Microsoft utility called eventcombMT.exe.  You can use it in GUI mode or script using it.  Have it filter the success/failure Event ID for W32Time on each device/server.

    http://www.microsoft.com/downloads/details.aspx?FamilyID=7AF2E69C-91F3-4E63-8629-B999ADDE0B9E

    Adam


    Tuesday, September 04, 2007 2:02 PM
  • Thank you, Tomack.   I tried the first three on your list.   Time.mit.edu and the other two.    They work perfectly.

     

    'Tail.

    Thursday, September 06, 2007 7:05 AM
  •  just Bobert wrote:

     

    you trying changeing the time sync server to one of the follow:....?
    tick.usno.navy.mil
    tock.usno.navy.mil

     

    Thank you thank you thank you thank you thank you!

     

    I used tock.usno.navy.mil and now it finally synchs in and gives me the correct time! I've been cracking my brains out with this problem and now know why people use linux etc!

     

    Cheers Bobert!

     

     

    Wednesday, September 12, 2007 10:09 AM
  • 12 Sept 2007 running XP home this problem is reocurring - time is always wrong on startup and attempts to synch with server using Control Panel>Date & Time are failing. As per original post, I hope Miscrosoft's people read this!!!

    Wednesday, September 12, 2007 6:39 PM
  • I also have McAfee installed which caused this problem for me. Had to add the IP of my ISPs NTP server as "Trusted IP" to the McAfee Firewall.

    Anyone with a firewall should probably check if this helps.

    The article of McAfee can be found here:
    http://ts.mcafeehelp.com/eSolution.asp?docID=419449

    Thanks dbw1050 for the solution!
    Wednesday, September 12, 2007 10:25 PM
  • Okay, I'm so sick and tired of this problem.  Can you explain to me, a normal computer user, how to fix this problem?  I'm really wanting to fix my time synch problems in XP on my laptop.  I keep getting error messages.  Once, it was fixed... I changed the server I synched to and it worked for 2 hours!  The next time I turned on the computer, I got an error message that said:"An error occurrd getting the status of the last synchronization.  The rpc server is unavailable."

     

    Can you walk me through this?

    Saturday, September 15, 2007 4:35 AM
  •  MJJL wrote:

     

    For small Lans or for Individual Clients we are simply sending an email to all the clients computers flagging it as a company Security Update:

    We simply instruct them "to click on the time icon on the desktop, then click the Internet Time tab, and then copy the following blue text only - tick.usno.navy.mil - and next paste it in the Server: Field, then click on Apply, then Update Now and finally OK.  Done, no more error messages. 

     

     

    This worked well for me.  At first, it seemed to fail when I clicked the 'update now' but it was successful after a couple of tries.  I am using a Vista computer up to date with system patches. 

    Saturday, September 15, 2007 6:34 PM
  • I have tried all fixes from MS and both time.nist.gov and time.windows.com have quit synchronizing my computer.  The last error message was: "an error occurred getting the status of the last synchronization.  Element not found."  I don't think Microsoft is doing anything about this.

     

    Sunday, September 16, 2007 11:51 PM
  • I'm not sure what you mean by having "configuration options with the Event Logs".  Could you elaborate?

     

    Thanks,

    Russ-S

    Wednesday, September 19, 2007 2:16 AM
  • I think I figured out the problem, guys -- I had the same issue for months -- whenever I tried to sync the time, I got an error message saying something like, "Cannot establish connection, time synchronization failed."  No matter which server I used (and I tried dozens), it always came back with this message.

     

    One simple step fixed the problem -- I disabled my McAfee firewall.  I didn't even enable it in the first place, I was fine with the Windows firewall.  However, when McAfee was installed, it disabled the Windows firewall and was running its own.  Now that I stopped it and went back to Windows, the time sync works perfectly.

     

    Hope this helps!

    Tuesday, September 25, 2007 5:28 AM
  • time.windows.com and time.nist.gov are not working and it took me forever to find this page

     

    if I put the two below it works????

     

     tick.usno.navy.mil;  time.mit.edu

     

    I am now switching them in the registry replacing the two default with the two working ones.

     

    A simple fix I hope.

    Tuesday, September 25, 2007 5:53 PM
  • After searching for an answer; here's what worked for me (add trusted IP to firewall):

    http://service.mcafee.com/FAQDocument.aspx?id=307135&lc=1033&partner=McAfee&type=TS&ia=1

     

    time.windows.com still didn't work for me, so I used time.nist.gov (ping time.nist.gov = 192.43.244.18)

     

    Hope I save someone some time! Good luck

    Thursday, October 04, 2007 5:17 PM
  • I think this link might shed some additional light...

     

    http://tf.nist.gov/service/its.htm

     

    Towards the bottom it says the following:

     

    Time Protocol (RFC-868)

      This simple protocol is now used by only about 1% of ITS customers. It returns a 32-bit unformatted binary number that represents the time in UTC seconds since January 1, 1900. The server listens for Time Protocol requests on port 37, and responds in either tcp/ip or udp/ip formats. Conversion to local time (if necessary) is the responsibility of the client program. The 32-bit binary format can represent times over a span of about 136 years with a resolution of 1 second. There is no provision for increasing the resolution or increasing the range of years.

      The strength of the time protocol is its simplicity. Since many computers keep time internally as the number of seconds since January 1, 1970 (or another date), converting the received time to the necessary format is often a simple matter of binary arithmetic. However, the format does not allow any additional information to be transmitted, such as advance notification of leap seconds or daylight saving time, or information about the health of the server.

    Starting on 14 April 2007 the server time.nist.gov will no longer respond to requests for time in the TIME format (as defined in RFC-868). These requests are generated by a number of different programs including DATE, RDATE, and other programs that connect to the time server using tcp or udp port 37. All of the other NIST servers (except for time-nw.nist.gov) will continue to respond to requests to either tcp or udp port 37 for time in the format specified in RFC-868.

    However, this format has poor error-handling capabilities in general, and many of the client programs that use this format are poorly written and may not handle network errors properly. Therefore users are strongly encouraged to switch to the Network Time Protocol (NTP), which is more robust and provides greater accuracy. We eventually intend to phase out support for the TIME format on all servers.

    Please send questions or comments regarding this issue to Judah Levine: jlevine@boulder.nist.gov

     

     

     

    Also this page ahs tons of servers:    _________>>:

     

    http://tf.nist.gov/service/time-servers.html

     

     

    Friday, October 05, 2007 8:02 AM
  •  

    Hi.

     

    Just a problem with this. Ive never used command prompt before so im sure its me thats doing something wrong (but i do use vista, so im not going to blame myself yet)

     

    What you posted here is helpful, but when i type the first thing "net stop w32time" and press enter, it says "system error 5 has occured. Access is denied"

     

    Could you PLEASE please help me with this. Im really fustrated that the smallest problem of not being able to sync the clock, makes ALOT of more problems.

     

    Please email me.

     

    Thankyou for your time

     

    Luke

    Monday, October 08, 2007 6:06 PM
  • Luke, you need to run the command prompt in a higher privilage mode.  right click your command prompt shortcut and select "run as administrator".

     

    additionally, this post is way long, you might get more attention starting a new post for something like this.

     

    Tuesday, October 09, 2007 5:36 PM
  • I tried a number of sync sites but it wasn't until I reset my clock manually to the correct date that I had success with an internet sync. It seems that the time servers can't sync time until the date matches!?!

     

    Jim G.

     

    Wednesday, October 10, 2007 3:47 PM
  • Still broken. 

     

    I think after a few months now it is safe to assume that Microsoft no longer supplies a synchronization service?

     

    Has anyone seen any announcements on this elsewhere?

    Friday, October 19, 2007 5:20 PM
  • well they haven fixed it i suffered this exact problem this morning ( tuesday october 23 10:30 am) i take it this means nobody from microsoft reads these forums i wonder if they will ever fix it

    Tuesday, October 23, 2007 7:36 PM
  • I have suffered for several months, and I have never been able to fix the Microsoft problem.

     

    So, as a last resort, I downloaded a third party time Time Synchronisation software from Softnik Technologies and it works perfectly.

     

    Problem solved.

     

    Thursday, October 25, 2007 9:43 AM
  • Amen.

     

    Monday, October 29, 2007 1:59 PM
  •  AJ_prog wrote:

     MJJL wrote:

     

    For small Lans or for Individual Clients we are simply sending an email to all the clients computers flagging it as a company Security Update:

    We simply instruct them "to click on the time icon on the desktop, then click the Internet Time tab, and then copy the following blue text only - tick.usno.navy.mil - and next paste it in the Server: Field, then click on Apply, then Update Now and finally OK.  Done, no more error messages. 

     

     

    This worked well for me.  At first, it seemed to fail when I clicked the 'update now' but it was successful after a couple of tries.  I am using a Vista computer up to date with system patches. 

     

     

     

    I did what AJ-prog and MJJL suggested and it has worked so far (for now). But now when I click on the time icon there is not an INTERNET TIME tab available anymore. I can't see how this won't pose a problem in the future.

     

    Can anyone tell me where this tab went? What happens if my time synchronization stops working again?

    Wednesday, October 31, 2007 4:52 PM
  • You may as well add Windows 2000 to the list of complaints.  The only thing I can do is point my time zone to the correct time zone and the time will be one hour earlier.  I have searched Microsoft and cannot find any mention or fixes for Windows 2000.  Anyone else having this problem?

    Thursday, November 01, 2007 12:04 PM
  • After going through the threads, and trying a bunch of stuff; here is what worked for me.

     

    Turn off McAfee firewall.

    Turn on Windows firewall

    Copy and paste the following address on the internet tab of your desktop time:  tick.usno.navy.mil

    click:  update now

    click:  apply

     

    Works every time so far.

     

    (It's navy, can't be more than a few minutes off)

    Monday, November 05, 2007 11:02 PM
  • Thanks! That "tick.usno.navy.mil" ALMOST was a total solution. When I used it, the clock time did update (finally!), but the application still said "error when ...synchronzing..." or whatever. BUT, after I rebooted, the time remained good (synchronized) and the error message was replaced by (the good message ...I tried writing what I said but this post kept automatically sticking "smiley faces" in there. Yikes). Anyway, it worked, at least for the one sync.

     

    I then tried the time.windows...and time.nist... again (thinking that maybe something and self-fixed) and they we still resulting in error messages even after reboots. (Windows XP SP2 or whatever on a Tablet PC

     

    Thanks again. But, I don't know if I'll stay using "navy" except "in emergency" seeing that it's not a civil site. Perhaps there are others besides nist and windows, though, that are "dot.com" 

    Thursday, November 08, 2007 7:53 PM
  • Hi:

    I opened up port 37 on my firewall and it fixed the problem. I am using Vista Ultimate and the MIT time server. Thanks!

    Michael Nisbett
    Sunday, November 11, 2007 5:58 AM
  • My problem is accessing McAfee. How did you do that?

     

    Monday, November 12, 2007 8:44 PM
  • This was more than helpful and after redoing my entire registry, perhaps using the XP guidlines and not the Vista ones (hope that doesn't create a problem later) I found the problem was indeed McAfee and that IP worked FANTASTIC!!

    Thanks for saving me time and frustration over the hours I already spend doing it....
    Wednesday, November 21, 2007 9:15 PM
  • For those of you who have McAfee and can't time Sync here is the latest.Step by step to do what Netripper  said..(This  for a windows XP machine)

    DON"T open your port 123 . That is not secure.

    Here is how tech support at mcAfee solved the problem.. Basically you're simply finding the ip address for the time server and adding it to your list of trusted ip addresses in the firewall program.....
    Double click on your clock icon at lower right corner of the desktop screen and select "Internet Time" on the tabs in your Date and Time window that pops up
    Ensure Automatically update with the internet time server is selected.
    Observe the name of the Server field and write it down.
    ie: time.windows.com
    Now click Start, Run and type "cmd" and press ENTER.
    command prompt window is opened
    Type ping time.windows.com and press ENTER. The ping results may return "Request timed out" if the server is set not to respond to ping attempts.
    The first line displays:

    Pinging <Server Name> [IP Address] with 32 bytes of data:


    Write down the [IP Address] and close the command window.

    For example given, the ip address would be... 207.46.197.32
    Now double-click the Red "M" icon in the systray to open the SecurityCenter.
    From the Basic Menu
    Click Internet & Network and click Configure which is on the center right.
    click Firewall protection is enabled and click Advanced.
    Click Trusted and Banned IPs.
    Select Trusted IP Addresses from the drop-down menu.
    Click "Add and select Single IP Address" then type the Server IP Address (207.46.197.32) in the IP Address: field.
    Click OK then click Yes.
    Close the Firewall Window, then close the SecurityCenter.
    Please restart your system to take the changes get affected.
    Check your time and update it to see that the changes have fixed your problem
    Saturday, November 24, 2007 9:00 PM
  • Actually, I now see that the McAfee technical assistant read from a FAQ. The link to that FAQ is.....

     

     

    http://service.mcafee.com/FAQDocument.aspx?id=307135&lc=1033&partner=McAfee&type=TS&ia=1abs

     

    If you go to the McAfee Tech support page and do a search using the terms "Time Update" you should get this document

     

    the instructions are more clearly listed there. If ANYONE having problems running the time updater is using a personal firewall they should consider adding the ip address for the time server to their firewall's list of trusted sites...

     

    Saturday, November 24, 2007 11:26 PM
  • Thank you so much for the options you listed on your post.  The time.mit.edu worked for me!  All other things I had previously tried had failed. 

    Wednesday, November 28, 2007 8:35 PM
  •  

    Hi Malcolm

     

    I get the same error message (an error occurred getting the status of the last synchronization.  Element not found) and i have tried EVERYTHING !  have you had any joy or have you found the MAGIC sntp server if so pls post it

     

    Thanks a lot

     

    btw happy new year Smile

    Saturday, January 05, 2008 11:54 PM

  • For those still frustrated with this problem, dbw1050 's  way works great! 

    Just go into McAfee's firewall, advanced settings, Trusted IPs, and add 192.43.244.18   as a trusted IP.  Then go into Windows Vista's Internet time and change the sync server to
    time.nist.gov

    Works like a charm!



    Thursday, January 17, 2008 4:43 PM
  • Ok here goes !!

    After months of being unable to synchronize my clock I DID IT !!!!!

    and heres how :-

    run this script (windows key & r)

    net stop w32time
    w32tm /unregister (ignore error message)
    w32tm /unregister (enter a second time)
    w32tm /register
    reg add hklm\system\currentcontrolset\services\w32time\parameters\ /v NtpServer /t reg_sz /d time.nist.gov /f
    net start w32time
    w32tm /resync


    NOW reboot PC
    when restarted double click your clock
    you should notice the sntp server is now time-a.nist.gov and apply box is already checked this means it has worked.
    Just press 'update now' and HEY PRESTO it has synchronized

    *bows*

    THANKS FOR NOTHING MICROSOFT !!!



    Thursday, January 17, 2008 9:06 PM
  • Dear john :0

    run this script to be able to update time.

    net stop w32time
    w32tm /unregister [ignore error message]
    w32tm /unregister [enter a second time]
    w32tm /register
    reg add hklm\system\currentcontrolset\services\w32time\parameters\ /v NtpServer /t reg_sz /d time.nist.gov /f
    net start w32time
    w32tm /resync

    Reboot PC
    then go to clock and click 'update now'

    Let me know how u got on
    Thursday, January 17, 2008 9:08 PM
  • Dear john :0

     

    It worked!!

     

    Best news in ages.

     

     

     

     

     

     

    Friday, January 18, 2008 9:01 AM
  •  

    Rotherboy

     

    What solution worked for you ??

    Sunday, January 20, 2008 2:51 PM
  • The solution was the script that started.......

     

    netstop w32time.... etc

     

    It worked at the first attempt. I use XP, so I don,t know if it will work with Vista.

     

     

     

     

    Sunday, January 20, 2008 3:08 PM
  •  

    instead of trusting the IP, you could check your McAfee firewall settings...

     

    go to advanced settings, select "System Services" and you'll find a host of windows services that are blocked to protect your system... including... "Network Time Protocol Port 123".

     

    click it and you are right as rain.

     

    Saturday, February 23, 2008 9:49 PM
  • Just wanted to say thanks for the port info!  I've been searching for the time sync solution for about a year, of course nothing worked.  As soon as I opened the port, it solved the problem.  Too easy.

     

    Monday, March 10, 2008 5:41 AM
  • I kept messing with the Windows firewall and never thought of McAfee.  Thanks.  Fixed me too!!  Benn messing with this for months.  OK, messed with it a few times over the course of several months.

    Monday, March 31, 2008 11:06 AM
  • Faberd,

     

    Wow!  After innumerable attempts at resolving this problem, your e-mail supplied the magic bullet.  I had tried all the other suggestions in earlier posts, but this was the only thing that worked.  Thanks so much.

    Since I have McAfee firewall turned off, it never occurred to me that it might still be the problem.

     

    Anyway,

     

    You 'da man!

     

    Steve

    Friday, April 04, 2008 7:26 PM
  •  

    I've tried everything you guys suggested on this post.  I just got my time sync service working properly using time.microsoft.com by switching the global policy setting for NTP from NT5DS to NTP - kept everything else the way it was.  Stopped, restarted the NTP service, did a resync and it works perfectly.

     

    I did this on a PDC and now all the time sync errors on the rest of the servers in the lab have gone away as well.

    Friday, April 04, 2008 8:07 PM
  • Worked for me also: my time was 25 minutes off!

     

    Thursday, May 22, 2008 4:22 AM
  • Thanks JohnGalt this post (  JohnGalt on 19 Apr 2007 6:47 PM) fixed the problem on my vista machine. I use time.gov and it worked fine, thanks alot!!!
    Tuesday, May 27, 2008 1:22 AM
  • I'm glad it worked!

     

    Now Microsoft: Since you borked this with your Daylight savings time update, why don't you release an update that fixes this perminantly for everyone?  In the last week alone I've seen 25 computers all out by at least 30 minutes or more because of this problem STILL.

     

    (and no, it isn't that POS mcaffee on their computers, I don't let people run that CRUD.)

    Tuesday, May 27, 2008 1:05 PM
  • "The time service has detected that the system time needs to be  changed by +86402 seconds. The time service will not change the system time by more than +54000 seconds. Verify that your time and time zone are correct, and that the time source tick.usno.navy.mil,0x9 (ntp.m|0x9|0.0.0.0:123->192.5.41.40:123) is working properly."

    I found a solution to my synchronisation problem - just have to set manually your clock before updating internet time. And that's it. It works.

    Monday, June 09, 2008 1:29 PM
  • I resolved my McAfee firewall problem in the following way:

    From McAfee Home

    Click "Internet & Network" then "configure"
    The first section should be "Firewall protection is ..." click the "Advanced" button in that section.
    In the left side column the second choice should be "Program Permissions", select it.
    Click the "Add Allowed Program" button.
    Enter "C:\Windows\system32\rundll32.exe" as the file name and hit enter.

    Rundll32 should have full access. Don't know if it needs it, but it got the job done.

    Anyway this worked for me. That and I did a Google search for a new time server and put it into windows registry. I'm sure someone will let me know if I did wrong and look forward to it.

    My next projects are: add seconds to my taskbar clock and figure out how to get the clock to update more often then once every seven days.

    Check out while you're at it http://theautodidacticuniversity.muux.org/.

    Wednesday, September 10, 2008 7:36 AM
  • I have OpenNTPD running on my Linux household server, and my server's time is perfect. It grabs times from 4 stratum 1 and 8 stratum 2 servers and averages them together,a dn changes how fast my computer's clock ticks so that it never goes off (although it resyncs twice daily).

    Anyway, I recently set up OpenNTPD to listen and act as a NTP server. I pointed my vista machine at it, and it complained that "[t]he peer's stratum is less than the host's stratum." Even when my server was only syncing off a stratum 1 server, making it stratum 2, Vista still complained.

    PS: This machine has never been set to sync, and was 15 minutes off. I fixed that already, by hand of course.

    [ EDIT ]
    5 seconds after I posted this, the message changed to complaining that the remote peer was not synced. Wtf.
    Saturday, December 06, 2008 10:22 PM
  • It says an error occurred when I try to sync with any time server, I've tried my isp's, the pool.org ones, time.windows.com
    But I'm able to sync the time on this same computer from VMs running inside the computer, so it's not a firewall issue.

    In vista I don't have a "type" string in the registry, it's a dword number.

    I've had occasional issues with the time sync over the years with vista, xp.  I have a feeling it doesn't work on a lot of computers, but people don't go around checking it until their motherboard battery goes out and the time is off.


    I ended up using this instead, it works fine so there's obviously a problem with the time sync and not the computer...


    but in vista you have to click "run as administrator" to run the installer.
    Saturday, May 09, 2009 9:15 AM
  • The above utility is great - thanks.

    By the way, for UK / Europe users, sync up to pool.ntp.org, works every time. http://www.pool.ntp.org/zone/europe But I have the same problem with the clock randomly setting to an odd value for no apparent reason, wideley reported here.
    Sunday, July 26, 2009 8:49 AM
  • I would like to thank you.
    I tried the resync at command prompt and it seems that it worked well I only did a restart and the window didn't come up saying that I would have to end now  C:windows\system32\w32tm.exe.  So I think that it work for me.

    Thanks Whatssaup
    Wednesday, September 16, 2009 12:15 AM
  • I don't know whether this will help anyone out there, but until recently I've had a lot of trouble synching with an internal server after a building a new box...
    doesn't work...doesn't work... suddenly works after mucking around. Turns out to be "user error". When changing the ntp server name I used to then click "Update now". BZZT wrong. You need to click "Apply" for the new name to stick, then "Update now"
    Wednesday, September 23, 2009 5:42 AM
  • I have 3 computers on my home network. All pointing to time.nist.gov

    Vista Home Premium

    Server 2003

    XP Professional

    XP and the Server update correctly with no problems. No need to open port 123. That eliminates a router issue

    Vista refuses to work with no firewalls active. Tried multiple time servers to no avail.

    So definitely a Vista issue

    Monday, June 28, 2010 12:18 PM
  • I have done that and it doesn't help at all.  I am running Windows 7 Home Premium

     

    Friday, July 01, 2011 6:00 PM