none
You'll need to provide administrator permission to delete this folder...

    Question

  • Hi,

    I'm hoping someone can provide a simple answer to this problem.

    I am trying to delete a folder (and all of the files in it) and I am getting the following errors:

    1. You'll need to provide administrator permission to delete this folder. (Continue/Skip/Cancel)
    2. I select Continue
    3. You need permission to perform this action. You require permission from MyPC\Bob to make changes to this folder. (Try Again/Cancel)

    The problem is that I am logged in as MyPC\Bob, and Bob is an Administrator account.

    So, how exactly do I ask myself for permission ? And how do I give myself permission ?

    Bob has 'Full control' of the folder.
    Bob is the owner of the folder.
    But Bob cannot delete the folder because Bob has to ask Bob for permission..... /boggle.

    L.

    Wednesday, April 28, 2010 1:46 AM

Answers

All replies

  • Hi,

     

    I would like to confirm what files you would like to delete?

     

    In Windows 7, the files in system folder are protected. To delete them, you may try to disable User Account Controller (UAC).

     

    Does it work?

     

    Regards,


    Arthur Li - MSFT
    Wednesday, April 28, 2010 5:59 AM
    Moderator
  • I suffer from the described problem. I created folders as an admin and I want to delete them. No avail despite having all permissions I can find. I tried to find out about my rights and shared a folder. I cannot reset the sharing. This is extremely frustrating as there is no logic behind this. The "explanations" don't touch the problems and are useless.

     

    Mau be you can shed some light on this.

    Tuesday, November 29, 2011 6:02 AM
  • I had exact same problem and i was able to get around by deleting inside folders first and then the root folder in the end.

    May not be what you looking for, but worth trying.

    For example you have folder MyPC\Bob\Some folder

    Delete first "Some Folder"

    Delete "Bob" in the end.

    • Proposed as answer by PaducahMan Friday, December 23, 2011 3:57 AM
    • Unproposed as answer by PaducahMan Friday, December 23, 2011 3:58 AM
    • Proposed as answer by InertiaESP Friday, January 10, 2014 8:43 PM
    Tuesday, November 29, 2011 6:24 AM
  • Right Click on the folder (or file) you want to alter, select Properties>Security> Edit.  Then under Permissions give yourself Full Control, then click OK.  Now go back and perform the task you wanted and there would be no more annoying messages!  

    • Proposed as answer by crazydogdude Saturday, February 01, 2014 12:38 AM
    Friday, December 23, 2011 4:03 AM
  • you need to take ownership of the folder that you want to delete.. right click on the folder>properties> then click the "security" tab> click on "advanced" near the bottom> click on the "owner" tab> then click"edit"... you will now see who owns the folder... > click on the administrator account that you are using and want to use for full control.. and remember to highlight the "Replace Owner on Subcontainers and objects" box>click "apply"> click "ok"> and a pop up asks if you want to replace the permissions folder with a new permissions folder containing you full control.. click yes.... to be honest I just did all this to my whole drive.. just to be certain..  :)..... you may have to turn off "inheriting permissions".. but that is a whole other story 
    Thursday, April 26, 2012 7:20 PM
  • so i tried to do that, thing is when i press on security tab and click advanced under all those tabs (permissions, owner, etc) is a message that says " You do not have permission to view or edit this object's permission settings", and i dont really want to format my whole drive because windows are there. im suspecting on a malware, but Security Essentials haven't found anything. 
    • Proposed as answer by davtha Sunday, June 10, 2012 4:31 AM
    • Unproposed as answer by davtha Sunday, June 10, 2012 4:31 AM
    Sunday, April 29, 2012 10:37 AM
  • I also experienced this problem. The only thing that worked for me was booting up from a windows DVD and deleting the folders via the command promt. Windows is soo user-freindly
    Monday, May 21, 2012 9:17 PM
  • I have had the same issue and found that going to the parent folder of the sub folder, in my instance the Music folder, right click on that, click properties on the general tab go to the bottom and un-highlight the read only box, press apply then click okay in the pop up box.  The pop up box then scrolls through and appears to change permissions to all the sub folders.  I was then able to delete the sub folders in the music folder as usual.
    Sunday, June 10, 2012 4:37 AM
  • I'm embarassed to admit the solution to my inability to delete a folder.  I was using 7-Zip to look at the contents of the folder.  Later when I tried to use Explorer (and the Command Prompt) to delete the folder, I got the error message that it couldn't delete the folder.  Well duh.  After a lot of head scratching, I finally noticed, and I changed 7-zip off the path.  Bingo!  Folder gone.

    I'm a little puzzled, though, at the error message that indicated that it was an Administrator/Owner issue rather than a conflict issue.  This was very misleading.  I guess the "lesson learned" is to never trust error messages.
    • Edited by BobCrunch Saturday, July 21, 2012 9:17 AM
    Saturday, July 21, 2012 8:38 AM
  • So to delete it, Bob has to cut the folder to his disktop (be srure that all subfolder\files are closed), then Bob can delete that folder easyley. (tested in win7)

    That all

    End.




    • Edited by Khalid 1398 Thursday, December 06, 2012 8:35 PM c
    Thursday, December 06, 2012 8:30 PM
  • I had this problem, I tried everything that's been said up here, so, I did something simpler...

    1. Go to the desired folder and open it.

    2. Delete all content inside, you may find that a folder within the desired folder can't be deleted.

    3. Go inside THAT folder and delete everything in there.

    4. Go back to the folder that you just entered, and delete it.

    5. Delete the folder that you wanted to delete in the first place.

    I know, I make it sound like Inception, but it works.

    Monday, January 07, 2013 6:46 PM
  • you need to take ownership of the folder that you want to delete.. right click on the folder>properties> then click the "security" tab> click on "advanced" near the bottom> click on the "owner" tab> then click"edit"... you will now see who owns the folder... > click on the administrator account that you are using and want to use for full control.. and remember to highlight the "Replace Owner on Subcontainers and objects" box>click "apply"> click "ok"> and a pop up asks if you want to replace the permissions folder with a new permissions folder containing you full control.. click yes.... to be honest I just did all this to my whole drive.. just to be certain..  :)..... you may have to turn off "inheriting permissions".. but that is a whole other story 

    Useless in my version of windows 8 pro Jan 27, 2013. No 'owner tab' and on.

    Sunday, January 27, 2013 6:34 PM
  • Fantastic! After 2hrs of trying to delete, i tried your way and it works 100%.Thank you.
    Wednesday, May 08, 2013 1:42 PM
  • hi-open file, then INDIVIDUALLY delete each line item. the stupid thing will go away.  
    Saturday, July 27, 2013 11:03 PM
  • I have the same issue but mine is impossible to fix. 

    1)Can't enter the folder at all. (even tho it's empty right now)

    2)Can't uncheck the read-only option as someone suggested.

    3)Can't give administrator previleges to myself even though im the administrator.

    Thursday, August 15, 2013 3:24 PM
  • I also came across this problem, but i solved this problem through this way.

    Firstly, cut this folder to the desktop;

    Secondly, opening this folder until the last one ( because  some other folders inside it);

    Thirdly,right click the last folder (the innermost one)>properties>then click the "security"tab> Under the title of "Group or user names: Users(YOUR NAME\Users), Authenticated Users, SYSTEM,Administrators(YOUR NAME\Administrators), choosing one of them, click "edit " >then choose one of them ( below the title "Group or user names") ( if you are not sure which one, you can try it one by one ) > click" Full control" of the title of Allow line. Then you can delete this folder.

    Fourthly, following above step to delete the previous folder of the last one and the rest can be done in the same manner.

    • Proposed as answer by QUY LUONG Sunday, November 03, 2013 9:00 AM
    Wednesday, October 02, 2013 4:54 AM
  • GENIUS!!!!!!! I just sat here for at least half an hour trying to figure out how to delete a folder... once I unchecked that box I was able to go into it and delete it all :)
    Tuesday, October 15, 2013 12:36 AM
  • If you still can not delete files and folders after you have successful done as previous instructions, you will need run cmd and use this command:

    rd <folder name> /s/q

    I hope you can do it.

    Sunday, November 03, 2013 9:03 AM
  • Hi Quy

    Thanks for the idea but (for me) it was not successful.

    ACCESS IS DENIED

    Your tip was however useful in identifying the files responsible for the problem. So Thank You.

    Thursday, November 21, 2013 4:21 PM
  • What I did was:

    1. right-click the file

    2. select properties

    3. then un-check the Read-only and Archive

    4. press OK and that's it.

    Monday, November 25, 2013 8:33 PM
  • Yes, this method worked easily in Windows 7.

    Thanks

    Thursday, December 12, 2013 3:00 AM
  • Thanks, that worked for me!

    Saturday, December 28, 2013 2:47 AM
  • I know this is old but here's another potential solution.

    I ran into this same problem on Windows 7 after moving a folder full of pics and word docs from my desktop to an external hard drive which appeared to work just fine except the folder was still left (empty) on my desktop.  When trying to delete the folder off of my desktop, I got the same Admin permission needed and folder in use errors even though I have all permissions as the actual Admin.  I tried many of the things (including rebooting etc.) on here but nothing worked.

    What worked for me:

    1. Right click the folder you are trying to delete.
    2. Click Properties
    3. Select the 'Previous Versions' tabYou should see multiple versions of the same folder name from days or weeks prior.  These are basically automatic backups that were taken in the background.
    4. Select an older version of the folder that you want to delete under the 'Previous Versions' tab.
    5. Click 'Restore' button.  You will see a warning that the folder will be restored and WILL overwrite the existing folder.  If this is okay, then...
    6. Click 'Yes' to restore the folder when prompted.
    7. Right click the folder and select Delete once it has been restored.

    This procedure repopulated the empty folder that I could not delete.  I then right clicked on the folder and selected delete and the folder finally went to the recycle bin where I was able to successfully empty it.




    Friday, February 14, 2014 5:30 PM
  • This worked for me, since the file only had a user rights for someone (something assigned by Google Drive?) that was a relic from the previous installation (I upgraded from XP to Windows 7)  Adding my account to access the file with full control finally worked.

    Thanks PaducahMan

    Friday, June 06, 2014 4:24 PM
  • Hi,

    Make sure the folder isnt shared on your local network. It worked for me.
    Sunday, July 13, 2014 4:48 PM