none
Network Security Key Mismatch

    Question

  • Hi all,

    Using windows 7, I have a persistent problem connecting to the Internet. When I try to connect to my router (wifi), I get "Network Security Key Mismatch" after entering the password for my connection. I am 100% positive that I am typing the password correctly.

    I have tried manually creating the network connection, so I can specify the security type, etc. I get the same result.

    I can connect to my neighbours unprotected wifi, so I know the hardware and drivers are functional. The problem is only when I connect to my router (linksys).

    It works fine when using Vista.

    This is the only thing stopping me from using Windows 7 full time (and indeed purchasing it for my three family computers).

    Can anybody help me? I've trawled the Internet many times looking for an answer.

    Thanks in advance,
    Nik


    Thursday, June 18, 2009 7:44 AM

All replies

    • Proposed as answer by Marlon87 Thursday, December 09, 2010 6:45 PM
    Thursday, June 18, 2009 8:47 AM
  • Hi Filip, and thanks for your reply.

    I did read that thread, but I didn't think it applied to me, as my MAC address hasn't changed. If I put my HDD with Windows Vista back into the machine, it connects without difficulty. Does this imply that the thread you linked to doesn't apply to me? Forgive my ignorance!

    To clarify, I have a laptop, with the original HDD in, I can connect fine. When I swap the HDD to a new one which has my Windows 7 installation on it, I get asked for the security key over and over.

    I have seen a couple of forum threads on other forums which seem to have the same problem as me, but there hasn't been a response to these threads.

    Thanks again for your assistance.

    Nik
    Thursday, June 18, 2009 10:09 AM
  • Nik,

    Have you tried to manually configure the wireless connection?

    1. Open the Network and Sharing Center
    2. In the left pane click Manage Wireless Networks
    3. In the list of networks right click your wireless network and click Properties
    4. Click the Security tab and check its settings

    I have seen a number of times that WPA was chosen instead of WPA2 or that TKIP was chosen instead of AES encryption.

    Ensure the settings here resemble the security settings on your access point.

    I hope this fixes your connection issues.


    Ray
    • Proposed as answer by NextXPertMVP Thursday, June 18, 2009 12:31 PM
    Thursday, June 18, 2009 12:31 PM
  • When you manually configure it, try unchecking the hide characters as I type check box just in case there is a mistype somewhere.
    • Proposed as answer by BlackdeathXS2 Sunday, October 25, 2009 8:10 PM
    Thursday, June 18, 2009 1:58 PM
  • Had same problem

    Try entering password with CAP locks on - This worked for me
    Sunday, October 25, 2009 8:14 PM
  • Let me know if you find the answer to your question about "Network Security Key Mismatch" for Windows 7 using Linksys.  I'm having the same issue.
    Saturday, December 26, 2009 11:30 PM
  • Having the same problems... have tired everything mentioned thus far with no luck.  Hope someone can help.
    Sunday, December 27, 2009 7:04 PM
  • i was having this same problem with my new laptop and Linksys wireless router. here's how i solved it...
    -went into my router's wireless security settings and changed from WEP to WPA2 Personal
    -changed from TKIP to TKIP+AES
    -set to 64bit 10 hex
    -set password
    -saved settings

    after that i was able to connect without a problem. seems my windows 7 doesnt like WEP at all and prefers AES over TKIP
    • Proposed as answer by KarissaLi Monday, May 14, 2012 8:42 PM
    Saturday, January 02, 2010 3:39 PM
  • I had this problem in Win 7 and what I had done was not correctly match up the Key # in the WEP security in my modem/router setting with the number set in the wireless network setting.  Win 7 defaults to Key 1 but my used passphrase was on Key 2 on the modem settings.  Not sure this is your issue, but FYI
    Saturday, January 23, 2010 6:47 PM
  • What kind of linksys was it? I have a WTR54 (802.11) and it doesn't offer me a WPA2 personal option. I get a lot of WPA2 Shared Key or WPA2 radius options. Is my router just old?
    • Proposed as answer by younesadam15 Sunday, June 26, 2011 8:03 PM
    Wednesday, February 10, 2010 4:31 AM
  • Thanks Ray, this fixed my problem, I'm amazed that Windows doesn't determine I am using AES encryption on it's own.

    I had to manually add the wireless network and specify the settings. I never had to before Win 7 though...
    Monday, February 22, 2010 11:23 AM
  • Hello, I'm having the same issues and none of the suggested solutions have worked.

    In my case, what happened is my D-link router suddenly couldn't find a network connection, so I phoned them and they had me change from WEP to WPA2, and delete and recreate the name for my network. This worked fine on my Windows XP PC, but my laptop (Windows 7) will not connect to this same (new) wireless connection, and I get the same msg of Key Mismatch.

    When I try to add/create a new wireless connection to match the new settings, it just puts an "X" in the box showing all available connections, and says it does not match the settings of the one I just created! Very frustrating, and sorry if I'm not explaining this too well... I am not very technical. If I try a different setting (say, WEP or WPA2 with TKIP, even though I know this is not correct) it accepts it, but then I get the Key Mismatch every time I try to connect.

    Any assistance/suggestions would be greatly appreciated.

    Thursday, March 25, 2010 4:37 PM
  • I had the same problem with my Linksys router until a few minutes ago, I tried resetting my password since the it wouldn't work..."Network Security Key Mismatch."  I uninstalled Linksys on my 'old' laptop, which has XP, reinstalled the router, and got a new encryption key.  I got on my new laptop (Windows 7), selected my router name, entered the new encryption key and it worked!!!!  Here I am typing this wirelessly....after working on this all afternoon.  I didn't have to change any settings on my new laptop.  This stuff really frustrates me when it doesn't work.  Hope this works for you.
    Sunday, March 28, 2010 3:27 AM
  • Hello,

    Thanks for your response. I managed to the problem fixed by calling D-link and working it through with them (they are still supporting the product for free, even though I bought it several months ago, so kudos to them).

    For anyone else who has this problem, the main issue appears to be that my new laptop (< 1 month) does not accept the WPA2-PK setting as it is incompatile with the built-in wireless network driver. So, I changed the setting to WEP, and also re-named the security key, passwords, etc. while doing this, and all now works well.

    Cheers.

    Sunday, March 28, 2010 9:24 PM
  • This was frustrating to me because i called linksys and they didnt help. told me i had to pay. so this is wat i did to fix mine using windows 7.

    1.Unplug router then plug it back in.

    2. right click the conection

    3. left click the connection

    4. it will tell u to hold the wireless button on the router do that instead of typing your phrase. The internet will conect by itself and there u go.

    5.If it doesnt work repeat step 1-5

    Hope this solves your problems.

    Thursday, April 08, 2010 12:39 AM
  • I had the same problem and just found out that Windows 7 is case sensitive.  The security key is case sensitive.
    Friday, April 23, 2010 11:32 PM
  • Has anyone found a solution to this yet ? Tried 100 different suggestions from all different people and still can't connect wirelessly.Windows 7 is a bad joke! How dare they put this on the market like this.
    • Proposed as answer by YAKUDO Wednesday, July 07, 2010 2:08 AM
    Monday, May 10, 2010 12:36 PM
  • ya, I have the solution.

    The security key is the one that was generated automatically after configuring the router for the first time and using it on the first wifi connecting device (e.g. laptop). If you have it then good otherwise restore the router to factory default setting.

    This time save the automated password generated after putting the router pin while connecting with wifi network on the first device.

    Use the same pin for all the device in future.

    • Proposed as answer by divyanshjha Friday, July 02, 2010 6:10 AM
    Friday, July 02, 2010 5:36 AM
  • With Me

    The problem was my security WEP key, in the ROUTER was in lower case.

    Once I made the key UPPERCASE in BOTH the router AND the laptop everything was fine.

    Wednesday, July 07, 2010 2:10 AM
  • Had the same problem with a Toshiba notebook. It wouldn't connect to the wireless netwerk no matter what. Desperate I changed the SSID and accesskey. I made it a WEP code with 10 x 0 as password, couldn't type that wrong, right? Tried a couple devices on this network, worked just great. However, the Toshiba just would not work.

    What I did was putting the wireless settings of another notebook, on which the network worked fine, on a flashdrive. I then installed these on the Tosiba and it would connect just fine.

    Friday, July 23, 2010 8:13 AM
  • try WPA2-AES instead of WEP. you will need to reconfigure the router.
     
    On Fri, 23 Jul 2010 08:13:06 +0000, Mmore wrote:
     
    >
    >
    >Had the same problem with a Toshiba notebook. It wouldn't connect to the wireless netwerk no matter what. Desperate I changed the SSID and accesskey. I made it a WEP code with 10 x 0 as password, couldn't type that wrong, right? Tried a couple devices on this network, worked just great. However, the Toshiba just would not work.
    >
    >What I did was putting the wireless settings of another notebook, on which the network worked fine, on a flashdrive. I then installed these on the Tosiba and it would connect just fine.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Friday, July 23, 2010 8:53 AM
  • So many suggestions here! Yet none of them worked for me! lol

    I managed to fix my problem though. I am on Windows 7 and it works fine on ALL networks I have ever connected to except an old wireless access point I have just started using at home. It only has WEP for encryption and I used 128bit. Under this, I could use manual hex key, the routers stringed passphrase, ASCII or a normal passphrase. I tried normal passphrase first but my computer would reject the passphrase I had configured in the router! For some reason it would only accept "admin" but the result was limited connectivity. I would reset the access point after each reconfiguration (through the configuration page, not physically).

    I solved my problem by using ASCII and having to use a 13 character key (that's annoying!) but hey, my computer didnt reject the passphrase and it has full connectivity now =)

    Thursday, July 29, 2010 1:06 AM
  • I was having the same problem with my father-in-law's laptop.  I use logmein free to work his pc's up in Montana from here in Texas.  We wrestled with it for a couple of hours trying some of the above suggestions with no success.  Finally I rebooted his router and everything worked fine.  Someday I will learn to try the simple stuff first.
    Sunday, August 15, 2010 10:07 PM
  • great answer for your wireless security mismatch problem is not a modem or window 7 perse rather than the following to solve yhour issue:

    1 enter the security code provided by the router company. another thing you could do is reinstal the router software so that you can get a new security code

    2 restart your computer. if ask to enter the security code again when attempting to use the wireless, enter it with the caplock on and you done

    good luck

    • Proposed as answer by palermodude Friday, April 15, 2011 7:10 PM
    • Unproposed as answer by palermodude Friday, April 15, 2011 7:10 PM
    Monday, December 13, 2010 5:28 PM
  • I had the same issue.

    I fixed the problem by taking one of the response's advice above.

    I went into the Network & Sharing Center.

    I saw that W7 had saved the initial WEP setting with my initial passcode.

    I had changed my mind regarding WEP, because it disabled my Wireless N, and only gave me "good" reception instead of "excellent".

    But I restored factory settings on the router (one of several times as I started to figure out what I was doing), and then attempted to change to WPA2-PSK so that I could have a much quicker internet - as instructions said that it would.

    However, it kept the older WEP setting in memory on the "Managed Wireless Networks", and the older WEP happened to be first in line for connection.

    So, when I entered the WPA2-PSK passcode and saved it, when I tried to get back online, it first attempted to connect with the WEP - and that was the old passcode, not the new one that I had changed it to for the WPA2-PSK.

    Therefore, I "removed" the WEP connection from the list of "Managed Wireless Networks", then I went back in and entered my password (by resetting again factory settings on the router) and voilà... it worked.

    It worked because there was no longer a mismatch between "networks" having differing securities and passcodes. I am sure that if I had both passcodes the same, it would have connected, albeit WEP.

    I hope my experience has helped any others out there with the same issues. It did take me a bit of time to figure it all out - but I learned a lot in the proces and will be available to help out friends who have the same issues. I feel like I am now ahead of the curve regarding routers, and I can see that I am a minority of people in my wireless range that have WPA2-PSK on N. Many still have G, and a few even have WEP.

    Cheers,

    palermodude

     

    Friday, April 15, 2011 7:24 PM
  • Hi,

     

    PLEASE BE SURE THAT WPS PIN AND PASSPHRASE ARE NOT THE SAME THING

     

    For instance, I was able to connect my vista laptop to my router with the wps pin (all numbers) while I connected my windows 7 netbook with the passphrase which was composed of letters.

     

    Good luck!


    Tuesday, April 26, 2011 9:03 PM
  • I was entering the security key as printed on the side of my router and it didn't work.
    I pressed the reset button and held it for 10 seconds and it connected fine when I entered the key again...
    Turns out that by doing that I reset the security key to it's default (the one printed on the router). If I had remembered that my dad had changed the security key months ago I could have entered that and it would have worked fine.
    So
    Before you press and hold reset, make sure the security key/password hasn't been changed at any time since getting it because hitting reset will restore the default security key to the one printed on the router.
    Thursday, May 12, 2011 12:27 AM
  • I have the same problem but trying to connect to a range extender. I enter the correct WEP key but it still says there's a mismatch. I went to Manage Wireless Networks. It turned out it didn't show any security for that device. I entered a WEP Key, which is the same for the original wireless router, but it still says there's a possible mismatch.

    Should I configure the range extender with a different key password than the router? Should I change the range ext. from WEP to WAP or whatever other options there are?

    It has taken me many hours just to make the range ext. work. Now that I was able to configure it correctly with my XP machine, my Windows 7 is still making things difficult.

    Any suggestions?

    Jorge

    Friday, May 27, 2011 10:29 PM
  • For those who are still struggling with this issue...this is how i got around it. I am using Lynksys Wireless-G, my security settings are WEP... I struggled with this for over 2 weeks, i read all manuals and googled everywhere but nothing was of help untill this morning... It looks strange but i understand now thta it is not.... step 5,6,7 and 12 are the most important

    1. connect your laptop to your wireless router with ethernet cord(ensure proxy server IP add is not set)
    2. go into the router settings normally http://192.168.1.1/ you may be required to enter your credentials
    3. go in to the wirelss security settings
    4. enter your passphrase
    5. important: click on "generate" button and about 4 security keys will be generated
    6. copy one of these generated keys.
    7. save and apply and exit this window.
    8. Goto network and sharing center
    9. select "Manage wireless networks"
    10. delete any network reference listed that may conflict with the network you are connecting to.
    11. exit the window
    12. now with that that try reconnecting and when prompted for passphrase or security key paste the generated key that you copied from step 6 above
    13. then shout bingo...you should be home and try
    Tuesday, June 21, 2011 10:08 AM
  • WEP isn't safe. This isn't a solution that anyone should consider. Most likely
    you need to update the firmware in your old Linksys router to properly support
    at least WPA (WPA2 would be best). What exact model router and what firmware?
     
    On Tue, 21 Jun 2011 10:08:27 +0000, de Goldman wrote:
     
    >
    >
    >For those who are still struggling with this issue...this is how i got around it. I am using Lynksys Wireless-G, my security settings are WEP... I struggled with this for over 2 weeks, i read all manuals and googled everywhere but nothing was of help untill this morning... It looks strange but i understand now thta it is not.... step 5,6,7 and 12 are the most important 1. connect your laptop to your wireless router with ethernet cord(ensure proxy server IP add is not set) 2. go into the router settings normally http://192.168.1.1/ you may be required to enter your credentials 3. go in to the wirelss security settings 4. enter your passphrase 5. important: click on "generate" button and about 4 security keys will be generated 6. copy one of these generated keys. 7. save and apply and exit this window. 8. Goto network and sharing center 9. select "Manage wireless networks" 10. delete any network reference listed that may conflict with the network you are connecting to. 11. exit the
    >window 12. now with that that try reconnecting and when prompted for passphrase or security key paste the generated key that you copied from step 6 above 13. then shout bingo...you should be home and try
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Wednesday, June 22, 2011 2:24 PM
  • Hi Nik,

    I also am working with Windows 7. If your problem is the same as the one I just fixed, you are lucky this is easy-peasy to correct.

    My wireless was working fine, but seemed slow, so I tried to go in and improve my router security. I kind of bumbled around, not exactly sure what I was doing, and afterwards I got the security key mismatch message. Oh no! How do I fix that?? :O

    This is so simple I hope it will work for you. The security key you type in at the wireless connection prompt is NOT the password you use to access your router. THis drove me crazy! The correct network security key is the "WPA Shared Key" from your router's wireless settings.

    To find this key, log into your router's home page. I use Linksys so hopefully this will be the same for you. From the router home page, click on "Wireless" tab; click on the subtab "Wireless Security".  You should see this info:

     Security Mode:  (such as WPA2 Personal)

     WPA Algorithm: (such as AES)

     WPA Shared Key: (lots of characters that look random)

    I copied the string of characters in the WPA Shared Key block. Then when I went to log into the wireless connection, I pasted the string and checked the block for it to remember that entry. A little less secure, but much easier than having to look up the key every time I want to log in.

    You should also confirm the settings on your wireless connection match the information from the Wireless Security tab of the router (that stuff I just listed above).

    To check it, click on "control panel", then "Network and Internet", then "Manage Wireless Network".  Right click on your wireless network, select "Properties", select the "Security" tab. "Network Security Key" must match the router's wireless "WPA Shared Key" entry.

    So, a simple problem, I got the router's password confused with the router's WPA Shared Key entry.

    I hope this is helpful,

    sw

     

    Friday, October 21, 2011 12:52 AM
  • Hi All

    Just been having the same problems on a Tosh with realtek on Win 7 with Linksys router

    Originally the Linksys was set for WPA2 AES, I tried putting the Linksys in WPA2 Mixed i.e. AES & TKIP still no joy.

    Went to the Tosh site and downloaded the latest WLAN Driver for realtek driver for Win 7 (Aug 2011 ) and Hey Presto it worked.

    Hope this helps someone

    Alan

    • Proposed as answer by 01Alan Tuesday, October 25, 2011 6:40 PM
    Tuesday, October 25, 2011 6:39 PM
  • This works, I have just tried it, Thanks 

    Stephen Doherty :)

    Tuesday, November 15, 2011 7:07 PM
  • This answer worked for me. I deleted the network connection that we formerly used (we created a new name for the wireless router connection), and started over again. Success. Thanks NuWaveDave!
    • Edited by ExExZonie Tuesday, November 29, 2011 3:10 AM
    Tuesday, November 29, 2011 3:07 AM
  • Annoyingly, the information Netcomm provide you may be wrong. Check out:

    http://media.netcomm.com.au/public/assets/pdf_file/0017/74150/NP202Wn_How_do_I_Find_the_Wireless_Password_v1.4.pdf

    The password for newer units is actually "a1b2c3d4e5", not a 64 infront of the 6 digits in the SSID.

    Also you can go to that website and download a utility to change the password to something better. 

     

    Wednesday, January 25, 2012 12:19 PM
  • Hi,

    This is the way I treated this on a Windows 7 64 bit because this is not happen on 32 bit. I when to wireless management and remove all wireless network saved in there and the one I want.

    I hope this work.

    Wednesday, February 01, 2012 9:25 AM
  • i was having this same problem with my new laptop and Linksys wireless router. here's how i solved it...
    -went into my router's wireless security settings and changed from WEP to WPA2 Personal
    -changed from TKIP to TKIP+AES
    -set to 64bit 10 hex
    -set password
    -saved settings

    after that i was able to connect without a problem. seems my windows 7 doesnt like WEP at all and prefers AES over TKIP

    This works for me!!

    at the beginning I was using a 2-wire-router. then I changed back to the ATT one.. feel bad that my windows 7 (x86) could not connect to the network even I can connect with the same password on my iphone. I am using a NETGEAR router, and finally try this and connected!!!! thank god~ because it keeps saying mismatch. When I do the search, people say use the WEP to generate the Encryption (WEP) Key.. no~ this will not work on win7 (x86). so try the WPA2 out, will work!!

    Here is a example I created for you guys, hope that will help!

    First. GO TO YOUR NETGEAR IP ADDRESS TO LOGIN. USUALLY THE USER NAME AND PASSWORD WILL BE: ADMIN AND PASSWORD. <- LOWER CASE

    NEXT, CLICK TO WIRELESS SETTING AND CHANGE TO SELECT WPA2 AS SHOW BELOW. ENTER YOUR OWN PASSPHRASE.

    LAST, APPLY.

    AND TRY IT OUT ON YOUR LAPTOP! XD




    • Proposed as answer by KarissaLi Monday, May 14, 2012 8:53 PM
    • Edited by KarissaLi Monday, May 14, 2012 8:58 PM
    Monday, May 14, 2012 8:53 PM
  • Hi, i had the same problem and this is how i fixed it....

    Open Internet Explorer, in the address bar type   "192.168.1.1"  hit enter.

    a log in box will appear, type   "admin" as user name and  "admin" as pasword.

    this will log you into your modem.

    Click on ..Wireless....then click on....security...

    once in security look for "WPA Pre-Shared Key" beside this it will say "click here to display"  click that and write down the code that it displays.

    go back to ...control panel.....network and internet....network and sharing centre.....connect or disconnect.

    when the box appears to enter your security key, enter the code that you wrote down (in my case it was a different code to what was on the bottom of the modem).

    close everything and restart the computer....Happy surfing :)

    Tuesday, November 20, 2012 12:19 PM
  • Thank you soooooo much!  This finally worked!!!!  So frustrating....

    Wednesday, October 09, 2013 2:37 AM
  • I want to know how to fix the key pls man I forgot my key (Network Security Key Mismatch)
    Monday, June 02, 2014 7:21 PM
  • Connect to the router manually using an Ethernet cable. Enter the router settings page and check out the security configurations. Try changing some settings and see if the problem persists. Good luck mate, cheers!
    Tuesday, June 03, 2014 2:31 AM