none
Windows 7 search exact phrase

    Question

  • Hi,

    I've got a problem with windows 7 search. I want to search an exact phrase in some files, into search box I insert content:"hello world", but it returns all files containing hello and word, not the exact phrase "hello world".

    For example my search returns documents containing

    word hello

    or

    hello friends I live in world

    Is it a bug of windows 7 search ?

    Thanks

    Stefano

    Tuesday, January 18, 2011 2:34 PM

Answers

  • Hi,

     

    Thanks for update.

     

    I have investigated this issue, and found this is a known issue. I just reported this to our feedback team. I think this behavior will be adjusted in the further and I will keep you updated.

     

    Thanks again for your efforts.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Bruste Friday, January 28, 2011 11:12 AM
    Friday, January 28, 2011 9:12 AM

All replies

  • Hi,

     

    No, it is a mechanism of windows search, if you only input hello world in search box, it would return the items which contains both words hello and world.

     

    If you want to pinpoint exactly what you're looking for, please input “hello world” (with quotation marks) in search box, this would return the result with the exact phrase hello world.

     

    You could refer to the following article:

     

    Windows Search: Tips and Tricks

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, January 20, 2011 9:21 AM
  • Hi Alex,

    yes, I always used the quotation marks (my search is content:"hello world") ! but windows always returns all files containing both words hello and world, not the exact phrase.

    why?

    Thanks

    Stefano

    Sunday, January 23, 2011 6:10 PM
  • Hi,

     

    Thanks for your update.

     

    Ensure that the target has been indexed, you could refer to the following link:

     

    Improve Windows searches using the index: frequently asked questions

     

    If this issue persists, we can take the standard method to rebuild the research index to check the result:

     

    1.    Open the Control Panel.

    2.    In the Instant Search box, type Index.

    3.    Click on Indexing Options.

    4.    Click on Run as Administrator and allow the privileges.

    5.    Click on Advanced, then Rebuild.

     

    If this issue persists, try to run Fixit to see the result.

     

    Also, you could create a new user to test if this issue still exists.

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, January 24, 2011 10:13 AM
  • Hi Alex,

    thanks for your answer.

    If i put my example files into MyDocuments, that is indexed, the search works well.

    If I put the files into a not indexed directory the search doesn't work correctly. Why does the search result is different between indexed and not indexed directories?

    The problem is I can't index the directory with all my svn projects, there are many files into svn system folders (.svn) and the pc will slowdown. I'm afrait there's no solution, right ?

    Thanks

    Stefano

    Monday, January 24, 2011 12:28 PM
  • Hi,

     

    Did this issue only occur to the *.svn files?

     

    I suggest you test with other files to check if the issue persists.

     

    To make this issue clear, please capture some related screenshots for us:

     

    How to capture a screenshot

    =========================

    1)       Press the Print Screen key (PrtScn) on your keyboard.

    2)       Click the "Start" menu, type "mspaint" in the Search Bar and Press Enter.

    3)      In the Paint program, click the "Edit" menu, click "Paste", click the "File" menu, and click "Save".

    4)       The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5)       Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click “Desktop” on the left pane and then click "Save".

    6)       Then Upload to SkyDrive.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, January 26, 2011 10:00 AM
  • Hi,

    my problem isn't related to .svn files. The problem is that a search of an exact phrase produces different results if the files are indexed or not.

    Steps to reproduce the problem

    - Create a file named test1.txt containg the phrase "hello world" (whitout quotes)

    - Create another file named test2.txt containg the phrase "world hello" (whitout quotes)

    - Put the files into a directory not indexed

    - Into search box in explorer type content:"hello world"

    - It returns both files

    - Put the same files into a indexed folder (My Documents for example)

    - Into search box in explorer type content:"hello world"

    - It returns only the first one, correctly

     

    Here a screenshot of the first search (into a not indexed folder):

     

    Here a screenshot of the second search (into a indexed folder):

    Wednesday, January 26, 2011 12:37 PM
  • Hi,

     

    Thanks for update.

     

    I have investigated this issue, and found this is a known issue. I just reported this to our feedback team. I think this behavior will be adjusted in the further and I will keep you updated.

     

    Thanks again for your efforts.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Bruste Friday, January 28, 2011 11:12 AM
    Friday, January 28, 2011 9:12 AM
  • Hi Alex,

    thanks for your work.

    Stefano

    Friday, January 28, 2011 11:14 AM
  • Clarification: Double quotes are required to do an exact phrase seach in Windows 7.  The use of single quotes are the source of confusion.
    Thursday, March 03, 2011 4:55 PM
  • Another suggestion might be:

     

    Use a dedicated program to do your search:

     

    - like total commander (shareware) with very good search function

    or

    - the free dedicated search program "wanyword" (search for so called "whole word": hello world)

     

    I am very pleased that searching is great with these programs.

     

    egman

    Friday, March 04, 2011 3:28 PM
  • Cant believe they've made it so difficult. this must be a fundamental need in windows - find me all files that contain an exact phrase or combination of words .

    Thats right up there with switching the computer on.

    Didn't anyone think this one through during the planning stages ?

    Tuesday, July 10, 2012 12:44 PM
  • Hello,

    Although I agree searching within files should be fundamentally simple and straight forward, here is way to get Windows 7 to search within files for the exact string:

    First of all, Windows 7 seems to rely heavily on the fact that you have to index the location that you want to search.  As mentioned earlier in this thread, you cannot search for exact string, even with double quotes if the location has not been indexed (regardless of the options set in the "search" tab under "folder options").

    1. So, simply type your search in the location you wish to search. 

    2. If the location has not been indexed, a yellow bar will appear informing you that the location has not been indexed.  If you click on the yellow bar, you can add the location to the index.

    3. Once the indexing has been completed, you will then be able to seach for exact string matches, when search within a file.

    You can also exclude sub-directories, or even remove items that have been previously indexed by going to the "Indexing Options" under the control panel.  (Just click the start button and type the word index in the "search program and files" dialog box).

    To modify your selections, just click on the "Modify" button.  In the "Indexed Locations" window, under "Change selected locations", uncheck and check the locations that you wish to add/remove.

    Hope this helps someone.

    Cheers,


    Paul

    Wednesday, October 24, 2012 4:28 PM
  • Hello,

        I was initially excited when my work computer was upgraded to Windows 7, but with this horrible search capability, I really wish Windows 7 was never invented.  That being said, I can index my local files and search through those for exact phrases, but like many other people, I save all my work on the servers, not locally, for obvious reasons.

    My question is whether there is a way to search files stored exclusively on the servers for exact phrases, the same way I used to be able to do it in other versions of Windows.  I appreciate any help that you can provide, and really hope whoever's bright idea it was to completely ruin the search functionality in Windows is now in the unemployment line.  

    Thanks!

    Tuesday, January 08, 2013 9:27 PM
  • They obviously don't want to fix this problem.  Same thing in Windows 8, 2 years later...
    Sunday, May 12, 2013 4:25 PM
  • Indexing is NOT a solution. For the same reasons that others have mentioned, I will NEVER index my disks or any folders -- especially on my work machine. (Millions of people use their machines for making a living and not just goofing off, playing games or writing letters to Grandma!) I am sick of these kinds of asinine responses, which are cop-outs so that Microsoft can blow this problem off and not address it. This worked perfectly with previous operating systems with non-indexed disks and folders. Now, it does not work in Windows 7; so, it’s a bug. PERIOD! FIX IT and stop jacking us around.

    Saturday, July 27, 2013 1:37 PM
  • findstr at the command prompt still works quite well (Yeah, I'm really old)
    Sunday, April 13, 2014 2:21 PM
  • Unbelievable this still is not working. MS must be the most horrid software company in the world.
    Friday, July 11, 2014 9:39 AM
  • Confirmed this is still not working for Windows 8.1 Pro... sad.

    We have 100+ text files and I'm trying to search for a particular term inside the text file on a mapped drive... unfortunately it matches all variants or parts of the term, rather than the whole phrase - so I don't get 10-15 results that I normally would have expected... but rather 100+ results - thanks Microsoft (being sarcastic) :)

    Tuesday, August 05, 2014 6:50 PM
  • I agree with TwilightsLastGleaming in saying that indexing should not be the solution.

    I still prefer Windows 7 over Windows 8, but I have to say I'm thoroughly dissatisfied with the Search function in both... I really enjoyed the Search function in XP - not sure why they didn't follow that model.

    Tuesday, August 05, 2014 6:56 PM
  • Hi,

    I've got a problem with windows 7 search. I want to search an exact phrase in some files, into search box I insert content:"hello world", but it returns all files containing hello and word, not the exact phrase "hello world".

    For example my search returns documents containing

    word hello

    or

    hello friends I live in world

    Is it a bug of windows 7 search ?

    Thanks

    Stefano

    Try this in your search box..

    ~="hello world"

    • Proposed as answer by Milopita Thursday, September 04, 2014 9:07 AM
    Monday, August 11, 2014 1:23 AM
  • ~="hello world" seems to work, even for locations that are not indexed. Thanks.
    Thursday, September 04, 2014 9:07 AM