locked
Windows 8: No network adapters after resume from standby/sleep

    Question

  • I have an Intel 82577LM Gigabit NIC and an Intel Centrino Advanced-N 6200 AGN.  I have updated all the drivers to the latest releases.  My laptop (Lenovo T510) has the latest bios, chipset drivers, etc.  Everything works great...  Until I put the machine in sleep.

    On resuming from standby, I cannot connect to wireless or wired.  The adapters show up as working fine in Device Manager but nothing (no interfaces) is listed when I do an ipconfig /all.  I cannot connect to any network until I go into computer management, uninstall the adapter and then scan for hardware changes so it is re-installed. The worst part is I lose all my wireless security passwords every time I complete this procedure.

    I never have this problem in Windows 7, Ubuntu, XP or any of the other disparate OS's I've run on this system.  This is not a driver issue and seems to be related to power management in Windows 8.

    I know how to research a problem like this and have yet to come across a solution.  Any recommendations or fixes?

    Saturday, March 10, 2012 7:14 PM

Answers

  • I was actually able to just get this fixed.  The issue is with the Oracle VirtualBox Bridged Network Driver.  Once I disabled this on each NIC, the problem was resolved.  Looks like the only way to connect a VirtualBox VM in a consistent fashion is to use NAT mode instead of Bridged.

    I am running the latest Oracle VirtualBox release as of 3/10/2012 (4.1.8 r75467).  I'll report this problem to Oracle in hopes they update their drivers.

    In the meantime, I just converted my VM to a VHD and installed the new Hyper-V role.  No need for VirtualBox now that Hyper-V is integrated into Windows 8!

    Sunday, March 11, 2012 1:42 AM

All replies

  • I had a similar problem where the adapter(different one) wouldn't be recognized at cold startup either, in addition to after resume from sleep.

    I fixed the cold startup problem by going into the Power options in Control Panel and click "Choose what the power buttons do" on the left.  Then click "Change settings that are currently unavailable" near the top.  Uncheck the "Turn on Fast startup" option.

    Then I disabled sleep which probably isn't a good solution for a laptop.  It's more than likely a driver issue that needs to be tweaked for Windows 8.  Just have to wait and see if they release Windows 8 specific drivers.

    Saturday, March 10, 2012 8:13 PM
  • I was actually able to just get this fixed.  The issue is with the Oracle VirtualBox Bridged Network Driver.  Once I disabled this on each NIC, the problem was resolved.  Looks like the only way to connect a VirtualBox VM in a consistent fashion is to use NAT mode instead of Bridged.

    I am running the latest Oracle VirtualBox release as of 3/10/2012 (4.1.8 r75467).  I'll report this problem to Oracle in hopes they update their drivers.

    In the meantime, I just converted my VM to a VHD and installed the new Hyper-V role.  No need for VirtualBox now that Hyper-V is integrated into Windows 8!

    Sunday, March 11, 2012 1:42 AM
  • Excellent!  I had Virtualbox installed too, I'll give it a try...no news will be good news.
    Sunday, March 11, 2012 3:36 PM
  • BTW, if you have any VirtualBox VDI's you need to convert to run with HyperV, just run: VBoxManage clonehd source.vdi target.vhd --format vhd

    VBoxManage can be found in C:\Program Files\Oracle\VirtualBox\.  I had several VM's and they all converted fine and are up and running in Hyper-V now.  Make sure you uninstall the Oracle Virtualbox Additions and install the Hyper-V integration pack on the VMs.

    Monday, March 12, 2012 5:44 AM
  • Here is the bug report in case anybody else wants to confirm this issue w/ Oracle: https://www.virtualbox.org/ticket/10317
    Monday, March 12, 2012 6:16 AM
  • I'm having the same problem on a physical machine... any suggestions?
    Thursday, March 29, 2012 1:15 AM
  • I'm having the same problem. No connection at all after sleep. VirtualBox is not installed, so you obviously had a different issue. What can I do?
    Tuesday, April 03, 2012 5:07 AM
  • Hi Andrew, can confirm this issue, also made a note on the bug report.

    Alsx Verboon www.verboon.info

    Sunday, April 08, 2012 7:24 PM
  • How did Hyper-V work out for you?  I actually installed VBox because of this:

    http://social.technet.microsoft.com/Forums/en-US/w8itprovirt/thread/2a3b16b9-a56f-484f-8db5-322008821c9f

    And then stumbled here when I found this issue.  Hyper-V made my machine freak out, lock up and just stop responding.  I guess I'll just use NAT.  Actually, I'll just use Windows 7.  The Preview just wont cut it for me.

    Tuesday, April 24, 2012 1:55 AM