none
Network and Sharing Center falsely reports no network or internet access

    Question

  • Initially the network icon and sharing center were correctly indicating network connection status.  After the third windows update session in 4 days it now is constantly stating that I do not have network or internet access.  This is not the case as IE and Firefox, Outlook 07 and Thunderbird all can get online without issues.  Also network commands (ping, tracert, ipconfig) work from the command line and show positive connections and even IP addresses.

    If anyone has suggestions on what is wrong or better yet can help me solve this please say so.

    CB

    Sunday, May 31, 2009 10:15 PM

Answers

  • No I do not have two network cards - only the on board LAN connector.  This network device works fine without issues in Device Manager (no bangs or red stop icons) and shows that the correct 'signed' driver is present.

    Right now I have re-installed the card from device manager (right click on network card listed, choose uninstall) then re-scan for new hardware and it is up and running again.  Same driver (latest) installed and the Network Places icon is showing correct information as well as the sharing center.  As soon as the computer enters standby, sleep or hibernate or I have to restart (warm or cold boot) this will change back to 'No Internet Access' in both the icon on the taskbar and in network sharing center.

    Again this appears to be an issue with Rhine PHY and Windows 7.


    Hi CB

    This may be associated with a known bug in Windows 7 with the Sleep/Hibernate components.

    The bug appears when a hardware/software component fails to re-initialize when the system resumes from Sleep or Hibernation or will not enter the suspend state.


    These bugs have only been seen on specific systems that have combinations of certain hardware/software installed.

    The only way we have to deal with these issues in the RC build is to try and avoid using the Sleep/Hibernate functions as much as possible. If you experience this bug and still need to use the Sleep or Hibernate functions be aware that you could possibly lose any unsaved information in applications.

    The latest information we have is that these issues are fixed in the RTM build.

    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Saturday, July 18, 2009 10:37 PM

All replies

  • CBHendricks,

    Have you tried the troubleshooter?
    Sunday, May 31, 2009 10:33 PM
  • Try going into the device manager and deleting the NIC card.
    Windows will find it again and reinstall it using the drivers.

    It will make sure the IP stack is flushed and all hardware conflicts are gone.

    I've seen this one time on a user's laptop. They had something wrong with the NIC and I could not get a good IP.

    I had to do what I described above and then Windows was able to use the NIC.
    Monday, June 01, 2009 2:54 AM
  • The issue is that the Network and Sharing Center (and the network icon on the taskbar) report 'no internet access' all the time and occasionally reports 'not conected to local area network' from time to time.  Uninstalling and then re-installing the network card from the Device Manager restores funtionality to the sharing center but the issue comes back after the next system standby or shut down.

    I have connectivity - network card is present and fully functional both with command line and IE/Firefox and Network Card is loaded in Device Manger and does not report problems.  The only issue is that the Network and Sharing Center combined with the system tray (taskbar?) icon for the center are reporting errors or trouble status incorrectly.

    This would appear to be a minor bug - I need to know if anyone else is getting issues with the onboard NIC (mine is VIA Rhine II PHY) and if so are the issues similar to what I have.

    Thanks

    Thursday, June 04, 2009 3:24 PM
  • CBHendricks,

    Do you have 2 network cards (maybe wireless and wired)?

    Friday, June 26, 2009 7:02 PM
  • No I do not have two network cards - only the on board LAN connector.  This network device works fine without issues in Device Manager (no bangs or red stop icons) and shows that the correct 'signed' driver is present.

    Right now I have re-installed the card from device manager (right click on network card listed, choose uninstall) then re-scan for new hardware and it is up and running again.  Same driver (latest) installed and the Network Places icon is showing correct information as well as the sharing center.  As soon as the computer enters standby, sleep or hibernate or I have to restart (warm or cold boot) this will change back to 'No Internet Access' in both the icon on the taskbar and in network sharing center.

    Again this appears to be an issue with Rhine PHY and Windows 7.

    Sunday, July 05, 2009 5:52 PM
  • Hey and I thought I was the only one with this issue :>) I am running an Asus motherboard with onboard NIC and have having the same issue. Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20) It is so weird, it keeps stating that I have no internet access and yet here I am. Anyon out there have any ideas?
    Saturday, July 18, 2009 3:46 PM
  • No I do not have two network cards - only the on board LAN connector.  This network device works fine without issues in Device Manager (no bangs or red stop icons) and shows that the correct 'signed' driver is present.

    Right now I have re-installed the card from device manager (right click on network card listed, choose uninstall) then re-scan for new hardware and it is up and running again.  Same driver (latest) installed and the Network Places icon is showing correct information as well as the sharing center.  As soon as the computer enters standby, sleep or hibernate or I have to restart (warm or cold boot) this will change back to 'No Internet Access' in both the icon on the taskbar and in network sharing center.

    Again this appears to be an issue with Rhine PHY and Windows 7.


    Hi CB

    This may be associated with a known bug in Windows 7 with the Sleep/Hibernate components.

    The bug appears when a hardware/software component fails to re-initialize when the system resumes from Sleep or Hibernation or will not enter the suspend state.


    These bugs have only been seen on specific systems that have combinations of certain hardware/software installed.

    The only way we have to deal with these issues in the RC build is to try and avoid using the Sleep/Hibernate functions as much as possible. If you experience this bug and still need to use the Sleep or Hibernate functions be aware that you could possibly lose any unsaved information in applications.

    The latest information we have is that these issues are fixed in the RTM build.

    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Saturday, July 18, 2009 10:37 PM
  • Check you firewall settings. I had the same problem on both RC and RTM. Uninstalling and reinstalling the network card gets a popup from my AV (Kaspersky) asking if the network is public, local or trusted. Public and local both give the symptoms described. Trusted gives a nice, clean "internet Access" icon. Anybody know whioch port needs to be open?

    /jeremy
    Monday, August 24, 2009 9:51 AM
  • I have experianced this with the RC and RTM versions.

    MY ISSUE: Fresh install of Win 7 x63 or x86, icon shows internet access, windos updates work fine, install office 2007, works fine!
    Install ANY of these antivirus approved by microsoft (Kaspersky for workstation for Win7, Free AVG, NORTON) all create the "no internet access" warning but internet works fine.

    UNINSTALL Antivirus software issue goes away!
    Anyone try to replicate this on their machines to see if my pattern is consistant??
    Monday, August 24, 2009 2:13 PM
  • Well I have the excact same issue since Windows 7 RTM. Previously in Windows 7 RC I did not have this issue where the (wireless) network connection icon has a red cross through it. I was using the excact drivers for the RC and RTM. This is pretty frustrating - espcially knowing that this is NOT hardware and also NOT software driver related. As mentioned previously I did not have this problem when I was running Windows 7 RC with the exact same drivers. I also tried using the Windows 7 RTM native drivers as to the DELL drivers which did not resolve anything.

    Surely there must be a way to resolve this issue or send some or other debug data to Microsoft to resolve something this small but so annoying?
    Friday, October 02, 2009 4:35 PM
  • we have the same problem and none of the above works.  hibernate/suspend is off.  nic uninstalled/installed and we restarted firewall (ipcop) and switches (netgear, layer 2).  can traverse my local LAN w/ file sharing and browse internet perfectly.  we have an open ticket w/ microsoft.  the problems is that we cannot ping microsoft.com from only a few pcs on our local LAN (statically assigned ips on a 10.1.20.0/24 private LAN). the little globe will come and go from the pic of the two pcs in the bottom rt. of the taskbar.  the globe will only appear if microsoft.com is pingable.  very strange that we can ping all other ip addresses with no issue.  all effective machines are sp2 vista or windows 7.  i will post findings soon.  microsoft is trying to duplicate issue in their lab...
    Wednesday, October 07, 2009 5:25 AM
  • This is an email I just sent to a colleague of mine who is working this issue with Microsoft:

    ****************
    Please show this attachment to your rep at Microsoft for tt #1113702451.  I looks as if there is a setting in their firewall that has been enabled called, DISABLE PING RESPONSE.  Explain to them that this issue is occurring from multiple sites on different ISPs and different firewalls.

    ****************

    The attachment I am referring to is a screenshot of ping microsoft.com not replying, but tracerrt working just fine through my dns, out my router, into the cloud, and timing out on Microsoft's side.  So it looks to be a simple firewall setting on Microsoft's side.  I know in my firewall (ipcop 1.4.21) there is an option for disable ping response.  I have called friends in NY, FL, NC, and TN, and none of them can ping microsoft.com.  This is why the globe will NOT show up and Network and Share Center and  falsely reports no internet access.  We are getting a 403 Forbidden error code back when we click on the red X in Network and Share Center.  The Microsoft guy said that the globe not appearing has nothing to do with this (I beg to differ!) and he suggested we reinstall SP2, which we did, to no avail.  Still waiting for a call back from Microsoft....
    Wednesday, October 07, 2009 6:50 PM
  • The response does make sense but I have another computer running Windows 7 RTM and the network icon is displaying without any error indication. The host is running under Vmware Fusion. 

    Just to clarify - my icon never displays correctly where it used to with Windows 7 RC and Vista irrespective of network location. I am using the same drivers on all operating systems as DELL has to yet release Windows 7 drivers for this specific model. I also ran with no DELL drivers and used only the Microsoft drivers with the same result.

    Is there any debug log I can send?
    Thursday, October 08, 2009 1:13 PM
  • CbHendricks on this forum you asked if the person having internet difficulties had 2 NICs, i have 2 NICs and I am having an issue with internet telling me that i have no cord properly plugged/btroken(the cords are fine) except that they are missing the plastic clip in and i do have 2 NICs so would this cause a problem? i have windows 7 64 bit proffesional drivers are signed correctly, etc except one of my NICs is not recognized but i used to be able to use it on xp, any help would be appreciated.
    Ben

    • Proposed as answer by ITofOne Tuesday, November 03, 2009 9:51 PM
    Wednesday, October 28, 2009 2:50 AM
  • I had this same issue with Windows 7 telling me I had no internet access but still being able to browse.  After some digging through our firewall logs I was able to discover the problem.  It seems that Windows 7 sends an http request to bay24-f40.bay24.hotmail.com in order to verify internet connectivity.  Now on our firewall we have hotmail.com blocked for obvious reasons. 

    When i disabled the firewall rule blocking hotmail.com the exclamation point went away. 

    I would check to make sure hotmail.com isn't blocked at your locations.
    • Proposed as answer by ITofOne Tuesday, November 03, 2009 9:55 PM
    Tuesday, November 03, 2009 9:55 PM
  • Is there anything news on this issue?

    Friday, December 04, 2009 6:29 AM
  • There is a simple solution to do.
    If you do this step by step.
    You never will be prompted by network yellow warnings.
    Pay attention!

    1. Open Kaspersky Internet Security 2010.
    2. Go Settings.
    3. Select Firewall label
    4. Click over Configuration/Settings
    5. Now select Networks right next to Filtering Rules.
    6. Find your network adapter, should be connected if you've got only one, and choose "modify"
    7. You can assign custom name, change to "Trusted Network " (Category)
    You have advanced options too.

    This is the easy and fast method.  But there is another if the first fails.

    1. Now in Firewall Settings, click on Filtering Rules.
    2. Look and find down "Add " over Address
    3. This step is very important, you need to add a new network service. Give it a name, and add "Local Address ", these addresses must be your default gateway, first and second DNS provided by your ISP you can find it through internet, once added. ACCEPT

    This last step can be difficult but is easier than it looks. Your default gateway appears on your local area connection status over details. I Hope you succeed.

    Bye
    Monday, January 11, 2010 11:16 AM
  • Hi,

    I am also getting the same problem in Vista Ultimate 64 bit OS. Mine is a laptop and the model is Dell Studio 1555. At present only the OS and the MS Security Essential is installed. I have installed the OS after formatting the C$ and using only Dell recomanded drivers which comes along with the Installation kit. My machine is standalone one and connected to Airtel Broadband using the Beetel 110TC1 modem and ethernet cable.

    My Problem is, the exclamatory mark comes on the network icon in System tray very often and I will not be able to browse any more. If I try to repair the network connection it does not help. And most interesting thing is, if I try to trouble shoot from the Device Manager my etherner device does not respond. And at last if I try to restart the machine, it crashes with blue screen. After getting the exclamatory mark, if I restart the machine straight forward, it gets restarted correctly and the network problem gets resolved.


    Problem signature:
      Problem Event Name: BlueScreen
      OS Version: 6.0.6001.2.1.0.256.1
      Locale ID: 1033
    Additional information about the problem:
      BCCode: 9f
      BCP1: 0000000000000004
      BCP2: 0000000000000258
      BCP3: 0000000000000000
      BCP4: 0000000000000000
      OS Version: 6_0_6001
      Service Pack: 1_0
      Product: 256_1
    Files that help describe the problem:
      C:\Windows\Minidump\Mini013110-01.dmp
      C:\Users\animesh.kar\AppData\Local\Temp\WER-92820-0.sysdata.xml
      C:\Users\animesh.kar\AppData\Local\Temp\WER9655.tmp.version.txt
    Read our privacy statement:
      http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

    Please help me out.
    Thanks.
    Thursday, February 04, 2010 9:58 AM
  • I am building the first Windows 7 Professional 32-bit PC for our company and have been working on this issue sporadically for the past week.  Finally today, I decided to go straight to the main Microsoft Support site to search out a solution there.  I filtered my search by Windows 7, the site detected that I have Windows 7, and what do you know the exclamation point disappeared and now shows that I have internet access.  I think ITofOne's fix would work as well but apparently not necessary to go that far.

    Once again the priciple of KISS worked.

    Thursday, March 18, 2010 5:02 PM
  • Hey CB,

    If i understand correctly,You can use the internet 100% n all but ur just bothered about the network icon in the taskbar showing "No internet Access"???

    I had the same thing buggin me for a while. I have 4 shared IP's from 1 real IP.
    So i normally put it on DHCP.
    EVERYthing worked fine (Firefox, IE, Chrome, download managers, windows update etc etc) but that iicon showed "No internet access"(really annoying)
    Trying to get rid of the annoying icon (with the small yellow triangle), i specified the IP's in the IPv4 field on my LAN network card
    Still the same message.

    But then, i specified the IP's and then clicked "tick" on the "Validate settings upon Exit".
    Soon as i pressed okay, the thing checked some setting and then I had INTERNET written on my icon. YES!!!

    Trying it WILL work.... (if you know which Ips to put) :)

    cheers

    Monday, May 31, 2010 8:55 PM
  • I did what TheWiz61 did and it works! I configured a static IP with my router as gateway and DNS, no more annoying icon. I did have some real intermittent internetconnectivity issues, apart from the annoying icon, so hopefully this solves that issue as well...
    Saturday, July 31, 2010 7:24 AM
  • hey did you ever fix this problem? I have the exact same setup
    Tuesday, April 19, 2011 11:24 PM
  • Any solutions on this one. I have the exactly the same issue on Windows 7 clients and also on Server 2008 R2.

    Saturday, December 03, 2011 9:24 AM
  • Try this open  Command Prompt as Administrator type netsh winhttp import proxy source=ie restart and all should be fine
    Wednesday, December 28, 2011 3:13 PM
  • I had the same exact issue has everybody else. I was able to resolved it by adding manually my DNS servers. 

    My IPS was giving me 3 DNS servers on automatic. Copied the IPs address and manually added them to the list. I then added external servers from google and openDNS. 

    Issue is now resolved.

    Wednesday, February 08, 2012 3:52 PM
  • Try this open  Command Prompt as Administrator type netsh winhttp import proxy source=ie restart and all should be fine

    Using this didn't help and, in fact, somehow killed my access to our Novell servers. However, to get myself out the that mess, I used:

    netsh winhttp reset proxy

    ...and that not only got me back onto my Novell network but fixed the network icon bug.

    Tuesday, May 01, 2012 6:38 PM
  • I had the same issue, I simply adjusted the power plan settings in 'Control Panel\All Control Panel Items\Power Options'. Set system to never hibernate\sleep, issue resolved no more false network connectivity message.

    WOnt help though if for whatever reason one likes to set their system to sleep. MS will need to address this issue - though with win8 now I doubt they will bother :P

    Thursday, September 06, 2012 11:43 PM