none
How do I turn off all the default tablet settings in Windows 7 Home Premium?

    Question

  • As a user of Home Premium, I've learned I don't have the Local Group Policy Editor, which, judging by my searches, has been the answer provided for turning off certain Windows 7 tablet settings, such as the feedback ring when tapping the pen or the little tooltips that display when pressing certain keys. In Home Premium, is there a way to disable all these safely? It's causing my strokes to lag and distort in certain art programs.

    Edit: Also, it appears that Photoshop (CS3) is not detecting pen pressure, along with other Java-based art programs. I don't know if these are related, but it was working fine in Windows XP before I upgraded to Windows 7, so I can only assume the fault lies with the way Windows 7 handles tablets versus the way Windows XP handled tablets.

    Edit #2: And just in case it matters, I'm using a Wacom Intuos3, and just today I downloaded the latest driver which was Windows 7-compatible (6.1.2-4(RC)).
    Monday, November 02, 2009 7:23 AM

Answers

  • Although I'm using Windows 7 Professional, I'm also using the same tablet, drivers, and version of Photoshop. I was able to go into services.msc and safely disable Tablet PC Input Service while still being able to use my tablet both in Photoshop and on the Windows desktop (the Wacom drivers picked up the slack, I guess). Tablet and Pen & Touch control panels can disable a lot of the tablet features, but disabling the service itself was the only way I've been able to disable that annoying "ripple" effect and lag when clicking with the pen.

    As for your first edit: sometimes Photoshop just won't detect my pen pressure and a quick unplug/replug and restart of PS fixes it, but I imagine that was the first thing you tried; so I've got nothing.
    • Marked as answer by Robinson Zhang Tuesday, November 03, 2009 3:21 AM
    Monday, November 02, 2009 11:47 PM

All replies

  • Not sure if this is the right thing to do, but this is really an urgent problem for me, so I'm going to bump this.
    • Proposed as answer by JamesHD720 Sunday, August 05, 2012 5:11 PM
    • Unproposed as answer by JamesHD720 Sunday, August 05, 2012 5:12 PM
    Monday, November 02, 2009 8:06 PM
  • Although I'm using Windows 7 Professional, I'm also using the same tablet, drivers, and version of Photoshop. I was able to go into services.msc and safely disable Tablet PC Input Service while still being able to use my tablet both in Photoshop and on the Windows desktop (the Wacom drivers picked up the slack, I guess). Tablet and Pen & Touch control panels can disable a lot of the tablet features, but disabling the service itself was the only way I've been able to disable that annoying "ripple" effect and lag when clicking with the pen.

    As for your first edit: sometimes Photoshop just won't detect my pen pressure and a quick unplug/replug and restart of PS fixes it, but I imagine that was the first thing you tried; so I've got nothing.
    • Marked as answer by Robinson Zhang Tuesday, November 03, 2009 3:21 AM
    Monday, November 02, 2009 11:47 PM
  • Even so, you at least offered advice. I'll try the services.msc trick. Thanks!
    Tuesday, November 03, 2009 1:50 AM
  • Er, when you turned off Tablet PC Input Service, did the click ring immediately disappear, or did you need to wait a few minutes or did you have to reboot first? Because I turned it off and it was still doing the click ring.
    Tuesday, November 03, 2009 10:44 AM
  • It's silly, but did you click the Stop button? Setting it to Disabled will keep it from starting when Windows starts, but until you actually restart your computer it'll keep running unless you hit Stop.

    edit: and yes the ripple turned off immediately after the service stopped running
    Tuesday, November 03, 2009 10:49 AM
  • I have the same setup as well.

    For the stroke lag issue, I found that it was the "click and hold --> right click" function that caused this. To fix this, go to the windows search and type in "Pen and Touch."

    In that menu, select the "press and hold" function, settings, and uncheck that box for enabling it. Once you do this, it'll turn off that annoying blue ring that appears when you hold down the pen.

    As for the "ripple" effect, I'm not sure on how to remove this, but it doesn't cause any stroke lag at least for me.
    Saturday, November 14, 2009 5:52 PM
  • I too am having the same problems and also use photoshop,

    the problem lies with the pen and touch control panel option, it has check box titled "perform common actions quickly and easily" which Like me I assume you disabled because when you are using the pen to draw ar paint, the "flicks" are very annoying.

    Consiquently, when you turn off the flicks, it also turns off the pens pressure sensitivity! As yet I havent found a solution but it looks like microsoft will have to fix the pen and touch settings to allow sensitivity AND disable the "flicks", my guess is that when i find a solution it will be a registry hack.

    Sorry I dont have the answer but I believe this is the problem and you need to know what the problem is in order to fix it, when/if i find a fix i'll post it here

    Thursday, February 24, 2011 10:27 AM