none
Windows 7 states I'm not connected to any networks when in fact I am connected to my wireless network??

    Question

  • Win 7 Ultimate 64byte
    The network icon in the tray is red with a red X.
    Network and Sharing center states I am currently not connected to any networks.
    I click on 'Connect to a Network', at the top of the pop up it says 'Not Connected', below the 'Connections Are Available' icon it shows my wireless network and connected.
    I can't connect to a HomeGroup.
    Internet connectivity is working.
    Saturday, January 23, 2010 3:29 AM

Answers

  • I found a solution for (my version of) this problem.  My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected".  As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am). 

    I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.  

    The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above.  Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".

    Within seconds, Network and Sharing Center tells me I'm connected to my domain.  Yay!
    A reboot was required to fix the tray icon and its popup.

    However, I'm still unable to add my VPN connection.

    I'm interested in hearing from you guys if your registries miss the same permissions?  If so, Windows 7 must have a bug somewhere with misaligned service permissions/rights.
    • Proposed as answer by ugumba Tuesday, February 02, 2010 7:13 PM
    • Marked as answer by Niki HanModerator Wednesday, November 16, 2011 3:22 AM
    Tuesday, February 02, 2010 3:08 PM
  • Hi,

     

    Please also try following steps to troubleshoot the issue.

     

    1. Download the latest network adapter driver from the manufacturer website and install it in compatible mode. If the issue persists, please temporarily disable the adapter and re-enable it again for a test.

     

    2. Verify relevant service

     

    a. Click "Start", go to run, type "services.msc" (without quotation marks) in the open box and press Enter.

    b. Click Continue button to verify the administrator permission.

    c. Right click the "Network Location Awareness" service and choose Properties.

    d. On General tab click Start.

    e. Choose Automatic next to Startup type.

    f. Click OK.

     

    3. Restart the computer in Safe Mode with Networking for a test.

     

    Thanks,

    Novak

    • Proposed as answer by iphone 2.2.1 Saturday, January 30, 2010 5:55 AM
    • Marked as answer by Novak Wu Thursday, February 04, 2010 8:05 AM
    Thursday, January 28, 2010 2:44 AM

All replies

  • I have been having this same problem for probably about two months. I've tried everything i can think of, and nothing worked. I can't even find anyone else with the same problem; this is the first time I've seen someone else who has the same troubles. I'm using the standard Windows Seven Home Premium. The only difference between my problem and yours is that my Network and Sharing center shows that I am connected to the internet; the Network Icon simply won't update. It's stuck on the red x; yet when I hover over it, it says "Internet Access". A fix for this would be greatly appreciated.
    • Proposed as answer by JerNoon Wednesday, April 25, 2012 11:45 PM
    Saturday, January 23, 2010 8:51 PM
  • have u checked if any other networking adapter is enabled? coz this usually happens when u have more than one adapter running ,specially if u currently using wireless cards so i recommend disable the others adapters which u r not using atm...if later on u need them ,then just reenabled it..
    hope this helps,
    RR
    Saturday, January 23, 2010 10:26 PM
  • Thanks for your response. Unfortunately, it didn't work.
    I disabled both network adapters and rebooted. No change.
    Sunday, January 24, 2010 12:49 AM
  • Hi,

     

    Please also try following steps to troubleshoot the issue.

     

    1. Download the latest network adapter driver from the manufacturer website and install it in compatible mode. If the issue persists, please temporarily disable the adapter and re-enable it again for a test.

     

    2. Verify relevant service

     

    a. Click "Start", go to run, type "services.msc" (without quotation marks) in the open box and press Enter.

    b. Click Continue button to verify the administrator permission.

    c. Right click the "Network Location Awareness" service and choose Properties.

    d. On General tab click Start.

    e. Choose Automatic next to Startup type.

    f. Click OK.

     

    3. Restart the computer in Safe Mode with Networking for a test.

     

    Thanks,

    Novak

    • Proposed as answer by iphone 2.2.1 Saturday, January 30, 2010 5:55 AM
    • Marked as answer by Novak Wu Thursday, February 04, 2010 8:05 AM
    Thursday, January 28, 2010 2:44 AM
  • I have the same problem, and I think it's causing me problems with my vpn.  I stopped and restarted my "Network Location Awareness" service and NW/SC found my network, but upon restart it went back to not picking it up.  Like the user above I have internet access, but it doesn't show up.  In the nwsc when I mapped my network and trouble shooted the connection it says that the DNS server was not responding, which can't be right b/c I can access the internet.  I verified that it was working by successfully pinging my DNS.
    Saturday, January 30, 2010 2:20 AM
  • Win 7 Ultimate 64byte
    The network icon in the tray is red with a red X.
    Network and Sharing center states I am currently not connected to any networks.
    I click on 'Connect to a Network', at the top of the pop up it says 'Not Connected', below the 'Connections Are Available' icon it shows my wireless network and connected.
    I can't connect to a HomeGroup.
    Internet connectivity is working.

    Ive seen this happening a few times with win7, the network still works, but windows thins its not connected. I havent spent too much time on it since the connection is still working, looks more like an icon bug to me. When the icon says its not connected, connection properties says it is.
    • Proposed as answer by JImeats Tuesday, April 12, 2011 9:30 PM
    Saturday, January 30, 2010 6:46 AM
  • Yea but, with windows not seeing me as connected to the network, I cannot use connect to my VPN.
    Saturday, January 30, 2010 10:01 AM
  • So when I do the for-mentioned restart of the  Network Location Awareness Service, It restarts the connection, and as soon as it identifies it kicks it back out.  I can still access the internet but nwsc still says im not connected, and I can't connect to my vpn... I'm running out of idea's
    Saturday, January 30, 2010 2:37 PM
  • I found a solution for (my version of) this problem.  My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected".  As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am). 

    I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.  

    The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above.  Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".

    Within seconds, Network and Sharing Center tells me I'm connected to my domain.  Yay!
    A reboot was required to fix the tray icon and its popup.

    However, I'm still unable to add my VPN connection.

    I'm interested in hearing from you guys if your registries miss the same permissions?  If so, Windows 7 must have a bug somewhere with misaligned service permissions/rights.
    • Proposed as answer by ugumba Tuesday, February 02, 2010 7:13 PM
    • Marked as answer by Niki HanModerator Wednesday, November 16, 2011 3:22 AM
    Tuesday, February 02, 2010 3:08 PM
  • Investigating the corresponding registry key on another Windows 7 PC (where NSC has worked fine all the time), reveals that by "factory default", explicit permissions are granted to the accounts "NlaSvc" and "netprofm".

    These permissions had disappeared on my problem PC - and I have no idea what caused it.

    Now, I can't find a way to add permissions to these account names, as they can't be located in the domain or on the computer, so my fix in the previous post still stands.

    For the record:  I've been using NCP Secure Entry Client, VMWare Workstation, SQL Server 2005, Visual Studio 2005/2008 and Mobile Device Center, some of which may have had a part in causing the problem (besides Windows 7).
    Wednesday, February 03, 2010 11:52 AM
  • Very good, I got my network back, but as you are having the same issue, I cannot connect to my vpn.  Will work with this and let you know. Thanks
    Wednesday, February 10, 2010 8:01 PM
  • I am having the exact same problem! I can't connect to my VPN and tried the above solution. The problem started like 1 weeks ago.

    I added the localsevice and network service to the administrator group, and my VPN works. Is there a bug in a recent updates that caused this error?

    Thursday, February 18, 2010 5:51 AM
  • I have been googling for an answer to this situation for over a month.  Ugumba, I must thank you for your research because that finally solved my not being relegated to a Windows 7 network.  Like most stated, everything worked, but Wndows 7 just wouldn't know it.  I will say that I'm not surprised that this situation reared it's ugly head.  Since I switched my main development machine from XP sp3 to Win 7 RC, the 'only' problems that I've been encumbered with by Windows 7 (which I love working with) have been caused by the assignment or un-assignment of security permissions in various parts of the Registry.  I do appreciate the fact that Microsoft (and in particular--MSDN) released the RC of Windows 7 as soon as they did (again, I will say this OS is steps better than anything that's been released in a long time), but there stills need to be some meticulous QA done from a developer's and user's standpoint.  These this don't really stop progress, but they drive you CRAZY...

    Ugumba, again, many thanks.  PHEW!!!  Hope to bump into everyone in this forum again soon.

    John Kellgren
    From PICK and IBM to now, this has been a thirty year circle to get color and a mouse...
    Monday, March 01, 2010 4:49 PM
  • Dear Novak,

    Does the dial-up modem icon disfunciton affect performance?  No.

    Is it as annoying as ____ when it shows I'm not connected and I know I am?

    YES!!

    Thanks a lot for this icon fix.  Note: You suggested to put Automatic next to the Startup type.  For my icon to work right I set it to Automatic (delay)  Works great now thanks.  You belive I was doing a recovery just to get my icon back.  Yikes.

    Yours truly,

    Ron Korn

    Tuesday, August 24, 2010 2:07 AM
  • Ok, trying to figure out how to do all of this.  I am having the same message.  All I want to do is connect my videos to my XBox.  How do I add full access for the Networkservice and Local Service?
    Wednesday, November 03, 2010 9:03 PM
  • I also have this issue

    win 7 home premium 64 bit

    I have a router with 2 pc attached to it and 1 is in a homegroup and the other is not - when I try to get the other one to connect it complains about the same thing - not connected to a network.

    Seems to me that the problem is that the computer thinks that I am in a public network and I can't change the properties to say it is a home network

    I have most of the issues described above

    Any help very gratefully recv'd 

     

    thx

    BF

     

    Sunday, November 21, 2010 11:00 AM
  • Thank you! This fixed my issue too!  I reset the permissions on that key, restarted the Network Location Awareness service, and it worked!  You have no idea how annoying it was seeing that I had no connection, and I've spent countless hours trying to fix this, and all this time it was just a registry permission issue.

     

    Thank you!

    Sunday, January 16, 2011 2:56 PM

  • I found a solution for (my version of) this problem.  My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected".  As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am). 

    I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.  

    The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above.  Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".

    Within seconds, Network and Sharing Center tells me I'm connected to my domain.  Yay!
    A reboot was required to fix the tray icon and its popup.

    However, I'm still unable to add my VPN connection.

    I'm interested in hearing from you guys if your registries miss the same permissions?  If so, Windows 7 must have a bug somewhere with misaligned service permissions/rights.

    This is the true solution to my case where my machine is running on Windows 7 Enterprise. After assigning permissions to the parent and subkeys, my network connection becomes visible and i am able to set up vpn as well.

    Thanks Ugumba!!  You are much better than those IT experts who can only follow the standard troubleshooting program that everyone can do.

    • Proposed as answer by Just1103 Monday, January 16, 2012 5:02 PM
    Tuesday, January 18, 2011 4:39 AM
  • I just have to thank you ugumba. I had to do a repair install and lost the ability to join my network. Your fixed worked! I had been searching for a solution for over 2 months. I'd like to also thank all those who posted their experiences and progress. It has been a tremendous help!
    Wednesday, February 02, 2011 9:28 PM
  • Seems like this might be the solution to this problem - would one of you be very kind and post step by step instructions on how to add these permissions? I know how to open regedit, but I don't know where to go after that.

     

    I haven't been able to connect to my home network for months, even though my internet connection is fine, and none of the other solutions I've seen have helped. 

    Friday, February 04, 2011 8:09 PM
  • Hi there,

     

    Ugumba's suggestion worked for me too.

     

    Thanks

    David.

    Tuesday, March 01, 2011 8:27 PM
  • Thanks you! This fixed my problem!  I've spent a lot of time on the phone with Microsoft Tech support unable to fix this, and scouring the Internet for a solution.  My computer now knows that it's connected to the Internet and I can create/join homegroups.
    Tuesday, March 22, 2011 4:00 AM
  • This finally resolved my issue, after spending hours of research and trial and error, thanks! :)
    Friday, April 01, 2011 8:32 PM
  • Just had the same problem.  Look at the top row of your keyboard, the third from the left ... looks like an antenna (also has F2 on the key).  Just press it once and your internet will come back.  Very painful lesson I learned, too.  Good luck.
    • Proposed as answer by TimFrasier Friday, December 21, 2012 1:01 AM
    Tuesday, April 12, 2011 2:34 PM
  • Just had the same problem.  Look at the top row of your keyboard, the third from the left ... looks like an antenna (also has F2 on the key).  Just press it once and your internet will come back.  Very painful lesson I learned, too.  Good luck.
    Tuesday, April 12, 2011 2:35 PM
  • Ugumba's answer fixed my problem as well.

    The problem with the network showing as "not connected" caused my Lync 2010 communicator to give me the following error:
    "Cannot sign in because the server is temporarily unavailable" and denied my login.

    After fixing the permissions on the registry, my Lync connected flawless.

    Thanks.



    Wednesday, April 27, 2011 12:18 PM
  • I am having the exact problem which Ugumba was experiencing. I am very excited to see there is a solution.

    But the problem is, I do not have any clue how to use Ugumba's method. I am not familiar with modifying windows reg keys. I am still learning.

    So please, could somebody please kindly show me the step-by-step instructions on how to use Ugumba's method to solve the problem?

    I really need to fix this problem.

     

    Thank you so much!!

    Saturday, April 30, 2011 2:04 AM
  • Ok I had the same problem and used the following to make it work following Ugumbas post

     

    Click Start

    Type Run

    Type Regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Right Click Network List

    Right Click Permissions

    For all users except CREATOR OWNER ensure that you have Full Control and Read ticked for all other accounts.

    Reboot your machine

     

    Red X has gone on mine and the internet works ok

     

    Now going to try a VPN and set up a homegroup. Will let you know in 10 minutes

     

    • Proposed as answer by deanfp Saturday, April 30, 2011 10:00 PM
    • Unproposed as answer by deanfp Saturday, April 30, 2011 10:00 PM
    Saturday, April 30, 2011 9:43 PM
  • VPN and Homegroup working fine.

     

     

    Saturday, April 30, 2011 9:59 PM
  • deanfp, thank you for your reply. I followed your instructions and it worked, partially. My situation is like this:

    I have three computers on my home network. One desktop (windows 7 home-premium 64 bit, pc1), two laptops (one is windows 7 home premium 64 bit, pc2 , one is windows 7 ultimate 32 bit, pc3). The desktop is wired to the router and two laptops are wirelessly connected to the router.

    I created a home group from laptop pc2. I can join the home group from pc3 without any problem. But I can not see the home group from desktop pc1, because it says the computer is not connected to any network. But actually I can access internet from this computer. That is my reason I came here for help.

    I followed the instructions and reboot. Now my desktop pc1 can see the home group. And this computer is part of the home network. That's great! But when I tried to join the home group I created from pc2 by clicking "join now" , and then typed in the password, it says " a homegroup can only be created on a home network. To change your network location setting, open network and sharing center in control panel".

    I am confused... Is this desktop not part of the home network? If it is not, why it can still detects there is a homegroup.

    Is there something wrong with my router setup?

     

     

    Sunday, May 01, 2011 6:02 PM
  • Hi

     

    I dont know too much about Homegroups but....

     

    Are they on the same version of Windows?

    Also do you have a router or a hub? I think most routers only allow 5 devices and it can be that if your synching a mobile or blackberry to the router it could be using up the number of allowed connections.

    Failing that can you maybe try removing the homegroup from the pc wired to the router and set it up on one of the others and then try adding pc2 and pc3 to the group?


    Sunday, May 01, 2011 7:15 PM
  • I don't know if this is exactly the problem described above but it is very similar. I was fixing my microphone for online game I had in another tab when a red x appeared on my network connection. It says "Not Connected - No connections are available" my internet doesn't work either so it is not just the red x. All when I look at the network map it says "The adapter is not connected". Troubleshooting doesn't work, I tried Ugumba's solution and I have tried disabling and enabling the network adapter yet I still cannot connect to the internet. I don't know what I did to cause the problem and I have no ideas left on how to fix it. Oh and I don't think it is my router because I can get on my laptop just fine.
    Tuesday, May 03, 2011 6:21 PM
  • i was having the same problem. but now solved.

    what i did was ..

    1. I disabled all the unwanted network connections

    2. then there was a connection bridge with my Wirless connection. so i disabled it also.

    plz chk the screenshot http://www.picscrazy.com/view/deskn

    3. my problem was solved.

     

    NB: the 'services.msc' and disabling just the network connection didnt solve my problem earlier.

    • Proposed as answer by dr.visakh Friday, May 20, 2011 4:40 PM
    Friday, May 20, 2011 4:38 PM
  • Awesome, I had the exact same problem.  This worked like a charm.

     

    --Rod

    Saturday, May 21, 2011 7:40 PM
  • Thank You Ugumba! I was getting nowhere until I stumbled upon your post.

    Granting write permission to the Network list key in the registry has fixed my problem.

    As a test I tried to create a VPN cnnection and was unsuccessful. Windows does not "see" an adapter (modem or network card) it can use.

    I'm attempting to correct this now by resetting the registry to default permissions using Subinacl and will post my results.



    Edit: Resetting permissions on the whole registry did not help, I still cannot create VPN connections. I don't need one on this system but I figured I'd post the info. I'll keep trying, If I find a solution I'll post it here.
    • Edited by SuperCoolFool Monday, August 08, 2011 5:08 PM Spelling
    Monday, August 08, 2011 5:04 PM
  • Ok I had the same problem and used the following to make it work following Ugumbas post

     

    Click Start

    Type Run

    Type Regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Right Click Network List

    Right Click Permissions

    For all users except CREATOR OWNER ensure that you have Full Control and Read ticked for all other accounts.

    Reboot your machine

     

    Red X has gone on mine and the internet works ok

     

    Now going to try a VPN and set up a homegroup. Will let you know in 10 minutes

     

    That worked for me also!! Thank you!!
    • Proposed as answer by Fjeldal Tuesday, August 23, 2011 6:17 AM
    • Unproposed as answer by Fjeldal Tuesday, August 23, 2011 6:17 AM
    Thursday, August 11, 2011 2:33 AM
  • Ok I had the same problem and used the following to make it work following Ugumbas post

     

    Click Start

    Type Run

    Type Regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Right Click Network List

    Right Click Permissions

    For all users except CREATOR OWNER ensure that you have Full Control and Read ticked for all other accounts.

    Reboot your machine

     

    Red X has gone on mine and the internet works ok

     

    Now going to try a VPN and set up a homegroup. Will let you know in 10 minutes

     


    I did the above, which partly worked but found that I still couldn't select Home, Work or Public.

    Solved it by renaming the NetworkList\NLA\Cache, which after a reboot apparently fixes the issue. Wondering if that could have solved the problem alone?

    Click Start

    Type Run

    Type Regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Expand NetworkList

    Expand Nla

    Right click and Rename Cache to e.g. Cache.old

    Reboot your machine

     

    • Proposed as answer by Fjeldal Tuesday, August 23, 2011 6:22 AM
    Tuesday, August 23, 2011 6:21 AM
  • Ok I had the same problem and used the following to make it work following Ugumbas post

     

    Click Start

    Type Run

    Type Regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Right Click Network List

    Right Click Permissions

    For all users except CREATOR OWNER ensure that you have Full Control and Read ticked for all other accounts.

    Reboot your machine

     

    Red X has gone on mine and the internet works ok

     

    Now going to try a VPN and set up a homegroup. Will let you know in 10 minutes

     

    That worked for me also!! Thank you!!

    this worked till i did a restart, now it is back to saying connected to network/no internet access.. and a few programs i have wont work untill they have internet access {like Steam client}, ive tried using different routers/modems i own. still no luck. all the permissions and services are started and working as such. but still no idea why windwos wont say its connecte to the internet

    thanks in advance for any help

     

    Friday, September 23, 2011 12:22 PM
  • Yay!  No more Red X

    Thanks to ugumba and deanfp for the solution that worked for me!

    I think this happened because I deleted the user account that created the HomeGroup (because it was corrupt.)

    Thank you so much for your help!

    Eric

     

    Monday, October 10, 2011 11:36 PM
  • Here's what finally worked for me.  Go into device manager, right-click on the wireless adapter and choose uninstall.  Then, after the adapter is uninstalled,  right-click on your computer name at the top and choose Scan for hardware changes.  The wireless adapter reappears and it installs properly as a network adapter throughout the system.  Reconnect to your wireless network and you're up and running.
    • Edited by RyanBrubaker Sunday, November 13, 2011 10:23 PM
    • Proposed as answer by bbanks69b Monday, March 19, 2012 3:57 AM
    Sunday, November 13, 2011 10:23 PM
  • Thank-you so much for this post. They should make a knowledge base article from this.  We just recently deployed Lync in our business as well and two users were having this issue as well. This fix really solved the problem quickly for us.

    Thanks again!!

     

    Friday, December 16, 2011 9:20 PM


  • Win 7 Ultimate 64byte
    The network icon in the tray is red with a red X.
    Network and Sharing center states I am currently not connected to any networks.
    I click on 'Connect to a Network', at the top of the pop up it says 'Not Connected', below the 'Connections Are Available' icon it shows my wireless network and connected.
    I can't connect to a HomeGroup.
    Internet connectivity is working.
    went throught most suggestions (except reg and permission changes-thats a pandoras box) but didnt work. five hours later i manually setup my wireless router and it worked fine.   windows should bundle aspirin or oxycoton with their product.
    Friday, December 16, 2011 11:07 PM
  • GOTO Hkey_local_machine\software\microsoft\windows NT\current version\networklist and right click on each folder inside it such as NEWNETWORKS and NLA and PERMISSIONS, PROFILES and SIGNATURES then choose permissions after clicking right click now when you open the permissions dialoge for each file you`ll have a list of USERS and a list of permissions so give each user in the list a full control and you`ll see the problem solved. i did that before some minutes and i`m so happy now because i solved it. and i want to help each body to solve it too. so this image will help you: http://www.megaupload.com/?d=SIM1VV9Z
    • Proposed as answer by foto2guy45 Wednesday, March 06, 2013 11:39 PM
    Thursday, December 22, 2011 5:50 PM

  • I found a solution for (my version of) this problem.  My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected".  As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am). 
    I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.  
    The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above.  Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".
    Within seconds, Network and Sharing Center tells me I'm connected to my domain.  Yay!
    A reboot was required to fix the tray icon and its popup.
    However, I'm still unable to add my VPN connection.
    I'm interested in hearing from you guys if your registries miss the same permissions?  If so, Windows 7 must have a bug somewhere with misaligned service permissions/rights.

    This is the true solution to my case where my machine is running on Windows 7 Enterprise. After assigning permissions to the parent and subkeys, my network connection becomes visible and i am able to set up vpn as well.

    Thanks Ugumba!!  You are much better than those IT experts who can only follow the standard troubleshooting program that everyone can do.

    Thanks, Ugamba.  It worked on my Win7 Pro x64 Computer like a charm.  You're the man!
    Monday, January 16, 2012 5:03 PM
  • I'm still having the same problem after following these steps... does anyone know of anything else I can do? Would this affect my ability to use a network printer?
    Wednesday, February 01, 2012 4:10 AM
  • thank you very much

    It Solves my problem within seconds.

     

    Saturday, February 04, 2012 6:44 AM
  • I have a similar but slightly different problem. I'm connected to a network with internet (which is how I'm posting this) but the icon is the yellow star for "connections available". If I open the network and sharing centre, it shows that I'm not connected to the internet, although obviously I am because I'm posting this. When the network is still in the 'identifying' phase, though, I get white bars as I would for a normal connection -- and then it goes back to the yellow star.

    I've tried every fix in this thread and none of them have worked for me.

    I have all the same problems -- can't connect to homegroup (and therefore can't, say, stream media to an XBox) and can't log in to EA's Origin, but I can log in to Steam.

    Anyone know what's up?


    • Edited by The Squid Wednesday, February 15, 2012 12:36 AM
    Wednesday, February 15, 2012 12:28 AM
  • Thank you ugumba for the fix.  It worked perfectly.
    Saturday, February 25, 2012 5:51 PM
  • Well i have done all the steps with the register fix

    also reinstalled the latest wifi drivers a few times.

    reboot.

    still not working, and this is freaking me out.

    Can't acces the network or anything only directly by ip number and not always so i got a problem with my lan printer.

    Any one have another idea ? running win 7 X64  on a asus n53sv laptop

    Monday, February 27, 2012 11:14 PM
  •    I have the same problem as many others: cannot log onto Origin's online application. My network icon in the taskbar shows my network, but has a yellow triangle with an exclamation point and a popup message that says "no internet connection"; so Origin's application will not let me log in and play my Mass Effect 3 game, although every other application(Internet Explorer, Steam, etc) sees and accesses the Internet, despite the "no internet" message.

    I used Ugamba's solution and Deanfp's step-by-step on two different computers running Win 7 Ultimate 64 bit, and on both computers it solved the problem successfully... but only until the next bootup. I've run Regedit since then, but all permissions I updated remain in place, and I still have the "no internet" and therefore Origin still won't work.


    Saturday, March 10, 2012 2:36 PM
  • Here's what finally worked for me.  Go into device manager, right-click on the wireless adapter and choose uninstall.  Then, after the adapter is uninstalled,  right-click on your computer name at the top and choose Scan for hardware changes.  The wireless adapter reappears and it installs properly as a network adapter throughout the system.  Reconnect to your wireless network and you're up and running.
    I tried everything in this thread and nothing worked until I tried what RyanBrubaker posted this and I tried his suggestion and my wireless connection is showing up now, thanks RyanBrubaker.
    Monday, March 19, 2012 4:05 AM
  • Thanks Ugumba!!

    Ram.

    Friday, April 13, 2012 6:21 AM
  • In my case all i did was change the available profile and it worked for me i'm using windows 7 home edition and broadband connection.

    Go to start and wright regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Expand Networklists

    Expand Profiles 

    click on the folders under the profile and next to description it will have the name of the connection pick the folder that has the name if the one u are using and right click it go to permissions in user tike allow full control should work for you now.

     

    • Proposed as answer by faisal al-ali Tuesday, April 24, 2012 8:06 AM
    Tuesday, April 24, 2012 8:05 AM
  • That worked for me, I disabled every connection but the one i was using and my network icon shows im connected again...Thanks
    Wednesday, April 25, 2012 11:46 PM
  • "Here's what finally worked for me.  Go into device manager, right-click on the wireless adapter and choose uninstall.  Then, after the adapter is uninstalled,  right-click on your computer name at the top and choose Scan for hardware changes.  The wireless adapter reappears and it installs properly as a network adapter throughout the system.  Reconnect to your wireless network and you're up and running."

    This has worked for me. I have been trying for weeks to get a solution. My new HP Pavilion dv6 laptop would connect to the wifi at home but at work I had the constant message "Unable to connect". And at home we have two routers and it would only connect to one of them. I tried changing the registry as Ugumba suggested but that did not work for me.

    • Edited by CynRitaNa Saturday, April 28, 2012 12:12 PM Wanted to include quote from post that worked for me
    Saturday, April 28, 2012 12:11 PM
  • Got the problem just now (I was like WTF?!), and found the solution a few minutes later (LUCKY!) after justifying what others had recommended -- seriously, I wouldn't go to regedit just for this pest...

    All I did was to ensure that the Network List Service, and the Network Location Awareness are both set to "Automatic". Then, I rebooted.

    Just my three cents :)

    Wednesday, November 21, 2012 10:48 AM
  • The F2 option worked for me as I was having a difficult time with a new laptop (Asus A54C) that kept losing the connection after a couple Windows 7 (Home Premium) Updates.  I tried everything else including reinstalling the WLAN drivers, disabling firewalls, etc.

    Thanks a lot!

    Friday, December 21, 2012 1:03 AM
  • I was having same problem on a windows 8 upgrade from windows 7. Main problem was that I could not create a home network. I could not connect to VPN. Strangely this would only happen on one of my connections at work. If I went home and got on wireless I could connect VPN. But while at work the connection would just be called ETHERNET and it would say "Your computer is not connected to any networks." meanwhile I would be on the internet and in a workgroup with 5 other machines. Changing the permissions above fixed the problem. After my next reboot - I immediately was asked if the new network I was on was a private or public and I could now use VPN. Thanks so much for posting this. It was the only thing that was really pissing me off about windows 8.
    Monday, December 31, 2012 7:59 PM
  • GOTO Hkey_local_machine\software\microsoft\windows NT\current version\networklist and right click on each folder inside it such as NEWNETWORKS and NLA and PERMISSIONS, PROFILES and SIGNATURES then choose permissions after clicking right click now when you open the permissions dialoge for each file you`ll have a list of USERS and a list of permissions so give each user in the list a full control and you`ll see the problem solved. i did that before some minutes and i`m so happy now because i solved it. and i want to help each body to solve it too. so this image will help you: http://www.megaupload.com/?d=SIM1VV9Z

    omarooo1-

    Thanks a bunch!! I've been reading every post and trying just about every solution, but yours was the one that finally fixed it. No more red X!

    Wednesday, March 06, 2013 11:40 PM
  • Thanks - great work - "replace all child object permissions with inheritable permissions from this object," was the trick! Sweeeet.
    Wednesday, April 10, 2013 8:04 AM
  • this worked for me
    Friday, April 12, 2013 8:32 AM
  • HOLY FREAKIN CRAP I've been trying to figure this out for the past 2 years. YOUR'E A HERO.

    However someone should make a tutorial because it took me like 2 hours to find what you're talking about.

    Friday, April 26, 2013 4:02 AM
  • I found a solution for (my version of) this problem.  My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected".  As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am). 

    I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.  

    The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above.  Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".

    Within seconds, Network and Sharing Center tells me I'm connected to my domain.  Yay!
    A reboot was required to fix the tray icon and its popup.

    However, I'm still unable to add my VPN connection.

    I'm interested in hearing from you guys if your registries miss the same permissions?  If so, Windows 7 must have a bug somewhere with misaligned service permissions/rights.
    This solved my problem too, many thanks, you're my hero!
    Saturday, May 04, 2013 9:22 AM
  • Thank you Ugumba - this solution also worked for Windows 8 - fixed Windows 8 Store not being able to connect. 

    Thursday, May 16, 2013 2:19 AM
  • my problem is the connected icon still says I'm not though I am but this process allows me to have homegroup and mapped drives running while my router is set for remote access. That had been driving me nuts for 7 months. Thanks so much. Before this I always had to set my router back to default to use homegroup when not doing remote access.

    The whole problem started with the connection icon when I switched wireless devices


    • Edited by walldoo99 Sunday, May 26, 2013 4:08 PM add a note
    Sunday, May 26, 2013 4:07 PM
  • I tried everything here, nothing worked for me until I did this:

    Open a Command Prompt (from Start/All Programs/Accessories)

    Type "ipconfig /release" (Without Quotes, though) then,

    Type "ipconfig /renew" (also without Quotes)

    It will automatically disconnect you from the internet and your adapter, then reconnect. The red X disappeared in a second or two and reconnected and now the X is gone!

    Worked for me, only took a few seconds to try. If you've tried everything else and you still have this problem, try my solution. Good luck to all!

    Sunday, June 23, 2013 3:02 AM
  • thanks - worked first time and took seconds - this has bugged me for 6 months - vpn access now ok
    Thursday, June 27, 2013 3:19 AM
  • thanks - worked first time and took seconds - this has bugged me for 6 months - vpn access now ok

    jimsrant, I'm glad it worked for you. It couldn't have been simpler, a five second fix that I was tearing my hair out trying all the solutions talked about on this thread - none of which worked (for me, at least - I guess some of the solutions worked for some people). It's frustrating when you go through so many different attempts that don't work and then something simple works in the end.

    If others find my solution helpful, please post that it worked for you on here, so that others can benefit from trying it for themselves. Nothing to lose trying such a simple solution - if it works, it works - if not, try some of the other things mentioned in this thread. But my solution is so easy and only takes seconds to try, why not give it a shot?

    Thursday, June 27, 2013 10:13 PM
  • hey guys. this seems to be the best way to solve this problem .

    just run services.msc and search for your adapter service it's might be deactivated or manual for me wlan service configuration then make it automatic press apply then press start and you'll see the notification back to it's position and big thanks for ugumba...

    hope it's works. and sorry for my bad language

     

    Saturday, August 24, 2013 4:09 AM

  • I just solved the same issue on my windows 7 pc by following these simple steps: 

    1. Right click on "My Computer" and choose "Properties".

    2. Click on "Device Manager" in your new window

    3. Device Manager window will pop-up. 

    4. Now click on the arrow of "Network adapters". Now right click on your available network adapter.For example: "Intel(R) 82567LM-3 Gigabit Network connection. Uninstall it. 

    5. Now, click on the "Action" tab of your Device Manager window and click on "action for hardware changes". Computer will search you the best available network and install it automatically. It will also indicate your new driver has been installed in the task bar. After couple of seconds your network tray icon will be fully functioning. 

    Friday, August 30, 2013 4:00 PM
  • Thanks for your help :)

    But i'm wondering,

    Does anyone knows why this happens???

    Many thanks

    Thursday, September 12, 2013 7:50 AM
  • Happens frequently for me. In fact I have this page bookmarked because I keep forgetting how I fix it.

    But today I discovered another way to fix it (for me).

    First I renamed the cache to cache.old as suggested above by Fjeldal

    Then run CMD as admin and enter:

    net stop netprofm (click yes if prompted to confirm)

    net start netprofm

    Red X all gone :-)


    Wednesday, October 02, 2013 8:46 PM
  • In my case all i did was change the available profile and it worked for me i'm using windows 7 home edition and broadband connection.

    Go to start and wright regedit

    Expand HKEY_LOCAL_MACHINE

    Expand Software

    Expand Microsoft

    Expand Windows NT

    Expand Current Version

    Expand Networklists

    Expand Profiles 

    click on the folders under the profile and next to description it will have the name of the connection pick the folder that has the name if the one u are using and right click it go to permissions in user tike allow full control should work for you now.

     

    This worked for me...had to go into the profiles because I tried it at the higher level as described in previous posts and that did not work...had to find the profile that had the connection I needed but it wasn't next to Description...it was next to Profile Name.

    example:

    Description   Network

    Profile Name       Network 2

    That's the one I wanted! Thanks for the fix!

    Wednesday, October 09, 2013 7:50 PM
  • We updated from Win7 to Win8 last year.  Metro apps weren't working.  We tried a refresh.  Then I noticed that stupid windows didn't think I was connected to a network.  Tried this fix and all is well in the world.

    Now to update to 8.1.  THANKS!!!!

    Sunday, October 20, 2013 1:15 PM
  • Thank you, ugumba, this worked for me too, and also seems to have resolved the dial up connection that has always preceded connection to my wireless internet.
    • Edited by KorrigAnnie Friday, November 01, 2013 1:44 PM
    Friday, November 01, 2013 1:43 PM
  • Worked for me getting Network/Sharing to show connection.  Have yet to reboot to see if icon is fixed ... will post update then.

    Thanks!


    Mike McIver

    Saturday, November 23, 2013 9:46 AM
  • I had same issue with using Wireless network. 

    just in case it can help anyone.

    I just deleted the saved wireless networks, changed the NAME of the wireless network in my router and then connected again with the new name and it worked fine now. 

    Friday, December 06, 2013 6:39 PM
  • Hello

    In my case, there was incorrect firewall settings which restricted my home group communication

    I fixed the problem by running the troubleshooter and when it is done (connected through home group) I restarted the machine and uninstalled the wireless driver software

    again restarted the machine and its now all well. no red cross on network icon

    Hope this may work for you

    Regards

    Tuesday, December 17, 2013 7:07 AM
  • i know this is a really old thread, but this is the problem i'm having, too - except up on an ethernet, not wifi.

    when i checked network sharing centre, it said there wasn't enough storage to set up the network - which was unthinkable, bec i have 1-1/2TB storage.

    when i shut my bluetooth headset off while it was charging via USB, the problem went away.

    Wednesday, December 18, 2013 6:46 AM
  • THIS !!!!   This problem was busting my head all day trying to rejoin a new domain.   All the Win 7 machines showed 'No connection available' and a red cross on the Network icon.

    Changing the permissions to the NetworkList branch in the registry fixed it in an instant.

    Thank you so so much !!   Made my day and I can now sleep tonight.

    Saturday, December 21, 2013 11:10 PM
  • I had tried every solution put forward with not success until the one put forward by Faisal al-ali.  This solution works for me.  thank you very much. 
    Wednesday, December 25, 2013 6:40 PM
  • Having had a similar problem I wanted to share my experience. First, my network tray icon was showing as no wireless connection while the popup dialog box showed I was connected. I had no bars and there was a circle with a diagonal line through it on top of the wireless icon adjacent to the bars. That said, I was unsure why the network tray icon was reflecting as no connection.

    Short and sweet, I went to the Device Manager and saw that my 3G Broadband adapter was showing a yellow triangle and upon investigation saw that the drivers were not loaded. I uninstalled and allowed the drivers to reload and then went into the Lenovo Access Connections software and disabled this adapter to prevent connections when unwanted. Once I had done this, I saw that the network tray icon indicated a wireless connection properly without the circle with the diagonal line through it. FYI.


    • Edited by chuckenheimer Monday, December 30, 2013 5:14 PM clarity
    Monday, December 30, 2013 5:13 PM
  • This fixed the issue for me, though, I have Windows 7 Home Premium, and all I had to do was give "Full Control" permissions to this key and its subkeys to the user "netprofm" which only had "Read" permissions when I first looked at this key. Then, Network and Sharing center properly displayed the network, and the icon corrected itself after I disconnected from and reconnected to the network, no reboot required.


    • Edited by Zeconte Thursday, January 30, 2014 4:33 PM
    Thursday, January 30, 2014 4:29 PM
  •  you are a specialist thanks
    Thursday, February 20, 2014 10:32 AM
  • Hi

    I am not quite understanding how to add the required permissions.  I can find the Keys in regedit but how do you add permissions for  NlaSvc and Netprofm services ?

    could you explain it as if you were telling a five year old as I'm not so good at these things.

    Thanks

    Sunday, February 23, 2014 2:47 PM

  • Solution: click Start>right click on computer> select manage> click device manager> expand network adapter> right click on the network adapter and select uninstall> up near the top of the box click "scan for hardware changes"> that will reinstsall the adapter and reset the network>scan the wifi> connect and enter the password> AND problem solved!!! :)))) 

    OR

    Control Panel, all control panel items, troubleshooting, network and internet, internet connection, manually enter the input of your network (eg: WPA-Personal), enter password, your computer will configure.. and boom! working..
    Saturday, March 15, 2014 8:22 PM
  • I love it when the advice is to download this or that program to fix a problem that prevents me from getting onto the internet in the first place...helloooo!
    Sunday, March 23, 2014 1:02 AM
  • Thankyou!!!! This fixed my problem in Win8.1.
    Thursday, April 03, 2014 2:55 AM
  • Thanks for the info.  There were permissions issues, but ultimately...I had to uninstall the network drivers and re-install them.
    Monday, April 07, 2014 6:10 PM
  • Hi I have a hpdv6-6c 10us laptop with Windows 7 home premium 64 bit I took it to my parents house and found out I could not connect to wifi in the wifi icon show me a list of available networks including my parents wifi but when clicking to connect or connect automatically does not do anything does not ask for anything (the key or anything) click on manage wireless networks  click on add and does not do anything so I  can not connect to my parents wifi someone that could help please.

    I used a usb adapter I carry with me and connects but only by using the adapter utiliy does the samething if a try it with windows so I know both adaptesr work and it is a windows issue

    Hope someone could help me fix it.

    thanks

    Friday, April 25, 2014 5:33 PM
  • GREAT! Thank you soooo much...
    Wednesday, May 07, 2014 6:11 PM
  • I have the same problem.  How do you explicitly "replace all child object permissions with inheritable permissions from this object"?  I'm not as advanced as everyone else, but would like to fix this problem asap before I go overseas...

    Thanks!!!

    Wednesday, May 21, 2014 6:23 PM
  • Thank you !!!!!

    Great solution worked for me - it has been driving me insane for months.

    I didn't find there was any shortcut to adding the permissions, I simply went down the tree as suggested and amended all the permissions in turn.  5 minutes later no red X in the wireless icon and for the first time in 6 months my lappy knows what a homegroup is again!

    Thanks again guys, for the solution and the addition 'how to' notes making it fool proof, even for me.

    Tuesday, May 27, 2014 8:19 PM
  • First back up the registry
    Go to Start > Run --> type in regedit and hit OK. 
    Navigate to the key HKEY_CURRENT_USER\Software\Classes\LocalSettings\Software\Microsoft\Windows\CurrentVersion\TrayNotify. 
    Delete the values IconStreams and PastIconsStream. 
    Open up the Task Manager, go to the Processes tab, select explorer.exe and click End Process. 
    Open the Applications tab and click New Task at the bottom-right of the window. 
    In the message box that pops up type in explorer.exe and hit OK. 
    Explorer.exe will reload, and the missing icons should now be back in the system-tray where they belong. 

    Wednesday, May 28, 2014 1:33 AM
  • Thanks Ugumba!

    This solved my issue with the red x in the icon for wireless network. I had tried all other answers previously with no luck.

    To be clear for anyone who is not completely computer literate.

    1. Goto Start menu and type regedit in the "search programs and files" box then press enter.

    2. Agree to allow the program to make changes to the computer.

    3. Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\NetworkList

    4. Right click on NetworkList and select Permissions

    5. Click on each of the user sets individually (i.e. CREATOR OWNER, Systems, Administrators (xxx) etc. ) and ensure each option has a tick in the box for Full control. then click Apply Changes.

    6. Now Click on the advanced button.

    7. tick the box next to "replace all child object permissions with inheritable permissions from this object"

    8. Click the Apply button and then after click the OK button.

    9. Problem should be fixed now, but please close all windows and the Registry Editor and restart your machine.

    Saturday, June 07, 2014 12:35 PM
  • thank you very much, that work well for me!
    Tuesday, June 10, 2014 12:45 AM
  • This blog post does a great job of explaining things a little more in depth. http://blogs.technet.com/b/networking/archive/2009/06/19/missing-network-map-under-network-and-sharing-center-in-windows-vista-or-windows-server-2008.aspx

    I found that to fix the issue properly, I reset permissions for the key "HKLM\Software\Microsoft\WindowsNT\CurrentVersion\NetworkList\" and all sub keys.  I looked at a working system to see all the correct permissions.

    The bigger question is "What changed them?"  If it's Malware, you may just want to re-image :(

    • Proposed as answer by Hollisorama Wednesday, June 18, 2014 6:23 PM
    Wednesday, June 18, 2014 6:22 PM
  • Thank YOU!!! have been searching high and low for an answer and thanks to you ding dong the x is dead...
    Tuesday, June 24, 2014 12:18 AM
  • Worked For me....Thank you very much!!!!
    Saturday, June 28, 2014 7:48 AM
  • Ok, there are several reasons this can happen, I will tell you all of them one at a time.

    Let me explain, one reason is that windows update has a call home when your computer starts up and you login initially.  The second is that Windows itself also has a further call home built into it, again trigged when you login or the internet connection is up.  There is another call home, in windows update if you download the Microsoft network adapter update (usually given for invidia lans) that one as well, has its own call home.

    So, if you block any of these sites listed below, you will be connected to the internet, just not to Microsoft, which will trigger the "No internet access" exclamation point on your internet connection icon.

    Sites blocked as listed that will create this issue:

    www.msftncsi.com and Microsoft.com

    Now that is partially the root cause of my particular issue.  And could be the cause of yours.

    having NLA (Network locational awareness) shut off can also cause this issue because your network adapter cannot talk to the rest of the network.

    Here is how I fix it, I make sure I am not blocking either of those sites, or that my site blocking is momentarily off.  Then, I unplug every single piece of networking equipment (from the power) and plug them back into the power one at a time.  Then I turn off the effected machine.  I then plug each piece of networking equipment that is local to my interior network back in, one at a time and wait for them to be connected to the piece before them.  Then turn the machine back on.

    The issue should be resolved.  If not, I suggest  you remove the windows update that originally caused the network adapter issue.  Then go through the process again.

    Saturday, August 09, 2014 10:11 PM