none
Windows 7 - slow opening of share drive folders - network connection issue

    Question

  • We have a generic computer with an ASUS motherboard in my office that has Windows 7 on it and it's having network connection issues. It will store the network username and password but access to the server share folder is VERY slow. Even if I don't store the network password I still have the same issue. Minimum of 5-10 seconds to open even empty folders.

    I've installed a second hard drive on the computer and installed a fresh version of Windows XP on it and the network connection works perfect.

    I've installed fresh versions of Windows 7 32-bit and 64-bit on the first hard drive and both have the slow network issue. I've also tried a new network card and still have the same issue.

    I've not yet installed any antivirus and turned off Windows firewall with no success. There are also no other startup programs running since these are fresh installs.


    • Edited by imagine9 Thursday, March 15, 2012 4:45 PM
    Thursday, March 15, 2012 4:43 PM

Answers

  • The issue occurs if network devices does not support auto-tuning feature well. You may disable auto-tuning and see if it can resolve the issue. Refer to:

    http://support.microsoft.com/kb/934430

    The article is also applied in Windows 7.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, March 19, 2012 8:50 AM
    Moderator

All replies

  • Try changing binding order (Adapters and Bindings tab)

    1. Click on Start > type “network connections” in the search box and then click on “View network connections”
    2. Then Click on Organize > Layout > Menu Bar
    3. From the menu bar click on Advanced > Advanced settings
    4. This will give the order in which the network connections are accessed.

    • Proposed as answer by NTI1 Sunday, June 02, 2013 1:06 PM
    Thursday, March 15, 2012 5:29 PM
  • Here is a link that I have used to help with some speed issues.

    http://www.sysprobs.com/windows-7-network-slow

    I would start by disabling Remote Differential Compression

    Thursday, March 15, 2012 5:40 PM
  • I will try both of your replies when I am back in the office Monday.

    In the meantime I brought the problem computer home and tried it on my home network and I can now say this is an issue with Windows 7 talking to a server with Windows 2003 R2 on it because it works perfect at my house.  My house has all Windows 7 computers on its network.

    Any ideas on how to get the Windows 7 computer to network correctly with the Windows 2003 server? The puzzling part of this is that there are other Windows 7 computers networking correctly with the Windows 2003 server.

    Friday, March 16, 2012 3:52 AM
  • The issue occurs if network devices does not support auto-tuning feature well. You may disable auto-tuning and see if it can resolve the issue. Refer to:

    http://support.microsoft.com/kb/934430

    The article is also applied in Windows 7.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, March 19, 2012 8:50 AM
    Moderator
  • Arthur your link supplied the workaround fix. 

    I disabled auto-tuning on the Windows 7 machine and now it accesses the server share drive perfectly.

    The article you sent says the issue is caused by a conflict with the SonicWall firewall we have yet the two issues it points to as causing it were not "enabled" on our firewall.  So I'm still not sure what setting to change on the firewall to correct this.  For now I have left the auto-tuning "disabled" on the Windows 7 computer.

    A call to SonicWall tech support yielded nothing on this.  They are clueless to this issue but were able to confirm for me that "Strict TCP Enforcement Option" and "Enforce strict TCP compliance with RFC 793 and RFC 1122" were both NOT enabled on our firewall.

    Two questions:

    1. Are there any potential issues I can run into by leaving auto-tune disabled on the Windows 7 machine?
    2. Any ideas about what else could be causing this issue inside the SonicWall TZ 200W firewall?

    Monday, March 19, 2012 9:36 PM
  • Curious as I use server 2008 r2 for servers and windows 7 for clients and I have no problem with portables connected wirelessly

    i do not use a 3rd party firewall as my cisco box has that built-in


    Windows MVP 2010-11, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint, Cloud, Virtualization etc. etc.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews

    Monday, March 19, 2012 10:50 PM
  • Auto-tuning has been causing multiple issues usually the problem lies with drivers and\or network devices causing the issues. 
    Monday, March 19, 2012 11:58 PM
  • Will disabling auto-tuning cause anything else to go wrong?
    Tuesday, March 20, 2012 3:40 PM
  • Auto-tuning is an extra feature which is not required to be enabled
    Tuesday, March 20, 2012 4:20 PM