none
you need permission to perform this action - when copying file from xp to vista over network

    Question

  • Im a copying files from my xp laptop to my new vista laptop, having mapped to the c drive over the network.

     

    It copies most files then get error you need permission to perform this action, specifically .jsp files.

     

    After searching the net i have logged into both systems with same username and password but still not copying.

     

    There must be a simple answer to this, I called MS office in the UK but they didnt want to help unless I gave them 200 quid.

     

    Jason

    Friday, September 19, 2008 1:22 PM

Answers

  • Hello,

     

    You current issue might be caused by several reasons, please perform the following instructions to narrow down the issue.

     

    First of all, please refer to the following webpage to see whether it is helpful.

    Destination Folder Access Denied - You need permission to perform this action in Vista

    http://webisee.com/2008/05/19/destination-folder-access-denied-you-need-permission-to-perform-this-action-in-windows-vista-when-trying-to-delete-file-usb-drive/

     

    1. Do not use mapped drive. Instead, connect to the network sharing folder directly and then try the copy operation.

     

    2. Just copy the problematic JSP file to see if it always fails with this specific file. If so, rename the file extension from JSP to txt and try to copy again. How it works?

     

    3. Make sure that you provided the Full-Control permissions of both Sharing and Security settings to Everyone for the Windows XP folders.

     

    4. Confirm that you logged the Windows Vista computer with the Administrator account and turn UAC off temporally.

    1) Click the Windows Pearl (Start Button) in the lower-left corner of the screen-> Control Panel.

    2) Select Classic View on the left and double-click the User Accounts icon.

    3) Click Turn User Account Control on or off option.

    4) Uncheck the User User Account Control (UAC) to help protect your computer and click OK.

    5) If prompted, choose restart, otherwise restart from the Start Menu.

      

    5. Temporarily disable/uninstall all Anti-Virus programs or firewalls. If you have installed any Anti-Virus programs or firewalls on both Windows XP and Vista, please temporarily disable/uninstall all the firewalls and Anti-Virus programs, as this may be helpful in resolving this problem.

    Note: In order to prevent virus attack during this process, please run a complete virus check first. Then you can reinstall the anti-virus software after our troubleshooting steps.

     

    If the problem persists, let's perform a Clean Boot on both Windows XP and Vista computer. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

     

    6. Start Windows in Clean Boot mode

    Note: You must be logged on as an administrator or a member of the Administrators group to complete this procedure.

    1) Click Start. (Click Run first for Windows XP OS)

    2) Copy and paste "msconfig" (without the quotation marks) in the box, and click Enter.

    3) Switch to Services tab and then Check Hide All Microsoft Services.

    4) Click Disable All.

    5) Switch to the Startup tab and then Click Disable all.

    6) Click OK.

    7) Click Restart to restart the computer and test the issue.

     

    Good Luck!

     

    Monday, September 22, 2008 11:36 AM

All replies

  • Hello,

     

    You current issue might be caused by several reasons, please perform the following instructions to narrow down the issue.

     

    First of all, please refer to the following webpage to see whether it is helpful.

    Destination Folder Access Denied - You need permission to perform this action in Vista

    http://webisee.com/2008/05/19/destination-folder-access-denied-you-need-permission-to-perform-this-action-in-windows-vista-when-trying-to-delete-file-usb-drive/

     

    1. Do not use mapped drive. Instead, connect to the network sharing folder directly and then try the copy operation.

     

    2. Just copy the problematic JSP file to see if it always fails with this specific file. If so, rename the file extension from JSP to txt and try to copy again. How it works?

     

    3. Make sure that you provided the Full-Control permissions of both Sharing and Security settings to Everyone for the Windows XP folders.

     

    4. Confirm that you logged the Windows Vista computer with the Administrator account and turn UAC off temporally.

    1) Click the Windows Pearl (Start Button) in the lower-left corner of the screen-> Control Panel.

    2) Select Classic View on the left and double-click the User Accounts icon.

    3) Click Turn User Account Control on or off option.

    4) Uncheck the User User Account Control (UAC) to help protect your computer and click OK.

    5) If prompted, choose restart, otherwise restart from the Start Menu.

      

    5. Temporarily disable/uninstall all Anti-Virus programs or firewalls. If you have installed any Anti-Virus programs or firewalls on both Windows XP and Vista, please temporarily disable/uninstall all the firewalls and Anti-Virus programs, as this may be helpful in resolving this problem.

    Note: In order to prevent virus attack during this process, please run a complete virus check first. Then you can reinstall the anti-virus software after our troubleshooting steps.

     

    If the problem persists, let's perform a Clean Boot on both Windows XP and Vista computer. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

     

    6. Start Windows in Clean Boot mode

    Note: You must be logged on as an administrator or a member of the Administrators group to complete this procedure.

    1) Click Start. (Click Run first for Windows XP OS)

    2) Copy and paste "msconfig" (without the quotation marks) in the box, and click Enter.

    3) Switch to Services tab and then Check Hide All Microsoft Services.

    4) Click Disable All.

    5) Switch to the Startup tab and then Click Disable all.

    6) Click OK.

    7) Click Restart to restart the computer and test the issue.

     

    Good Luck!

     

    Monday, September 22, 2008 11:36 AM
  • I was trying to transfer some media files from a Vista laptop to an XP desktop.  I shared the entire Media partition (Right click, Sharing and Security, etc.) and I didn't check the box Allow Network Users to Change My Files.  I ran into the You don't have permission error, then I checked the Allow Network...box and it worked fine.  
    Wednesday, December 31, 2008 9:38 PM
  • This is such a messed up bug of windows 7.  I am configuring 2 new laptops, one Vista and one Windows 7.  The Vista one doesn't have this problem surprisingly.  Windows 7 doesn't even give the administrator user access to overwrite their own files.  I get the "you need permission to do this" so much windows 7 is turning out to be a nightmare just merging a large folder.  It tries to hold it all in memory and crashes merging large folders.  Doing one folder at a time I randomly come across lack of permissions using the only account that is supposedly an administrator. 
    I heard Vista used to have this bug and it seems they fixed it Vista but not in Windows 7 because I am not getting any such error doing all the same things in a fully patched vista.  7 is patched too but i am getting these permission bugs like crazy still.

    Wednesday, March 03, 2010 4:13 AM
  • I had tried disabling UAC, removing startup items and even uninstalling any of my software I suspected could be culprit and no luck.  I got a bit further following the advice of another post, enabling the hidden administrator account and restarting.  Funny I still got the "you need permission..." error when copying and merging a large folder, but at least this time there was no virtual memory warning and system crash and when I chose to skip the files it couldn't copy nothing has crashed yet...
    I'll wait until it's done and look individually at the files left over.
    Wednesday, March 03, 2010 11:33 AM
  • The problem you describe is what I've been wrestling with.

    I have my old XP system  and my new Windows 7 system.

    I have one account on each, which is the same, with the same password,  and it is an administrator on both.

    I have setup a share on the XP system and can connect to it, but when I try to copy the music files to my new Win 7 "MyMusic" folder, I get the permissions problem.I played with all the folder permissions I could. But since both users are admins, this should not be necessary.

    I finally resorted to copying the files from XP to a USB drive and then to the Win 7 MyMusic folder. Amazingly enough this worked.

    So there is something messed up with the network security. One would think that going through the network with all the user id and permission stuff, that it would be easier that using an external device. I actually think that making it so easy to use the external device so easy, e.g. not uid or password, is a security exposure.

    I would like to find a way to get the network copy to work. I thought of using the homegroup but I don't think XP knows this concept.

    Jeff

    Wednesday, June 13, 2012 3:55 PM