none
Windows 7 will not enter sleep mode or hibernate

    Question

  • I have Windows 7 Ultimate x64 installed on my desktop computer. Often it wakes up on its own for various reason but that not the problem. The problem is that sometimes it doesn’t go back to sleep. If I press the sleep button on the keyboard the screen briefly goes blank and returns. I have tried checking the “powercfg /requests” command and sometimes find issues but not always. I will try to use the “shutdown /h” command in the command console and again the screen goes blank like it going to shutdown but the screen returns. The error message in the command console window is “The system cannot find the path specified.(3)”. I need to shutdown the computer to fix the problem but the problem will eventually return.

     

    Can anybody help me or have any suggestions?

    Saturday, January 02, 2010 12:13 AM

Answers

  • As your motherboard is Intel DG965WH , you can go to Inter website to get all the new drivers, espically the new Chipset driver.

    As the Intel Management Engine driver, you can refer to this following link to apply the Vista driver as a workaround.

    http://communities.intel.com/community/openportit/vproexpert/microsoft-vpro/blog/2009/02/24/management-engine-interface-mei-and-serial-over-lan-sol-device-driver-compatibility-in-windows-7

    Once you applied these drivers, please test your issue again. In addition, you can test in the Clean boot mode.

    Clean Boot
    ======================
    This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. Select the Services tab in the open window. Check the “Hide all Microsoft Services” option and click Disable All.
    3. Switch to the Startup tab and click Disable All.
    4. Click OK to save the settings and select Restart when prompted.
    5. Check whether or not the issue still occurs.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't adversely affect the system or other programs. We can still manually run these programs later.

    How to return from a Clean Boot state
    ============================
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. On the "General" tab, click "Normal Startup - load all device drivers and services".
    3. Click "OK". Click "Restart" when you are prompted to restart the computer. 

    Good luck!

    John
    • Marked as answer by Vivian Xing Monday, January 11, 2010 9:50 AM
    Wednesday, January 06, 2010 3:07 AM

All replies

  • First, please let me know if you are using a wireless mouse or keyboard.

    In my opinion, please update all hardware drivers to be the latest version, since it may be caused by the driver conflicts. Then please verify the Power Plan setting.

    Check the "Save Power" settings
    ======================
    1. Click Start, type "devmgmt.msc" (without quotation marks) in the search bar, then press Enter. Click Continue button to verify the administrator permission.
    2. Expand the Universal Serial Bus Controllers, locate USB Root Hub, right click on it and choose Properties.
    3. On the Power Manager tab, check the checkbox beside "Allow this computer to turn off this device to save power".
    4. Click OK to apply this setting.
    5. You can use the same method to check the save power option of your network adapter card.

    Set the media sharing option
    ===================================
    1. Click the Start Button, type in "POWERCFG.CPL" without the quotation marks in the search bar and press "Enter".
    2. Under the Power Plan in use click the Change plan settings.
    3. Click Change advanced power setting.
    4. Click Change settings that are currently unavailable.
    5. If the User Account Control windows prompts, click continue.
    6. Locate to Multimedia settings and click the “+” beside it.
    7. Expand the When sharing media.
    8. Click on the Setting and click the small arrow, choose Allow the computer to sleep.
    9. For your convenience, please set the time shorter for a quick test. For example: Turn off the display 1 minute and Put the computer to sleep 1 minute.

    I hope this can help you.


    John
    Monday, January 04, 2010 6:28 AM
  • John, Thanks for replying.

     

    First; no I do not have a wireless keyboard or mouse.

     

    As for the drivers, there was one that needed to be updated for a Hauppauge TV tuner card. There is another device marked PCI simple communications controller that has no drivers. I don’t know what that device could be.

     

    I couldn’t find any “devmgmt.msc” command. I assume you are referring to the device manage. The USB root hubs and network device was already set for sleep node as you suggested. The power settings also had already been set to the mode you suggested.

     

    Let me emphasize that my problem is not that it never goes to sleep. The problem is that eventually this will happen and it tends to occur after it is automatically waken up and that is not always the case either. This problem seems to be occurring now almost on a daily basis.

    Monday, January 04, 2010 10:43 PM
  • First, I would like to tell you that I know your comptuer can't keep in the sleep mode or hibernation. Please let us know your computer model. Please apply the latest BIOS, chipset driver for your comptuer first, then test if your comuter can keep in sleep mode.

    In addition, please check if your Hauppauge TV tuner card is compatible with WIndows 7, you can check it in the following link:

    http://www.microsoft.com/windows/compatibility/windows-7/en-us/Browse.aspx?type=Hardware&category=TV%20Devices&subcategory=TV%20Tuners 

    If your TV tuner is compatible with Windows 7, you can get the latest driver from the Hauppauge website.  

    As the unknown PCI device,  you can try the following steps to inditify it.

    To manually identify the devices we have to find out the device instance ID which has two parts, one is the vendor ID and the second is Device ID. Once we have got the vendor ID and identified the device ID, we can easily find the drivers for our device.

    To find the device instance ID go to Device Manager –> Right click the unknown device –> Properties –> Details.

    Now from the drop down menu select Device Instance Path.

    It will give you a string value which contains the vendor ID and the Device ID. The string is like this:

    HDAUDIOFUNC_02&VEN_14F1&DEV_5045&SUBSYS_103C30D5&REV_10014&2675E3A&0&0002

    Now, you can serch the find the device from the following website.

    http://www.pcidatabase.com/

    After that, you can go to the computer manufacture's website to download the proper driver.

    I hope this can help you.


    John
    Tuesday, January 05, 2010 3:30 AM
  • The computer is home built using an Intel DG965WH mother board. I did find a newer version of the BIOS and updated it.

     

    The Hauppauge TV tuner is compatible with Windows 7. I did find new software including new driver for this that I am going to try.

     

    Your instruction did help me find the PCI simple communications controller. It is an Intel Management Engine that provides thermal management for Intel Desktop Boards. There are no Windows 7 drivers from Intel for this.

    Wednesday, January 06, 2010 12:21 AM
  • As your motherboard is Intel DG965WH , you can go to Inter website to get all the new drivers, espically the new Chipset driver.

    As the Intel Management Engine driver, you can refer to this following link to apply the Vista driver as a workaround.

    http://communities.intel.com/community/openportit/vproexpert/microsoft-vpro/blog/2009/02/24/management-engine-interface-mei-and-serial-over-lan-sol-device-driver-compatibility-in-windows-7

    Once you applied these drivers, please test your issue again. In addition, you can test in the Clean boot mode.

    Clean Boot
    ======================
    This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. Select the Services tab in the open window. Check the “Hide all Microsoft Services” option and click Disable All.
    3. Switch to the Startup tab and click Disable All.
    4. Click OK to save the settings and select Restart when prompted.
    5. Check whether or not the issue still occurs.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't adversely affect the system or other programs. We can still manually run these programs later.

    How to return from a Clean Boot state
    ============================
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. On the "General" tab, click "Normal Startup - load all device drivers and services".
    3. Click "OK". Click "Restart" when you are prompted to restart the computer. 

    Good luck!

    John
    • Marked as answer by Vivian Xing Monday, January 11, 2010 9:50 AM
    Wednesday, January 06, 2010 3:07 AM