none
HomeGroup get an error of must have IPv6 enabled

    Question

  • When I try to create a homegroup on either of my computers I get the error Your network connection must have IPv6 enabled to create or join a homegroup.
    When I check the properties it is enabled.
    I can see all the drives and access all shared drives from either computer, why is homegroup not working?
    Sunday, November 01, 2009 11:27 AM

Answers

  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

     

    • Proposed as answer by Lee_Marshall Tuesday, November 03, 2009 7:06 PM
    • Marked as answer by Novak Wu Wednesday, November 04, 2009 7:22 AM
    Monday, November 02, 2009 1:06 AM

All replies

  • Hope you get an answer soon.

    Two days searching for an answer.
    Sunday, November 01, 2009 12:45 PM
  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

     

    • Proposed as answer by Lee_Marshall Tuesday, November 03, 2009 7:06 PM
    • Marked as answer by Novak Wu Wednesday, November 04, 2009 7:22 AM
    Monday, November 02, 2009 1:06 AM
  • Works a dream, thanks Novak!
    Tuesday, November 03, 2009 7:03 PM
  • Worked perfectly! Thanks!
    Thursday, November 19, 2009 11:13 PM
  • I had te "Enable IPv6"  problem on both of my newly upgraded to Windows 7 computers.  On the PC, this edit of the TCPIP6 parameter worked perfectly.  However, on my HP laptop, I performed the edit, then tried to "Join the Homegroup", and I got the same problem.

    So, I opened regedit again and went to the TCPIP6 parameter and the registry had reverted back to the the original "ff" value for the parameter.  I tried the edit several times and even tried rebooting after making the edit a few times.  I eventually discovered that the "0" value seemed to revert back to "ff" during the reboot.

    I also eventually edited the parameter for ControlSet001, 002, and 003 from "ff" to "0" but still got the same result.

    In any case, I could never get the laptop to join the homegroup because it would always say I needed to enable IPv6.

    FYI, IPv6 is enabled in the properties of the network adaptor.

    Is there some other copy of the registry somewhere that iI am missing that could be causing this?

    I appreciate any help you can provide.
    Tuesday, December 01, 2009 8:13 PM
  • Thanks, Great!
    Wednesday, December 02, 2009 2:34 PM
  • I made the changes exactly as you described to ALL the computers I wanted on the homegroup and it worked!!!  Thank you so much for your help.  I will spread the word with all the new Windows 7 users I know.
    Wednesday, January 20, 2010 11:55 PM
  • Just a Note here Create a DWORD -> DisabledComponents
    "# Note If the DisabledComponents entry is unavailable, you must create it. To do this, follow these steps:

       1. In the Edit menu, point to New, and then click DWORD (32-bit) Value.
       2. Type DisabledComponents, and then press ENTER.
       3. Double-click DisabledComponents.

    # Type any one of the following values to configure the IPv6 protocol, and then click OK:

       1. Type 0 to enable all IPv6 components. "


    Friday, January 22, 2010 8:15 PM
  • This is nice information to have just in case I run into this situation while trying to help others get their Homegroup up and running.  Thank you.
    Sunday, January 24, 2010 1:46 AM
  • I have done everything you suggest, but still cannot create a homegroup. I STILL get the IPV6 error message. I have a desktop with Windows 7 and a laptop with Windows 7. When I try to change the value in TCP/IP6  parameter from ff to 0, it reverts back as soon as I exit. I've spent at least 5 hours on the phone with tech support from both computers, and with Costco Concierge tech support (which is excellent, BTW), and no one has been able to fix this.

    One tech person says Microsoft is aware of this problem, but has not issued a patch. Is this a MS problem? If so, why hasn't it been fixed by now?

    Are there other places to change IVP6?

    Any other ideas for me. Surprised that others have had success with this.
    Tuesday, February 02, 2010 7:10 PM
  • SOLVED
    I had exactly the same problems, i'd get the network and homegroup working, then i'd restart one of the pc's then nada
    Easy fixed though
    open regedit
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters
    change disablecomponents to 0
    then right click on the parameters folder and click on permissions
    unclick all fullcontrol permissions to all the users/groups
    apply
    repeat to all networked pcs
    restart
    DONE!

    PS you still need to ensure that the services Peer Networking Grouping and PNRP Machine Name Publication Service are on automatic
    • Edited by yogi2200 Wednesday, February 10, 2010 11:21 AM forgot to add some info
    • Proposed as answer by Fred Cone Sunday, April 04, 2010 12:10 PM
    Wednesday, February 10, 2010 11:20 AM
  • Works great, Thank You
    Monday, March 29, 2010 10:42 AM
  • Thank you, thank you, thank you, Novak Wu and yogi2200 !

    Those changes made the fix stick on all my 32-bit PCs!

    However, before it would stick after a reboot on my 64-bit PCs, I had to change DisabledComponents in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters to a QWORD (64-bit) binary zero value instead of a DWORD (32-bit).


    Fred Cone
    • Proposed as answer by Fred Cone Sunday, April 04, 2010 12:07 PM
    • Edited by Fred Cone Sunday, April 04, 2010 12:23 PM Added credits
    Sunday, April 04, 2010 12:05 PM
  • This answer not only fixed my issue with not being able to join the home group but also resolved the problem I was having with streaming to my Xbox 360 with Media Player 12.  Thank you so much.
    Monday, April 26, 2010 4:17 PM
  • Hi,

     

    Absolutely right!  I have followed other threads on the same topic without success.  This was great!

    Thanks for a clear and concise answer to a difficulty problem.

    Sunday, May 09, 2010 11:50 PM
  • Thanks sooo much ... This has been bugging me for months and could not get it fixed at all.

     

    Wednesday, June 30, 2010 3:04 PM
  • This worked like a charm for both of my machines. Thank you so much for your help and insight.
    Saturday, August 21, 2010 10:00 PM
  • I had te "Enable IPv6"  problem on both of my newly upgraded to Windows 7 computers.  On the PC, this edit of the TCPIP6 parameter worked perfectly.  However, on my HP laptop, I performed the edit, then tried to "Join the Homegroup", and I got the same problem.

    So, I opened regedit again and went to the TCPIP6 parameter and the registry had reverted back to the the original "ff" value for the parameter.  I tried the edit several times and even tried rebooting after making the edit a few times.  I eventually discovered that the "0" value seemed to revert back to "ff" during the reboot.

    I also eventually edited the parameter for ControlSet001, 002, and 003 from "ff" to "0" but still got the same result.

    In any case, I could never get the laptop to join the homegroup because it would always say I needed to enable IPv6.

    FYI, IPv6 is enabled in the properties of the network adaptor.

    Is there some other copy of the registry somewhere that iI am missing that could be causing this?

    I appreciate any help you can provide.


    I have the exact same problem on my Dell laptop, everytime I restart, the DisabledComponents parameter resets to ff? Every other setting is correct and all the services are started and on automatic. I have the most recent drivers for wifi card and am using Zonealarm free and AVG free. Disabling these makes no difference.

    Win 7 Pro x64, Intel WifiLink 6300

    Someone please help, homegroup is completely useless to me???

    • Proposed as answer by Durry Saturday, February 19, 2011 3:16 PM
    • Unproposed as answer by Durry Saturday, February 19, 2011 3:16 PM
    Tuesday, November 09, 2010 9:54 PM
  • I'm glad I stumbled on this thread as I haven't been able to enable IPv6 either but your solution worked for me too.  Thanks!
    Friday, January 28, 2011 12:04 PM
  • I have been researching the issue on why IPV6 would not start for weeks.  This post answered the question and worked.  Thank you
    Thursday, February 03, 2011 2:25 PM
  • Great fix !  Thanks !

    Monday, February 14, 2011 2:09 AM
  • Hi Guys

     

    had the same problem on my  HP Pavilion. looking around the web an answer came up that it could be ZoneAlarm.

    Go to firewall settings/ Blocked zone secuity/ advanced and tick enable ipv6 network.

    It worked for me.

     

    Saturday, February 19, 2011 3:21 PM
  • Thank you, it took every one of these steps to get one of my computers hooked up to my homegroup (Windows 7 32bit).  The last tip from Durry finally made them all work.  Thank you again.
    Saturday, February 04, 2012 11:33 PM
  • Hi Novak,

    Many thanks! worked first time I followed your instructions.

    Sunday, February 26, 2012 3:11 PM
  • Brilliant! It may be three years on, but the regedit portion of this solution fixed my IPv6 straight away. Many thanks.
    Sunday, February 26, 2012 6:54 PM
  • Also consider any system enhancement tools that you may be using.  I ran the UniBlue application, SpeedUpMyPC, and discovered that everything fixed by performing the steps in this thread would have been undone in an effort to implement system tweaks to speed up my pc.  Take note of all of the services in this thread and compare the list with any recommendations to disable entries by your system performance enhancement tools.  SpeedUpMyPC worded their recommendations to make the average non-computer professional believe that these items were not needed "Disable the unnecessaryh service <servicename>"  Since this thread specifies the service "Display Names" (i.e. Peer Networking Grouping) you may miss these entries if your system performance tools display them as their actual service name (i.e. p2psvc).  Below is a list of these entries with both Display Name and Service Name so you can prevent your tool from automatically undoing these efforts in the future causing you to go through this all over again.  These services also have other services that must not be disabled as they are dependent upon them to run (referred to as Dependencies).  The startup type can be set to Manual allowing the two services that need them to run when needed.

    SET Startup Type to Automatic:

    Peer Networking Grouping (Service name: p2psvc)

    PNRP Machine Name Publication Service (Service name: PNRPAutoReg)

    -- Dependencies: SET Startup Type to Manual:

    Peer Name Resolution Protocol (Service name: PNRPsvc)

    Peer Networking Identity Manager (Service name: p2pimsvc)

    If either of the dependencies are disabled for whatever reason, the two services that are dependent upon them will fail to load as well.

    I hope this helps those who still have issues after starting the two services discussed in the rest of this thread.

    Wednesday, March 07, 2012 3:06 AM
  • awesome.... hats off.........
    Sunday, April 29, 2012 5:18 PM
  • I've found the definitive solution:

     

    If one of your computers is connected to the router with a cable and the others are connected by wifi you'll get the IPv6 error messgae.

     

    I know this is true because my pc and laptop used to be in a homegroup, then the pc gave the error message when I cabled it to the router, and the message disappeared when I connected via wifi - it has to be the cable connection to the router.

     

    Yay me!

    Wednesday, October 10, 2012 4:19 PM
  • Ok, I tried everything on this page but still could not create a homegroup under windows 8.1.

    I was getting the same error about ipv6 which I have been trying to fix since upgrading to 8.1 a couple of months ago.

    In the end how I have just fixed it is to change the windows workgroup name from the default WORKGROUP to something else, I called mine HOME

    and then I was able to create the homegroup and everything is normal once again even though my connection says no internet access under IPV6.

    Sunday, January 26, 2014 8:48 PM
  • Thanks again for the solution!
    Saturday, April 19, 2014 6:53 PM