none
Windows Media Player 12 Error C00D11B1 Problem

    Question

  • Hi,

    I get the an error message on my PC running Windows 7 64-bit, andI am trying to play a Digital Copy of a movie.

    I contacted the studio, and they let me re-download the files, and the problem persists.

    I tried all the steps here - http://windows.microsoft.com/en-US/windows7/C00D11B1 - and nothing works.  What can I do?

    Thanks.
    Thursday, March 04, 2010 4:21 PM

Answers

  • thanks...i got it to work! :)

    i downloaded the digital copy on another computer, where it worked, so i wont be sure about this computer for a little bit

     

    thanks again!

    • Marked as answer by Vivian Xing Thursday, April 22, 2010 8:23 AM
    Saturday, April 17, 2010 7:16 PM

All replies

  • Hi,

    I would like to confirm if other file can be played correctly.

    To troubleshoot this issue, you can try the following method:

    ·         Method 1. register DLL files:

    ======================
    1. Click the Start button, type CMD in the Start Search box.
    2. Right click on CMD and choose Run as administrator.
    3. Type the following commands and press Enter at the end of each line:

    Regsvr32 MSMPEG2ADEC.dll

    Regsvr32 MSMPEG2VDEC.dll

     

    Method 2:

    ==================

    1, Click the Start button, type Regedit in the Start Search box and press Enter.

    2, Navigate to the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Audio\

    3. Right click on Audio and choose New -> DWORD value

    4. Name it as DisableProtectedAudioDG, change the value from 1 to 0.

     

    NOTE: Please backup registry before making any change.

     

    Method 3: Update BIOS and device drivers to latest version.

    You can also try the DRM reset tool as below?

    http://www.napster.com/client/drmreset/DRM_reset.exe

    Hope it helps.


    Vivian Xing - MSFT
    • Proposed as answer by turbosupra1 Tuesday, August 02, 2011 2:41 PM
    Friday, March 05, 2010 7:13 AM
  • Hi,
    
    Sorry it took me so long to respond - I didn't see the reply.  Didn't get a notification even though I asked for one.
    
    Anyways, thanks for the response.
    
    I tried Method 1.  It did not work.
    
    I tried Method 2, but there's already a file there so it won't let me save a file with that name.
    
    How do I do Method 3?  I'd like to do that before I do the Napster thing.
    
    Thanks.
    Tuesday, March 09, 2010 6:47 AM
  • As for method 3, just download the program and run it.
    Vivian Xing - MSFT
    Wednesday, March 10, 2010 3:09 AM
  • I tried installing that file, but it keeps saying I'm running programs that need to be shut down when I am not.  I even when into the task manager and shut things down.

    What can I do?

    Thanks.
    Thursday, March 11, 2010 12:49 AM
  • How about right click on the DRM_reset.exe and choose Run as administrator?
    Vivian Xing - MSFT
    Thursday, March 11, 2010 2:51 AM
  • same problem :(
    Thursday, March 11, 2010 4:08 AM
  • How about right click on the DRM_reset.exe and choose Run as administrator?
    Vivian Xing - MSFT
    hello?
    Saturday, March 13, 2010 2:09 AM
  • Please try installing it as below:

     

    Install program under compatibility mode & Administrator level

    =================

    1. Right click on the installation file (setup.exe) and click Properties.

    2. Click on the Compatibility tab.

    3. Select Run this program in compatibility mode for.”

    4. Choose Windows Vista (Service Pack 2) from the drop down list.

    5. Select Run this program as an administrator” option under the Privilege Level topic.

    6. Click Apply, click OK.

     

    Right click on the setup file and choose Run as administrator to install it again.


    Vivian Xing - MSFT
    Thursday, March 18, 2010 6:49 AM
  • Is there an easier way to figure out what programs I need to shut down via the task manager?  I still can't get the file to install.
    Monday, March 22, 2010 3:42 AM
  • hello?
    Wednesday, March 31, 2010 1:40 AM
  • Hello?  help please.
    Thursday, April 15, 2010 3:46 AM
  • Hi i was having the save problem as u above, am i have found a solution.

    i used this method:

    "Method 3: Update BIOS and device drivers to latest version.

    You can also try the DRM reset tool as below?

    http://www.napster.com/client/drmreset/DRM_reset.exe

    Hope it helps."
    Vivian Xing

    like you said before you had a error with it saying you were " running programs that need to be shut down" well so did i so i started looking at the services currently running and i found WMPNetworkSvc and stopped it and i was able to use the Napster reset toll which work.

    You can stop the service by going into task manager > services > WMPNetworkSvc right click and stop service

    Hope this helps

     

    Friday, April 16, 2010 12:08 AM
  • thanks...i got it to work! :)

    i downloaded the digital copy on another computer, where it worked, so i wont be sure about this computer for a little bit

     

    thanks again!

    • Marked as answer by Vivian Xing Thursday, April 22, 2010 8:23 AM
    Saturday, April 17, 2010 7:16 PM
  • thanks...i got it to work! :)

    i downloaded the digital copy on another computer, where it worked, so i wont be sure about this computer for a little bit

     

    thanks again!

    Saturday, April 17, 2010 7:16 PM
  • I tried all the suggestions you provided with a new file, and I am having the same problems - the error page I get sends me here: http://windows.microsoft.com/en-US/windows7/C00D11B1

     

    Please advise.  Thanks.

    Thursday, July 29, 2010 5:03 AM
  • Thank you so much Viv.....the command line stuff worked for me really well...Prior to that I was only able to run matroska files n avi files failed to open up on wmp 12. However I tried out different codec packs but none of them seemed good enough.....But the method u described above ie.,

      Method 1. register DLL files:

    ======================
    1. Click the Start button, type CMD in the Start Search box.
    2. Right click on CMD and choose Run as administrator.
    3. Type the following commands and press Enter at the end of each line:

    Regsvr32 MSMPEG2ADEC.dll

    Regsvr32 MSMPEG2VDEC.dll

     

    is simply awesome n now every video formats works just fine....thanks mate...u made my day :)...

    Thursday, September 23, 2010 10:04 AM
  • Hi,

    I would like to confirm if other file can be played correctly.

    To troubleshoot this issue, you can try the following method:

    ·         Method 1. register DLL files:

    ======================
    1. Click the Start button, type CMD in the Start Search box.
    2. Right click on CMD and choose Run as administrator.
    3. Type the following commands and press Enter at the end of each line:

    Regsvr32 MSMPEG2ADEC.dll

    Regsvr32 MSMPEG2VDEC.dll

     

    Method 2:

    ==================

    1, Click the Start button, type Regedit in the Start Search box and press Enter.

    2, Navigate to the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Audio\

    3. Right click on Audio and choose New -> DWORD value

    4. Name it as DisableProtectedAudioDG, change the value from 1 to 0.

     

    NOTE: Please backup registry before making any change.

     

    Method 3: Update BIOS and device drivers to latest version.

    You can also try the DRM reset tool as below?

    http://www.napster.com/client/drmreset/DRM_reset.exe

    Hope it helps.


    Vivian Xing - MSFT


    This worked for me, thank you. I also registered the dlls as well, for good measure.

    If you are nervous about navigating the registry, copy the text below and put it in a file called "disableDRM.reg" and then run it and click yes to the prompt.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Audio]
    "DisableProtectedAudioDG"=dword:00000000

    Tuesday, August 02, 2011 2:44 PM
  • I did the following to fix this for me:

    support.microsoft.com/?kbid=891664

     

    We had applied a wim across all the computers at a client site and it was a hardware mismatch with the DRM licensing. The section that specifically fixed it for us was:

     

    1. Reset Windows Media DRM by deleting all the files in the Windows Media DRM folder. Note that the Windows Media DRM folder is a hidden system folder. To view hidden files and folders, follow these steps:
      1. Click Start, and then click My Computer.
      2. On the Tools menu, click Folder Options, and then click the View tab.
      3. Click Show hidden files and folders, and then click to clear the Hide protected operating system files check box.
      The following are the typical locations of the Windows Media DRM folder, depending on your operating system version:
      • Windows Vista: C:\ProgramData\Microsoft\Windows\DRM
      • Microsoft Windows 2000 and Windows XP: C:\Documents and Settings\All Users\DRM
      • Windows 98: C:\Windows\All Users\DRM
      • Windows Millennium Edition: C:\Windows\DRM
      If you cannot find the Windows Media DRM folder, the exact location of the folder on the computer is stored in the following registry key. Make sure that this key points to a valid path:
      HKEY_LOCAL_MACHINE\Software\Microsoft\DRM\DataPath
      Note By default, the path is displayed in binary format. To see the path in plain-text format, double-click DataPath. In the Edit Binary Value dialog box, the path is displayed in the column on the right.

    Finally reinstall the DRM system

    1. Individualize the Windows Media DRM system.

      To install the latest Windows Media DRM components, see the instructions on the following Microsoft Web site:

     

     

    Friday, November 04, 2011 10:01 PM
  • Thank You thank you thank you! It worked perfectly. I did exactly what you said and it worked! I can now rip CDs again! :D
    Friday, February 14, 2014 11:25 PM