none
Windows cannot connect to WEP

    Question

  • Hi,

    I just upgraded to windows 7 and cannot connect to the internet. My router uses WEP encryption and I always get a windows cannot connect error message however if I go tyo my neighbor's home who uses a router with WPA encryption I can get on the net without any problems. I did not have this problem before my upgrade. Any ideas how I can fix this?

    Thursday, June 04, 2009 1:16 PM

Answers

  • WEP is NOT safe. You need to change to at least WPA.


    Even if that means buying new hardware.


    --


    Barb Bowman


    MS-MVP


    http://www.digitalmediaphile.com


    http://digitalmediaphile.wordpress.com


    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx





    On Thu, 4-Jun-09 13:16:09 GMT, Akins wrote:


    >
    >
    >Hi,
    >
    >I just upgraded to windows 7 and cannot connect to the internet. My router uses WEP encryption and I always get a windows cannot connect error message however if I go tyo my neighbor's home who uses a router with WPA encryption I can get on the net without any problems. I did not have this problem before my upgrade. Any ideas how I can fix this?
    • Proposed as answer by bsm330 Thursday, June 04, 2009 7:28 PM
    • Marked as answer by Adam M MCP Monday, June 15, 2009 4:59 PM
    Thursday, June 04, 2009 4:11 PM
  • Hi,

    may be this advice is of no use, because you already know.
    I also had the problem, using WEP (which surely is not the safest way) and a pass-phrase.
    After all I recognised, that I had to put in the pass-phrase in hex, not in ascii. I did this, and it worked fine (the hex-code of my pass-phrase I could see in the router-software).

    Best Regards
    Axel
    • Marked as answer by Adam M MCP Monday, June 15, 2009 4:58 PM
    Friday, June 05, 2009 8:10 AM

All replies

  • Have you tried connecting to your router with no security enabled?

    If you can't connect, the router probably isn't compatible with Windows 7.

    If you can, try changing the SSID and the WEP key.
    Thursday, June 04, 2009 2:31 PM
  • WEP is NOT safe. You need to change to at least WPA.


    Even if that means buying new hardware.


    --


    Barb Bowman


    MS-MVP


    http://www.digitalmediaphile.com


    http://digitalmediaphile.wordpress.com


    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx





    On Thu, 4-Jun-09 13:16:09 GMT, Akins wrote:


    >
    >
    >Hi,
    >
    >I just upgraded to windows 7 and cannot connect to the internet. My router uses WEP encryption and I always get a windows cannot connect error message however if I go tyo my neighbor's home who uses a router with WPA encryption I can get on the net without any problems. I did not have this problem before my upgrade. Any ideas how I can fix this?
    • Proposed as answer by bsm330 Thursday, June 04, 2009 7:28 PM
    • Marked as answer by Adam M MCP Monday, June 15, 2009 4:59 PM
    Thursday, June 04, 2009 4:11 PM
  • First of all is your computer a laptop or desktop; that will rule out compatibility. Next, is that yes wpa is much more secure and some could even argue stable, but what is your WEP encryption set too? I would play with those settings and see what works and doesn't. I like the idea of taking the security off to see if you can connect, but I have never had an incompatable router. Regardless of brand or type the only thing that has to be compatible is the wireless signal ( and that is pretty easy as long as its not A or B).
    Thursday, June 04, 2009 7:53 PM
  • What nic and router are you using?
    Thursday, June 04, 2009 10:50 PM
  • Hi,

    may be this advice is of no use, because you already know.
    I also had the problem, using WEP (which surely is not the safest way) and a pass-phrase.
    After all I recognised, that I had to put in the pass-phrase in hex, not in ascii. I did this, and it worked fine (the hex-code of my pass-phrase I could see in the router-software).

    Best Regards
    Axel
    • Marked as answer by Adam M MCP Monday, June 15, 2009 4:58 PM
    Friday, June 05, 2009 8:10 AM
  • So far, not a single answer to the simple question.  Do any of you bother to READ the question, or do you just spout your own advice as a puppet?  The question was: HOW TO ENABLE WEP IN WINDOWS 7. I have been an MCSE since 1997, and I believe you should ANSWER the question.  The question was not: Is WEP a safe protocol to use? MANY legacy devices use WEP exclusively, and a user does not need to hear that YOU think WEP is unsafe.  The user was asking for your KNOWLEDGE on how to connect legacy devices to Wi-Fi under windows 7 settings.  The user did not as for your OPINION of the connection they have/NEED to use.
    Thursday, June 03, 2010 3:20 AM
  • So far, not a single answer to the simple question.  Do any of you bother to READ the question, or do you just spout your own advice as a puppet?  The question was: HOW TO ENABLE WEP IN WINDOWS 7. I have been an MCSE since 1997, and I believe you should ANSWER the question.  The question was not: Is WEP a safe protocol to use? MANY legacy devices use WEP exclusively, and a user does not need to hear that YOU think WEP is unsafe.  The user was asking for your KNOWLEDGE on how to connect legacy devices to Wi-Fi under windows 7 settings.  The user did not as for your OPINION of the connection they have/NEED to use.

    I was the first to reply and I think I offered a few suggestions without mentioning the insecurity of WEP.
    Thursday, June 03, 2010 7:22 AM
  • actually, if you have certain N wireless NICs, they will not connect using WEP
    as support is not in the drivers. There are some Intel NICs for example. WEP was
    made optional in the final 802.11n specification. And some users do not know how
    unsafe WEP is. Most people would like the choice of securing their networks
    properly. Most MCSE's I know consider security to be important. YMMV.
     
    On Thu, 3 Jun 2010 03:20:05 +0000, Fademan wrote:
     
    >So far, not a single answer to the simple question. Do any of you bother to READ the question, or do you just spout your own advice as a puppet? The question was: HOW TO ENABLE WEP IN WINDOWS 7. I have been an MCSE since 1997, and I believe you should ANSWER the question. The question was not: Is WEP a safe protocol to use? MANY legacy devices use WEP exclusively, and a user does not need to hear that YOU think WEP is unsafe. The user was asking for your KNOWLEDGE on how to connect legacy devices to Wi-Fi under windows 7 settings. The user did not as for your OPINION of the connection they have/NEED to use.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Thursday, June 03, 2010 9:15 AM
  • Akins,

      This is an annoying problem, but you can enable WEP on Windows 7. I am amazed you can connect to open services, but not a WEP network... 

      Windows tries to protect you from connecting to the WEP access point by not letting it happen automatically, or asking for your password like it used to with other systems.  You have to manually build the network profile.  Assuming you just upgraded your pc, thus you know the laptop is compatible with the Access point, otherwise you may have other issues.

    Open the network and Sharing Center.

    Select "Set up a new connection or Network"

    Select "Manually connect to a wireless network"

    Enter Network name-  this is case sensitive.

    Save.

    Now the problem you are likely having:

     Ether choose the change settings or find the network profile you just created under Manage Wireless Networks, and open it up.

      On the "Security tab" you will see Security Type is  "No authentication (Open)".  You likely have to set it to "Shared".  Now you have to re-enter your security key.

     

    There may be a way around this more directly, but since you cannot choose shared key on the original setup, you are out of luck.

     

    I hope this works, and I really hope this is not the way microsoft really designed this functionality...

     

    I agree with the others, upgrade your device or reconfigure device for more security.  I hope my response actually helped you and others get through your problem, not just directing you to go by more hardware.

     

     

     

    • Proposed as answer by dr shoib Sunday, December 09, 2012 5:42 PM
    Thursday, July 01, 2010 6:31 PM
  • I Had the same problem and this is what I did on 01 AUG 2010:

     

    1. I accessed my router by using a wired connection.

    2. I went to administration part

    3. Under administration there was a choice for "Authentication and Encryption"

    4. I click on "Authentication and Encryption"

    5. It gave me a choice to disable security under that. 

    6. I disabled security and was able to connect to my router wirelessly.

    7. After I connected wirelessly, I accessed my rourter and re enabled security.

    8. I rebooted the computer (took out the cat5 cable) and it always connected to the wireless WEP connection with no problem.

     

    Hope that helps you

    Sunday, August 01, 2010 7:11 PM
  • the issue with your solution is that WEP is not safe. WPA2-AES is the
    recommended encryption type.
     
    On Sun, 1 Aug 2010 19:11:23 +0000, kambiz33 wrote:
     
    > I rebooted the computer (took out the cat5 cable) and it always connected to the wireless WEP connection with no problem.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Monday, August 02, 2010 10:05 AM
  • Dear Barb

    I regular this forum for tech support for annoying issues and I am personally well aware of the issues with WEP security. At times I am still required to connect to WEP connections, that it is outside of my control to change. Your repetitive and unhelpful post only deteriorate the forum and make it less useful. Are you aware that this is one of the first things one comes across when googling for WEP issues in windows 7? But all people see if you spouting the problems with it, once is understandable but I believe you posted this AT LEAST 3 times, this will only reduce traffic to the website as people do not for help but only people telling them they are wrong. I hope you seek to improve this behavior. 

    Monday, December 27, 2010 9:55 AM
  • Not everyone is personally aware of the WEP risks. And not everyone who visits
    here is an expert on wireless networking. Everyone is entitled to an opinion,
    though.
     
    On Mon, 27 Dec 2010 09:55:36 +0000, DigiWin wrote:
     
    >I regular this forum for tech support for annoying issues and I am personally well aware of the issues with WEP security
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Monday, December 27, 2010 11:58 AM
  • I cannot help you but I can say that the responses so far have been depressing. I have the same issues as you do. When I take my laptop somewhere it can see the network O.K. but when I try to connect it just fails with no error message. Assuming that the problem is that Windows 7 does not like WEP and therefore you may not connect is just so crazy I cannot believe it. Here is a link which shows how to connect. I have not tried it but I may do if I can find no alternative. I would much prefer if windows 7 just came back and said "this is WEP do you wish to continue ?" This big brother approach just does not seem right. Regards Tom

    http://windows.microsoft.com/en-US/windows7/Set-up-a-security-key-for-a-wireless-network
    • Edited by TomAtSignet Thursday, May 05, 2011 11:12 PM Add link
    Thursday, May 05, 2011 11:10 PM
  • Man on the Moon is 100% correct on this one.  I've seen this several times before.  For whatever reason Vista and Windows7 both don't seem to setup WEP connections properly.  Once you run through the manual procedure listed above (take note, as mentioned above the SSID is CaSe SENSitive), you'll have to manaully edit the connection, click the security tab, and change it from "open" to "share" and retype in your wireless key

    The responses above (especially from Barb 3 times) are simply People intentionally trying to not help you, and there should be a way to flag them as such.  Just because you believe WEP shouldn't be used, you don't hijack someone's thread to explain that.  Give them advice on how to fix their problem, and THEN, if you feel the need, express to them the benefits of doing it a different way, and how to do it.

    Hopefully after 2 years, Akins has been able to fix their problem.

    Tim

    Thursday, July 21, 2011 1:15 AM
  • I have to disagree. Helping someone configure WEP, especially someone who does
    not know how risky WEP is, is like telling them to leave the key to their car in
    the ignition and the car windows open.
     
    On Thu, 21 Jul 2011 01:15:55 +0000, pattontj wrote:
     
    >The responses above (especially from Barb 3 times) are simply People intentionally trying to not help you, and there should be a way to flag them as such.  Just because you believe WEP shouldn't be used, you don't hijack someone's thread to explain that.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Thursday, July 21, 2011 10:53 AM
  • I have to disagree. Helping someone configure WEP, especially someone who does
    not know how risky WEP is, is like telling them to leave the key to their car in
    the ignition and the car windows open.
     
    On Thu, 21 Jul 2011 01:15:55 +0000, pattontj wrote:
     
    >The responses above (especially from Barb 3 times) are simply People intentionally trying to not help you, and there should be a way to flag them as such.  Just because you believe WEP shouldn't be used, you don't hijack someone's thread to explain that.
     

    Barb Bowman

    http://www.digitalmediaphile.com


    WOW.  Can somebody say "One Trick Pony." Does this forum allow for the possibility of putting somebody on ignore status, because Ms. Bowman certainly deserves to be shut down.
    Saturday, July 23, 2011 6:52 PM
  • I would agree, her comments are far from helpful. Once is enough, but to keep spamming 'WEP is bad' is far from helpful.
    Thursday, July 28, 2011 9:51 PM
  • Thank you to all that have given a reply to this questions it has helped me a lot.

    To Barb I was given 2 brand new netgear N300 wireless router by a company. One will be used as a repeater to connect between buildings. Once I put the routers into repeater mode I can only use WEP encryption as this is all the router will allow me to use. So even with a brand new router I have to use WEP. There is also the fact that some people do not make the thousands of dollars as you must do to go out and buy new hardware just because there is better models out there. Be happy that some encryption is better than none at all. 

     

     

    Friday, July 29, 2011 2:08 PM
  • I certainly understand the economics of upgrading hardware. Too bad the N300
    can't operate in Access Point Client mode (as that would support WPA). Running
    connectivity between buildings is a whole other ballgame. If you elect to think
    about spending a small amount of money, you might consider getting a D-Link DAP
    1522 (about $66 from Amazon). You might be able configure THAT as an access
    point client to the first WNR2000 in the main building, depending on the
    hardware REV of that device. Then, with the 1522 in building 2, you'd plug the
    second Netgear into one of the ports of that 1522. There are more ports on the
    1522 so if you had wired clients in building 2, you could hard wire them, etc.
    You would be able to secure the network with WPA2 with that kind of set up. The
    DAP-1522 or 1555 is what I recommend because I personally use them.
     
    As a generality, there are several ISPs in the US that offer free, or nearly
    free wireless routers (or combo modem/router devices which I look at less
    favorably). In the US, you might be able to get a free wireless router from the
    FCC (with a couple of strings) http://www.testmyisp.com/index.php but I don't
    know how many they have left. I did some work with the Sam Knows project a
    couple of years ago.. Comcast for sure offers a free wireless router (for $10
     
    On Fri, 29 Jul 2011 14:08:44 +0000, mogubytes wrote:
     
    >To Barb I was given 2 brand new netgear N300 wireless router by a company. One will be used as a repeater to connect between buildings. Once I put the routers into repeater mode I can only use WEP encryption as this is all the router will allow me to use. So even with a brand new router I have to use WEP. There is also the fact that some people do not make the thousands of dollars as you must do to go out and buy new hardware just because there is better models out there. Be happy that some encryption is better than none at all. 
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Monday, August 01, 2011 4:05 PM
  • I, too have need to connect regularly to WEP routers.  I am I.T. Director of an international software company and am fully aware (so please don't warn me a million times) that WEP is insecure.  Having said that, I must connect to WEP - really, it's nobody's business WHY, I just have to and there is no security problem.

    I followed the advise of Man On The Moon and connected just fine:

     

    Open the network and Sharing Center.
     
    Select "Set up a new connection or Network"
     
    Select "Manually connect to a wireless network"
     
    Enter Network name-  this is case sensitive.
     
    Save.
     
    Now the problem you are likely having:
     
     Ether choose the change settings or find the network profile you just created under Manage Wireless Networks, and open it up.
     
      On the "Security tab" you will see Security Type is  "No authentication (Open)".  You likely have to set it to "Shared".  Now you have to re-enter your security key.
    

     

     

    Thanks Man On The Moon  you have saved me a lot of time.  Much appreciated.


    • Edited by frozenjim Friday, September 09, 2011 10:37 AM My bad... Man On The Moon was actually 100% correct. ;-)
    Friday, September 09, 2011 10:36 AM
  • Thanks for your help!!!
    Saturday, October 22, 2011 12:53 AM
  • "Buy new stuff cuz Microsoft said so" isn't much of an answer. I don't really care what the very bestest thing is - I care that I have 4 devices in the house,and on WPA nothing worked. On WEP everything works except the Windows 7 laptop. I'm so fed up with this answer showing up in every thread I could scream! I have one old laptop and a brand new Blu Ray and a brand new Xbox that only connected on WEP. It's enough that we're planning to move to Mac when we end up replacing the computers.
    Saturday, December 17, 2011 12:47 AM
  • The problem is caused by incompatible driver. Method to resolve as follows:

    1. Right Click on Computer and Select properties
    2. Select/Click Device Manager
    3. Expand the Network Adapters
    4. Right Click on the Wireless Adapter and select Update Driver Software…
    5. Select/Click Browse my computer for driver software (Locate and install driver software manually.)
    6. Select/Click Let me pick from a list of device drivers from my computer  (This list will show installed driver software compatible with the device, and all diver software in the same category as the device)
    7. Select/Click Have Disk
    8. Browse for the compatible Driver (Either on your original driver CD,  download from internet Downloads Folder, or your prefer location such as Desktop)
    9. Select/Click/Open on the Driver and to install

    After the successful l driver installation, connect the internet by using the wireless adapter.  Occasionally, you may encounter the problem such as connected to network but without access to internet.  Just go to Control Panel/Network and Sharing Center and Click on the “Red X” between the Network and Internet to auto rectify the connection problem.

    Cheers! Hope this is helpful.

    Tony Koay

    Saturday, May 05, 2012 2:26 AM
  • Actually, I found just the opposite - it was "Shared" and I had to change it to  "No authentication (Open)".   

    ( "Encryption Type" = "WEP" ; I still need the security key.  I have an old dlink router and it does not support WPA )
    Saturday, June 16, 2012 8:12 PM