none
Windows 7: I E. 8 Crashes & Locks up: "Server Busy" Error HELP!

    Question

  • Greetings:

    I have been working a problem that just appeared with our companies upgrade to Windows 7: We use a product called MicroFocus Test Partner to test our various applications availablty daily: However, since the upgrade to windows 7 the testing has failed consistantly especially if the system takes a long time for example to pull up an image from a file server: The system will error with "Server Busy": Then it locks up everything until you kill the exe of the software TestPartner.

    When the IE 8 Locks up with Server Busy: You can not release it via 'Switch to' or 'Retry' or any other window function: You must kill the TP exe to clear the error:

    This is what we have done so far, but with no success:

    - Modified internal dll code within software (renamed dll that looks for java to .OLD.dll)

    - Modified HKCU/software/Micro/TestPartner/Database/DeprecatedODBCTimeout key from 600 to 9999

    -Modified internal Test Partner software utility sub function to set attachtimes from 200 to 300 ( 5 mins) before error

    However, this did not help: The system still hangs when this error comes up and will not release the 'deadlocked' process.

    Can you help?  This problem has been going on too long.

    Jeff L

     



    • Moved by Carey FrischMVP, Moderator Wednesday, June 29, 2011 9:15 PM Moved to more appropriate forum category (From:Windows Vista Service Packs/Windows Server 2008 Service Packs)
    Wednesday, June 29, 2011 5:16 PM

Answers

  • Hi,

     

    I would like to suggest you check which version you are currently using, based on my research, only TestPartner 6.3 can support Windows 7 system:

     

    TestPartner Documentation

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    You could try to update to the latest version to check the result. If this issue persists, it is recommended to contact the Micro Focus for further help:

     

    SupportLine Global Support Numbers - Micro Focus

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, July 01, 2011 8:15 AM
    Moderator

All replies

  • Hi,

     

    I would like to suggest you check which version you are currently using, based on my research, only TestPartner 6.3 can support Windows 7 system:

     

    TestPartner Documentation

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    You could try to update to the latest version to check the result. If this issue persists, it is recommended to contact the Micro Focus for further help:

     

    SupportLine Global Support Numbers - Micro Focus

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, July 01, 2011 8:15 AM
    Moderator
  • Greetings,

    Thanks Alex for your reply: Here is what I have:

    -Windows 7 SP1

    -TestPartner 6.3.0 Build 185

    - Modified internal dll code within software (renamed dll that looks for java to .OLD.dll)

    - Modified HKCU/software/Micro/TestPartner/Database/DeprecatedODBCTimeout key from 600 to 9999

    - Modified internal Test Partner software utility sub function to set attachtimes from 200 to 300 ( 5 mins) before error

    - cv patch installed for memory leak

    As of this writing still getting IE 'Server Busy' errors, TestPartner & Compuware are gathering to work the issue out: This is also effecting other clients and internally.

    Thanks

     

     


    Jeff Laatsch
    Wednesday, July 06, 2011 8:50 PM