none
WDS and TFTP open Timeout Error - TFTP Service running?

    Question

  • I am receiving a TFTP Open Timeout Error while trying to PXE boot with WDS running. It has worked in the past. I began to troubleshoot by looking at the error logs, and I was getting Error ID 722, unable to open UDP port on my interface.

    So I stopped the WDS service and ran NETSTAT -AO and it showed that PID 1742 was using port 69, and that PID was assigned to TFTP service. I don't recall installing that service specifically, but if I stop the service and restart WDS, everything seems to work fine, until I reboot.

    The question is, what could the separate TFTP service be running under? I can't find anything in my server features or roles that are obviously the source. Any ideas on where I could look?

     

    Thanks,

    Brandon

    Monday, August 29, 2011 1:52 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Please check if the TFTP boot server host IP is wrong in DHCP server first.

     

    Recheck your DNS settings using Configure the Socket Pool

    http://technet.microsoft.com/en-us/library/ee649174(WS.10).aspx

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, August 30, 2011 8:40 AM
  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, September 05, 2011 9:00 AM
  • My apologies for the delay.

     

    As stated in the original post, it works fine when I disable the TFTP service before re-starting WDS.  It's fully functional, in fact.  But if I restart the server, and WDS tries to automatically start, it encounters the errors mentioned above in the event logs for the role, and when any device tries to PXE boot.

    The question is/was: Is the TFTP service something that can/should be removed, and is there any idea what might have caused it to be installed in the first place. The OS is a fairly new install, and I have put relatively little on it aside from WDS. In the meantime, I'm just disabling TFTP service so that WDS functions as it should.

     

    Thanks,

     

    Brandon

    Monday, September 05, 2011 3:35 PM
  • Hi,

    I believe it can be disabled. To disable TFTP, edit %Systemroot/System32/Drivers/Etc/Services by changing the line "tftp 69/udp" to "tftp 0/udp". This disables the TFTP client.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Proposed as answer by Escovan Tuesday, June 12, 2012 7:33 AM
    Wednesday, September 07, 2011 7:51 AM
  • Hi,

    Any update?

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, September 09, 2011 3:20 AM