none
Windows Wireless Profile deleting itself!

    Question

  • We've got a weird problem on our laptops... We are using Windows to manage the wireless connections and it keeps playing up.

    - On some occasions, the profile is still there but forgets ALL settings you have specified (reverts to WPA instead of WPA2, for example)

    - On most occassions, it deletes the profile altogether!

    - If you connect to another Wifi network (e.g. at home) it deletes the corporate profile and creates its own new one for your home Wifi!

    Anyone else experienced this? Got a fix?

    Our setup: Windows 7 Professional x86, Server 2008 R2 Domain and Cisco network infrastructure.

    Tuesday, February 21, 2012 11:48 AM

Answers

All replies

  • Hi,

    Please test the issue via the below steps first.

    1. Please open search, type “services.msc” and scroll down to “WLAN AutoConfig”, stop it.

    2. Locate to “C:\ProgramData\Microsoft\Wlansvc\”. Delete everything in this folder except “profiles” folder. Then, delete all in “profiles” folder except “interfaces”. Delete everything in the “interfaces” folder.

    3. Repeat the step1 to restart “WLAN AutoConfig” service.

    4. Now reboot your system to test the issue again.

    If the issue persists, I suspect it is related to the settings of Domain environment. I suggest using one laptop to test the issue in non-Domain environment and clean bootmode.

    If the wireless profile can work properly in non-Domain environment, you may need to check the domain configurations.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, February 22, 2012 10:09 AM
    Moderator
  • I have a laptop user that has the same problem.

    Dell M4600 Laptop - New
    16Gb Ram
    Win 7 64

    Wireless profiles are behaving abnormally on a brand new Dell M4600. We have two wireless networks within our work environment. We have manually created the connection profiles for each wireless network. User has entered information for his home network as well. The next day upon arriving at work, he has to enter the password to connect to either network. He is not using our domain at work either.

    If profiles are retained he cannot connect automatically even though it is checked.
    Sometimes the profiles disappear, sometimes they don't. Either way, he has to manually enter the connect password. I have tried the following recommended solution, and it did not work.

    Navigate to
    "C:\ProgramData\Microsoft\Wlansvc\ delete everything in this folder  leaving only a folder called "profiles" delete everything in the "profiles" folder except for a folder called "interfaces" delete everything in the "interfaces" folder)
    Restart "wlan auto config" connect to your wireless network, enter
    your passkey, (ensure the connect automaticly box is checked)
     
    Restart your computer job done, your computer will now connect to your wireless network automaticly on boot.

    Ideas?

    Thanks in advance.


    • Edited by Curious2k3 Wednesday, February 22, 2012 11:40 AM
    Wednesday, February 22, 2012 11:36 AM
  • Hi,

    Please test the issue via the below steps first.

    1. Please open search, type “services.msc” and scroll down to “WLAN AutoConfig”, stop it.

    2. Locate to “C:\ProgramData\Microsoft\Wlansvc\”. Delete everything in this folder except “profiles” folder. Then, delete all in “profiles” folder except “interfaces”. Delete everything in the “interfaces” folder.

    3. Repeat the step1 to restart “WLAN AutoConfig” service.

    4. Now reboot your system to test the issue again.

    If the issue persists, I suspect it is related to the settings of Domain environment. I suggest using one laptop to test the issue in non-Domain environment and clean bootmode.

    If the wireless profile can work properly in non-Domain environment, you may need to check the domain configurations.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    thank you for your reply, i will give this a go and feed back my results.

    Thursday, February 23, 2012 2:47 PM
  • The recommended fix above did not resolve the issue for me as I mentioned  before. I read a forum post elsewhere that stated to try the following. I have not been able to verify this yet.

    Try this:

    run msconfig (start > run (or just type into the "Search programs and files" field above the windows orb) > msconfig)
     
    this brings up the System Configuration dialog box
     
    click the Startup tab
     
    scroll to find your wifi adapter's startup program (in original posters case it was NETGEAR)
     
    uncheck the box next to this startup item.
     

    Let me know if it resolves the issue.

    • Edited by Curious2k3 Monday, February 27, 2012 3:23 PM
    Monday, February 27, 2012 3:20 PM
  • Hi,

    Please test the issue via the below steps first.

    1. Please open search, type “services.msc” and scroll down to “WLAN AutoConfig”, stop it.

    2. Locate to “C:\ProgramData\Microsoft\Wlansvc\”. Delete everything in this folder except “profiles” folder. Then, delete all in “profiles” folder except “interfaces”. Delete everything in the “interfaces” folder.

    3. Repeat the step1 to restart “WLAN AutoConfig” service.

    4. Now reboot your system to test the issue again.

    If the issue persists, I suspect it is related to the settings of Domain environment. I suggest using one laptop to test the issue in non-Domain environment and clean bootmode.

    If the wireless profile can work properly in non-Domain environment, you may need to check the domain configurations.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    thank you for your reply, i will give this a go and feed back my results.

    Hi all,

    The recommendations didn't fix my issue. Also, the suggestion to disable the startup program in msconfig didn't either (it wouldn't really be a viable fix anyway).

    From this though, it looks as if the wireless profiles are just XML files. Is this correct? I'm not missing anything am I?

    I'm now thinking in terms of mass deployment to users. I would only have to copy the XML file into the WLANSVC folder and they will have the network connectivity, correct? Furthermore, locking that down with permissions should stop it been overwritten? I may try that for a start.

    EDIT: Nevermind, that failed miserably!


    • Edited by TheMagic89 Tuesday, February 28, 2012 11:17 AM
    Tuesday, February 28, 2012 11:14 AM
  •  

    Hi,

    Copy the XML file cannot be work. Please understand that every network card has a unique MAC address. The MAC address will be record in wireless profile, the XML file.

    As you want to deploy the wireless configuration, we can detect the wireless devices reference the following thread.

    http://social.technet.microsoft.com/Forums/en/mdt/thread/f59ef79c-e699-46d7-bb49-7c5a5338a3cd

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, March 02, 2012 9:01 AM
    Moderator
  • Ok so we are having the same issue.

    Most of our problems occur after a bad shutdown or boot up.  (I.e. hold power button in or computer lost power before completing the set-up.

    any thought solutions on this?

    Friday, June 01, 2012 11:54 PM
  • Any Solution so far?  we are having the same problem. I can manualy deploy the wireless profiles but thats a pain i want to fix group policy
    Friday, June 01, 2012 11:55 PM
  • After speaking with the user this morning he stated the following workaround has resolved the above issues. Although it is not clearly understood how.

    1. Make sure wireless access is off

    2. Turn the computer on and log into Windows

    3. Turn wireless access on

    4. Profiles are remembered and working

    Unknown why this seems to work although he stated it does.

    User name change to InfoTech2000 from Curious2k3 due to Outlook dot com issues.

    • Edited by InfoTech2000 Tuesday, March 05, 2013 4:19 PM Reflect name change
    • Proposed as answer by InfoTech2000 Tuesday, March 05, 2013 4:22 PM
    Tuesday, March 05, 2013 4:18 PM