none
Windows 7 freeze by Windows Live Messenger 2009

    Question

  • Hello. I test Windows 7. But after I install Windows Live Messenger 2009 Windows 7 freeze.
     

    My english is not good
    People who speak Dutch its welcome
    Sunday, January 11, 2009 12:23 PM

Answers

  • Solution to the problem of freezing with WLM 2009 (reasonable workaround for now)

    i can run WLM 2009 disabling Hardware Acceleration of Video Card.

    Disable Hardware Acceleration and run in compatibility with Vista, for the icon in taskbar too;)

    This is a solution for the problem to the Freeze of the computer, obviously this solution is temporary.

    Solution:

    Disable Hardware Acceleration and run in compatibility with Vista.

    For Disable Hardware Acceleration, Need to right click the desktop, select Change Resolution, click on the "Advanced" link, go to the Troubleshooting tab, and move the slider left to the third notch.


    This is no longer as a New Post, and if any topic Mod may leave as well, since it is very helpful to many who have the same problem, and this may solve other bugs.


    thanks to
    Gus Perez, who also spoke on the solution
    In My Own Summer The Shade is A Tool!!
    • Proposed as answer by MessiahX Wednesday, January 14, 2009 3:39 PM
    • Marked as answer by Alex T JrModerator Friday, January 16, 2009 5:31 AM
    Wednesday, January 14, 2009 3:39 PM
  •  i can run WLM 2009 disabling Hardware Acceleration of Video Card.

    here a link how to disable hardware acceleration: http://www.deskshare.com/Resources/articles/dmc_turnoffhardwareacceleration.aspx

    Disable Hardware Acceleration and run in compatibility with XP SP2, for the icon in taskbar too;)

    This is my solution for the problem to the Freeze of the computer, this is temporal solution obviusly.

    again sorry for my English ;)
    In My Own Summer The Shade is A Tool!!
    Tuesday, January 13, 2009 1:06 AM

All replies

  • i have the same problem, if you can fix, help me please ;)
    Thanks!
    In My Own Summer The Shade is A Tool!!
    Sunday, January 11, 2009 7:39 PM
  • Hello,

    I'm using continuosly Windows Live Messenger 2009 with no issues so far. Only freezes with Messenger?
    W7 Beta running on an AMD Semprom 3200+ (1800Mhz) with 2 Gbs of RAM and a built-in Nvidia 6100 VGA, and mate, it runs like a charm!
    Sunday, January 11, 2009 7:50 PM
  • I'm actually seeing this as well but only on one of the three Windows 7 installs I've done so far. To get around it, boot up in Safe Mode (F8 at boot time), open regedit, go under HKCU/Software/Microsoft/Windows/CurrentVersion/Run and get rid of the messenger key (or modify it so it doesn't actually launch it).

    Would love to know if anyone has a way to actually have it work. It currently hard locks Windows seconds after Messenger starts forcing me to physically shut the machine down.
    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Monday, January 12, 2009 2:16 AM
  • Try running WLM2009 in Compatibility Mode of Windows Vista.
    Monday, January 12, 2009 2:20 AM
  • Note that my suggestion to remove the Run key was only so that Windows doesn't lock up immediately at startup. It doesn't actually fix the freeze that seems to happen whenever Messenger runs.
    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Monday, January 12, 2009 2:22 AM
  • Worth a try but compatibility mode didn't work for me. The freezing continued. I tried Vista and XP SP2 modes as well as some of the other checkboxes there are as options. None seemed to the trick unfortunately.
    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Monday, January 12, 2009 2:28 AM
  • Hi, sorry if u think im trying to butt in with answers. I edited the post because it look like an *attack*. And oh, i didnt notice u were a MSFT employee.
    Monday, January 12, 2009 2:33 AM
  • No worries, I thought your suggestion was definitely a good idea, it just unfortunately didn't work. Thanks for suggesting it and I never took it as an attack. :)

    I do work at MS but in a completely unrelated area. Hoping someone does help us out though or if it's an actual bug (looking likely at this point) that it gets understood so it's fixed in the future.

    Thanks.
    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Monday, January 12, 2009 2:35 AM
  • I was also trying to webcam earlier today with windows live messenger 2009 on windows 7 beta and it just froze up and would not work.  I switched to my vista partition and used WLM 2008 and it worked fine to webcam.  Don't know if it's a windows 7 issue or a WLM 2009 issue because I had installed WLM 2009 on my vista box and xp laptop and WLM 2009 didn't webcam on my vista box either....didn't try it on my laptop with xp on it.
    Monday, January 12, 2009 3:06 AM
  • For those of you that are having problems... do you all have a webcam in and on? I've been running win7 and wlm2k9 for quite some time and haven't encountered any issues. I don't use a webcam so I was checking to see if the issue was related to the msgr interaction with the hw or the webcam features of wlm specificallyl

    /bR

    |brianReisman
    • Proposed as answer by Lemuel C Tuesday, February 02, 2010 7:39 AM
    Monday, January 12, 2009 4:37 AM
  • yes..using a "logitech quickcam communicate stx" model.
    Monday, January 12, 2009 5:22 AM
  • I've installed Windows 7 on three laptops so far (a MacBook Pro, a Compaq Presario, and a Toshiba Satellite). The Toshiba is the one this is happening on, WLM 2009 is working fine on the other two. It's a Toshiba Satellite M45-S335.
    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Monday, January 12, 2009 5:35 AM
  • Hello, If I start up in safe mode, then I can use WLM 2009 best without problems. Stopper problem is only at WLM 2009
    Monday, January 12, 2009 6:19 AM
  • I Using the Messenger Miranda IM, sometimes it will be broken with win7, but i think it will be better with the next Version
    Monday, January 12, 2009 6:30 AM
  • I'm having the same issues with WLM 2009 and Windows 7. I don't have a webcam, but I do have a TV card that in XP WLM recognizes as webcam, it can be the same issue. Compatibility mode also don't work. It could be an issue with the webcam integration in windows 7.
    Monday, January 12, 2009 12:25 PM
  • Gus Perez said:

    I've installed Windows 7 on three laptops so far (a MacBook Pro, a Compaq Presario, and a Toshiba Satellite). The Toshiba is the one this is happening on, WLM 2009 is working fine on the other two. It's a Toshiba Satellite M45-S335.


    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez


    I have a toshiba satellite A135-S4467 as well and I have this problem!

    I also have a logitech cam which was installed in windows vista and i am guessing the installation carried over to windows 7 with my update but havent used it yet and its not plugged in
    Monday, January 12, 2009 4:19 PM
  • I have the same issue that I posted in a different thread. I was able to stop the freeze up by running the application in 256 colors. Obviously this is a work around to prevent the lock ups, but you can't really use messenger (or your system in my opionion) in 256 colors.  I'm quite certain due to thsi work around that it is related to video card drivers or something similar. I can run messenger 2009 in vista ultimate on the same machine without issue...
    Monday, January 12, 2009 5:58 PM
  • I have the same issue where the latest build of Live Messenger hard locks my display/input (the PC seems to be doing something in the background). This is on a Lenovo X41 Tablet with Intel 915 GM intergrated graphics. No such issue was present all the way up to Vista SP2 so far on the same hardware. Here are my data points:

    • It freezes up anytime Messenger is run, including right after installing Live Essentials, on a subsequent reboot  and logon (since it's now set to auto run), and whenever IE visits any live.com pages that launch the Messenger add-on control.
    • Obviously the quick fix to the immediate problems is to disable the auto startup and the IE add-on.
    • Runs fine in Safe Mode.
    • I haven't tried video in it yet, so no comment on webcam issues.
    • I have found that if I disable hardware video acceleration and then launch Messenger, it runs fine. If I then re-enable acceleration, it seems to keep on running fine as well.
    • The same sort of lockup occurs if I try to run the performance score index on my system, I think the last thing I see before it locks up is an item about evaluating media codec performance. Again, if I turn off video acceleration, the index completes fully.
    • I am wondering if this is some sort of Direct 3D issue given my crappy video card and the fact that Windows Live now installs some sort of Direct 3D package as part of its setup.
    Monday, January 12, 2009 7:21 PM
  •  My details from same problem-

    Fresh install of 7 from beta site.
    Installed MSN messenger from http://download.live.com/?sku=messenger.
    OS froze hard with no ctl-alt-del option and no shut down.
    Hardware power cycle nessesary.
    Restart, logon then freeze.
    Restarted in SafeMode, msconfig and took messenger out of the startup groups.
    Restarted successfully

    Toshiba Portege M200, 2 GB RAM
    Windows Live Messenger Version 2009 (Build 14.0.8050.1202
    In my Control Panel\Programs\Programs and Features I have these installs from the MSN Live install package:
    MS SQL Svr 2005 CE
    MS Sync framwork runtime Native v1
    MS Sync framwork services Native v1
    Windows Live Essentials, Sign-in Assistant, Sync and Upload Tool

    More Details:
    Tried to execute Messenger, OS froze, went to Safe Mode again and there were 2 instances of Messenger. Unchecked new instance and rebooted successfully

    .
    1 minute ago| Report abuse
    Monday, January 12, 2009 8:52 PM
  • Peter Rysavy said:

    I have the same issue where the latest build of Live Messenger hard locks my display/input (the PC seems to be doing something in the background). This is on a Lenovo X41 Tablet with Intel 915 GM intergrated graphics. No such issue was present all the way up to Vista SP2 so far on the same hardware. Here are my data points:

    • It freezes up anytime Messenger is run, including right after installing Live Essentials, on a subsequent reboot  and logon (since it's now set to auto run), and whenever IE visits any live.com pages that launch the Messenger add-on control.
    • Obviously the quick fix to the immediate problems is to disable the auto startup and the IE add-on.
    • Runs fine in Safe Mode.
    • I haven't tried video in it yet, so no comment on webcam issues.
    • I have found that if I disable hardware video acceleration and then launch Messenger, it runs fine. If I then re-enable acceleration, it seems to keep on running fine as well.
    • The same sort of lockup occurs if I try to run the performance score index on my system, I think the last thing I see before it locks up is an item about evaluating media codec performance. Again, if I turn off video acceleration, the index completes fully.
    • I am wondering if this is some sort of Direct 3D issue given my crappy video card and the fact that Windows Live now installs some sort of Direct 3D package as part of its setup.

    hi men, a Question, how i disable the Hardware Acceleration?? I Have the Same Video Card in my Laptop, please how disable acceleration?? Thanks and is someone have it a solution ploease posted.

    Sorry for my english ;)


    In My Own Summer The Shade is A Tool!!
    • Proposed as answer by MessiahX Tuesday, January 13, 2009 1:00 AM
    • Unproposed as answer by Alex T JrModerator Friday, January 16, 2009 5:32 AM
    Tuesday, January 13, 2009 12:07 AM
  •  i can run WLM 2009 disabling Hardware Acceleration of Video Card.

    here a link how to disable hardware acceleration: http://www.deskshare.com/Resources/articles/dmc_turnoffhardwareacceleration.aspx

    Disable Hardware Acceleration and run in compatibility with XP SP2, for the icon in taskbar too;)

    This is my solution for the problem to the Freeze of the computer, this is temporal solution obviusly.

    again sorry for my English ;)
    In My Own Summer The Shade is A Tool!!
    Tuesday, January 13, 2009 1:06 AM
  • Great, this is definitely a reasonable workaround for now. Note that I was able to get it to work fine without completely turning off hardware acceleration on my machine. I just had to set it to the third notch from the left--the one that says the following in its description: "Disable all DirectDraw and Direct3D accelerations, as well as cursor and advanced drawing accelerations. Use this setting to correct severe problems with DirectX accelerated applications."


    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Tuesday, January 13, 2009 4:19 AM
  • Does hardware acceleration have do something with my video card?

    My videocard is verry old.

    I have Messenger in the Compactibily mode on windows xp sp2. This does not work.
    Tuesday, January 13, 2009 6:20 AM
  • Jeffcoboy1, MessiahX suggested the XP SP2 compatibility mode specifically to get the Messenger icon to show up in the tray (though I think Vista compatibility mode works as well for that). It doesn't help with the actual hang/freezing.

    Dropping the hardware acceleration is what seems to be working for everyone so far though and it does have to do with your video "hardware." I don't have access to a Win7 box now so I can't describe the exact location of where you can make the change but, roughly, you need to right click the desktop, select Change Resolution, click on the "Advanced" link, go to the Troubleshooting tab, and move the slider left to the third notch.

    That should hopefully do the trick for you.
    Gus Perez -- Dev Lead -- Windows Azure Tools for Visual Studio -- Microsoft -- http://blogs.msdn.com/gusperez
    Tuesday, January 13, 2009 8:11 PM
  • I think this is really an issue with the drivers or with the card itself. Let me see:
    - I can't run the performance index, it says something about drivers,
    - I can't run any TV app, just freezes like the messenger issue,
    - Windows Chess game freezes windows 7.
    So I conclude that anything that requires Direct3D or DirectShow freezes my windows 7.

    I know that my card doesn't meet the "minimum required" specs, but everything works. Dxdiag.exe says Direct3D enabled and everything else is enabled. My card is an ATI RADEON 9200 (AGP), hopping to change it to ATI HD3450 (AGP) fast.

    [EDIT] Disabling Direct3D and DirectDraw did the trick. Now, I'm positive it's an issue with the drivers .[/EDIT]
    • Edited by Trop Wednesday, January 14, 2009 1:38 AM
    Wednesday, January 14, 2009 12:56 AM
  • I got the webcam to work,,,kind of....I was able to connect in a webcam session with my webcam functioning on the widows 7 box, and only a mic with no webcam on an xp laptop.  The audio chat was working fine, and I could see the video on my xp laptop that was being captured on the windows 7 box....don't know what that means as far as an answer to the issue, but maybe someone on here can take that additional info and figure out the problem.
    Wednesday, January 14, 2009 1:22 AM
  • I have reinstall XP because dualboot not works with Windows 7 and because WLM 2009 not working.

    Averybody thx for de help.
    Wednesday, January 14, 2009 6:16 AM
  • Hello,

    I have the same issue on a HP TC4200, which is rather old and does not have a webcam attached to it (yet)

    Hans Hinnekint
    Wednesday, January 14, 2009 10:14 AM
  • Solution to the problem of freezing with WLM 2009 (reasonable workaround for now)

    i can run WLM 2009 disabling Hardware Acceleration of Video Card.

    Disable Hardware Acceleration and run in compatibility with Vista, for the icon in taskbar too;)

    This is a solution for the problem to the Freeze of the computer, obviously this solution is temporary.

    Solution:

    Disable Hardware Acceleration and run in compatibility with Vista.

    For Disable Hardware Acceleration, Need to right click the desktop, select Change Resolution, click on the "Advanced" link, go to the Troubleshooting tab, and move the slider left to the third notch.


    This is no longer as a New Post, and if any topic Mod may leave as well, since it is very helpful to many who have the same problem, and this may solve other bugs.


    thanks to
    Gus Perez, who also spoke on the solution
    In My Own Summer The Shade is A Tool!!
    • Proposed as answer by MessiahX Wednesday, January 14, 2009 3:39 PM
    • Marked as answer by Alex T JrModerator Friday, January 16, 2009 5:31 AM
    Wednesday, January 14, 2009 3:39 PM
  • For NVIDIA people i have found the following to work using the NVIDIA control panel (Right click on desktop and go to NVIDIA Control Panel).

    Click on the Manage 3d Settings link on the left menu and then on the right click the Program Settings tab.

    Click the Add button and navigate to where you have installed Windows Live Messenger 2009 and select msnmsgr.exe.

    I used the following settings:

    Anisotropic filtering - OFF
    Antialiasing - Gamma Correction - OFF
    Antialiasing - Mode - OFF
    Conformant texture clamp - OFF
    Texture filtering - Anisotropic sample optimisation - OFF
    Texture filtering - Quality - PERFORMANCE

    Then hit apply.

    I have used those settings (after much testing) and found that using them have stopped WLM9 from crashing and best thing of all, these settings will only apply to WLM9.

    Hope this helps.
    Saturday, January 17, 2009 8:45 PM
  • no problems with Asus M51VA - HD 3650
    Saturday, January 17, 2009 9:48 PM
  • dont know if this has been mentioned BUT has anyone tried to change the applications compatability mode? I would try Vista and see. I myself have not had these problems though
    zero061099
    Saturday, January 17, 2009 11:03 PM
  • Somebody has already suggested this in Page 1, but this merely place the icon in the "right" position in the tasktray.

    Regards
    Sunday, January 18, 2009 8:54 AM
  • Yes!!!

    The solution from Gus was the solution for my problem

    Thanks Gus.
    Sunday, January 18, 2009 1:22 PM
  • I tried installing the English version (instead of the Danish) and it  seems to be working just fine now.
    Sunday, January 18, 2009 4:37 PM
  • This is strange i've installed Windows 7 And windows9 pack so far windows live mail works but ran that in Vista mode as it was missing the hide me when mimimized. Windows Live Messenger have had no problems not once froze on me and i'm using ATI 2400HD card. The only thing that is getting on my nerves is when you mimimze it stays on taskbar not in system tray like it use to.
    Sunday, January 18, 2009 5:15 PM
  • It'll do that if you run it in Windows Vista compatibility mode.
    Sunday, January 18, 2009 5:21 PM
  • Acer Aspire 5000 here,,,
    I had the same issues, all I did was disable hardware acceleration and change the compatibility to XPSP2 and now it works.
    Good workaround.
    Tuesday, January 20, 2009 10:25 PM
  • I was getting the Blue Screen when I tried to open my TV Tuner app (MSI TV@anywhere Plus) when WLM was running. I changed the compatibility mode to Vista and it fixed the problem. Thanks for the suggestion.

     

    Friday, January 23, 2009 6:35 AM
  • I have a bluescreen as i open SUPERAntispyware

     

     

     

    sorry for my bad english

    Friday, January 23, 2009 3:14 PM
  • another data point
    Dell Inspiron 8100 (laptop)
    in order to get Windows live messenger to not lock up the keyboard, I need to 'disable all Direct Draw & Direct 3d, cursor & advanced drawing accelerators'.
    I do not need to run in any 'compatibility mode'

    Video card/driver is:
    Dell 8100

    Device type: Display Adapters
    Manufacture: NVIDIA
    Location: PCI bus 1, device0, function 0

    Driver Provider NVIDIA
    Driver Date 6/24/2003
    Driver Version 4.4.8.2

    Driver was downloaded directly from DELL website.

    Sunday, February 01, 2009 3:53 PM
  • Ok,

    So here is my take on this problem.

    Windows 7 is not the problem here, it is Messenger 9.

    I have Windows 7 running and so far the only program I have had problems with is Messenger 9.

    It works when Messenger 9 wants to and that is not very often.

    Switch back to Messenger 8 and that works with out any problems.

    Wednesday, February 04, 2009 8:43 PM

  • Hi jeffcoboy1,

    not only you!? Me too!?-:((

    I also have a bluescreen if I open SUPERAntispyware!?
    Thursday, February 05, 2009 8:46 AM
  • I have the same problem, on a Gateway CX2619 tablet with the Intel 915GM/GMS video card. Its possible this is a problem with only specific video cards, or drivers. Any hopes of a patch or fix other than changing the video acceleration? My video card driver is version 6.14.10.4543.
    Dustin
    Friday, February 06, 2009 8:59 PM
  • I had the problem too, with my Dell Inspiron 1300 running on the Intel 915g. I've turned down the hardware acceleration so that it now works, but is there any patch or anything coming out? I'd like to watch videos in good quality without having to get rid of messenger..
    Friday, March 20, 2009 10:28 PM
  • Hello,

    How di I uninstall WIndows Live Messenger 9?? and be able to switch back to Messenger 8?

    thanks!
    Friday, April 24, 2009 6:45 PM
  • I made an upgrade from Windows Vista. Had the same freezing problem. Somehow I managed to stop the Messenger right after Windows start from the Task Manager. Then I removed Windows Live Essentials program and after reboot made reinstall. Also seemed that one optional update to Windows Live Essentials was necessary. Now everything works fine!
    Friday, April 24, 2009 9:36 PM
  • I have slightly different but similar problem.

    Everything fine with Live Messenger and Windows 7 but when in conversation and I click the 'change conversation theme' near the bottom, then messenger freezes.  Once frozen, I cannot right click the messenger notification icon to close or taskbar icon to close.  In the case, I have to open up Windows Task Manager and end the process.

    Very minor problem in my case but very annoying if I accidentally click the little button to 'change  conversation theme' when in the middle of a conversation.



    System and Software Specs:

    Windows 7 Professional 64-Bit Retail  -  All Updates as of November 15, 2009
    Windows Live Essentials 20xx  -  Latest Build, Downloaded November 1, 2009.

    AMD Athlon X2 64-Bit
    4GB Ram
    500GB Hard Drive



    My Questions:

    Is this possibly a Windows problems or Live Essentials problem? 
    Is Microsoft working on a HotFix (Windows) or Update (Live Essentials)?

    Monday, November 16, 2009 5:23 AM
  • I disabled my webcam and killed the picture that was taken with it.  My WLM remained up as long as I had the computer on this morning (about 2 hours) without crashing for the first time.  I have been trying it after each update to see it the update fixed it.  My logitec Web Cam has been blocked by Windows 7 because "bluetooth" is incompatible.  That gave me the idea that maybe I should also kill the picture I was using because it was taken with the camera.

    Tuesday, February 02, 2010 7:44 AM
  • Not sure if anyone is still having issues or not but i found another solution to the same problem. I was getting strange errors in my event log related to my custom theme. I have since erased the event and don't know exactly what it was, but it was related to my video card(Zotec Gf 9600GT on x64 Pro) and windows desktop manager. It was strange because messenger was the ONLY thing that would freeze. Everything else ran fine, no matter what i was doing. I noticed that in the optional windows updates there was an optional manufacturer supplied driver update for my video card, and despite all the warning lights going off from the drivers supplied by WU on XP, i decided to install it. After i rebooted i fired up live messenger and it has since run fine.

    I noticed that alot of people have had to turn hardware acceleration down and disable certain video features, and that really sucks. Maybe check windows update for driver updates?(As far as i know they aren't microsoft drivers, but drivers actually supplied by the manufacturer and the ones for my card were from January of this year.) The problem could perhaps also lie in inadequate video resources. Maybe try turning off transparency and some other visual effects...

    Hope this helps!
    Friday, February 26, 2010 3:39 AM
  • I've seemed to narrow the problem down on my machine...Windows 7 x64  WLM 14.0.8089.726

    It looks like the freezing is related to the ad content that is displayed at the bottom of the main window.  If I'm typing and it starts freezing, I notice that it resumes when the ad switches.  But if the main window is minimized, the freezing doesn't occur.  The freezing seems to occur most often when there are MSN video ads, because they revolve more often than other ads.

    Thursday, May 20, 2010 4:30 PM
  • Hi, I have had the same problem with W7 x64. I advise you to try to use WLM 2010 Beta. I hope that helps you like It helped me.
    Wednesday, August 04, 2010 10:54 PM