none
Autoconfiguration IP Address (Preferred)

Answers

  • Have you checked to ensure that your DHCP server hasn't ran out of IP addresses?

    Do you have both a ethernet NIC as well as the USB NIC?




    Also, I found something that someone else suggested:


    Start | All Programs | Acessories

    Right-clicking on the Comand Prompt | Run as Administrator

    Type:
    netsh int ip reset c:\resetip.txt
    netsh winsock reset c:\winsock.txt
    exit

    Restart computer
    Wednesday, July 29, 2009 9:37 PM

All replies

  • Are you talking about getting a 169 address?  If so, what that means is that your machine is set up as a DHCP client, but no DHCP servers gave the machine an IP address.  By default, Windows looks for a DHCP server, but if one cannot be found, it'll autoconfigure a 169 address.

    You can fix this by giving it a static IP address or making sure that the machine has access to a DHCP server.
    • Edited by Sick Freak Wednesday, July 29, 2009 9:42 PM
    Monday, July 27, 2009 10:04 PM
  • Hi,

    Thanks but maybe I'm missing something here because my understanding would be that if the 169.xxx.xxx.xxx address is "preferred" then I'd have to use static which kind of defeats the purpose, at least insofar as DHCP is concerned.

    On the Alternative tab, there appears to be no way to turn it (apipa) off, so is this a feature or a foe?
    Monday, July 27, 2009 11:23 PM
  • If you have a DHCP server, then the machine should be grabbing a valid address from it.  If you don't want DHCP, then you'll need to use a static, or disable the TCP/IP.

    Monday, July 27, 2009 11:31 PM
  • I do want DHCP, but it seems that APIPA is preferred for some reason. I don't know why but it is annoying to say the least as I have tried no less than 3 different servers.
    Tuesday, July 28, 2009 3:18 AM
  • Have you set up a DHCP server somewhere?  If so, ensure that you have connectivity to it (routing / firewall /etc.)  If the PC doesn't have access to it, then it will do APIPA by default.
    Tuesday, July 28, 2009 3:44 PM
  • Hi,

    DHCP is working but only via USB, which is a bit strange, but what I am thinking is maybe Vista "prefers" to use apipa thereby allowing access to the internet only via a second terminal, particularly in circumstances where other connections eg wireless have been created.
    Wednesday, July 29, 2009 12:34 AM
  • Is your network access via a USB NIC?
    Wednesday, July 29, 2009 3:29 PM
  • Thank you,

    Yes that is correct, as it is the only way I can currently access the network, unless of course I configure a static IP, however short of the latter "solution" I believe it to be rather strange that it simply refers to the connection as being "LAN or high-speed network" which is not very descriptive I don't think for even a technical support person.

    Thanks again
    Wednesday, July 29, 2009 8:40 PM
  • Have you checked to ensure that your DHCP server hasn't ran out of IP addresses?

    Do you have both a ethernet NIC as well as the USB NIC?




    Also, I found something that someone else suggested:


    Start | All Programs | Acessories

    Right-clicking on the Comand Prompt | Run as Administrator

    Type:
    netsh int ip reset c:\resetip.txt
    netsh winsock reset c:\winsock.txt
    exit

    Restart computer
    Wednesday, July 29, 2009 9:37 PM
  • Hey Thanks Sick Freak.

    So why are there .txt files?
    Thursday, July 30, 2009 5:09 AM
  • It's just a log file.
    Friday, July 31, 2009 7:22 PM
  • Hello all,

    Ive received this problem on a work domain and the resolution that we finally came up with is to turn off the Windows firewall completly as we are using Trend firewall. Once it was restarted and joined to the domain again it is working just fine.

    Hope this helps.

     

    • Proposed as answer by gashraf Tuesday, February 28, 2012 12:59 PM
    Wednesday, February 02, 2011 6:10 PM
  • If this error is in first time of assign the ip address ,uninstall lan driver and install it ,,and  remove the tick of ip 6 in lan properties restart the system and assign it , it may work
    Tuesday, February 28, 2012 12:55 PM