none
Windows 7 Pro Power Options keep resetting

    Question

  • Hi, I have a Vaio laptop running Windows 7 Pro and whenever I enable hibernation by turning off the hybrid sleep, the setting resets itself after the laptop is restarted.

     

    I've created a custom power plan that has hibernate enabled and even if this is selected when shutting down, when the laptop boots up again it has reset to the default "balanced" power plan.  This is annoying as to hibernate the laptop the power plan needs to be changed if the computer has been shutdown or restarted.

     

    Any ideas how this can be resolved?  It's been restored to factory mode about 2 weeks ago.  I uninstalled the Vaio Power options as I thought this might be interfering but the problem remains.

     

    Thanks
    Friday, February 04, 2011 3:59 PM

Answers

  • Hi, 

    Would you please let me know if the computer is in a domain environment? If so, the power option is controlled by Group Policy on server.

    If the computer is not in domain environment, please open an elevated command prompt windows and type the following command.

    Powercfg /l

    Note: You will see all Existing Power Schemes. Use notepad to note the GUID which you want to choose and go to type the following command.

    powercfg /setactive  Sheme_GUID

    After that, please restart the computer to check if the setting revert. If so, please modify the following registry.

    Note: Before editing the registry, please back up it first. If any issue occurs, we can just double-click the backup registry to restore it.

    http://windows.microsoft.com/en-US/windows7/Back-up-the-registry

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}

    1.Right-click PreferredPlan, and then click Modify.

    2.In the Value data box, enter one of the following:

    Type 381b4222-f694-41f0-9685-ff5bb260df2e to use the Balanced plan.

    Type a1841308-3541-4fab-bc81-f71556f20b4a to use the Power saver plan.

    Type 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c to use the High performance plan.

    For more information, you can refer to the following KB: 

    http://support.microsoft.com/kb/935799

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Tuesday, February 15, 2011 1:49 AM
    Monday, February 07, 2011 2:51 PM
    Moderator

All replies

  • Try using msconfig and disabling all start up applications. Then see if the settings stick.
    Please do not forget to select the best answer if it helps you! The Ultimate computer newbie guide since the discovery of spoon feeding! The Computer Manual dot Com
    Friday, February 04, 2011 4:01 PM
  • Thanks for your reply, just tried that, but still resets the settings unfortunately.  Any other ideas what could be causing this?
    Friday, February 04, 2011 4:40 PM
  • Hi, 

    Would you please let me know if the computer is in a domain environment? If so, the power option is controlled by Group Policy on server.

    If the computer is not in domain environment, please open an elevated command prompt windows and type the following command.

    Powercfg /l

    Note: You will see all Existing Power Schemes. Use notepad to note the GUID which you want to choose and go to type the following command.

    powercfg /setactive  Sheme_GUID

    After that, please restart the computer to check if the setting revert. If so, please modify the following registry.

    Note: Before editing the registry, please back up it first. If any issue occurs, we can just double-click the backup registry to restore it.

    http://windows.microsoft.com/en-US/windows7/Back-up-the-registry

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}

    1.Right-click PreferredPlan, and then click Modify.

    2.In the Value data box, enter one of the following:

    Type 381b4222-f694-41f0-9685-ff5bb260df2e to use the Balanced plan.

    Type a1841308-3541-4fab-bc81-f71556f20b4a to use the Power saver plan.

    Type 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c to use the High performance plan.

    For more information, you can refer to the following KB: 

    http://support.microsoft.com/kb/935799

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Tuesday, February 15, 2011 1:49 AM
    Monday, February 07, 2011 2:51 PM
    Moderator
  • Im having the the exact same issue, my power plan keeps resetting itself, it is a custom power plan and its my home computer running windows 7 pro 64bit

    Friday, December 06, 2013 2:14 AM