none
DHCP and WDS on separate servers

    Question

  • I have DHCP and WDS running on separate servers. When I try to PXE boot my client, it doesn't get an address. The DHCP server sees the request it just isn't giving it to the client. Both servers are on the same subnet.

    This was all working before when DHCP and WDS were on the same machine. Has anybody run into this problem or have a solution?
    Monday, June 18, 2007 6:50 PM

All replies

  • In WDS ensure that both boxes are unchecked on the DHCP tab of the server properties.

     

    In DHCP configure options 66 and 67.

    Monday, June 18, 2007 7:03 PM
  • They are unchecked and the problem persists.
    Monday, June 18, 2007 7:09 PM
  • What do your options 66 and 67 look like in DHCP?

    66: servername

    67: boot\x86\wdsnbp.com

    Monday, June 18, 2007 7:24 PM
  • You need to add and configure option 60 on the DHCP server

     

    Michael

    Monday, June 18, 2007 10:02 PM
  • If you have your DHCP and WDS on separate machines, you should not have to do anything special. WDS was designed to work in this scenario out of the box. In case you had changed the default settings around, please run the following commands from the command line. The MMC does not show the current values in the DHCP tab correctly, there is a known issue being tracked for this.

     

    wdsutil /set-server /usedhcpports:yes

     

    Make sure that the firewall if configured on the WDS Server is set to allow packets coming in on port 67, 68, 69 and 4011.

    You do not have to configure option 66\67 or Option 60 on the DHCP Server in order to get this scenario to work. If you do have them configured please remove them. ( You need to have option 60 configured and usedhcpports set to no, if your dhcp server and wds server are running on the same machine ) .

     

    If your client machines are on the same subnet as your DHCP \ WDS Servers, they will get answered fine. If they are not on the same subnet or if they go through a DHCP relay agent or a router, you need to update the IP helper tables to route the requests to include both the WDS Server and the DHCP Server. If you do not want to update the IP helper tables, then you can use option 66\67 on the DHCP Server to redirect clients to the WDS Server.

     

    You can find more details regarding the various configurations in the WDS white paper at http://go.microsoft.com/fwlink/?LinkId=81031 

     

    Thanks

    -Sudha.

    • Proposed as answer by Trikz Thursday, December 08, 2011 10:29 AM
    Monday, June 25, 2007 11:49 PM
  • So if I want to avoind updating our helper tables I should stick with having options 66/67 configured? This is best in some environments where making router/switch changes require an act of congress for fear of down time.
    Tuesday, June 26, 2007 2:24 PM
  • I was getting the error "PXE-E55 ProxyDHCP service did not reply to request on Port 4011" and couldnt  understand why, because I have the DHCP and WDS services running on physically separate computers on the same subnet (no ip helper issues!), which I thought should work straight out of the box OOB. I was using Ghost server and my DHCP server had Option 60 enabled which must have been causing the problem. So I removed the option 60 and ran the command "wdsutil /set-server /usedhcpports:yes" and it all worked just beautifully!

    Thanks for the post Sudha.

     

     


    Trikz MCSE
    Thursday, December 08, 2011 10:41 AM