none
Windows 7 Behaving as if Alt Key is Stuck

    Question

  • I have a Lenovo G570, running Windows 7 Home Premium 64-bit.

    I first discovered this problem a few weeks ago whilst playing Heroes Of Newerth, it was behaving like ALT was being held down, I couldn't type and it was unplayable, it happened many times and it seemed to only happen during or after I had played HoN. But it gradually became worse and started happening all the time and when I hadn't been playing at all. I clean re-installed Windows 7 Home Premium twice since then and it has gotten to the point of me being unable to type to login upon restarting the computer.

    It seems to stop temporarily (for only a couple of minutes) after time but doesn't stay corrected for long. When it does happen I can't type, and when I do push keys it goes to the shortcut associated with the key as if I was holding ALT (e.g pushing F brings up FIND/SEARCH) and double clicking a folder brings up the folder's Properties menu.

    Thanks to anyone who can help, I searched everywhere and couldn't find a solution anywhere.

    Also I have taken my laptop apart as well as plugged in an external keyboard and have determined ALT is NOT being physically held down/stuck.
    Monday, October 08, 2012 9:32 AM

Answers

All replies

  • Monday, October 08, 2012 1:06 PM
  • Hi,

     

    In addition to the sticky keys, please also try the following:

     

    1. Check whether this issue occurred in Clean Boot and Safe Mode

    2. Use another user account or create a new profile to test the issue. For information, Fix a corrupted user profile

     

    Hope this helps.


    Vincent Wang

    TechNet Community Support

    Tuesday, October 09, 2012 7:46 AM
    Moderator
  • Stupid but simple.
    I connected additional keyboard, not instead of the one connected.
    As soon as Windows completed installing the new keyboard both keyboards were functioning like new.
    I disconnected the additional keyboard and the original one continue to function normally.

    I am not sure but I think it has something to do with the Human Interface Device Access Service.

    I tried restarting this service before the dual keyboard trick but it did NOT help

    Tuesday, March 19, 2013 2:48 PM
  • Try this if you are still looking for a solution>   Go to >Control Panel > Regional and Language Options > the second tab "Languages".  In the field >"Text services and input languages" click on >"Details".  In the second field "Installed Services", check your keyboard layouts.  IF "US-International" is highlighted as currently in use,  click on the "Remove" button and selected the "US" layout.  The two keyboard mappings are not the same.                    
    Tuesday, April 30, 2013 3:53 PM