none
Windows 7 Forgets mapped drive credentials

    General discussion

  • Does anyome else find that that win7 continually prompts for username and password of mapped drives - apparently ignoring the "remember my..." check box?

    Friday, January 16, 2009 9:35 AM

All replies

  • I've seen that after hibernate/suspend actions and resuming the network connection.

    eq. connected drivemapping, hibernate laptop.
    Resume after 15 minutes, and with a working (webbrowsing/MSN works) network connection, Explorer pops-up for credentials for the network share.

    My laptop is domain-joined, btw.
    Friday, January 16, 2009 3:34 PM
  • It does the same for me. Forgets the drives every reboot. So I simply map them then dont restart, lol. 
    Friday, January 16, 2009 4:36 PM
  • Yeah, same issue here, it won't remember them forever, just for that session.
    Thursday, January 22, 2009 5:13 AM
  • this is the same for XP, at least it does this to me from a computer in a workgroup mapping to a share in our domain.
    Friday, January 23, 2009 11:44 PM
  • Is this a bug then? 

    If its a 'feature' we have to write a script to retain the mapping each time eh? - Not very good as the password would be clearly visible in the cmd or vbs file. 

    Does anyone know any other work-arounds? 

    Tuesday, January 27, 2009 5:35 PM
  • Same is happening for me as well.  This must be a bug, there is no way this would fly in an enterprise environment.  
    Wednesday, January 28, 2009 9:02 PM
  • Craig9876 said:

    Same is happening for me as well.  This must be a bug, there is no way this would fly in an enterprise environment.  



    Sure it fly in an enterprise environment lol. We spend a lot of time remapping network drive in enterprise environment where I work. It seem to be a 8 years standing bug with Microsoft!

     

    The weird thing is that linux workstation using SAMBA do not suffer from this bug!

     

     

    Wednesday, January 28, 2009 11:06 PM
  • Really?  I've been working in a Windows environment for a long time, and have never had that problem with my users.
    Wednesday, January 28, 2009 11:21 PM
  • Yep really 

     

    Let's say a user need to connect to a network drive that he hasn't use for a long time and boom it does not work anymore!

    Then we just disconnect that network drive delete the link and redo it.

    Sure it happen a lot and in a lot of different location and company too.

    Wednesday, January 28, 2009 11:44 PM
  • It used to work for me in Vista and XP.  It's jaw-droppingly rubbish to have to map each time.  Isn't the whole point of mapping for it to be, well, mapped!?
    Friday, January 30, 2009 8:47 PM
  • I'm in the same situation, it works flawlessly in Vista and XP so it must be a bug. Not to worry, it will be fixed. 
    Saturday, January 31, 2009 1:07 AM
  • I have been having the same problem ...
    I just found the "Credential Manager" in the 'Control Panel'
    (Control Panel\User Accounts and Family Safety\Credential Manager)

    I can't guarantee that this will fix everything, but so far so good!
    Thursday, February 05, 2009 5:18 AM
  • D-TrainCanada Your fix worked. Nice job, and thanks, I was getting sick of continually entering my credentials.
    Friday, May 15, 2009 2:55 AM
  • D-TrainCanada,
    This didn't work in my case.  We are trying to map a Domain controlled share using different credentials than what the user logs in to the network with.  No matter how we set it up either as a Windows credential or as a generic credential the mapping fails upon reboot and the drive must be disconnected and remapped.  I hope someone figures this out soon, or it may delay our roll out of Windows 7 in our Enterprise.


    Thanks
    B
    Friday, October 02, 2009 9:19 PM
  • Fix does not work in my case either and all computers are using the same credentials they use for user login, not different ones yet upon reboot it continually prompts for username and password of mapped drives ignoring the "remember my..." check box. One does not have to remap, but one does have to continually re-enter user/pass to get to drives after reboot or even sleep.
    Friday, October 02, 2009 9:32 PM
  • Update,

    We fixed the issue we were having here.  It turned out that the mapping was for our FTP server and that box is not on the domain.  We needed to include the box's name before the credentials just like if you are signing into a domain.  Once we added the    System name\username   and then password, all was good.

    Thanks
    B
    Wednesday, October 14, 2009 4:37 PM
  • Same here, it's driving me mad having to enter password all the time when I start a new session of VS studio 2005 using VSS web. Used to be able to save the password in the password manager, but that function doesn't seem to work anymore either.... :(
    Monday, October 19, 2009 9:33 AM
  • Update,

    We fixed the issue we were having here.  It turned out that the mapping was for our FTP server and that box is not on the domain.  We needed to include the box's name before the credentials just like if you are signing into a domain.  Once we added the    System name\username   and then password, all was good.

    Thanks
    B
    Thankyou!!!! This has been driving me crazy for weeks!


    Fred 666 - your company needs to look at what they're spending their IT delivery dollars on my friend. What you describe is in no way normal.
    Tuesday, November 03, 2009 10:32 PM
  • The solution that puts the domain name first works.

    you have to enter things in this format

    username: RemoteDomain\username
    password: password

    "RemoteDomain" will show up listed under "Domain:" and if you check the remember box it will not forget them.


    if you do not enter the remote domain, the default settings are:

    username LocalMachine\username
    password: password

    and no matter what it will forget them on the next logon.

    ...at least it worked for me
    Thursday, November 19, 2009 4:53 AM
  • Thank you!

    I typed "Credential Manager" in the windows search box and added

    Address: \\NetworkAttachedName
    Login: \LoginName
    Pass: ******

    The \LoginName starts with "\" so that windows doesn't use the current domain or machine name as a domain name in the login (which would be Domain\LoginName)
    I couldn't add the box to a domain because the box is an Apple AirPort with attached hard drives
    Sten
    Monday, November 23, 2009 3:41 PM
  • None of the given advice has worked for me so far. What finally worked for me was 'net use'.

    1. Get to the command shell (Win+R, cmd, Enter)
    2. net use Z: \\remote\folder * /USER:DOMAIN\username /PERSISTENT:YES
    3. Type in your password at the prompt

    Obviously, change Z: to whatever drive letter you want and modify the other fields to fit your situation. "/PERSISTENT:YES" is needed so it remembers it on next login. For some reason this method works, but the checkbox in the dialog window doesn't... All that fancy aero graphics and it can't even do what the command line does.

    For more information, try "net use /h".
    Saturday, March 13, 2010 4:17 PM
  • _stefan's method works.  Just be sure to do it TWICE if the mapped drive will be used to install software.  Once in an non-administrator command prompt, and again in an adminstrator command prompt.  Otherwise Win7 will ask for the password during software installs.

    Wednesday, June 02, 2010 6:58 AM
  • See also the network security policy tweak at:

    http://www.gadgetgrill.com.au/2009/11/19/windows-7-fixing-the-mapped-drive-credentials-problem/

    Thursday, June 10, 2010 5:58 AM
  • None of the given advice has worked for me so far. What finally worked for me was 'net use'.

    1. Get to the command shell (Win+R, cmd, Enter)
    2. net use Z: \\remote\folder * /USER:DOMAIN\username /PERSISTENT:YES
    3. Type in your password at the prompt

    Obviously, change Z: to whatever drive letter you want and modify the other fields to fit your situation. "/PERSISTENT:YES" is needed so it remembers it on next login. For some reason this method works, but the checkbox in the dialog window doesn't... All that fancy aero graphics and it can't even do what the command line does.

    For more information, try "net use /h".

    please can someone do a 'lamens' tut on this.... reason y i say this is because after the first bit of the command ( net use Z: \\remote\folder ) i get lost.

     

    we have the next bit = * /USER:DOMAIN\username

    thats the bit that needs explaining for us newbies. how does this need to be entered for a home user? is the USER part referring to the laptop account username or the username of the nas share? Then we have :DOMAIN   would this be  WORKGROUP/HOMEGROUP etc or the name of the PC/laptop? Then the last bit,  \username  ..... what username is this referring to?

     

     

    My setup is a home network. Modem Router, NAS Drive, win7 64bit laptop set up in WORKGROUP.

     

     

     

    TY :)

     

     

     

     

    Monday, June 28, 2010 9:01 PM
  • Thank you!

    I typed "Credential Manager" in the windows search box and added

    Address: \\NetworkAttachedName
    Login: \LoginName
    Pass: ******

    The \LoginName starts with "\" so that windows doesn't use the current domain or machine name as a domain name in the login (which would be Domain\LoginName)
    I couldn't add the box to a domain because the box is an Apple AirPort with attached hard drives
    Sten

    Just also need to add that when the 'session' came to an end and windows came back with the username and password error i was scratching my head for ages as to how to get round this. I also noticed that once this happend i was unable to find or connect to the nas drive.

     

    The quick answer to this was to goto the credential manager and delete the credential saved for the nas drive. i gave it a moment and BOOM, nas drive appear and i was able to connect to it again.

     

     

    TY :)


    Monday, June 28, 2010 9:33 PM
  • DavidGLyons provided a nice description at http://www.w7forums.com/windows-7-does-not-save-network-login-credentials-username-and-password-t1621p2.html

    I have found that if you DON'T enter the credentials when prompted, but instead go to credentials manager and add the credentials explicitly, you get a persistence level of 'enterprise'. Otherwise you get a persistence level of 'log in session'. As a result my credentials have persisted across logins.

    Sunday, July 11, 2010 4:01 PM
  • That is great that you can get it working and all but this is by no means a fix for domain environments that utilize industry standard password change policies. Users shouldn't have to change their password and then be sure to get into the control panel and update their credentials manager for each mapped drive.  What if users had to update credentials saved for outlook in exchange environments every 45days when they have to change their password via group policy.  They would never require this for Outlook and they shouldn't for mapped drives.

    Right now whenever a Windows 7 Pro domain users computer goes to it disconnects and the mapped drives and they don't reconnect when the computer is awoke.  Users have to reboot or log off and log back in to invoke a script that disconnects the mapped drive and reconnects it.  A temp solution that isn't very green is to turn off sleep mode so the system is always on or off via Policy.  So much for Going Green and converting the rest of the organization from XP Pro to Windows 7.

    This is probably another under the cover attempt to push Enterprises into using SharePoint since it is not being universally accepted.  This needs to be changed via patch for Professional and Enterprise Editions of Windows 7.  Don't try and force us into buying more products and changing the way entire staff access their data.  I don't have the political clout to force an entire government sector into do things differently and pay more to replace a system that is simple to manage with one that is complex and has worked great for the last 12 years with no complaints.  If I can't force this organization to use SharePoint then don't make my life miserable because you still want me to use it.

    • Edited by Russell Manning Thursday, November 18, 2010 4:08 PM Add our current fix.
    Thursday, November 18, 2010 4:02 PM
  • Bit off-topic, but... For those who have mapped drives showing in Explorer with a red X:

    There is a also another "problem" with mapped drives, explained here:

    http://support.microsoft.com/kb/297684

    Note the workaround is done on the computer sharing the resources, not the computer that has the drives mapped.

    Cheers,

     


    G H
    Monday, January 03, 2011 10:48 PM
  • I found that if I set the mapped drive to have the exact same login as my windows login it solved the problem.  If you can't do that, take a look at the Map Network Drive dialog and there is a "Connect using different credentials" option.  This might defer to the credentials manager but I haven't tried it yet.

    Tuesday, March 22, 2011 1:02 AM
  • @Bradley Elder The credentials Manager solved it for me! For some reason the wrong credentials were in the vault, changed them and it works like a charm now. Thnx!
    Tuesday, April 19, 2011 7:38 AM
  • None of the given advice has worked for me so far. What finally worked for me was 'net use'.
    1. Get to the command shell (Win+R, cmd, Enter)
    2. net use Z: \\remote\folder * /USER:DOMAIN\username /PERSISTENT:YES
    3. Type in your password at the prompt
    Obviously, change Z: to whatever drive letter you want and modify the other fields to fit your situation. "/PERSISTENT:YES" is needed so it remembers it on next login. For some reason this method works, but the checkbox in the dialog window doesn't... All that fancy aero graphics and it can't even do what the command line does.
    For more information, try "net use /h".

    please can someone do a 'lamens' tut on this.... reason y i say this is because after the first bit of the command ( net use Z: \\remote\folder ) i get lost.

     

    we have the next bit = * /USER:DOMAIN\username

    thats the bit that needs explaining for us newbies. how does this need to be entered for a home user? is the USER part referring to the laptop account username or the username of the nas share? Then we have :DOMAIN   would this be  WORKGROUP/HOMEGROUP etc or the name of the PC/laptop? Then the last bit,  \username  ..... what username is this referring to?

     

     

    My setup is a home network. Modem Router, NAS Drive, win7 64bit laptop set up in WORKGROUP.

     

     

     

    TY :)

     

     

     

     

    Actually, a "layman's" version would be nice for the novice Windows 7 user, particularly for those of us who haven't sprung for the Pro version. We understand that there is a difference: for instance, Windows Home premium users don't have gpedit.msc on our systems, so we can't use that strategy. There's no "domain", just a workgroup. Would this strategy work for us? The router appears to not dynamically assign IP addresses: the one for my desktop seems persistent.

    Anyone?


    Saturday, April 30, 2011 6:30 AM
  • It's a problem with Home versions of Vista and W7, Pro and up works fine.....
    Friday, September 02, 2011 12:55 PM
  • "It's a problem with Home versions of Vista and W7, Pro and up works fine....."

    Any word whether this will ever be fixed for Windows 7 Home Premium?

    Home networking is pretty common - most people with PCs that have been using computers for any length of time at all have a home network - so it seems a bit idiotic for Microsoft to suddenly "protect" users from auto-connectivity when previous versions have enjoyed that for so long. What I find particularly silly is that in a mixed OS-version environment like I have, the only hobbled computer is the one running Windows 7 HPrem: the other Win XP systems can connect to it, but it can't connect to them. Nice one.

    Friday, September 02, 2011 10:39 PM
  • Mine problem has been solved by a pure coincidance.. I have been mapping the drive all the time like \\server.domain.pl\FOLDER.

     

    Later that day I have tried to map the share like \\server\FOLDER ... and it worked like a charm, so the domain name in share name was te problem.

    Pawel

    Thursday, September 08, 2011 8:17 AM
  • Ran into same problem - two levels to fix.

    1: GPE change "Network security: LAN Manager authentication level" from "undefined" to "Send LM & NTLM - user NTLMv2 session security if negotiated" http://www.gadgetgrill.com.au/2009/11/19/windows-7-fixing-the-mapped-drive-credentials-problem/

    If you do not have access to GPE because you're not running pro, you can edit the appropriate registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
    Key: LSA  ( Add if not exist )
    Value Name: LMCompatibility ( Add if not exist )
    Data Type: REG_DWORD
    Value: 1

    2: Make sure you put a '\' before your username when you enter your different credentials for save.  Otherwise Windows will append your current domain to it.  IE: "myName" will become "localnet\myName" if you fail to save it as "\myName".

    This is the weirdest, since the connection made when you complete the mapping does not use the domain in the different credential, but it is used when windows re-starts...

    Friday, March 02, 2012 7:37 PM
  • Turn off enable protected mode in internet options under the security tab.
    Thursday, April 05, 2012 7:19 AM
  • I had the same problem ...
    I just found the "Credential Manager" in the 'Control Panel'
    (Control Panel\User Accounts and Family Safety\Credential Manager)

    It should work.Please try.

      
    • Edited by ANEESH BALU Wednesday, May 02, 2012 1:33 PM
    Wednesday, May 02, 2012 1:31 PM
  • I had the same problem ...
    I just found the "Credential Manager" in the 'Control Panel'
    (Control Panel\User Accounts and Family Safety\Credential Manager)

    It should work.Please try.


      

    Which version of Windows? Home Edition or Pro? Doesn't work in Home Edition...
    Wednesday, May 02, 2012 10:08 PM
  • OK, this is what i did to get it working after trying 100 other solutions.

    First this is on Win7 trying to map to a networked NAS.  It is a home system on a workgroup...not a domain.

    1.  Make sure computer and NAS or other networked share are on the same "Workgroup".

    2.  Make sure the share name on the networked share is the same as your username (login name for windows)...NOt the name of your PC.

    3.  If you makes sure of 1 and 2 above, then you should be able to reconnect at every startup automatically without entering a password as long as you tell windows to remember the password.

    I hope this helps and saves someone else two hours of agony.....and this is not the first time I have sat down and wasted hours on this problem.  I just hope I remember the solution if it happens again.

    The reason this happened for me is that I reloaded my computer from scratch and didn't set the workgroup name to what it used to be before so then it didn't match the workgroup name set on my NAS.  I also created a different logon for Windows than I was using before and that was another problem.  So, if you change network settings or logons on Windows on your computer or you change the network settings or share names on your other device, you will likely run into this issue.

    Bruce

    Sunday, September 02, 2012 10:39 PM
  • Which version of Win7? Home Edition?
    Sunday, September 02, 2012 10:44 PM
  • From a noob for noobs:

    This a solution for Windows 7 Professional users trying to map a network drive that uses log on details different to your Windows logon details.

    The problem is that when you tick the box "Connect using different credentials" Windows stores your logon details incorrectly, so you need to change them. Here's how:

    1. Map the drive using the wizard.

    2. Tick the box "Connect using different credentials" and enter your logon details.

    3. Go to "Control Panel", "Users accounts and Family Safety", "Credentials Manager"

    4. Remove the logon details Windows has created for your newly mapped drive under "Windows credentials".

    5. Click on "Add a Windows Credentials"

    6. Enter your details. Under "Internet or network address" enter "\\MYSERVER\SHARE" (MYSERVER being the name of your network drive and SHARE beiing the name of the folder you want to connect to.)

    7. Enter your logon details and click OK.

    That's it, Windows now has the correct details to log you in.

    Thursday, September 06, 2012 10:20 AM
  • I have found this same problem

    Yet This was my solution

    I have removed faulty mapdrive, and have changed the domain by using

    username : mydomain/logon

    password : password

    have a carefull look if your domain is not added as a username

    in this case

    All id like to add..

    Thursday, June 20, 2013 2:11 PM
  • Excellent this fix resolved the issue for me on mapped network drives. Thanks.
    Thursday, January 30, 2014 10:00 AM
  • Whoever manages this forum - thanks for keeping the info available - it still helps!

    bkstevens1, Thanks for your post - it put me on track to address the same type issue on my BlackArmor NAS 110.

    All good!

     
    Saturday, April 12, 2014 11:22 PM