none
"Run" button missing in "File Download" dialog

    Question

  • Running Vista 32bit, using IE7 with admin account.

    After downloading an exe file (from a source I trust) I can only choose to "Save" or "Cancel", the "Run" option is gone and I'd like to have it back.

    I've checked the security settings in IE7 but failed to find the change to make.

     

    Thanks, Hans
    Friday, August 22, 2008 5:37 AM

Answers

  • Hello Hans,

     

    Please try the following step and let me know the result.

     

    Reset IE7 Settings

    ===============

    1. Click Start button-> Control Panel.

    2. Change to Classic View on the left pane and double-click the Internet Options icon.

    3. On the Security tab, click Default level button for each icon in the Select a zone to view or change security settings.

    4. Click to Programs tab, and then click the Make default button if it is not grayed out.

    5. Click to Advanced tab, click Restore advanced settings button in the Settings area.

    6. Click the Reset button in the Reset Internet Explorer settings area and Click OK.

    7. Click Apply, and then click OK.

     

    Run Windows in Clean Boot mode

    =========================

    Note: You must be logged on as an administrator or a member of the Administrators group to complete this procedure.

     

    1. Click Start.

    2. Type "msconfig" (without the quotation marks) in the Start Search bar and click Enter on the keyboard.

    3. Switch to Services tab and then Check Hide All Microsoft Services.

    4. Click Disable All.

    5. Switch to the Startup tab and then Click Disable all.

    6. Click OK.

    7. Click Restart to restart the computer.

     

    For detailed step, please refer to the following Microsoft Knowledge Base Article and demo:

    http://support.microsoft.com/kb/331796

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista

    http://support.microsoft.com/kb/929135

     

    Create a New Windows Account

    ========================

    1. Open User Accounts by clicking the Start button, clicking Control Panel, clicking User Accounts and Family Safety, and then clicking User Accounts.

    2. Click Manage another account If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    3. Click Create a new account.

    4. Type the name you want to give the user account, click an account type, and then click Create Account.

     

    Create a user account

    http://windowshelp.microsoft.com/Windows/en-US/Help/68a1c4fd-b3f6-4cb9-93a1-8a6023836e531033.mspx#E1D

     

    Hope it works!

     

    Monday, August 25, 2008 10:27 AM

All replies

  • Hello Hans,

     

    Please try the following step and let me know the result.

     

    Reset IE7 Settings

    ===============

    1. Click Start button-> Control Panel.

    2. Change to Classic View on the left pane and double-click the Internet Options icon.

    3. On the Security tab, click Default level button for each icon in the Select a zone to view or change security settings.

    4. Click to Programs tab, and then click the Make default button if it is not grayed out.

    5. Click to Advanced tab, click Restore advanced settings button in the Settings area.

    6. Click the Reset button in the Reset Internet Explorer settings area and Click OK.

    7. Click Apply, and then click OK.

     

    Run Windows in Clean Boot mode

    =========================

    Note: You must be logged on as an administrator or a member of the Administrators group to complete this procedure.

     

    1. Click Start.

    2. Type "msconfig" (without the quotation marks) in the Start Search bar and click Enter on the keyboard.

    3. Switch to Services tab and then Check Hide All Microsoft Services.

    4. Click Disable All.

    5. Switch to the Startup tab and then Click Disable all.

    6. Click OK.

    7. Click Restart to restart the computer.

     

    For detailed step, please refer to the following Microsoft Knowledge Base Article and demo:

    http://support.microsoft.com/kb/331796

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista

    http://support.microsoft.com/kb/929135

     

    Create a New Windows Account

    ========================

    1. Open User Accounts by clicking the Start button, clicking Control Panel, clicking User Accounts and Family Safety, and then clicking User Accounts.

    2. Click Manage another account If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    3. Click Create a new account.

    4. Type the name you want to give the user account, click an account type, and then click Create Account.

     

    Create a user account

    http://windowshelp.microsoft.com/Windows/en-US/Help/68a1c4fd-b3f6-4cb9-93a1-8a6023836e531033.mspx#E1D

     

    Hope it works!

     

    Monday, August 25, 2008 10:27 AM
  • Thanks, that worked like moonshine.

    I tried to download another file after completing step 5, just in case I had done enough and my "Run" button was back.

    Thanks, you saved the day. Cheers, Hans

     

    Monday, August 25, 2008 10:31 PM