none
Several issues with Sync Center.

    Question

  • Dear All,

     

    First of all thanks for taking time to read this question thread.

     

    I want to give you all some more information about the company where I'm employeed.

    We have 2 sites in the Netherlands. We have 5000+ employees and most of them are working with WIN7 ENT x64 SP1 (Version 6.1 build 7601: Servicepack 1). The servers are on Windows Server 2008 R2.

     

    We are using a DFS path for the homedrives of the users. We have 4 namespaces for this. Examples

    \\COM.PANY.com\Users1

    \\COM.PANY.com\Users2

    \\COM.PANY.com\Users3

    \\COM.PANY.com\Users4

     

    We have enabled the Offline files and folders with allmost no restriction on the usage of this. The GPO is not configured except for 1 thing. It will sync with the folder Data on the homedrive: \\COM.PANY.com\Users1\username\data

     

    We encounter several issues with Sync Center and we want to have them resolved, that's why I finally come out here.

    Problem 1: During Sync and usage of the homedrive (ask properties of all documents and folders) will force the homedrive in a offline modus for several minutes.

    Problem 2: Syncing with other usernames.

    Problem 3: Files will not be synced.

     

     

    Problem 1:

    I can reproduce this problem at my own computer and several other computers.

    When the user or me will click in sync center to sync all partnerships it will start. But in the meantime if the user saves a large file to his home directory, or opens the root of his homedrive and presses CTRL+A and after this ALT+ENTER it will read a part of the homedrive and will be forced in a offline modus for several minutes (between 1 till 15 min).

    Tried really allmost everything I could found:

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/a2a3529b-a41d-4b71-bbfe-f1306a59c145

    http://support.microsoft.com/kb/981872

    http://social.technet.microsoft.com/Forums/ar-SA/itprovistanetworking/thread/dc594a07-7702-4b68-acc5-17213805fec2

    http://social.technet.microsoft.com/Forums/en-US/winserverfiles/thread/bf93ab14-f1a1-49f8-ba2f-867e2165fc6b

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/6ad53d1f-c54f-4099-bd6a-8058b6543f2a

     

    But the issue still remains, hope you all have some idea's for this.

     

     

    Problem 2:

    It's very odd and I can't tell you more then this, but hopefully you all have a brillant idea for this that resolves this problem.

    But once in a time a user reports that Sync Center gives an Access Denied error in the overview. When we connect to this user remotely we will see an username of a different user.

    It's a kind of magic, so hopefully you will know what you need or better yet, you will know how to prevent this.

    To solve the issue for the user is a reinitialize.

     

     

    Problem 3:

    The user saves his data on H:\Data, but because of problem 1 the data is only stored locally and will not be saved on the server. And some of all the users are not syncing anymore from 4-10-2011 (DD-MM-YYYY). We can't understand why it will not sync for some users after this date.

     

     

    I understand if this is unclear for you all, but this is my first post on TechNet. And I really want to solve this and if you need more information about this issue, please tell me how to get it and what and I will answer as soon as possible. I'm located in the GMT+1 and I will have a look at this forum during working hours and days.

     

    Hope to hear soon from you.

     

    Best Regards,

    John van Hoof.


    • Edited by Johnt_NL Friday, January 27, 2012 10:55 AM
    Thursday, January 26, 2012 2:53 PM

All replies

  • Someone? Please, it's really getting an issue. Could someone please give me an advise?
    Monday, January 30, 2012 9:28 AM
  • Hi John,

    If you can make sure that the network connectivity is still available when the issue occurs(homedrive offline mode), the status of the Offline Files may change into a Offline mode because the system detects a Slow Link when saving large files or query the properties of files.

    For Windows 7, the Slow Link Detect Interval is 5 minutes. That is, the machine detects if the Link is Slow every 5 minutes and it switches the Online/Offline mode according to the determined link speed.

    Therefore perhaps you may test on one of your Windows 7 client to increase the "Check for a slow connection every X minutes" value when the status is Online.
    Location to set the value: Control Panel > Sync Center > Manage Offline Files > Network tab

    In addition, I would also like to know if you have set the Size Limit of the Offline Files on the client side?
    Location to check the settings: Control Panel > Sync Center > Manage Offline Files > Disk Usage tab

    Best Regards,
    Steven Xiao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, January 31, 2012 12:14 PM
  • Dear Steven,

    I have created a batchfile to ping the server in a loop and it doesn't have a networkconnectivity that was down or not responding. So the network (should) be no problem.

    We have changed the setting within Sync Center about Slow Link Detect Interval to 1440 (24 hours).

    The Slow Link Detection is by the GPO "Not Configurate", so that shouldn't be the problem also and in the registry is showing IsSlowLink DWORD=0. (HKEYLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\History). So I assume that it never had a SlowLink?

    I have also tried to set the Slow Detection in the local GPO to 0kbps (Is never slow), didn't resolved the problem.

    Currently at my side, where I can reproduce the problem, the diskage is:
    All Files: 4,19GB in use (21,8GB Available)
    Temp files: 4,10GB in use (21,8GB Available)

    As my point of view to this problem:
    It isn't the network, because the servers are staying online and it's not the diskage of Sync Center neither the SlowLink policy of Windows/Sync Center.

     

    Hope to hear soon from you.

    Best Regards,
    John van Hoof

    Tuesday, January 31, 2012 12:29 PM
  • Hi John,

    Firstly I would like to let you know that the Offline Files slow link detection after Vista has been changed, due to the fact that the Offline File's status has become a per-share attribute(that is, in Win7 and Vista, the offline share1 can be offline while the other offline share2,3,4 are still online), the system just tries to access the share via SMB (not PING) to detect if the slow link exists. It is different with the former XP OS(all offline shares are the same online/offline status simultaneously).

    On the other hand, per my knowledge, a "Not Configured" GPO doesn't mean that the related settings is disabled on the affected machines. Your clients will still detect the slow link using the 5 minutes interval by default.

    You may completely disable the "Configure slow-link Speed" GPO under the path: "Administrative Templates > Network > Offline Files" to prevent your Win7 computers from using the slow-link mode.

    You can also enable and decrease the value of the "Configure Slow link speed" GPO under the path: Administrative Templates > Network > Offline Files. (It seems that you have done this?) Configures the threshold value at which Offline Files considers a network connection to be "slow". Any network speed below this value is considered to be slow.

    Best regards,
    Steven Xiao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, February 01, 2012 3:54 AM
  • Hi Steven,

    Thanks for your respond again! :) And for the information about the SMB, thanks didn't know that!

    Is there a way to monitor the SMB traffic?

    I know if you have nothing configured in the GPO, it will automatically go to the default setting of Windows and that is 500kbps. You will find a GPResult /r about that setting under in the post. But I had already set everything on Disable through the GPO because of the troubleshooting I already did, but I set everything back on default because it didn't worked. I even set the setting to "Always fast connection", didn't work either.

    But I can reproduce the problem every day I want, every time I want, so I think (and I could be wrong) it's not the slow link threshold. But I say it again, correct me if I'm wrong.


    ================================================
        Last time Group Policy was applied: 2/1/2012 at 9:17:42 AM
        Group Policy was applied from:         Server01.COM.PANY.com
        Group Policy slow link threshold:      500 kbps
        Domain Name:                                  COM
        Domain Type:                                    Windows 2000
    ================================================

    Wednesday, February 01, 2012 9:02 AM
  • Hi John,

    If the issue maintains when you have the GPO "Configure slow-link mode" (sorry for the type error in my last response) to disable Slow Link, perhaps it isn't the slow link detection that is causing the unexpected offline state.

    Have you tried the clean boot mode the eliminate the interference from any third-party software? If possible, test the scenario when both the server and the client are under the clean-boot mode.

    Clean Boot.
    ---------------------------
    a. Click Start, click Run, type "msconfig" (without the quotation marks) in the Open box, and then click OK.
    b. In the Startup tab, click the "Disable All" button.
    c. In the Services tab, check the "Hide All Microsoft Services" checkbox, and then click the "Disable All" button.
    d. Click OK and restart your computer.

    Best regards,
    Steven Xiao

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 02, 2012 12:01 PM
  • Hi Steven,

    Your type error doesn't matter, as long we understand each other :)

    I will try the clean boot this afternoon and I will let you know.

    Thursday, February 02, 2012 12:04 PM
  • Hi Steven,

    I have tested it, did a clean boot but the virusscanner McAfee will be started again when booted. So I uninstalled it.

    I have to inform you that I still have the same issue, ofcourse I have picked another laptop to check this. This will proof again that it is reproducable on every computer, everywhere at any time. :(

    Hope to hear soon from you.

    Thursday, February 02, 2012 1:23 PM
  • Hi John and Steven.

    It seams that we have exactly the same problem here at our site, as is described above.

    I have although tried one other thing. I did connect the share with direct link (H=\\%server%\%user%) instead of using DFS.  In my experience after trying a lot of different sync, I did not have any problem at all.  I did sync different folders (more then one) and files, and I did exclude files and folders.

    But as soon as I use DFS-link the problem starts again.

    //Peter

    Wednesday, March 21, 2012 12:20 PM
  • Greetings John, did you ever find the solution of your issues? Basically i'm having similar issues when people at my work login in the morning, sync center goes to 100% CPU processing and the computers start to work very slow. After an hour they recover in a "ok" speed.

    When i kill the sync center task the processor load drops to 5%.

    Wednesday, May 16, 2012 2:10 PM
  • Hi Hector,

    I didn't find any solution to this problem, we are still experiencing this issue.

    We didn't get the solution we where hoping for.

    Maybe the only solution is to kick Sync Center out of the Window(s)?

    Or in the worst case the hole Windows out of the Window(s)?

    Friday, May 18, 2012 8:04 AM