none
Windows 7 Printers Offline

    Question

  • I have been using Windows 7 Ultimate for a couple of weeks. Everything had been working fine. Suddenly, all my printers show offline. I tested the USB ports with another device and they are fine. I have made sure the rpinters are not marked as use offline and I have restarted the printer server. I also restored the system back to a point at which I believe the printers were working. I can get Windows to say the printers are ready but as soon as I try to print to one of them it shows a printer error. I have power cycled everything. Windows also does its normal beep when I plug or unplug in a printer in the USB ports. Any ideas?
    Thursday, September 03, 2009 4:07 AM

All replies

  • Hello R. Whitesel,

    The below steps are a fix for Windows Vista printers being offline:

    Here's are the steps:
    1. In Control Panel, Printers, delete offline printers. If they wont
    delete, it may be because there are pending print jobs in the queue. Open the
    printer and Cancel the jobs.
    2. In Printer properties, Ports tab, delete the previously installed
    printers (offline status) that appear as Client Side Rendering Provider
    under the Description column. To do this, highlight the port, then click on
    Delete Port button. Click Apply.
    3. Restart your PC.
    4. Now reinstall the printers as follows:
    5. Open Control panel, Printers, and click Add a printer.
    6. Click Add a local printer.
    7. Select the "Use an existing port" radio button, and select LPT1: (Printer
    Port). Click Next.
    8. Install the printer driver. Mine were found in the list inlcuded with
    Vista. Select the manufacturer and the printer. Click Next.
    9. In the next window, accept the printer name or type in a new name. Leave
    the "Set as default printer" box unchecked. Click Next.
    10. Windows Vista should now install the printer. A window should open saying
    "You've successfully added printer name.
    11. DO NOT Print a test page at this time, because nothing is connected to
    the LPT1 port on the laptop. Just press Finish. The printer you just added
    should appear in the Printers window.
    12. Click ONCE on the newly added printer to highlight it, then right-click
    and open Properties.
    13. On the Ports tab, click Add Port¦ select Local Port, then click New Port¦
    14. When the Port Name window open, Enter a port name as follows:
    \\computername\printername
    (replace computername with the name of your PC acting as print server, and
    printername with the name of your printer). Click OK.
    15. You should now have a new port listed on the Ports tab of the printer
    Properties, but now the Description should be Local Port, instead of Client
    Side Rendering Provider. Click OK.
    16. Now you can go to the General tab, and Print a Test Page.
    Hopefully, your test page will print. Then restart your computer to check
    that the printer comes back online."

     

    ERS43

    Friday, July 09, 2010 11:52 PM