none
Windows 7 "Network Cable Unplugged"

    Question

  • I'm the "Network cable unplugged" problem with Windows 7, 64 bit.

    I'm using the newest realtek drivers for my on board nic on an EVGA x58 mobo. My problem is a little different than most similar posts I've read, though, as I'm using a router and switch. This just started a few days ago, first I thought it was my switch. Nic lights were off on the pc and no activity was taking place on the switch.. if I plug the cat5 in straight from the router, I have instant activity and no problems. Sometimes if I change the port I'm using on the switch, it will mysteriously work but once after my computer woke from "sleep" the "network cable unplugged" message was there again. It's definitely NOT the switch since I've tested other devices in the same ports as the windows 7 computer. The switch is a Linksys 8 port gigabit.

    The last thing I had installed before this problem started happening was Adobe CS3 suite and flash player.. I'm not sure if that's related. I'm going to try booting into safe mode with networking and see if it will work well with the switch.

    I'm confused why I have activity while straight to the router and most of the time none (now) when connecting through the switch. Perhaps it's a matter of time before it stops seeing the router.

    I'm away from said computer at the moment, but I will post more details about actual nic model later. The drivers being used are realtek's newest version. (I believe it's 7.3xxx) .. not sure off the top of my head.
    Tuesday, November 24, 2009 1:26 AM

Answers

  • Hi,

     

    I would like to suggest the following:

     

    1.    Change another network cable.

     

    2.    Connect to another router or switch to see how it works.

     

    Thanks.


    Nicholas Li - MSFT
    Monday, November 30, 2009 8:51 AM

All replies

  • Perhaps you can disable the NIC from being turned off in the energy settings, this might help
    • Proposed as answer by cdobbs Saturday, November 28, 2009 8:06 PM
    Saturday, November 28, 2009 6:08 PM
  • What ijazbof said is correct, go into the properties of your nic and turn OFf power saving. Personally I see no reason for a PC to go to sleep, that's more for laptops than PC's. I never allow my machines (including laptops) to go to sleep. If I want them to sleep, I turn them off but otherwise, they are on 24x7 unless my laptop is on the road, then I just turn it off.
    MCSE, MCSA, MCDST
    Saturday, November 28, 2009 8:06 PM
  • cdobbs,
    Well YOU may not want YOUR systems going to sleep, but some us MUST have that function (The times call for all of to be GREEN).

    I have seen this with a few chipsets (realtek / nvida) but not with intel chipsets.

    I have a netbook that win 7 refused to see the cable 5 cable UNLESS the system is booted with the cable inserted. If the box goes to sleep I must disable / enable the nic to get it to set the connection (that is so linux / Mac).

    This is an issue which NEEDS to be solved (maybe by SP1).

    Saturday, November 28, 2009 8:47 PM
  • Hi,

     

    I would like to suggest the following:

     

    1.    Change another network cable.

     

    2.    Connect to another router or switch to see how it works.

     

    Thanks.


    Nicholas Li - MSFT
    Monday, November 30, 2009 8:51 AM
  • Assuming you'd rather actually have a working computer than go outside and enjoy the hot, polluted air while waiting for SP1...

    As a workaround for now, try just removing the power-saving settings in the Power Management for the network adapter:  Uncheck "Allow the computer to turn off this device to save power" and "Allow this device to wake the computer".

    I believe with this change the computer can still go to standby as a whole, so the guilt factor should be minimal.

    -Noel
    Monday, November 30, 2009 1:52 PM
  • Thanks for all the replies. Unfortunately I had already tried all things mentioned, before making this post.

    I've tried:

    1. 3+ different cat5 cables.
    2. Turning network power savings off, and the "Allow this device to wake the computer"
    3. Updated drivers
    4. Restarting network services (which didn't work, either)
    5. Everything else you could think of, including IRQ conflicts.

    Safe Mode with networking yields the same "network unplugged problem."

    The computer recognizes the router instantly, it is the switch that the nic does not activate for.
    Note that it IS NOT the SWITCH, since I have tested other devices in the same ports, and they work perfectly. The switch is a Linksys SD2008, 8 port gigabit switch.



    • Proposed as answer by TechCarpenter Saturday, January 02, 2010 10:11 PM
    Wednesday, December 02, 2009 2:25 AM
  • Had this problem after upgrading a PC from Vista to Win7.  What worked for me is to hardcode the linkspeed and duplex to 100/full instead of autosense.  Do this by going to:

    Start > right-click on 'Computer' > Manage > Device Manager > open network adapters, right click and open properties on your adapter > advanced tab > look for 'Link Speed & Duplex' and change value to '100Mbps Full Duplex'
    • Proposed as answer by TechCarpenter Saturday, January 02, 2010 10:14 PM
    Saturday, January 02, 2010 10:14 PM
  • Hiya - just to say this fixed it for me too.  I had this problem with win7 x64 and a "RealTek PCIe FE Family Controller".  I want my PC to go to sleep as its running media center, and I don't want it running at full whack 24/7, so it needs to wake up for recordings/playing stuff and otherwise sleep.  I didn't want to disable "allow windows to shutdown this device to save power" because that also disables wake on lan, which I want.  The solution was this, to go into the network adapter properties, and like TechCarpenter says, force the link speed (I did this for sleep mode too, as by default, the adapter drops from 100mbps to 10mbps in sleep, but I told it to be 100mbps always on the theory that when it comes up, its not finding the right speed, or not reinitialising something, so if its 100 always, it doesn't have any decisions to make :).

    Anyway, setting "Speed & Duplex" to be 100Mbps Full Duplex, and "WOL & Shutdown Link Speed" to "100Mbps First" has solved the problem.
    Thursday, January 07, 2010 8:29 PM
  • Had this problem after upgrading a PC from Vista to Win7.  What worked for me is to hardcode the linkspeed and duplex to 100/full instead of autosense.  Do this by going to:

    Start > right-click on 'Computer' > Manage > Device Manager > open network adapters, right click and open properties on your adapter > advanced tab > look for 'Link Speed & Duplex' and change value to '100Mbps Full Duplex'
    TechCarpenter is correct. I got my Laptop with Win7 Home Premium. When pluggin in it to my Desktop over a CrossOver cable it says "Network Cable is Unplugged". I changed Link Speed & Duplex settings to 100Mbps and it worked great.

    But when I selected 1Gbps full duplex both sides, it gives the old error message (network cable is unplugged). Any body resolved a situation like this? I want Gigabit ethernet, not Megabit ;)
    Tuesday, February 02, 2010 12:32 AM
  •  What are the settings on the desktop?
    Bill
    Tuesday, February 02, 2010 1:21 AM
  • May be a bit late, but I have a similar problem with my new Win 7 laptop and have been doing an extensive search for a solution (no luck yet!)

     

    Some Adobe products install Apple's Bonjour services which, according to some posts I've seen, seem to impact LAN connectivity. Have a look in your Program Files (x86) folder. You could try removing them and seeing if it cures your problem; there are plenty of instructions for this out there - sorry, I don't have a link to hand, though.

     

     

    Tuesday, April 06, 2010 4:48 PM
  • Hello NeoMaximus,

    Just read your message. I have the exact same problem. I have a  hub (3COM) connected to a Router going to the internet in a small office network with 6 PC's (mostly XP). When I connect my Windows 7 PC directly into a hub port, it connects immediately. However, when I connect at my desk (into the wall plug - RJ45), I get "Network Cable Unplugged". I tried several things:

    1) I tested the cables end to end (including patch cords) - all checked out ok.

    2) I tried setting the link-speed to 10, 100, full and half duplex - no change

    3) I made sure that all NIC settings are set to auto discovery in Network and File Sharing

    The only thing that I haven't done is set the link-speed on WOL and modify power saving settings as was suggested in some posts. I was wondering if you ever got a solution to your problem. I sure can use some help.

    Thanks 

    Wednesday, April 21, 2010 1:07 PM
  • Hello NeoMaximus,

    Just read your message. I have the exact same problem. I have a  hub (3COM) connected to a Router going to the internet in a small office network with 6 PC's (mostly XP). When I connect my Windows 7 PC directly into a hub port, it connects immediately. However, when I connect at my desk (into the wall plug - RJ45), I get "Network Cable Unplugged". I tried several things:

    1) I tested the cables end to end (including patch cords) - all checked out ok.

    2) I tried setting the link-speed to 10, 100, full and half duplex - no change

    3) I made sure that all NIC settings are set to auto discovery in Network and File Sharing

    The only thing that I haven't done is set the link-speed on WOL and modify power saving settings as was suggested in some posts. I was wondering if you ever got a solution to your problem. I sure can use some help.

    Thanks 

    I have the same problem, and my network card option doesn't have the option "Allow the computer to turn off this device to save power" , please can anyone help me on how to disable this option in register?
    Friday, August 06, 2010 2:28 PM
  • Hello NeoMaximus,

    Just read your message. I have the exact same problem. I have a  hub (3COM) connected to a Router going to the internet in a small office network with 6 PC's (mostly XP). When I connect my Windows 7 PC directly into a hub port, it connects immediately. However, when I connect at my desk (into the wall plug - RJ45), I get "Network Cable Unplugged". I tried several things:

    1) I tested the cables end to end (including patch cords) - all checked out ok.

    2) I tried setting the link-speed to 10, 100, full and half duplex - no change

    3) I made sure that all NIC settings are set to auto discovery in Network and File Sharing

    The only thing that I haven't done is set the link-speed on WOL and modify power saving settings as was suggested in some posts. I was wondering if you ever got a solution to your problem. I sure can use some help.

    Thanks 

    I have the same problem, and my network card option doesn't have the option "Allow the computer to turn off this device to save power" , please can anyone help me on how to disable this option in register?

    I too have the same problem. I did a clean install of windows 7 ultimate x32 on a HP pavilion slimline. This pc has both an integrated wireless LAN and a Nvidia nforce ethernet 10/100 mbps adapter.  Since the office has both signals I am using the wireless connection right now but is only 54mb and sometimes I only get one bar. Thats why I want to plug it into the ethernet connection cause we have high speed here up to 100mbs. 

    Any other computer in the office with xp or vista can connect to my desk's ethernet connection automatically but I get the network cable unplugged ____. I tried everything on the blogs but still nothing. Please help.

    Friday, August 06, 2010 7:55 PM
  • Hi i got a slightly different problem! i accidentally changed the speed/duplex setting on my ethernet controller.  I changed it from the auto setting to 1000mbfull and all of a sudden my adapters say network cable unplugged.  changing the settings back to auto or any of the other settings, 100mb full, 10mb half, etc, dont work!  All of the search results for the problem "network cable unplugged" are solved by changing the duplex setting away from auto but my problem is that i changed the setting first!  Please help!
    Sunday, December 05, 2010 7:31 PM
  • My new PC (Win7 64bit)worked well for a month and then suddenly I got this error "Cable Unplugged". Fortunately, my new mobo is ASUS M4A88TM-USB3 with Express Gate (it's own little onboard os that lets you surf the net, email, skype etc even before windows start). Internet through ExpressGate worked well, so I knew the problem was not H/W but Windows only. Once the PC went into windows, the orange light at the cable connector turned off. After 2 days of excruiciating RTFMs and tweaks nothing worked. I thought of PC102. Physically disconnected all cables including powersupply cables to PC, router, modem...everything. Connected back them in and voila!!! Windows recognized the cable!!! PC101 is reboot :) that didn't work. Of course, I did disable all WOL and also set the Speed/Duplex to 100MPS. I don't think these settings made much diff.
    ASD
    Monday, January 24, 2011 6:24 AM
  • Same problem, set the adapter to 100Mb full it works.  Set it to 1000Mb or auto and I get the Cable Unplugged message.  Wierd thing.  This same PC was running Windows 7 64bit and it worked fine on auto at 1000Mb.  All I did was reinstall Windows 7 64bit (Clean Install) off the same DVD and now i have the problem.  It has to be Windows as it worked before with the exact same hardware.  So all this change the cable, change the router it's a hardware problem is WRONG!  I've tried different cables different routers and switches.

    Microsoft!  You have a problem.  Can we get any responses besides it's a hardware issue?  Just look on the Net there are tons of forums with people writing about this same issue.  IT IS NOT HARDWARE.

    Thursday, January 27, 2011 10:37 PM
  • Also experiencing this error.  Lights stay on on the hub.  No amount of disconnecting and re-connecting the cable or changing cables has any effect.  The ONLY thing that temporarily fixes it is a windows re-start.  We have tried all of the settings changes suggested here and elsewhere no change at all.  This machine is part of an industrial CNC machine control so we are paying operators to stand around re-booting windows several times a day.  Seems to be a common Win 7 problem without any real solutions offered.
    Monday, November 26, 2012 10:53 PM
  • I owe you a beer!

    Rutger Rauws - Microsoft Student Partner.

    Sunday, September 29, 2013 9:59 PM