none
anonymous logon

    Question

  • I'd like to enable anonymous read/write access to a particular network share I have. The network share is on a Windows 7 x64 Ultimate computer. Computers that will be accessing and writing to the share will also be running Windows 7 Ultimate (both the x86 and the x64 versions). These computers all have the same user-name, and password, and are all hardwared to the network. So far, I have done the following:

    gpedit.msc -> Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options:

    in "Network access: Shares that can be accessed anonymously", I typed in the share name

    "Network access: Do not allow anonymous enumeration of SAM accounts and shares", and made sure that it was disabled.

    I also added anonymous logon read/write permissions to the share.

    I when I tried to write to the share, I got the error Code: 2147024891, which when I looked it up, translated to “general access denied”.
    Thursday, January 28, 2010 6:49 AM

Answers

  • Right click on the share->properties-Advanced Sharing->Permissions
    select everyone - tick the [Allow]Change box, click OK


    Hi crontab,

    In Windows 7 the "everyone" group does not include the "Guest" account.
    Arthur Xie - MSFT
    Monday, February 08, 2010 5:48 AM
    Moderator

All replies

  • You may need to specially give the Guest account full control permission for the shared folders.
    Arthur Xie - MSFT
    Tuesday, February 02, 2010 8:20 AM
    Moderator
  • Right click on the share->properties-Advanced Sharing->Permissions
    select everyone - tick the [Allow]Change box, click OK

    Tuesday, February 02, 2010 5:42 PM
  • Right click on the share->properties-Advanced Sharing->Permissions
    select everyone - tick the [Allow]Change box, click OK


    Hi crontab,

    In Windows 7 the "everyone" group does not include the "Guest" account.
    Arthur Xie - MSFT
    Monday, February 08, 2010 5:48 AM
    Moderator
  • What to do is, 1) enable the guest account, 2) remove guest from "Deny access to this computer from the network, 3) set Everyone to have access to share and file security permissions.

    • Proposed as answer by ssippe Monday, January 13, 2014 12:40 AM
    Saturday, January 15, 2011 7:05 PM