none
Windows 7 - Shutdown, Restart, Sleep and Hibernate buttons greyed out

    Question

  • Computer: Dell Latitude E6400 running Windows 7 Professional

    When the user clicks start -> shutdown > The shutdown, restart, sleep and hibernate buttons are all greyed out. This is actually the second user we've had with this issue with. For the first user I fixed the problem using the below gpedit.msc fix, but for this other user, it doesn't change anything.

    gpedit.msc fix:
    "User Configuration -> Administrative Templates -> Start Menu and Taskbar -> Remove and prevent access to the Shut Down, Restart, Sleep, and Hibernate commands" to Disabled.

    I've also tried adding the following registry keys
    HKEY_CURRENT_USER\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer created a 32bit DWORD named NoClose and set the option to 0. 
    HKEY_LOCAL_MACHINE\ Software\Microsoft\Windows\CurrentVersion\Policies\Explorer created a 32bit DWORD named NoClose and set the option to 0.

    Lastly I have scanned the machine with two different anti-virus programs, and each found no issues. I can't get the shutdown option to not be greyed out. Anyone have any suggestions I haven't tried already?

    Thanks,
    Vinny


    Vinny http://www.intermedia.net
    Tuesday, April 27, 2010 10:10 PM

Answers

  • AHA, I found in gpedit.msc under Computer Configuration -> Windows Setting -> Security Setting -> Local Policies -> User Right Assignment is a control for Shutdown, and the group "Users" was not in the list.

    I can't test to see if this worked as the computer is in NY, I'm in California and I have disconnected my OCS session, so I will update tomorrow when the user gets into work. Maybe this did the trick???


    Vinny http://www.intermedia.net
    Wednesday, April 28, 2010 10:39 PM

All replies

  • Hi,

     

    It still can be a group policy issue.

     

    I would like to suggest you perform the following troubleshooting steps:

     

    Delete All Group Policy Registry keys

    ========================

    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Search” box and press Enter.

    2. Locate the following key:

     

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]

     

    Right click on "Microsoft", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.

     

    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.

     

    3. Highlight Microsoft and click "Delete".

    4. Please repeat the above steps for the following registry keys.

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

     

    Note: if some keys do not exist, please ignore them.

     

    3. Exit the Registry Editor.

     

    What’s the result?

     

    Regards,

     


    Arthur Li - MSFT
    Wednesday, April 28, 2010 5:39 AM
    Moderator
  • I made the registry edits you asked for but there was no change. Shutdown, Restart, Sleep and Hibernate are all greyed out.

    After testing I ran a gpupdate /force. No change after that as well.

    I also noticed that if I click start, where the shutdown button used to be is Lock, and if I right click on Lock to change it to shutdown, the drop down menu next to "Power button action" is blank and shutdown is not in the list at all. None of the greyed out options are. Not sure if that helps you or not, but I thought it was worth mentioning.

    Thanks for all help you can provide, this one really has me stumped.


    Vinny http://www.intermedia.net
    Wednesday, April 28, 2010 10:16 PM
  • AHA, I found in gpedit.msc under Computer Configuration -> Windows Setting -> Security Setting -> Local Policies -> User Right Assignment is a control for Shutdown, and the group "Users" was not in the list.

    I can't test to see if this worked as the computer is in NY, I'm in California and I have disconnected my OCS session, so I will update tomorrow when the user gets into work. Maybe this did the trick???


    Vinny http://www.intermedia.net
    Wednesday, April 28, 2010 10:39 PM
  • That might work. Mine has Administrators, Users, Backup Operators

     

     


    Rich Why can't I be different and original like everybody else? - Vivian Stanshal
    Thursday, April 29, 2010 12:39 AM
  • Hi, i think this may be the problem I have. Tried all the other regestry edits and they dont work and USERS doesnt appear. But it wont let me edit this setting. Please help
    Tuesday, July 13, 2010 10:12 AM
  • Vinny,

     

    Thank you! This is the actual solution to this problem.

     

    As to the other solutions:
    gpedit.msc fix:"User Configuration -> Administrative Templates -> Start Menu and Taskbar -> Remove and prevent access to the Shut Down, Restart, Sleep, and Hibernate commands" to Disabled.

    All that the above does is enable the "power button options" icon be visible when the user presses CTRL+ALT+DELETE keys in the lower right corner of the screen. This does not affect that Start menu options once a user has actually logged in.

    Solution to the START menu problem:

    Computer Configuration -> Windows Setting -> Security Setting -> Local Policies -> User Right Assignment is a control for Shutdown, and the group "Users" was not in the list.

    This is the answer. The "Users" MUST be in this group. Even if you want this policy to apply for Domain Users, just adding "<domain>\Domain Users" will not work.

    Thanks again. 


    Thursday, August 19, 2010 4:18 PM
  • Hi all,

     

    I am following this thread because we have the same issue with a Windows 7 Ultimate 64bit installation on a Dell Latitude D830.


    I cannot enable the shutdown-restart buttons in the Start menu.

    Like you already explained the group 'Users' is not in the list, but I am not able to put Users in the list. The only entry is Administrators and I cannot add any other user or group.

    Even when I log in with a domain administrator account or the local administrator account, I cannot add 'Users'.


    Does anybody have an idea?

    Thx in advance.

    Thursday, May 12, 2011 3:23 PM
  • I had the same problem you need to make sure that you right click on the gpedit.msc file and select run as administrator. Once you do that follow the instruction and you should be go to go. Hope this is helpful.
    Wednesday, May 25, 2011 8:51 PM
  • Dear All,

     

    I had the same issue, and sorted it out by going into C:\Windows\System32\drivers.... the search for: SndSpkr.sys and SndTmr.sys . the I deleted both, then restart...that's it  everything else you do will work.

     

    Hope this helps.

    Saturday, October 01, 2011 5:15 PM
  • HI there Arthur!

     

    Just wanted to thank you! This worked for me with flying colors but I would not recommend it to a rookie! Making changes in the registry is not for the ill of heart!

    Wednesday, October 26, 2011 3:11 PM
  • I found this on another forum and it works great:

    If you are on a Samsung or Sony [there might also be others], then there is a "helpful" utility installed by the PC maker that is inhibiting your ability to set power plans. Type fast start in the Start menu search box & if such a utility exists then go to it & disable it - there are no unwanted side-effects. It achieves nothing that you cannot do yourself.

    For other PCs, go to the maker's folder in all programs and look for any similar name - fast start, fast sleep, mess-up-your-power-options.exe, that kind of thing.

    Since the symptom first reported by the sufferers of this afliction is always - cannot change what happens when I change the lid - I think you'll be right as rain when you've disabled Fast Start.

    Let me know how you get on,

    {I would say, "Good luck", but you will not need any luck

    • Proposed as answer by trose80 Friday, August 16, 2013 9:53 PM
    • Unproposed as answer by trose80 Friday, August 16, 2013 9:53 PM
    Thursday, June 07, 2012 8:49 PM
  • Under Computer Configuration -> Windows Setting -> Security Setting -> Local Policies -> User Right Assignment is a control for Shutdown I could not add the local administrator or users, Domain users is there, and add users button is grayed, any body have solution to add local admin /user ?
    Sunday, June 10, 2012 6:24 PM
  • Sheep,

                   IF your environment is controlled by AD, you can actually reset the workstation's account. Also, remove the workstation from the domain and rejoining it, and restart.

    • Proposed as answer by phllyy Monday, April 08, 2013 6:57 PM
    Monday, April 08, 2013 6:57 PM
  • 1.Reboot comp

    2. Tap F12

    3.Go into Bios>Video Settings>Enable Optimus. 

    4. Eat bacon

    Monday, September 23, 2013 4:28 PM