none
DNS Server Isn't Responding error when attempting to connect via wireless router

    Question

  • Hi, all. Every time I attempt to connect to the internet via my wireless router, I get the error message 'DNS Server Isn't Responding'. I have a Linksys WRT160N. I've already restarted the modem, router, and my laptop. When I connect directly to my laptop from the modem, I can easily connect to the internet. It's just the router that has issues.

     

    I also should add we got a new modem yesterday.

     

    And here is the ipconfig/ all.

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\Kali>ipconfig/all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Kali-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Peer-Peer
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Atheros AR8152 PCI-E Fast Ethernet Contro
    ller (NDIS 6.20)
       Physical Address. . . . . . . . . : 00-26-6C-59-D7-58
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::8195:49a8:46a:15c9%13(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Tuesday, December 07, 2010 10:05:15 AM
       Lease Expires . . . . . . . . . . : Wednesday, December 08, 2010 10:33:18 AM
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 335554156
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-B3-A7-A3-00-26-B6-EA-A0-43

       DNS Servers . . . . . . . . . . . : 208.67.220.220
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wireless Network Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
       Physical Address. . . . . . . . . : 00-26-B6-EA-A0-43
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{84BB7D5A-4B05-490E-9152-276B3B00D571}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{428F79B9-E62F-4783-9B44-AC4A65C6151B}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:3013:3c16:47d1:a5c4(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::3013:3c16:47d1:a5c4%16(Preferred)
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    C:\Users\Kali>

    Tuesday, December 07, 2010 4:18 PM

Answers

All replies

  • Three things spring to mind as possible causes:

    1.  Your router isn't configured correctly to point to your ISP's DNS servers.

    2.  Your PC isn't receiving the correct DHCP configuration from the router; ie. it's not pointing at the router for its DNS.

    3.  Although most have moved away from this, it's just possible that your ISP requires MAC registration and you registered your PC and not your router, thus the ISP isn't recognizing the connection when the router is attached to the modem.

    Tuesday, December 07, 2010 4:41 PM
  • When I initially set up the modem, my ISP told  me I would need to configure my router. However, they did not tell me how. When I type in the router's IP address to get to the settings, it says the page is taking too long to respond and doesn't load.
    Tuesday, December 07, 2010 4:44 PM
  • Then this is more of a Linksys issue than a Windows 7 one.  Still, there's a couple things you can check:

    Make sure the ethernet cable from the modem is plugged into the router's WAN port and not one of the LAN ports.

    Don't try to configure the router via wireless; use an ethernet cable from the PC to one of the router's LAN ports.  Once everything's configured it can be maintained via the wireless.

    Are you using DSL or cable?  I ask because configuring a router for DSL is different than it is for cable.

    Tuesday, December 07, 2010 5:01 PM
  • Sorry if I'm in the wrong place.

    I'm on DSL. But like I mentioned earlier, I can't access the router's settings page. So, I'm not sure how to configure it.

    Tuesday, December 07, 2010 5:03 PM
  • Okay, not an issue.  You may have a bad router though, if you can't get to the configuration page.

    It's been a while since I've set up a router for DSL, but here goes...

    You'll need to remove any software that you installed on your PC for your DSL service  (actually you don't, you just have to disable its connection, but I've always found simple removal to have fewer steps).

    Connect your PC to your router via ethernet to one of the router's LAN ports.

    Connect your router to your DSL modem via the router's WAN port.

    Make sure everything is powered on.  Use this sequence: Modem, Router, then PC.

    Your PC should now be getting its IPv4 address from the router.

    Try to connect to the router's configuration page. (http://192.168.1.1)

    Once on the Basic Configuration page you'll need to change the connection type to whatever your ISP is using.  DSL is usually (but not always) PPoE.

    Enter your ISP account information - username and password (and maybe domain name).

    Save the settings.  The router will reboot.

    Try to connect to the internet now, while still using the ethernet cable.  Does it work?  If so, go back to the router's configuration and set up your wireless.

    Tuesday, December 07, 2010 5:23 PM
  • I tried to  connect my PC to the router via ethernet. I get a new error message this time: "Local Area Connection" doesn't have a valid IP Configuation
    Tuesday, December 07, 2010 5:31 PM
  • Yeah, that's because it's trying to get its address from your ISP.  You'll need to remove your ISP's software or mess with your ethernet setting to disable PPoE on your network connection.
    Tuesday, December 07, 2010 5:37 PM
  • How do I do that? Sorry, but I know nothing about computers.
    Tuesday, December 07, 2010 5:48 PM
  • And yet you managed to post an IPCONFIG /ALL...  I know, not terribly difficult, but you'd be surprised at how many people don't have a clue.

    Anyway, could you possibly post an IPCONFIG /ALL from when it's hooked up to the router?  You'll probably have to save it as a .txt file, then open it in notepad and copy and paste it when you reconnect to your modem.  

    If you don't know how to output it to a .txt file you just append ">c:\ipconfig.txt", without the quotes but with the ">", to the IPCONFIG /ALL command.  This will create the text file in the root of your C: drive which you can then open with notepad at a later time.

    Tuesday, December 07, 2010 7:03 PM
  • I think the problem was in the router itself. I unplugged it and when I tried to plug it back in, it wouldn't light up at all.
    Tuesday, December 07, 2010 8:32 PM