locked
Ctrl key stuck on client when switching away from rdp session, alt-gr not honoured on host

    Question

  • Windows 8 Release preview / 64-bit

    Remote desktop session to a windows 7/ 2008R2 host (probably others too, but haven't tested):

    Client uses keyboard with alt-gr key (in my case, Belgian - Period).

    When first typing in the remote host, the alt-gr key is not honoured (need to press alt-gr twice in order to access alt-gr characters)

    If an alt-gr character was used in the remote session, when switching back to the client, the ctrl key is stuck in the client OS (need to press ctrl once to get at normal characters)

    Wednesday, June 13, 2012 5:38 AM

Answers

  • What is the kind of your keyboard? Have you installed any drivers or filter drivers for the keyboard?

    You may test whether the issue occurs with a regular USB keyboard.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    Thursday, June 14, 2012 3:13 AM

All replies

  • What is the kind of your keyboard? Have you installed any drivers or filter drivers for the keyboard?

    You may test whether the issue occurs with a regular USB keyboard.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    Thursday, June 14, 2012 3:13 AM
  • Thanks, I've traced the problem to  a faulty automatic keyboard switch. Everything works fine if I take the switch out of the loop.
    Thursday, June 14, 2012 2:11 PM
  • I have exact problem on Windows 8 Release Preview Build 8400.

    I use Logitech K800 Wireless keyboard (with Unifying receiver), no keyboard switches.

    The problem doesn't occur if I set "Apply Windows key combinations" to "On local computer".

    Is there a solution for this problem? I suppose this is a problem with the keyboard-system compatibility but I'd rather not change the keyboard.

    Sunday, October 14, 2012 3:50 PM
  • My keyboard is also a K800 so it wasn't the switch after all...

    You'll be happy to know that the problem is gone in Windows 8 RTM

    • Proposed as answer by surfenPL Sunday, October 14, 2012 4:00 PM
    • Unproposed as answer by surfenPL Sunday, October 14, 2012 4:01 PM
    • Proposed as answer by surfenPL Friday, April 19, 2013 5:15 PM
    Sunday, October 14, 2012 3:55 PM
  • I confirm, switching to Windows 8 RTM fixes this problem.

    • Edited by surfenPL Friday, April 19, 2013 5:15 PM
    Sunday, October 14, 2012 4:01 PM