none
Windows 7 Remote Desktop says: "The credentials that were used to connect to xx.xxx.xxx.xx did not work. Please enter new credentials".

    Question

  • Whenever i try to log on to my work server using remote desktop on windows 7, i get the above message (with xx.xxx.xxx.xx being the servers IP adress), no matter what i try. I have allowed connections from computers running any version of remote desktop in control panel -> system and security ->allow remote access, but to no avail. I have also tried using the domain name instead of the IP, but it still wont work.

    I can access the server from my XP machine, so the problem must be on the windows 7 machine somewhere.

    I hope you can help me.
    Tuesday, March 09, 2010 7:04 PM

Answers

  • Hi,

     

    I suggest you create a new admin account and login on the machine with new created account to check the result. If the issue persists, please restart the machine with the original user account and collect the following log file for research.

     

    Collect Event log

    =========================

    a. Click "Start", input "eventvwr" (without quotation marks) in the Start Search bar and press Enter.

    b. Right click on "Application" on the left frame, choose "Save Log file As"; in the pop-up window, click to choose the Desktop icon on the left frame, input "app" in the "File name" blank, and then click save.

    c. Right click on "System", with the same method, save it as "sys".

    d. Locate the two saved log files on the Desktop and upload it.

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Wednesday, March 17, 2010 2:09 AM
    Monday, March 15, 2010 7:43 AM

All replies

  • Hi,

    Please refer to the suggestions from the link below to troubleshoot the issue.

    Why can’t I connect using Remote Desktop Connection?

    Thanks,
    Novak
    Thursday, March 11, 2010 6:29 AM
  • I tried those steps and i still get the samme error. I'm also sure that the server i working as i have no problem accessing it from my xp computer, and i have doublechecked the IP, and it is correct.

    Very strange.
    Friday, March 12, 2010 4:51 PM
  • Hi,

     

    I suggest you create a new admin account and login on the machine with new created account to check the result. If the issue persists, please restart the machine with the original user account and collect the following log file for research.

     

    Collect Event log

    =========================

    a. Click "Start", input "eventvwr" (without quotation marks) in the Start Search bar and press Enter.

    b. Right click on "Application" on the left frame, choose "Save Log file As"; in the pop-up window, click to choose the Desktop icon on the left frame, input "app" in the "File name" blank, and then click save.

    c. Right click on "System", with the same method, save it as "sys".

    d. Locate the two saved log files on the Desktop and upload it.

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Wednesday, March 17, 2010 2:09 AM
    Monday, March 15, 2010 7:43 AM

  • I encountered the same problem.  Remote Desktop worked fine with Windows XP but failed when I tried to run it with Windows 7.  The problem turned out to be that the firewal was blocking the Reomote Desktop port.  Try the following:

    If you're using Windows Firewall:

    1.       Open Windows Firewall by clicking the Start button , and then clicking Control Panel. In the search box, type firewall, and then click Windows Firewall.

    2.       In the left pane, click Allow a program or feature through Windows Firewall.

    3.       Click Change settings.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

    4.       Under Allowed programs and features, select the Remote Desktop check box, and then click OK.

    Restart Remote Desktop.....  and everything should hopefully now work.

    Wednesday, March 17, 2010 6:29 PM
  • Screw Microsoft. Use "Terminals" app
    http://terminals.codeplex.com
    M.K.
    Monday, July 18, 2011 12:31 PM
  • Hi,

     I have the same problem with original poster.

     XP Machines have no problem connecting to Brand New Windows 2008 Terminal Server.

     But only Windows 7 Machines can't.

     I tried all kinds of suggestions, but it still does not work.

    Windows Firewall on Windows 2008 server has remote desktop already checked.

    I even tried to disable Windows Firewall, but still the same problem.

    Can someone help?

    • Proposed as answer by SLEE_OH Wednesday, September 14, 2011 7:11 PM
    • Unproposed as answer by SLEE_OH Wednesday, September 14, 2011 7:11 PM
    Wednesday, September 14, 2011 5:56 PM
  • I know this is way after the fact but I ran into something similar. The RDP from XP would open fine and did not have that initial login prompt. RDP from Win7 failed because I couldn't get past that extra login prompt.

    I was able to resolve by opening the .rdp file with Notepad and editing it (either the one saved for that particular server or just the default.rdp file hidden in My Documents).

    I placed the following line in it, saved it, and then launched it:

     

    enablecredsspsupport:i:0

    Found the info here:

    http://www.boredsysadmin.com/2008/06/how-to-disable-credentials-prompt-of.html

    Wednesday, November 02, 2011 10:35 PM
  • Just had exactly the same problem but the answer was very simple for me...

    in the RDP dialog I clicked the Options button to get at the advanced settings and in the general tab I put the username as DOMAIN\USERNAME as when the username and password was being sent to the server it was sending as HP-PC\USERNAME which of course was not the same domain as our server therefore was being rejected.....

    Check the system logs on the server and see if the logon attempt is 1. getting that far 2. the reason for refusal of the logon.

    Hope it helps.

    • Proposed as answer by mark kaminski Tuesday, March 13, 2012 7:51 PM
    • Unproposed as answer by mark kaminski Tuesday, March 13, 2012 7:52 PM
    • Proposed as answer by ukit Friday, October 12, 2012 9:02 AM
    Friday, November 11, 2011 1:56 PM
  • This error can happen if you generate a "standard" copy of windows server 2008 r2 and try to use it as the base VHD file, for creating other new servers.  We did this so we wouldn't have to keep re-installing 2008 R2 and applying all the service packs, in our  virtual environment. If you try this, you have to run the sysprep utility against your base copy of the VHD, before deploying it to other systems, as a Virtual Machine.  So, remove the VM that you want to use, from the existing domain and put it in a workgroup.  Then run sysprep. 

    When you re-boot a copy of your now "standard" VHD, you will have to re-join a domain and you'll have to change the name of the VM, because sysprep will set it to something strange.  For more information, see here:

    http://www.rayheffer.com/619/cloning-windows-server-2008-r2-use-sysprep-no-more-newsid/

    Or simply do what Ray says:

    1) Run Sysprep (on Windows Server 2008 this is located in c:\Windows\System32\Sysprep\Sysprep.exe)
    2) Ensure ‘System Out-of-Box Experience (OOBE)’ is selected
    3) Tick the ‘Generalize’ option (this resets the SID)
    4) Select ‘Shutdown’ from the Shutdown Options.
    5) Once the machine has shutdown, take your image and you are good to go!



    Tuesday, March 13, 2012 8:08 PM
  • "in the RDP dialog I clicked the Options button to get at the advanced settings and in the general tab I put the username as DOMAIN\USERNAME as when the username and password was being sent to the server it was sending as HP-PC\USERNAME which of course was not the same domain as our server therefore was being rejected.....

    Check the system logs on the server and see if the logon attempt is 1. getting that far 2. the reason for refusal of the logon.

    Hope it helps"

    this was the answer for me...

    so simple.. yet my frustration level was so high, i would have never found this on my own.  tough to think when angry.. anyway.. thanks!!!


    Wednesday, April 18, 2012 2:25 PM
  • "in the RDP dialog I clicked the Options button to get at the advanced settings and in the general tab I put the username as DOMAIN\USERNAME as when the username and password was being sent to the server it was sending as HP-PC\USERNAME which of course was not the same domain as our server therefore was being rejected.....

    Check the system logs on the server and see if the logon attempt is 1. getting that far 2. the reason for refusal of the logon.

    Hope it helps"

    this was the answer for me...

    so simple.. yet my frustration level was so high, i would have never found this on my own.  tough to think when angry.. anyway.. thanks!!!

    What was the solution? I have 15 desktops running windows 7, I can't connect via RDP from a windows XP box when it is using NLA. When I unckeck NLA I can connect without any issues. I can't go to all 15 systems to physically log in and disable NLA and I don't have access to the group policies on our servers. Does anyone know a way to disable NLA remotley...or a fix to this RDP authentication issue? I can't actually start trying to resolve the actual problem these 15 machines are having without being able to RDP in.

    Tuesday, May 01, 2012 5:08 PM
  • Thanks for the advice.  Worked like a charm.  We have a Windows AD Domain, and I had to specify that the credentials were domain  (domain\username) instead of just username.

    Thanks!

    Thursday, May 03, 2012 11:28 PM
  • What do you do when none of these solutions work?

    I've literally done thousands of PCs and this problem suddenly cropped up on brand spankin- new machines. Verified firewall, password, network settings, tried new profile, checked login credentials (machine\loginname) etc. Still no dice, no remote access.  I'll try to fully patch the Win 7 x64 machine, but this is ridiculous (it works for the other 100+ windows x64 Pro machines, why not these new ones?  Is there a difference?

    Thursday, July 05, 2012 9:16 PM
  • Thanks a million! This worked for me. I would not have thought of that.

    Saturday, September 08, 2012 8:19 PM
  • regarding AndersSorensens problem, this worked for me:

    asuming all settings on the computer you want to connect to (might be your "work PC") are set properly (..connections from computers running any version.. ; allow remote access ; etc.)

    The PC with which you want to connect to your PC at Work (might be your "Home PC"):

    - "windows security" dialog box:  "enter your credentials"

    --> klick: "use another account"

    --> Login: "your login at Work PC"@"domain name of your work PC"  /alternatively:   @"complete computer name of your work PC" 

    --> PW: "your password at work"

    You get the domain / computer name of your work PC as follows: (only at your work PC of course, NOT the home PC)

    "windows button" --> right klick "computer" --> "properties"

    Thursday, November 29, 2012 10:31 PM
  • i use to have the same problem, what happen is, sometimes when you change
    your user name the computer never reconize it, and remain the same in local disk (c) user folder.

    go to - my computer -> local disk  (c) -> user

    then you will find a folder with a lock on it, then use this folder name for your user name on remote desktop.

    • Proposed as answer by Mohanarangam Monday, April 28, 2014 4:10 AM
    Thursday, January 10, 2013 5:59 AM
  • I had a similar issue with one of our Remote App server, where the client was unable to connect from a Windows 7 client. It turned out to be the certificate that TS was using had expired. Renewed the certificate and pointed to the new one and everything is now working.
    Friday, February 07, 2014 6:39 PM
  • Thanks Alphonse, This step has worked for me :)
    Monday, April 28, 2014 4:11 AM
  • We are having this exact problem with few of our Windows 7 workstations. Funny thing is that some Win7 workstations can make the RDP connection to the server with out a problem (like my own) but then some give that "The credentials that were..." error.

    We know those accounts work because they function from RDP connection made from my workstation (and when you log on locally from console) but not from my collegues workstation. It does not matter if you try to log on with a domain user account or a local user account. It does not matter if you user domain\user or user@domain type of credentials while connecting. Our RDP settings are identical (we copied my local.rdp to his machine). Funny part is that from the machine that does not work you can still lock the user account by entering wrong password few times in a row. When you use correct user/password it just gives the "The credentials..." error but does not lock the user account.

    I have already tried about anything I can imagine (from disabling NLA to all the possible RDP settings in the server side). Though the setting work fine with my Win7 workstation. I cannot figure out what is different in our workstations so that mine work but his doesnt.

    If anyone has any suggestions I will gladly take the input :)

    Monday, September 22, 2014 12:25 PM