none
Unable to change primary display when using dual monitors

    Question

  • I am running Windows 7 RC Build 7100 in VMWare 6.5. The host OS is Vista x64 Home Premium running on a Dell Studio 1535. I have a Dell monitor attached as a secondary monitor, and I am attempting to share the desktop across both monitors. While I can do that, Windows 7 insists on using the external monitor as the primary monitor, and if I attempt to change the main display to the laptop monitor I am greeted with 'Unable to save display settings.' when I attempt to save. This dialog is shown twice. Has anyone else experienced this or know of a workaround?
    Tuesday, May 12, 2009 2:16 AM

Answers

  • Same here!
    Any solution?

    Works fine, btw my monitor is the secundary and my tv is the primary.
    Microsoft can't make a feature to change the ID's of the monitors? so simple!
    Monday, May 18, 2009 6:39 PM

All replies

  • I have a similar problem with my HP zd8000 with its ATI 600 Video card. I have a second LCD connected and it is detected as monitor #2. I can duplicate the desctop on both monitors but if I attempt to extend across both, it will put the main desktop on monitor #2. I can move open windows between monitors but I cannot reverse them.
    Thursday, May 14, 2009 1:41 AM
  • I have a system with Windows 7 RC1 and two monitors -- similar problem.   My main monitor is a Viewsonic and my secondary is a Samsung plasma TV.  When my system boots, BIOS posts to the Viewsonic as it should, but as soon as Windows 7 starts, it initializes the TV and the ViewSonic goes to power-save mode.  No matter what I do, Windows 7 will not recognize 2 displays and turn on the ViewSonic.

    I have simulated the same problem with Vista x64.

    I have tried multiple versions of the nvidia drivers (GTX 260)

    Windows XP Pro 32bit has no problem identifying both display and working in any configuration.

    I suspect this is an issues with x64 Windows.

    I hope we get some guidance on this.

    Thanks!
    Sunday, May 17, 2009 2:41 AM
  • Same here!
    Any solution?

    Works fine, btw my monitor is the secundary and my tv is the primary.
    Microsoft can't make a feature to change the ID's of the monitors? so simple!
    Monday, May 18, 2009 6:39 PM
  • I've seen a number of topics on this problem on a number of forums, but I thought I'd bump this old thread since it was the one I happened to be on at the moment. I've got the single most frustrating situation involving this problem. I had been running the Windows 7 release candidate since last fall, but it was about to expire. So this weekend I installed the final x64 Windows 7 and ran into this issue, which I did not have before. Here's my setup:

    GeForce GT 220
    Dell 2405FPW LCD as my main monitor (connected via DVI)
    Epson Cinema 720 projector (connted through HDMI via Onkyo TX-SR606 receiver, including audio from PC to receiver through this HDMI feed)

    This setup worked BEAUTIFULLY on my previous release candidate install. I don't recall which nVidia driver I was using on the release candidate setup, but it surely wasn't too old (I'd updated it once or twice over the months).

    But here my problem with the new Windows 7 final setup. It's unbelievably frustrating, too. Windows 7 insists on identifying the receiver/projector as monitor #1 and my main LCD as #2. Only if I power off the receiver does the LCD take #1 position (cause it's the only one, of course). If, however, I have the receiver turned on in addition to the projector also being on, things will work as I want, with the LCD behaving as the primary (I've check the "Make this my main display" option on the Dell LCD), even though it's still identified as #2. However, if I have the projector turned off and the receiver still turned on, the machine insists on making the LCD the secondary monitor. I just get the wallpaper and nothing else (no taskbar, apps, etc). I can move the mouse around on it, and if I blindly guess the right hotkey and mouse movements, I can move an app over to it. If I guess the right Windows+P actions, I can set it to "Projector Only," which gets me what I want visually as the projector and monitor identifications are backwards no matter what I do or don't have powered on (surely the result of the identities of the monitors being backwards). Problem with that is that it also disables the audio coming over the HDMI to the receiver when I do that. So basically, it's a no-win scenario. If I could just get it to set the LCD as #1 and the projector/receiver as #2 (no matter if the receiver and/or projector were on or off), it would surely solve all my problem. But alas, I cannot in all my screwing around figure out a way to get it to do that. I've tried the latest final version of the nVidia drivers (196.21) and the latest beta version (196.34), and they both behave identically.

    Is there some registry tweak I can do to change the identity of the monitors?

    Oh, here's a particularly fun side effect of the issue. If I have the projector off (which most of the time I do) and the receiver on (which I always do), when the computer starts it POSTs to the correct main LCD screen, but as soon as Windows 7 kicks in, all I get is a blank screen (as it's using the HDMI connection as the primary at that point), so I am unable to see the logon screen unless I turn off the receiver.

    Also, I don't know if this issue is directly related to my problem, but it's nice to see Microsoft offer a solution in the months since they posted this:


    </sarcasm>

    Any help would be GREATLY appreciated. This glitch is driving me bonkers.
    Tuesday, February 23, 2010 12:47 AM
  • wow, this is EXACTLY what happens to me!  What is wrong with this operating system
    Saturday, March 06, 2010 4:23 AM
  • Control Panel-->Appearance and Personalization-->Display--> Change Display Settings

    or

    Control Panel --> Display --> Change Display Settings

    Click "Identify" to see your primary (1) and secondary (2) monitor.

    Click the "Display" Drop Down Menu.

    Choose your intended primary display on the drop down menu.

    Check the box "Make this my primary display." (It appears under "Multiple displays" when you choose the the secondary display in the "Display" drop down menu.)

    Click Apply.

    If you check identify, your primary and seondary monitor will remain as they were before, but the display will show your choices for primary and secondary.  This how it worked for me.

     

     



    Sunday, November 13, 2011 3:00 PM