none
how to connect XP and win7

    Question

  • I have a DSL modem with a wireless router in the same box from bell. the desktop is connected by ethernet cable and runs XP. I have a laptop with wifi running win7. the laptop says there is a home group but shows itself only. running the network wizard on the desktop creates a network, but again only the desktop is shown.

    How can I make them see each other??

    addtl: laptop has McAfee and desktop has AVG with firewalls.

     

    Monday, October 17, 2011 6:03 PM

All replies

  • StephenCB wrote:

    I have a DSL modem with a wireless router in the same box from bell.
    the desktop is connected by ethernet cable and runs XP. I have a
    laptop with wifi running win7. the laptop says there is a home group
    but shows itself only. running the network wizard on the desktop
    creates a network, but again only the desktop is shown.

    How can I make them see each other??

    addtl: laptop has McAfee and desktop has AVG with firewalls.

     

    Change your network on your laptop to a work network, that way you get
    away from the homegroups (Homegroups do not work with XP PCs). Then you
    have to setup both (PC and laptop) to use the same Network settings and
    enable file and print sharing on both machines. Also turn on network
    discovery in Advanced sharing options on your Win7 laptop. Lastly you
    have to define, which files are shared and who is allowed to access the
    shared files.


    Wolfgang
    Monday, October 17, 2011 7:27 PM
  • can you pls explain how to 

     

    setup both (PC and laptop) to use the same Network settings 

     

    Thanks a lot.

    Monday, October 17, 2011 8:24 PM
  • StephenCB wrote:

    can you pls explain how to 

     

    setup both (PC and laptop) to use the same Network settings 

     

    Thanks a lot.

    In windows XP it's called Network Connections; in Win7 you find them
    under Network and sharing Center / Change adapter settings.

    There under the properties of a Network Connection you need the "Client
    for MS networks" and "File and Printer Sharing for MS networks" enabled
    and installed as well as TCP/IP on WinXP and TCP/IPv4 on Win7. The
    other entries here are not necessarily needed for file-sharing between
    PCs.

    You should enable NetBIOS over TCP/IP on the WINS tab of the properties
    of TCP/IP resp. TCP/IPv4 . The rest of the TCP/IP settings can remain
    default i.e.: everything popuplated by DHCP.

    You have to use the same workgroup for both machines, which you set via
    Properties of the Computer, by default this should be WORKGROUP, but
    you can set that to anything you like.

    Then after restarting with the new settings check the configuration by
    entering ipconfig -all in a cmd-prompt window. You should see both
    machines with similar but different IP-addresses and the same netmask
    and the same default gateway. In fact they have to be on the same
    subnet (that means if you do a logical AND of IP-address and netmask
    for both machines you get the same result). If you don't know how to do
    that, post both IP-address/netmask pairs and almost anybody here can
    tell you if they are on the same subnet.


    Wolfgang
    Monday, October 17, 2011 9:19 PM
  • I have a DSL modem with a wireless router in the same box from bell. the desktop is connected by ethernet cable and runs XP. I have a laptop with wifi running win7. the laptop says there is a home group but shows itself only. running the network wizard on the desktop creates a network, but again only the desktop is shown.

    How can I make them see each other??

    addtl: laptop has McAfee and desktop has AVG with firewalls.

     


    First of all i would suggest you to configure both firewall to allow the network access for both xp & win 7, if you don't know how to go about it, i would suggest you to uninstall it for the time being and next ensure network & file sharing is enable for both xp & win 7 and turn off password protected sharing in win 7

     

    Tuesday, October 18, 2011 12:45 AM