none
How to remove Homegroup and Libraries icons from 7 RC desktop (after Vista upgrade)?

    Question

  • I took the plunge and upgraded my Vista 64 to Win 7 RC. The upgrade process lasted over 6 hours (some 300GB on my C:drive with Vista), but, once completed, it has been working really very fast & smoothly. The original Vista system is backed up of course on an external HDD.

    What annoys me though, are 2 stubborn system icons on my 7RC desktop, Homegroup and Libraries. I don't use Homegroup and Libraries can be accessed via Taskbar or Start menu, so I want to get rid of these two icons, but they cannot be remove from the desktop as such, like "normal" icons.
    Personalize -> Change Desktop Icons doesn't seem to offer any solution for these 2 icons.
    I never had those desktop icons on earlier clean installs of Win7 Beta (on separate dual boot HDD), only now after the massive Vista->7RC upgrade.
    I also have retained an earlier "unofficial" other Win 7 7100 on another HDD (with less installed apps.), for comparison.

    Is there any registry hack or other method to remove these desktop icons?

    I'd be grateful for a solution.

    T.i.a.
    Uffe

    System specs: MB: Asus Rampage Formula, CPU: E8500 @ 4005 MHz, RAM: 4 GB Corsair 8500, GPU: Geforce 275 @ 715 MHz, Sound card: X-Fi Fatal1ty Extreme Gamer, HDD: 4 internal total 1.4 TB + 3 external for backups
    Thursday, May 07, 2009 11:39 AM

Answers

  • If a rightclick does not show a 'delete' item, it's probable that you have an ownership setting problem. You can rightclick the icon, then properties, Security tab, and Edit your user rights.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Saturday, May 09, 2009 5:55 PM
    Moderator

All replies

  • If a rightclick does not show a 'delete' item, it's probable that you have an ownership setting problem. You can rightclick the icon, then properties, Security tab, and Edit your user rights.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Saturday, May 09, 2009 5:55 PM
    Moderator

  • Right click Homegroup icon on desktop select Change Homegroup settings and choose Leave homegroup
    • Proposed as answer by KiRon69 Thursday, May 28, 2009 5:35 AM
    Thursday, May 28, 2009 5:35 AM
  • Hi,

    I recently deployed 7 into a Active Directory test domain. Is there any way to remove these icons from the destkop via group policy?
    Friday, October 02, 2009 6:18 AM

  • Right click Homegroup icon on desktop select Change Homegroup settings and choose Leave homegroup

    That isn't going to work.  You don't get a properties setting on the Homegroup icon on the desktop when you're not in a homegroup.  Right clicking on the icon doesn't give the option. At least that's the way it's working on my system.

    I'm with the original poster, both of these functions can be found elsewhere and it's highly irritating to have system icons sitting on the desktop that can't be deleted.

    Just as annoying as no longer having an option to select a Classic Mode menu, which doesn't make much sense seeing as how you can choose to have a Classic Mode desktop.

    Thursday, October 29, 2009 1:57 PM
  • To remove the Homegroup and Libraries icons from your desktop, open regedit.exe from the Start bar, and navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    In the NameSpace folder, there will be a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}. The value of the default item should be "Other users". This is the registry entry Homegroup icon. Delete the folder from the registry.

    In the NameSpace folder, there will be a folder (key) with the name {031E4825-7B94-4dc3-B131-E946B44C8DD5}. The value of the default item should be "Libraries". This is the registry entry This is the Libraries icon. Delete the folder from the registry.

    Go to your desktop and hit F5, the icons should disappear.
    MCP
    • Proposed as answer by Davi Nigro Tuesday, April 06, 2010 12:04 PM
    Wednesday, November 04, 2009 9:10 AM
  • Windows7 Home Premium
    After hours of being annoyed........

    1. Homegroup Icon:
    open my computer, control panel, system and security, administrative tools, services, then scroll down to: homeGroup listener and homeGroup provider, disable both. close out, log off. the icon should be gone when you log back on.

    2. Libraries Icon: carefully.......please, if no experience in registry get help.

    go to: start, run, type in: regedit, select the HKEY_Local_Machine key, navigate down finding: Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
    You will see several hexadecimal strings, select each one in turn, and the right pane will show you which icon is being selected. my library icon was the very first string and showed two lines on the right side of the page, first being: usersLibraries and the second being: remove message.

    when you find the appropriate library string, make a new folder in your my documents named: registry back up, then highlight the string on the left, go up to the top left of the registry page and click on, file then export. save the registry file in your new folder location. I also saved the two files on the right side of the page and named them what they were called on the page, so I would know what they were. (not sure I had to but did)

    After saving the registry files, next you can delete the string you have highlighted on the left which in turn, shows the name userLibraries (on the right side of the page).

    Poof it is finally Gone! available in your saved folder


    Hope this helps
    • Proposed as answer by Bazikcho Thursday, December 31, 2009 9:51 PM
    Sunday, November 15, 2009 9:47 PM
  • after i get to the HKEY_Local_Machine area, there isn't anything in anything in that folder :'(
    Wednesday, December 30, 2009 4:49 AM
  • nevermind i figured all that out. but after i deleted the string the icon was still there.
    Wednesday, December 30, 2009 5:02 AM
  • Thanks PradeepVG2!  This was easy and worked great for me.  I just deleted the two folders your listed for Libraries and Homegroup from the registry.  Now the icons are gone from my desktop. Thanks much! Gaelg
    Saturday, January 23, 2010 5:52 AM
  • Yes! it works!!
    • Proposed as answer by SomboonKH Thursday, February 20, 2014 4:47 AM
    Tuesday, January 26, 2010 7:09 AM
  • To remove the Homegroup and Libraries icons from your desktop, open regedit.exe from the Start bar, and navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    In the NameSpace folder, there will be a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} . The value of the default item should be "Other users". This is the registry entry Homegroup icon. Delete the folder from the registry.

    In the NameSpace folder, there will be a folder (key) with the name {031E4825-7B94-4dc3-B131-E946B44C8DD5} . The value of the default item should be "Libraries". This is the registry entry This is the Libraries icon. Delete the folder from the registry.

    Go to your desktop and hit F5, the icons should disappear.
    MCP


    Great PradeepVG2 ;)

    Thanks !

    Regards, Davi Nigro.


    MCP / MCSA / MCSA+M.
    • Proposed as answer by Vix2 Tuesday, April 17, 2012 2:59 PM
    Tuesday, April 06, 2010 12:05 PM
  • Worked like a charm for me!! Thanks, Pradeep!
    Friday, June 18, 2010 1:36 PM
  • PradeepVg2 ,

    You are the MAN.  I struggled to do this and you got me to it.  I come through sunnyvale/redwood, but not sure where you are.  I'd like to buy you a beer.

    Tuesday, July 20, 2010 8:23 AM
  • You the man. Worked like a charm... :) Thank you
    Tuesday, August 03, 2010 2:47 PM
  • Just used this answer and worked 100% flawless...thanks!
    Wednesday, August 04, 2010 1:04 AM
  • Thanks,

    This was just what I was looking for. I like Windows 7 but it kind of sucks when you can't modify the operating system to work the way you want it to. 

     

    Personally I think Library's is an extra process that just takes longer to get to where i want to go.

    Saturday, October 09, 2010 11:14 PM
  • THANK YOU SO MUCHHHHHHHHH !

    finally got rid of the HomeGroup !

    Tuesday, November 09, 2010 4:18 PM
  • Arh, Excellent work!!..

    'PradeepVG2' is correct it is a registry key, you have skillful knowledge when it comes to the Windows Registry.

    Thanks,

    Tuesday, December 07, 2010 7:52 AM
  • To all of you that have this problem. I too got it on my desktop but imediatelly I realized how those two got there...."Windows 7 manager" program form Yamisoft at http://www.yamicsoft.com/.

    To undo this using the "Windows 7 manager" select from left column "Customization/Customize System" then select top tab "Desktop". Here you will find "System icons on Desktop". Uncheck those you wish to remove from desktop.

     

    Palo

     

     

    Monday, January 10, 2011 2:25 AM
  • Is there a folder I can delete in the registry to get "Network," "Control Panel," and "Recycle Bin" off of the desktop toolbar, too?
    Monday, February 14, 2011 8:15 PM
  • try a program called WINDOWS 7 MANAGER  its a very helpful tool go to desktop cleaner and its well heal all of your desktop problems

    GoOD luCk 

    Sunday, March 06, 2011 10:12 PM
  • This worked! thank you :)
    Wednesday, August 24, 2011 11:25 AM
  • Yes, that registry edit (deletion) does remove the Library Icon, but it also breaks Windows Media Player's ability to RIP Cds in any format.

     

    Anyone know of another way to remove the Library Icon?

    Thursday, August 25, 2011 10:08 PM
  • Read no further everyone, this works, no registry editing or deep menu's needed.  Icon removes itself when you leave home group.
    Friday, September 23, 2011 6:29 PM
  • Read no further everyone, this works, no registry editing or deep menu's needed.  Icon removes itself when you leave home group.
    Friday, September 23, 2011 6:29 PM
  • Hi Pradeep,

    I just wanted to say thanks for something you did a couple of years back, that you probably don't even remember but which was a big help to me today. Back in Nov 2009 you took the trouble to post a solution to an annoying problem (the "Homegroup" and "Libraries" icons that stubbornly refused to die and be removed from the desktop). I know it's a long time ago but that post is still very useful to people, me included. I've just upgraded to 7 (finally!) and was really irked by the undead icons but your post drove a stake through their heart!

    Chris


    Monday, January 23, 2012 11:39 PM
  • Not sure if you've solved this problem in the meantime but if you right-click on the desktop, then click Personalize, then Change Desktop Icons, and then uncheck the ones you want to disappear.

     

    Sorkaa - Irish?

    Monday, January 23, 2012 11:59 PM
  • Absolutely fantastic - quick, no worries solution, and it worked!  Thank you so much.
    Tuesday, April 17, 2012 3:00 PM
  • i have had windows 7 on my pc since the beginning and one night the homegroup icon just suddenly showed up. not sure how it got there, it wasnt a shortcut and there was no right click option to remove it. after reading someone elses advice i right clicked on the desktop, selected personalize, then in the upper left corner of that window select change desktop icons. there was no option to show or remove the homegroup icon so i simply hit "restore default", hit apply and then "OK" and it was gone.
    Wednesday, August 29, 2012 5:21 AM
  • This will not work as there is no properties option when you right click, see the post below from KiRon69 for the correct way to do this.
    Wednesday, September 25, 2013 5:11 PM
  • The first option is the one I needed. The 'Homegroup' icon popped onto my desktop after downloading 'War of Warplanes'. I used your method and did not even have to restart my PC before it had gone.

    Many thanks,

    themaestro023

    (Win 7 Ultimate)

    Monday, February 03, 2014 1:37 PM
  • Happy to see that my suggestion helped many of you. I just got the same issue today and was able to fix using the same key which I had forgotten. It has been a very long time since stopped using the online forum, happy to have got the problem on my PC to realize that I could help many more with their PC issues going forward.


    MCP

    Tuesday, April 15, 2014 9:57 PM