none
DVDs plays but no sound

    General discussion

  • Can't figure out what's going on.  Music files and all other sounds play perfect.  Pop in a DVD and WMP plays it, but dead silence.  Shut WMP down and play music files again just fine.

    Anyone know what's going on?
    Sunday, April 19, 2009 2:36 AM

All replies

  • Have you looked at any of the volume controls? There are mute and other settings you can check.

    It's also possible the dvd install has put filter entries in the registry.
    Troubleshooting DVD playback in Windows Media Player 
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Sunday, April 19, 2009 9:39 AM
    Moderator
  • Well, I'm just going to assume W7/WMP has poor DVD support out of the box.  I installed PowerDVD and it plays everything perfect.
    Monday, April 20, 2009 1:47 AM
  • On a clean Windows 7 beta, Windows DVD play should not have issues. Your issue can be caused by some third party DVD Codec that is not compatible with Windows 7 beta or WMP 12. I suggest that you remove all third party DVD packs and players, including Power DVD, then check the result.
    Arthur Xie - MSFT
    Monday, April 20, 2009 9:14 AM
    Moderator
  • On a clean Windows 7 beta, Windows DVD play should not have issues. Your issue can be caused by some third party DVD Codec that is not compatible with Windows 7 beta or WMP 12. I suggest that you remove all third party DVD packs and players, including Power DVD, then check the result.
    Arthur Xie - MSFT

    No - install a codec package - you should now be able to watch dvds on wmp - there are a lot of german users complaining about this, but installing a codec pack should solve your problem
    Tuesday, April 21, 2009 11:23 AM
  • On a clean Windows 7 beta, Windows DVD play should not have issues. Your issue can be caused by some third party DVD Codec that is not compatible with Windows 7 beta or WMP 12. I suggest that you remove all third party DVD packs and players, including Power DVD, then check the result.
    Arthur Xie - MSFT

    No - install a codec package - you should now be able to watch dvds on wmp - there are a lot of german users complaining about this, but installing a codec pack should solve your problem
    As impressive as Windows 7 is about automatically downloading drivers, I'm disappointed that me (and countless others) will have to hunt through the internet trying to find an obscure, confusing codec install of some sort just to play a DVD.  Thumbs down to MS on this one.
    Wednesday, April 22, 2009 10:00 PM
  • Greetings benway,

    you can look for "official" codecs here in this link

    G'luck and regards.
    W7 Beta running on an AMD Semprom 3200+ (1800Mhz) with 2 Gbs of RAM and a built-in Nvidia 6100 VGA, and mate, it runs like a charm! And now on my VAIO FE31M Laptop.
    Friday, April 24, 2009 7:20 AM
  • Hi,
    I had the same problem as you in two different computers (both runing Win7 64 bits) after a clean install.
    Just wanted to share a sollution that worked for me, which I found in another forum:

    Basically go to Sound -> Speakers (right clic) -> Properties -> Advanced -> Uncheck : "Allow applications to take exclusive control of this device".
    Hope that works for you.

    • Edited by danielgr Monday, November 16, 2009 4:00 PM added SO info
    Thursday, September 24, 2009 8:41 PM
  • Yes, this *is* the solution. It fixed the lack of DVD audio in WMP 12 for me in a clean Windows 7 64-bit installation. Oddly, a 32-bit Windows 7 installation on another PC doesn't care if "exclusive control" option is checked or unchecked.
    Monday, November 16, 2009 3:10 PM
  • This is what worked for me with Windows 7 32Bit with same issue.  I was getting the Video of a DVD but NO SOUND!

    In Windows Media Player, Rightlclick and select "More Options"  >> select "Devices" tab >> select  "Speakers" in the Devices list>> "Properties"


    In the "Select Audio Device" drop down box it had "Default Audio Device".  I changed this to my Hardware Sound Device which was the other option in the drop down box. 

    Closed and reOpened Media Player and then finally the sound came through the speakers with the video on a DVD
    Wednesday, December 23, 2009 9:18 AM
  • danielrg, thank you so much for the solution. Your suggestion really WORKS!!! I had this problem on my Vista before. I completely reinstalled my operating system to Windows 7 (not because of the sound problem) and the problem remained. I was desparate, I tried to install codec package as I found recommendations to do it in other forums. Nothing however helped until I found your solution! I cannot believe it was so easy.
    Friday, October 15, 2010 8:26 PM
  • This problem still exists. I just did a clean install (32 bit) and installed all updates and had this problem. Unchecking the exclusive control box fixes it but I think that's "hacky" if you ask me. You don't want system sounds playing over a DVD your watching.

    Tuesday, November 08, 2011 10:21 PM