none
Multiple Monitor, change number!

    Question

  • My windows recognize my displays wrong.

    My monitor is the "projector" (2) and my tv is my "monitor" (1).
    Anyone knows a way to change it?

    I have tried swap the cables, swap the hdmi entrance, nothing works.

    Currently using a ATI graphic card, so the catalyst don't have the "display manager", driver beta, bla bla bla...
    Reference: http://forums.amd.com/game/messageview.cfm?catid=279&threadid=111183&highlight_key=y&keyword1=display%20manager

    Using:
    Windows 6.1.7100 x64
    ATI HD 4870 + Catalyst 9.4

    Monitor 22" Samsung (should be the number 1, left)
    LCD TV 32" Samsung (should be the number 2, right)

    See the screenshot:
    http://www.sevenforums.com/attachments/tutorials/11253d1242671080-display-projection-switch-capture.png (WRONG)

    I can swap the sides into the "screen resolution", btw all the times i press WIN+P i need to remember to select the projector (monitor).
    It's really annoying! Microsoft can't make a little function to change the ID's of the monitors? WILL BE GREAT!

    Any ideias??? thanks!

    []'s
    Monday, May 18, 2009 6:52 PM

All replies

  • try this:

    control panel -> display -> change display setting

    click on the display type you want as primary (or display 1) and check 'Make this my main display'

    hope it works
    Tuesday, May 19, 2009 10:30 AM
  • try this:

    control panel -> display -> change display setting

    click on the display type you want as primary (or display 1) and check 'Make this my main display'

    hope it works

    I made this, btw don't change the fact of my monitor still be the projector and vice versa.
    This option just choose when the taskbar will be displayed.

    Any other ideia?

    []'s
    Tuesday, May 19, 2009 4:10 PM
  • I've the EXACT same problem but with an nVidia card.

    My Windows 7 x64 Ultimate machine boots (BIOS POST, Loading Windows screen, etc) to my left monitor. The left monitor is already set as my primary, but identifies itself as 2 while the secondary monitor, (the right one) identifies itself as 1.

    If I swap cables around I can "correct" the swapped IDs, but then Windows will boot (BIOS POST, Loading Windows screen, etc) on the right monitor.

    I DO NOT want this.

    It should boot to the left, and the left should be primary...

    There MUST be some registry settings that determines this.

    • Proposed as answer by Tendor Friday, March 29, 2013 6:07 PM
    Friday, May 28, 2010 3:04 AM
  • I've the EXACT same problem but with an nVidia card.

    My Windows 7 x64 Ultimate machine boots (BIOS POST, Loading Windows screen, etc) to my left monitor. The left monitor is already set as my primary, but identifies itself as 2 while the secondary monitor, (the right one) identifies itself as 1.

    If I swap cables around I can "correct" the swapped IDs, but then Windows will boot (BIOS POST, Loading Windows screen, etc) on the right monitor.

    I DO NOT want this.

    It should boot to the left, and the left should be primary...

    There MUST be some registry settings that determines this.

    Annoying!!!

    I am using the final version now and I still have the same problem.

    I'm "glad" to know that at least I'm not the only one.

    One year later and the problem remains... LOL!!!

     

    []'s

    Friday, May 28, 2010 3:13 AM
  • I've the EXACT same problem but with an nVidia card.

    My Windows 7 x64 Ultimate machine boots (BIOS POST, Loading Windows screen, etc) to my left monitor. The left monitor is already set as my primary, but identifies itself as 2 while the secondary monitor, (the right one) identifies itself as 1.

    If I swap cables around I can "correct" the swapped IDs, but then Windows will boot (BIOS POST, Loading Windows screen, etc) on the right monitor.

    I DO NOT want this.

    It should boot to the left, and the left should be primary...

    There MUST be some registry settings that determines this.


    You are not alone.  I have just spent hours trying to resolve this, to no avail. 

    My Windows 7 x64 Home Premium boots to my TV (identified as display 1), then my computer monitor (display 2) appears after the system is done booting.  I have an nVidia Geoforce GT 220 card, and am using that control panel to swap monitors, etc.

    My TV, too, is on the right and Windows boots to that monitor.

    I am interested in any resolutions.

    • Proposed as answer by Robert Graf Friday, June 11, 2010 7:36 PM
    • Unproposed as answer by Rafael Cossovan Friday, June 11, 2010 9:29 PM
    Wednesday, June 02, 2010 12:14 AM
  • Hi, I had this same issue, and corrected it by following the instructions at the following URL:

    http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-multiple-monitor-problems

    • Proposed as answer by Robert Graf Friday, June 11, 2010 7:37 PM
    Friday, June 11, 2010 7:37 PM
  • My Computer has two monitors connected to it. The Monitor in front of me is primary (start menu is displayed on this monitor) and secondary is one to the right. Now during boot up the POST sequence is displayed on both monitors and when windows is done booting it displays secondary monitor in clone or extended depdning on the settings. In case i have disabled the secondary monitor, windows turns it off when the booting is complete.

    Now here i do not care about the Monitor ID and i do not need to take care. It seems i am missing something here and something different is happening on your monitor. I am using Vista and in case i wish to change monitors i right click on a 3rd party dual monitor software http://www.murgee.com/MurGeeMon/ and select the option change primary monitor.

    The Settings of Display settings allowed only to change where the start menu and desktop icons are displayed as you said in your answer, but why do you care about the number? Do you get the POST and boothing sequence only on 1 monitor? or as said i am missing something.

    Friday, June 11, 2010 8:44 PM
  • Hi, I had this same issue, and corrected it by following the instructions at the following URL:

    http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-multiple-monitor-problems

    What exactly there allow us to change the id of the monitor?
    Friday, June 11, 2010 9:30 PM
  • My Computer has two monitors connected to it. The Monitor in front of me is primary (start menu is displayed on this monitor) and secondary is one to the right. Now during boot up the POST sequence is displayed on both monitors and when windows is done booting it displays secondary monitor in clone or extended depdning on the settings. In case i have disabled the secondary monitor, windows turns it off when the booting is complete.

    Now here i do not care about the Monitor ID and i do not need to take care. It seems i am missing something here and something different is happening on your monitor. I am using Vista and in case i wish to change monitors i right click on a 3rd party dual monitor software http://www.murgee.com/MurGeeMon/ and select the option change primary monitor.

    The Settings of Display settings allowed only to change where the start menu and desktop icons are displayed as you said in your answer, but why do you care about the number? Do you get the POST and boothing sequence only on 1 monitor? or as said i am missing something.

    As i said...

    We got something called "Windows + P shortcut"...

     

    http://www.markwilson.co.uk/blog/2009/10/windowsp-is-the-presenters-friend.htm

     

    So, all this time my real monitor is "My Projector" and my TV is "My Monitor", LOL?

     

    If i set the monitor #2 (real monitor) as my default display, why him can't be my "My Monitor" and not anymore "My Projector"?

     

    Few lines of code should solve it, but, who cares!?

    PS: I will try the MurGeeMon software.

     

    []'s

    Friday, June 11, 2010 9:36 PM
  • Thank you soooo much! I never realized that it was so simple!
    Tuesday, July 13, 2010 3:50 AM
  • I still haven't got this resolved. Does anyone else have any more ideas?
    Tuesday, July 20, 2010 3:20 PM
  • Hey guys, just to let you know...

     

     

    I bought a new computer, this time, I bought a GTX 480 from MSI.

    Guess what?

    Three outputs, two DVI and a mini HDMI.

     

     

     

    The DVI ports have a number! So if I connect the monitor at the output #1, it will be my device #1.

    And unlike ATI, the two DVI outputs are not connected at boot, if you try to connect only the monitor at the output #2, you have no image.

     

    #1 = main.

    #2 = extended.

    As it should be in any video card.

     

    I didn't find any solution to that issue at my first post.

    Now, I found one, NVIDIA card!

     

    []'s

     

    Thursday, August 26, 2010 12:36 AM
  • Im having this same problem with windows 7 as well. This morning I did not have this problem, and it seems that now I do. My post NOW shows up on both monitors, and my primary computer screen shows up as my projector screen when i Windows+P. Anyone ever resolve this issue and get it back to normal?
    Tuesday, December 07, 2010 7:15 AM
  • Look for the control panel from your graphics card. I had this problem too. In the display settings box under the advanced settings, nVidia has a control panel that I used to manually switch the main display between my monitor and tv. (I have Vista it should be similar. I have a comp w/ Windows7 also) nVidia control panel also shows up in the windows control panel under appearance and personalization, other options.
    Thursday, January 06, 2011 4:29 AM
  • OK... I purchased a third monitor w/my new tower... since it's somewhat different (wider), I placed it in the middle of my two older monitors, I'm experiencing difficulty in using the cursor from the left monitor, to the middle one, to the third right monitor... instead it's beginning on the left monitor (and I think only because I physically swithced the two older monitors), then the cursor goes to the right monitor and then to the third newer middle monitor.

    I've got ATI, so what you're saying is that there's no fix for this unless the card is changed?

    Anyone else with this problem?

     

     

    Wednesday, March 30, 2011 5:10 PM
  • I finally figured it out.  There does not appear to be any settings for this on the video card settings pages (in my case NVIDIA Control Panel).  So, it appeared as the only solution was to physically swap out the monitors.  However, in Windows 7, if you navigate to the following:

    Control Panel\Appearance and Personalization\Display\Screen Resolution

    You can manually drag and drop the right display icon before the left display icon.  This will software-wise swap the two monitors.  Then you can select whichever monitor you want to have the start panel on.  How to actually change the numbers, I have no idea how to solve this.  In the end, it was logical, but not intuitive.  Good to note, by shifting the display icon up or down, you can correct for vertical alignment! Click on the icon and use the up/down arrows or ctrl_up/down for more precision.

    Regards,

    TinWood

    Tuesday, July 05, 2011 8:00 PM
  • Go to

    Control Panel\Appearance and Personalization\Display\Screen Resolution

    Select the moniter --> Check make this my main display(Check box near Apply button) --> Click Apply Button

    This is working for me. Try it.

    Monday, August 22, 2011 11:25 PM
  • I am happy to say tat I finally managed to solve this annoying issue.

    1. turn off your secondary display (likely a tv)

    2. go to display settings, there probably will be only one display left - your monitor, and it will be marked as 1

    3. restart your pc

    4. after logging back in go display settings, make sure settings are same as in step 2

    5. connect your secondary display

    Done! My TV finally is marked as 2, hurray!

    Thursday, September 29, 2011 3:17 PM
  • Very cool.  When you go to Control Panel > Appearance and Personalization > Display > Screen Resolution and see the monitor numbers, you can click and drag them into the arrangement you have. 

    http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-multiple-monitor-problems

    Sunday, October 30, 2011 9:18 PM
  • All the people pointing out basic control panel functions like the "make this my main display" checkbox are missing the point. This issue seems to be dependent on both hardware and the driver you're using, which makes the solution different depending on your setup. I recently installed the newest Catalyst beta driver from AMD (12.2) for my HD 5970, and it set my TV as #1 even though my monitor was still checked as my primary display. It got pretty annoying with a lot of property boxes and similar pop ups ending up on my TV by default.

    Most of the above suggestions did not work, I had to switch the two DVI cables plugged in to my card as the new driver seems to have hard assigned the two ports in the card to a particular display number. Unplugging the TV would set the monitor as #1, but it would take over again as soon as it was plugged in, even after a reboot so long as my desired primary display was plugged in to the right port (looking at the PC from the front). I guess it makes sense since primary displays are usually plugged in to the left side first, but still somewhat annoying that it isn't easier to swap them.

    Ultimately I don't think any one suggestion can be marked as the solution here, since it seems to depend on which card you're using and which driver version. Just try everything until you find what works for you.

    Wednesday, January 25, 2012 9:58 PM
  • This one solved my problem.  Gave me drag/drop control of monitor position where the NVIDIA panel did not.  It fixed the mouse too, when I moved the monitors.
    • Proposed as answer by c_bergren Tuesday, January 31, 2012 8:57 PM
    Tuesday, January 31, 2012 8:57 PM
  • This helped - Thanks!!  Now, when I start a full-screen app, it displays on the correct monitor.  Awesome!

    Wednesday, June 27, 2012 2:39 PM
  • Windows + P works for me :)

    As soon as my PC boots (the screen boots on TV), I press CTRL + P once and then give an enter (setting for extending monitors to all)

    Then my login screen will appear on the correct screen and I can login!



    • Edited by efgslats Friday, July 20, 2012 12:11 AM
    Friday, July 20, 2012 12:10 AM
  • My windows recognize my displays wrong.

    My monitor is the "projector" (2) and my tv is my "monitor" (1).
    Anyone knows a way to change it?

    Any ideias??? thanks!

    This Dual monitor ID "fix" from XP, is Very specific to changing the "ID" that is shown on a monitor. It is only about the number, and is not about what is primary. Being anal about it myself and wanting everything to be arranged perfectally , even though it did not matter at all, i had to figure out how to change it without re-installing all the display driver stuff.
    the answer was to remove the monitor drivers (or profiles) from the registry (it did not work from device manager).
    After the removal, you still have to install the monitors in the order you desire.

    I am only assuming that is  what you want, because like myself everyone has answers that dont address the actual ID number things.  I dont have a projector or a laptop, for me it was only about changing that blasted #1 and #2 to be visually correct.

    It is stated there, i will repeat, you should have a registry backup, or full system backup prior to messing with this, i always do myself, so changes like this are easily retractable.

    http://www.overclockers.com/forums/showthread.php?t=657768
    It is all written up there, and requires the user to observe what is going on, I can not think of a way to make a magic script for this, because you have to find your actual monitors.
    If this works for you and that was the actual problem you were having pass-it-on (took me forever to find it again)

    I got the clue for this from someone who had uninstalled all thier display drivers to accomplish the ID change, there had to be a better way.



    • Edited by psycogeec Tuesday, July 24, 2012 9:09 AM
    • Proposed as answer by JamesPC23 Sunday, December 23, 2012 11:54 PM
    • Unproposed as answer by JamesPC23 Sunday, December 23, 2012 11:54 PM
    Tuesday, July 24, 2012 8:48 AM
  • I have had this problem for the past few days. Although everyone seems to have found a way to fix it my fix was instead of going to the Control Panel then Display and trying to correct from there I clicked on the Intel Graphics and Media and was easly able to change the primary and secondary settings there.

    Merry X-mas

    Sunday, December 23, 2012 11:57 PM
  • I have a AMD radeon HD 7800 series, I went to screen resoluton then clicked on the catalyst control center beside the color management settings and opened the control center, I was able to choose weather i wanted my desktop to be on which screen and which monitor was left right middle etc, finally figured it out! :) you really have to go in your graphic card setting.
    Happy new year :)
    Monday, December 31, 2012 10:39 PM
  • I am having the same annoying issue on Windows 8 Pro. Window does not identify the monitors correctly. 
    My Setup:
    HP 25 inch monitor connected through DVI; My main display, currently marked as (2)
    A 42 inch HDTV connected through HDMI; My second display, currently marked as (1)
    HD Radon 7450 - Drivers and Catalyst Control Center are completely up to date. (CCC correctly identifies the displays)
    The Problem:
    I would like my HP monitor to be set to (1) so that when I use "Windows Key + P" I can select computer only and use my HP monitor. Currently I have to select Second Screen Only to see anything. My HDTV is set as (2) and using "Windows Key + P" I must select PC Screen Only to use my TV. This make zero sense in my mind and there is no option to switch the identity of the monitors in Windows OS. Catalyst Control Center works perfectly but has no control over how Windows itself sees the displays.
    This appears to have been a problem from Windows XP, to Vista, to Windows 7, and now Windows 8. I have found multiple threads on the issue, several user suggested solutions, but not one answer that works. How many OS versions must we wait for a fix, Microsoft? Anyone have a different possible solution?
    I have tried every option though screen resolution, uninstalling monitors and re-plugging them in a certain order, regedit found in one of the links below, and a couple of other options.
    Links:
    http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/f7cb8b78-2920-4334-a29a-85498726f4bb
    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/f9e088f5-5449-4ae6-97a3-92a972d3e1c6
    Saturday, February 16, 2013 1:29 AM
  • I had a similar problem with 2 HP Compaq LA2306x monitors at work (so I couldn't do anything that required administrative access.

    Every time I rebooted, I started with monitor 2 on the left, monitor 1 on the right. I'd have to set 2 as the primary every time, but that didn't fix the identifier numbers.

    I was able to switch the monitor identifiers by doing the following:

    1)Control Panel - Hardware and Sound - Personalization - Display Settings - Advanced Settings - Intel(R) Graphics and Media Control Panel - Graphics Properties

    From the Intel dialog, I went to basic settings, multiple displays

    My main monitor was listed as "Monitor HP LA2306", my secondary display was listed as "Digital Display HP LA2306". I change my primary to "Digital Display HP LA2306" and hit apply. My monitors did not physically change orientation, but now the left monitor (my main monitor) is 1 again.


    Hopefully other video cards have similar portals.

    And I hope this helps.

    Tuesday, June 04, 2013 12:50 PM
  • This link Provided

    Takes one to the main page, "The start button and taskbar aren't visible on the screen".  Really?  This doesn't address the question, how to assign monitor ID's, and is no help.  I (and others) probably got here by already trying the fundamentals.


    Wednesday, September 04, 2013 8:23 PM
  • All the people pointing out basic control panel functions like the "make this my main display" checkbox are missing the point. This issue seems to be dependent on both hardware and the driver you're using, which makes the solution different depending on your setup. I recently installed the newest Catalyst beta driver from AMD (12.2) for my HD 5970, and it set my TV as #1 even though my monitor was still checked as my primary display. It got pretty annoying with a lot of property boxes and similar pop ups ending up on my TV by default.

    Most of the above suggestions did not work, I had to switch the two DVI cables plugged in to my card as the new driver seems to have hard assigned the two ports in the card to a particular display number. Unplugging the TV would set the monitor as #1, but it would take over again as soon as it was plugged in, even after a reboot so long as my desired primary display was plugged in to the right port (looking at the PC from the front). I guess it makes sense since primary displays are usually plugged in to the left side first, but still somewhat annoying that it isn't easier to swap them.

    Ultimately I don't think any one suggestion can be marked as the solution here, since it seems to depend on which card you're using and which driver version. Just try everything until you find what works for you.

    You seem to get what the problem is. Now, here is my issue. I have a PC with an onboard VGA and an added video card with 1 VGA and 1 DVI. I have a monitor and a projector, both connected to the added card. The monitor connected to the VGA, the projector to the DVI, and all is good - the monitor comes up as 1 and the projector as 2. But the monitor had an issue, so I replaced it. Now the PC swapped assignments and it considers the projector as # 1 and the monitor as # 2. 

    If you have any idea how to solve it, I'd appreciate it. I'm lost.

    Friday, October 11, 2013 3:40 PM
  • Per some posts below this can be solved in Windows 7 and also Windows Xp 64 by going through Control Panel>Personalization>Display /Settings and then dragging the monitor boxes into the position you desire the displays to be numbered.  I then went back to Nvidia Control Panel and adjusted for multiple monitors primary or secondary etc. I am not sure about other operating systems. 
    Wednesday, October 30, 2013 8:29 PM
  • I found a reasonable work-around.

    Before that:

    #1 = My LG LCD 47" TV (Extended desktop)
    #2 = My Samsung SCLsomething 24" LCD screen (Primary screen)

    Any application that was newly run, opened up on my extended desktop area aka the #1 LCD TV screen, which I don't always have turned on.

    So, I opened my ATI Catalyst control panel, switched to desktop areas and clicked on "Swap displays". LCD computer screen became #1, but was not primary, LCD TV became #2 and was set primary.
    Then i set the #1 (LCD screen) to primary, applied settings. Rebooted and now all new programs open up on display #1 (the computer LCD screen).

    Might not be applicable to every person.

    Tuesday, March 18, 2014 12:17 PM
  • This worked for me.

    I had tried to fix this on the Screen Resolution many times before but it was not obvious that the displays could be dragged/dropped to swap monitors.  This was an aha moment. :-)  

    Thanks very much for posting.


    7 hours 4 minutes ago