none
How to disable thumbs.db files generation on network folders

    Question

  • I've read that Vista caches thumbs under the user folder, but when it comes to network drive, Vista like to litter my network folders with them.

     

    Does anyone know how to either disable the network drive thumb caching, or tell Vista to save the network drive thumbs with the regular thumbs in the user's folder?

     

    Having Vista pollute network drives with thumbs.db files is frustrating when you are organizing pictures or videos and you rely on folders being empty to know if you moved all the files out.  When each folder has a thumbs.db you have to clean a folder structure of all the thumbs.db then see if any files remain to know if you can delete the old folder structure.

     

    Vista should have the drive letter or UNC of where the folder is.  Vista should be smart enough to know if that folder doesn't exist to prune the thumbs out of the user folder thumbs.db file.  That way it wouldn't get too bloated with thumbnails of files that no longer exist.  If I have to rebuild thumbs of a network drive, I don't mind because I know they could have changed.

    Sunday, June 29, 2008 11:32 PM

All replies

  • I have exactly the same question. Does anyone know the answer?
    Help... please...

    Tuesday, July 22, 2008 4:08 AM
  • You could try this policy setting:

    Turns off the caching of thumbnails in hidden thumbs.db files.

    This policy setting allows you to configure Windows Explorer to cache thumbnails of items residing in network folders in hidden thumbs.db files.

    If you enable this policy setting, Windows Explorer does not create, read from, or write to thumbs.db files.

    If you disable or do not configure this policy setting, Windows Explorer creates, reads from, and writes to thumbs.db files.


    You'll find it under Windows Components\Windows Explorer GP

    • Proposed as answer by jcontrer Tuesday, November 05, 2013 7:35 PM
    • Unproposed as answer by jcontrer Tuesday, November 05, 2013 7:35 PM
    Tuesday, July 22, 2008 11:01 AM
  • It's a nice try, however it doesn't actually work.  I tried that months ago, and it still creates thumbs.db files on network drives.

    However, if you disable Thumbnails entirely  ('Turn off caching of thumbnail pictures' in the same gpedit location), it does seem to work.

    """
    If you enable this setting, thumbnail views are not cached.

    If you disable or do not configure this setting, thumbnail views are cached.

    Note: For shared corporate workstations or computers where security is a top concern, you should enable this setting to turn off the thumbnail view cache, because the thumbnail cache can be read by everyone.
    """
    Sunday, July 27, 2008 11:17 PM
  • Where specifically is the path to change these settings in Vista?

     

    Tuesday, August 12, 2008 5:38 AM
  • I don't know if you ever found this, but it seems to work, even on network folders:

    http://www.vistax64.com/tutorials/146891-simple-way-disable-thumbnail-cache-vista.html

    First, turn off thumbnail creation by opening Windows Explorer, clicking the Organize button and selecting Folder and Search Options.

    Click on the View tab and check Always show icons, never thumbnails. Click the OK button.

    Then, run Disk Cleanup on Drive C: and empty the cache so you can recover the disk space. You can find it in Accessories/System Tools.

    In Windows Explorer, navigate to the AppData\Local\Microsoft\Windows folder under your name. (If you can't find it, just copy the following: %LocalAppData%\Microsoft\Windows
    Paste it into the Address Bar and hit Enter.)

    Right-Click on the Explorer folder and select Properties.

    Select the Security tab.

    Click the Advanced button.

    On the Permissions tab, click the Edit button.

    Uncheck "Include inheritable permissions from this object's parent".

    Click the Remove button in the Windows Security box that pops up.

    Click the OK button on the Permissions tab.

    Click the Yes button in the Windows Security box that pops up.

    Close all the open boxes.

    Go back into the Folder and Search Options and uncheck the Always show icons, never thumbnails and you're done.

    Now, browse any folder you want and Windows will create the thumbnails on the fly, but won't save them to disk. I've verified that these Security Settings will not be overwritten by rebooting Windows. However, I don't know if the Explorer directory is used for anything else. I've been using Vista for over a year now and the only files in my Explorer directory were the thumbnail databases.

    If you think you can do the same thing to the thumbnail database files instead of the Explorer directory, you can't. I tried that first and Windows was still able to delete them and create new ones. This is also true if you try setting the file's Read-only, Hidden and System attributes.

    Don't worry about not being able to access the Explorer folder. You, as the Owner of the Explorer directory, can undo the changes, but apparently Windows can't.

    Saturday, May 09, 2009 7:30 AM
  • CAUTION: When I made the change:  

    Uncheck "Include inheritable permissions from this object's parent"  on the Permissions tab as noted in greenhart above

    It caused my MS Word Office 2003 to stop allowing the Save or Save As controls.  Thus, I could no longer update or save word documents.  I might have followed the instructions incorrectly, but watch out for this effect.  

    Tuesday, December 22, 2009 6:18 AM
  • I think the issue here is no one is specifically stating where these policies need to be instituted (server or Client) but to be honest, GPO / Local Policy is going to Flop for various reasons. I would Suggest to use the File Resource Manager Role specifically built into 2003 R2 / Windows 2008 to put a File Screen on the "Thumbs.db" File. 

    Plus you can block other annoying files such as Mac ".DS_Store" files, and if you are a network admin you can block copyrighted materials like MP3's.

    Just my 2 Cents,
    Clad

    Saturday, March 05, 2011 8:29 PM