none
InputLocale for English (United Kingdon) in Windows System Image Manager

    Question

  • Hello,

    I am creating an autounattended.xml file in Windows System Image Manager to install Windows 7 without any prompts.

    I have succeeded in all areas but one; setting the keyboard/locale to English UK.

    If I set the InputLocale, SystemLocale and UserLocale all to en-US the Windows 7 installation works completely unattended and installs the US locale. However if I change these to en-GB or en-UK I am prompted during installation to select the required locales. After hours of searching I cannot find a solution.

    Please can somebody tell me what I need to put into the following boxes to ensure Windows 7 is installed automatically with only English (United Kingdom) locales.

    What values do I need?

     Many thanks,

    Matt Courtman

    Cromwell Community College, UK

    mcourtman@cromwell.cambs.sch.uk

    Monday, April 19, 2010 2:52 PM

Answers

  • You may need to configure the Microsoft-Windows-International-Core component in the specilize phase as well.

    Dale

     

    Tuesday, April 20, 2010 3:14 AM

All replies

  • You may need to configure the Microsoft-Windows-International-Core component in the specilize phase as well.

    Dale

     

    Tuesday, April 20, 2010 3:14 AM
  • mcourtman did you manage to fix this?I have the exact same problem.

    I tried your solution Dale but its still the same.

    Friday, April 20, 2012 9:13 PM
  • Same problem here, anyone got an answer? 
    Monday, April 23, 2012 9:05 PM
  • Hi All

    My colleague & I suffered for days trying work it out. Dale is correct about the Microsoft-Windows-International-Core

    Here is the section of the XML that worked for us

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" ........................................................>
                <InputLocale>en-GB</InputLocale>
                <SystemLocale>en-GB</SystemLocale>
                <UserLocale>en-GB</UserLocale>
                <UILanguage>en-US</UILanguage>
            </component>

    Note the need for UILanguage to remain en-US here and in the SetupUILanguage

    Hope this helps


    • Edited by GutBucket1 Tuesday, May 01, 2012 4:14 PM missing info
    • Proposed as answer by GutBucket1 Tuesday, May 01, 2012 4:14 PM
    Tuesday, May 01, 2012 4:10 PM