none
"Local Area Connection" has an invalid IP configuration -

    Question

  • I built a PC about 3 weeks ago on Jul 31. Everything was working great until about a week and a half ago when I started losing my internet connection with the error message Local Area Connection has an invalid IP configuration. I figured there was something wrong with the adapter so I bought a USB eternet adapter, and after a few days of use I started losing my connection again, with the same error message. Meanwhile I'm still able to get internet access on other wired devices, and via wi-fi so the modem and router are working properly. I had Time Warner come out to check the line and equipment just to be sure, and everything was fine on their end. I also bought a new wireless router - Netgear WNR3500L. Also when I put the computer to sleep and wake it up, I get a connection, but how long it last varies between instantly losing the signal to about 30 minutes before it drops off. I've disabled and re-enabled the adapter several times, restored to an earlier point, but still this issue remains. Is the only solution a complete re-installation of Win 7? Cause I'm at that point now.
    Monday, August 22, 2011 10:29 PM

Answers

  • Try disabling IPv6.

    Check for the latest updates for your wireless card and the router firmware.

     

    Jerry

    Tuesday, August 23, 2011 8:18 PM
  • Hi,

     

    I would like to verify if you installed any software recently. How do you know there is something wrong with built-in adapter?

     

    I suggest you refer to the following steps to troubleshoot issue.

     

    1. Update your network adapter driver from manufacture's site first.

    2. check Advanced TCP/IP Settings. Local Area Connection Properties -> Internet Protocol Version 4 Properties -> Advanced -> IP Settings. If any IP address is configured, please remove it.

    3. Navigate to [HKLM\System\CurrentControlSet\Control\Network], right click Network, choose export and save on desktop as backup. Then delete the Config key in the right pane.

    4. Open CMD with elevated privileges and type: netsh int ip reset

    5. Start the computer in clean boot to check the result.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 25, 2011 9:16 AM

All replies

  • Try disabling IPv6.

    Check for the latest updates for your wireless card and the router firmware.

     

    Jerry

    Tuesday, August 23, 2011 8:18 PM
  • Hi,

     

    I would like to verify if you installed any software recently. How do you know there is something wrong with built-in adapter?

     

    I suggest you refer to the following steps to troubleshoot issue.

     

    1. Update your network adapter driver from manufacture's site first.

    2. check Advanced TCP/IP Settings. Local Area Connection Properties -> Internet Protocol Version 4 Properties -> Advanced -> IP Settings. If any IP address is configured, please remove it.

    3. Navigate to [HKLM\System\CurrentControlSet\Control\Network], right click Network, choose export and save on desktop as backup. Then delete the Config key in the right pane.

    4. Open CMD with elevated privileges and type: netsh int ip reset

    5. Start the computer in clean boot to check the result.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 25, 2011 9:16 AM
  • Does the message say IP Conflict?

    If yes, then multiple devices on your network are using the same IP address causing this problem. Please confirm status to enable further assistance.

     


    Kunal D Mehta - a Windows Server Enthusiast.
    Thursday, August 25, 2011 3:47 PM